Ubuntu

Gwibber "Smooth scrolling"

Reported by Pete Goodall on 2011-08-18
474
This bug affects 118 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
One Hundred Papercuts
Medium
Papercuts Ninjas
gwibber (Ubuntu)
High
Unassigned

Bug Description

Trying to read down my list of posts in Gwibber is very difficult because of a number of bugs. The one I'm reporting here is using the scrollbar to scroll through the list is in no way smooth and skips in big jumps. The effect is I cannot read while scrolling, and because it jumps so jarringly quickly I don't know if I have missed any posts. We need to implement smooth scrolling.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gwibber 3.1.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Thu Aug 18 10:08:40 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110728)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gwibber
UpgradeStatus: No upgrade log present (probably fresh install)

Pete Goodall (pgoodall) wrote :
Ken VanDine (ken-vandine) wrote :

The current design avoids smooth scrolling by always aligning a tile at the top. It might be a nice configuration option, to enable smooth scrolling however I think to do that would require significant refactoring.

Pete Goodall (pgoodall) wrote :

The effect is (IMHO) rather jarring. It makes it very difficult to scroll through the updates because it is constantly jumping. For me, at least, this is unusable. I don't know if anyone else sees it that way.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

I agree with what Pete says. Is there a way to page up/down somehow?

Ken VanDine (ken-vandine) wrote :

page up and page down works with the page up and down keys. I want to switch to a smooth scrolling model for 3.4.

Changed in gwibber:
milestone: none → 3.4
status: New → Confirmed
importance: Undecided → High
Oliver Smith (oliver-smith) wrote :

I also agree with Pete.
I love how Gwibber works - but the scrolling makes it too difficult to use. Especially for new Ubuntu users.

summary: - Gwibber window scrolls too fast when using the scrollbar
+ Gwibber "Smooth scrolling"
Diane Trout (diane-trout) wrote :

An additional effect of this bug is if you have a long post that is longer than your window, you can't read it.

This is mostly a problem with long facebook posts or short ones that received a number of comments.

I usually try using the mouse wheel to scroll.

TheCaméléon (pictuga) wrote :

To be honest, it's the main thing that makes me *not* use gwibber everyday. Every time I launch it this scrolling behaviour disappoints me, and I just go back to twitter.com where I can have "normal" scrolling.
The current scrolling behaviour makes tweets "jump" up and down, and I can't get my eyes to track tweets when scrolling, so I get lost in my tweets, without knowing were I was before scrolling a little bit.

However the idea of such a scrolling behaviour isn't stupid at all, but it's a bit hard to get accustomed to, and it isn't consistent with any other application.

(this scrolling behaviour is even worst since gwibber is at roughly 100% CPU when scrolling)

Matt Cockayne (uvir-5atm-hknf) wrote :

Something else that I notice when scrolling.

When a scrolling through a facebook stream that contains images the images are reloaded after each scroll, causing it to jump around even more than usual. I'm presuming this is because the window is having to redraw its contents every time we scroll.

Would be good to see this eliminated with along smooth scrolling

Jay S (topdownjimmy) wrote :

@Matt Cockayne

I filed a separate bug for this image-reloading behavior in October:
https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/875348

These bugs combined make Gwibber unusable in my opinion.

Bilal Shahid (s9iper1) wrote :

agreed

Changed in gwibber (Ubuntu):
importance: Undecided → High
Simon (simonbcn) wrote :

It still occurs in gwibber 3.3.2

Bilal Shahid (s9iper1) on 2012-02-22
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber:
milestone: 3.4 → 3.6
sticks (orawas) wrote :

I can't say that I'll be usingor even trying to use gwibber till this is fixed.

+1 - until scrolling is fixed, using gwibber is just awful.

Wouter (wouter-cools) wrote :

+1 - reloading avatars and no smooth scrolling makes Gwibber a dull boy (broken app, that is)

Dr. Amr Osman (dr3mro) wrote :

+1

Sven Romeike (lun4tic) wrote :

It doesnt actually need "very smooth" scrolling it just needs to get away from this "by post" scrolling that it seems to have currently. This is what makes the programm feel so awkward that I can not use it.

Changed in hundredpapercuts:
status: New → Triaged
Chris Wilson (notgary) on 2012-06-09
Changed in hundredpapercuts:
importance: Undecided → Medium
assignee: nobody → Papercuts Ninja (papercuts-ninja)
milestone: none → quantal-4-social-networking

A nice idea would combine the current tile alignment functionality with smooth scrolling. Think overshoot bounce on android phones.

Khurshid Alam (khurshid-alam) wrote :

+1

Cruz Bishop (cruzjbishop) wrote :

This is very annoying, especially when using a touchpad :)

Bilal Shahid (s9iper1) wrote :

we need more work on it ken!

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
status: Confirmed → Triaged
Alan Pope ㋛ (popey) on 2012-10-25
Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → nobody
Robert Bruce Park (robru) wrote :

As part of the Ubuntu Touch project, Gwibber has been rewritten in QML, which offers very nice smooth scrolling.

Changed in gwibber:
status: Triaged → Fix Released
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Simon (simonbcn) wrote :

Thanks. Is this fix available for Ubuntu Quantal?

Robert Bruce Park (robru) wrote :
Simon (simonbcn) wrote :

Thanks, but I have tried but it doesn't integrate in messaging menu nor gnome-accounts. Moreover I could't open Friends (gtk).

Robert Bruce Park (robru) wrote :

You're right, it doesn't integrate with gnome-accounts. Currently it only supports Ubuntu Online Accounts. I am willing to accept patches for GOA but nobody has submitted any yet. Gwibber trunk has been using UOA for some time now, even before the switch to Qml, so you must be using quite an old version if you are not using UOA in gwibber ;-)

I'm not entirely sure what you're referring to by 'friends (gtk)' but there is no Gtk interface (maybe you refer to the small example posting widget, but that is not a complete app). Friends is largely just the backend, it replaces gwibber-service, and the frontend has been replaced by Qml Gwibber. Can you give me more details here? What packages did you install? If you install 'gwibber' package from that archive it should bring in all the dependencies that it needs (if it doesn't, then that's a bug and I'd like to know about it!)

Simon (simonbcn) wrote :

gwibber is uninstalled when I install Friends in Quantal.

Ok, that's the problem. There isn't a gtk interface in Quantal for Friends
and messaging menu doesn't recognize it.

2013/3/29 Simon <email address hidden>

> gwibber is uninstalled when I install Friends in Quantal.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (700322).
> https://bugs.launchpad.net/bugs/828593
>
> Title:
> Gwibber "Smooth scrolling"
>
> Status in Gwibber:
> Fix Released
> Status in One Hundred Paper Cuts:
> Fix Released
> Status in “gwibber” package in Ubuntu:
> Fix Released
>
> Bug description:
> Trying to read down my list of posts in Gwibber is very difficult
> because of a number of bugs. The one I'm reporting here is using the
> scrollbar to scroll through the list is in no way smooth and skips in
> big jumps. The effect is I cannot read while scrolling, and because
> it jumps so jarringly quickly I don't know if I have missed any posts.
> We need to implement smooth scrolling.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gwibber 3.1.5-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
> Uname: Linux 3.0.0-8-generic x86_64
> Architecture: amd64
> Date: Thu Aug 18 10:08:40 2011
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110728)
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SourcePackage: gwibber
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/828593/+subscriptions
>

Simon (simonbcn) wrote :

Ok, that's the problem. There isn't a gtk interface in Quantal for Friends and messaging menu doesn't recognize it.

Robert Bruce Park (robru) wrote :

My apologies, the PPA dependencies are a little bit more complicated than I had anticipated for making this work in Quantal. Please try these commands:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper
sudo add-apt-repository ppa:super-friends/ppa
sudo apt-get update
sudo apt-get install gwibber

That should grab the latest gwibber and pull in all the necessary qt5 dependencies. After that, you'll need to make sure your account is registered in Ubuntu Online Accounts and it should more or less be working after that. Would love to have some feedback on how that runs.

Simon (simonbcn) wrote :

Are you sure? I have too many troubles to return to gwibber.

Robert Bruce Park (robru) wrote :

Well, nobody is forcing you to if you don't want to. I just thought you might like to try out the new Gwibber, which has been completely rewritten. If you try out the new one and don't like it, is is possible to revert back to the older one, you just have to remove the PPAs, uninstall gwibber/friends, and then reinstall gwibber=3.6.

sticks (orawas) wrote :

Thanks of the instructions! I don't mind giving it a go myself. I have raring on an older machine, so that might be an interesting test case. In terms of feedback, should I use this ticket to give any, or is there a different preferred avenue for it?

Robert Bruce Park (robru) wrote :

Thanks for your interest in testing! If you find new bugs, please file new ones. This particular bug has mostly run it's course I think. I should put those PPA instructions on a wiki somewhere...

For now, you can just file the bugs against lp:friends, and I'll organize them as necessary. We've split gwibber up into different components so it might not be immediately obvious which component is causing whatever bug you might be observing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers