Gwibber reloads images with every scroll: "Gtk-WARNING: Failed to set text from markup due to error parsing markup"

Bug #875348 reported by Jay S on 2011-10-15
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
Undecided
Unassigned

Bug Description

Every time I scroll down in Gwibber, no matter by how little, all the images from the visible posts disappear and then are reloaded. This makes things very difficult to read.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gwibber 3.2.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Oct 15 17:45:39 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gwibber
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (1 days ago)

Jay S (topdownjimmy) wrote :
Jay S (topdownjimmy) wrote :

Here is the terminal output I get every time I scroll in Gwibber:

(gwibber:5476): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity - escape ampersand as &

summary: - Gwibber reloads images with every scroll
+ Gwibber reloads images with every scroll: "Gtk-WARNING: Failed to set
+ text from markup due to error parsing markup"
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Martin Hansen (martin-h) wrote :

I also have this bug and get the same error message as @topdownjimmy

Changed in gwibber:
importance: Undecided → High
milestone: none → 3.3.3
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.3-0ubuntu1

---------------
gwibber (3.3.3-0ubuntu1) precise; urgency=low

  * New upstream release
    - Fixed memory leak in ActionBoxItem (LP: #909085)
    - Fixed race conditions in async image loading while scrolling (LP: #911619)
    - Hide window while gwibber exits (Michal Hruby)
    - Improved scrolling by enclosing comments and image previews in a
      Gtk.Expander, this fixes the tiles resizing while scrolling (LP: #875348)
    - Ported to valac-0.16
  * debian/control
    - build depend on valac-0.16
 -- Ken VanDine <email address hidden> Mon, 30 Jan 2012 10:55:24 -0500

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released

I am still having this problem in Precise final. I don't think this is solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers