Nautilus fails to browse windows shares

Bug #316862 reported by Mark Ellse on 2009-01-13
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs
Incomplete
Undecided
Unassigned
gvfs (Debian)
Fix Released
Unknown
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Forgive long explanation below detailing, as well as the range of the problem, some experiments to isolate the problem.
Windows peer-to-peer network with
(a) about twenty Windows 2000 and 98 machines
(b) one Ubuntu machine running Samba server for student purposes (smb.conf Workgroup = Students, Dapper LTS Server)
(c) one LTSP network with three terminals running Samba server for staff purposes (smb.conf set to make Staff the workgroup) (Intrepid, latest patches as of 13/1/09)
(d) one standalone Ubuntu Intrepid machine (smb.conf Workgroup = Staff, Intrepid, latest patches as of 13/1/09)
(e) two Ubuntu machines running from the live CD for test purposes. (No workgroup set)

It's a school. There are two workgroups: Staff and Students.

Windows (Staff) machines (a) always show the presence of the other machines on their (Staff) workgroup.
Nautilus on (b) to (e) intermittently displays the Windows machines on the Staff workgroup.
When Nautilus works, Places, Network on machines (c) and (d) displays the machines on the Staff workgroup, and also the Windows Network icon, through which you can find the Student workgroup. On machines (e), where no workgroup is set, one has to go through the Windows Network icon to the Staff network.
When Nautilus doesn't work, only the Windows Network icon is visible. Clicking that makes the other Windows networks visible, but no shares on the Staff workgroup are visible. But (b) on the Student network, is always visible.

BUT, Smb4K is installed on (c) and (d), and even when Nautilus is off, using Smb4K, one can seek, browse, connect to other machines on the Staff network.

The two machines (d) using live CD's are there for test purposes. They observe the same behaviour with Intrepid, Hardy, Gutsy live CDs.

Possibly associated bugs:
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/207072
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/26933
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/193232
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/282113
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/215570
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/73591

Thoughts:

i) I did not observe this behaviour when using Gutsy, so thought it was a post-Gutsy problems. But now it is clearly evident in Gutsy. That makes me think that the problem may have arisen not through a change in Ubuntu, but from a change in the Windows network. I did wonder if this was a consequence of a Windows 2000 security update, possible affecting the Windows browser service.

ii) I noticed that that attempting to browse the Staff workgroup via Places, Network, Windows Network, Staff results in an extremely rapid return of '0 items', whereas when browsing the other default (empty) workgroups (WORKGROUP, MSHOME) it takes about six seconds before '0 items' is displayed. This means that there is something on the network that is rapidly telling Nautilus that there is nothing there.

Zack Powers (zpowers) wrote :

Testing this in Jaunty on 4:40PM EST, Jan 13th.

When using the "Connect to Server..." dialog in Place->Connect to Server..., Nautilus gives an error when attempting to browse a share.

When opening Nautilus and using the "Network" shortcut to browse the network root, browsing various shares and workgroups work fine.

When pasting smb:// URLs into the nautilus address bar browsing also works fine.

Mark Ellse, could you clarify which method you used to browse the shares?

To see screen shots of me browsing different shares visit http://acm.umflint.edu/~zpowers/sambaError/

Mark Ellse (markellse) wrote :

Can't use Jaunty - flaky with my hardware. Am using Intrepid on live CD (same behaviour with Hardy) and Intrepid on two installed machines, one of which is an LTSP server. These have latest updates.

On live CD machines I connect by clicking Places, Network, then double-clicking Windows Network, Staff (the name of the workgroup). When browsing is working properly, this displays the contents of the workgroup. When browsing isn't working, the address bar shows 'smb://staff/' and Nautilus reports '0 items'. When browsing is working properly, the hosts on the workgroup are displayed.

On the fully installed machines I connect by clicking Places, Network. When browsing is working properly, this displays the contents of the Staff workgroup because of Workgroup=Staff in smb.conf. When not working the behaviour is as above.

I can always browse the student network and see and browse the student server. (There is nothing else to see because the other machines are on a different VLAN.)

If I type smb://172.19.53.n/, where n is the machine number, I can see the machine in question and browse it.

I cannot browse a machine by typing smb://staff/hostname/ in the address bar.

I observe that Nautilus, heirachically:
WILL browse a Windows network and see the workgroups,
WILL NOT (always) browse a workgroup to see the hosts on it
WILL browse a host on the network once it is contacting it via its IP address.

Smb4K will always browse the workgroup.

The behaviour is intermittent. When it occurs, none of the Ubuntu machines will browse the workgroup. This leads me to think it is a change in the Windows 2000 network that initiates the problem and the way that Nautilus interrogates the Windows browser service for a workgroup.

Download full text (4.5 KiB)

Dear Zack,

Thanks for taking this seriously. I've spent a few hours on it this morning
and added to the bug report what I have found.

For your information I attach to this email the screenshots of what I
observe. By the way, for historical reasons, our staff workgroup is given
the awkward name fo27183142, not Staff.

Cheers,

Mark

2009/1/13 Zack Powers <email address hidden>

> Testing this in Jaunty on 4:40PM EST, Jan 13th.
>
> When using the "Connect to Server..." dialog in Place->Connect to
> Server..., Nautilus gives an error when attempting to browse a share.
>
> When opening Nautilus and using the "Network" shortcut to browse the
> network root, browsing various shares and workgroups work fine.
>
> When pasting smb:// URLs into the nautilus address bar browsing also
> works fine.
>
> Mark Ellse, could you clarify which method you used to browse the
> shares?
>
> To see screen shots of me browsing different shares visit
> http://acm.umflint.edu/~zpowers/sambaError/<http://acm.umflint.edu/%7Ezpowers/sambaError/>
>
> ** Attachment added: "Screenshot-Windows shares on its-ds-1 - File
> Browser.png"
>
> http://launchpadlibrarian.net/21177450/Screenshot-Windows%20shares%20on%20its-ds-1%20-%20File%20Browser.png
>
> --
> Nautilus fails to browse windows shares
> https://bugs.launchpad.net/bugs/316862
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "nautilus" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: nautilus
>
> Forgive long explanation below detailing, as well as the range of the
> problem, some experiments to isolate the problem.
> Windows peer-to-peer network with
> (a) about twenty Windows 2000 and 98 machines
> (b) one Ubuntu machine running Samba server for student purposes (smb.conf
> Workgroup = Students, Dapper LTS Server)
> (c) one LTSP network with three terminals running Samba server for staff
> purposes (smb.conf set to make Staff the workgroup) (Intrepid, latest
> patches as of 13/1/09)
> (d) one standalone Ubuntu Intrepid machine (smb.conf Workgroup = Staff,
> Intrepid, latest patches as of 13/1/09)
> (e) two Ubuntu machines running from the live CD for test purposes. (No
> workgroup set)
>
> It's a school. There are two workgroups: Staff and Students.
>
> Windows (Staff) machines (a) always show the presence of the other machines
> on their (Staff) workgroup.
> Nautilus on (b) to (e) intermittently displays the Windows machines on the
> Staff workgroup.
> When Nautilus works, Places, Network on machines (c) and (d) displays the
> machines on the Staff workgroup, and also the Windows Network icon, through
> which you can find the Student workgroup. On machines (e), where no
> workgroup is set, one has to go through the Windows Network icon to the
> Staff network.
> When Nautilus doesn't work, only the Windows Network icon is visible.
> Clicking that makes the other Windows networks visible, but no shares on the
> Staff workgroup are visible. But (b) on the Student network, is always
> visible.
>
> BUT, Smb4K is installed on (c) and (d), and even when Nautilus is off,
> using Smb4K, one can seek, browse, connect to other machines on the Staff
>...

Read more...

Pedro Villavicencio (pedro) wrote :

more like a gvfs issue.

Mark Ellse (markellse) wrote :

Agreed. Where should I post it?

Sebastien Bacher (seb128) wrote :

would be useful to try using the gvfs version in jaunty, the smb changes will probably be backported to intrepid soon though if you prefer to wait and then to hardy

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Zack Powers (zpowers) wrote :

I agree with Sebastien, at some point after Jaunty reaches its feature freeze. It would probably be best to then test browsing with Jaunty. If the version of gvfs in Jaunty resolves the issue, a request to backport the package to Intrepid and Hardy should be made.

Also, has there been a bug report made with GNOME developers about this bug?

Sebastien Bacher (seb128) wrote :

there is a candidate update for intrepid now too, could somebody try using it or the jaunty version?

max (mikhmv) wrote :

I checked on Jaunty and Intrepid. Everything working. Thanks

Brad Needham (fishrcynic) wrote :

my problems only started after 01/01/09 exact date not known.
the above still wasn't working for me 02/07/09
and i was very very annoyed and frustrated.
(not with ubuntu with networking in general, i have had issues before but nothing like this)

so i activated a samba wins server
 - made one machine a wins server (picked on a ibex 386 server install) - made all other machines use wins (assortment of ubuntu, solaris, vista, xp, 2000 and others ) - allowed complete browsing in nautilus with default install (authenticated and guest) and fixed various ubuntu to xp, ubuntu to ubuntu, xp to xp etc issues with peer to peer networking. i have vanilla ubuntu hardy, ibex configurations (now with wins server = xxx.xxx.xxx.xxx and name resolve order = wins lmhosts bcast in smb.conf) - on windows machines i forced netbios over tcp as well.

stole the lines for the wins server from:
http://whereofwecannotspeak.wordpress.com/2007/10/24/samba-as-a-wins-server-in-a-windows-peer-network/

 nautilus browsing in jaunty 386, ibex 386 & amd 64, hardy 386 and amd64 all work now

i don't think this issue is a samba/gvfs issue itself or even limited to linux - xp machines that would not connect to each other now have no issues either. using a wins server cleans up xp only peer to peer networks (lan game connections over tcp now work consistently)

btw i still limit workgroup machine names to 8 characters to help old windows machines

Mark Ellse (markellse) wrote :

Workaround and associated faulty behaviour:
1. You can log onto a Windows share by typing smb://xxx.xxx.xxx.xxx (the IP address of the machine which has the Windows share) in the text based location bar.
2. While connected to the share as in 1, create a bookmark for the share Ctrl+D. This creates two bookmarks: one in the Nautilus window, and the other one in the drop-down menu for Places.
3. The bookmark in the Nautilus window works. Teach your users to use it!
4. The bookmark in Places drop-down menu returns the message: "Could not open location 'smb://172.19.53.101/' No application is registered as handling this file. I guess this is an associated bug.
5. Smb4K, with occasional crashes, seems to work most of the time for browsing the network.

Sebastien Bacher (seb128) wrote :

does anybody still get the issue in current intrepid version with the backported gvfs changes or jaunty? could you describe what you do exactly and what error you get?

Changed in gvfs (Ubuntu):
status: New → Incomplete
johnsdagg (johndaggett) wrote :

i seem to have the same gvfs/nautilus problem - recently installed 9.04 on a new drive but i can still boot into 7.10 off my older drive if i choose.

samba installed, can see shared folders on 9.04 box from any windows xp box
BUT 9.04 box is unable to reach windows shares using nautilus 2.26.2.

upon clicking on COMPUTER01 in my WORKGROUP computer list i get the following error:
Unable to mount location
Failed to retrieve share list from server
(see attached screenshot-1)

when i boot into 7.10 on the same box i do not have this problem.

i can work around by using ip address; i.e typing the following in nautilus:
smb://192.168.1.100/sharedfolder
but that is not a solution because i have other windows xp boxes on the network with dynamic ip addresses.

i'm not using any wins server on my network.
i turned off all firewalls.
workgroup=WORKGROUP on all boxes.

i've tried every relevant solution i could find on the ubuntuforum boards - nothing has helped.

i am an experienced windows tech person but relatively new to ubuntu... willing to test and provide any info i can to help figure this out... please give verbose instructions.

thanks,
john d.

johnsdagg (johndaggett) wrote :

similarly, i can make computer01 and computer02 entries in the /etc/hosts file which allows nautilus to behave as one would hope, but again this isn't a solution because i have other boxes on the network that use dynamic ip addresses.

example /etc/hosts file:

127.0.0.1 localhost
127.0.1.1 computer03
192.168.1.100 computer01
192.168.1.101 computer02

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Brad Needham (fishrcynic) wrote :

i am still using a wins server as that is the only way i get consistent results even with the xp machines.
new jaunty installs do not network smoothly (ie connections may or may not work with mostly may not work)
as soon as i add the wins server ip address to smb.conf -and restart samba - networking is good again

network consists of 2 xp mce, 2 xp home, 1 xp pro machines (all sp3)
1 hardy amd64, 1 intrepid server, 2 jaunty amd64, 2 jaunty (all up to date)

without wins - xp to xp connections are even iffy especially between different versions
with wins it works

Mark Ellse (markellse) wrote :

The behaviour is still there, and very disabling, with Jaunty, and with latest patches on Intrepid.

The behaviour is intermittent, but most of the time Nautilus is unable to browse Samba shares. Occasionally the Samba shares are browseable.
Agreed that browsing a Windows peer to peer network with a Windows machine is flaky, but though it sometimes fails at first attempt, it rarely fails at a second.

IMPORTANT When the Samba shares are not browseable, it is not possible to browse for a Samba printer, either.
BUT it is possible to connect to a Samba printer by using:
EITHER smb://xxx.xxx.xxx.xxx/printername
OR smb://workgroup/hostname/printername
meaning that the translation from workgroup/hostname to IP address (the essential requirement for browsing the network) is happening. (As mentioned above, SMB4K does this reliably.)

Sebastien Bacher (seb128) wrote :

the bug seems to list different issue and it's not really easy to work on it now, could somebody summarize exactly what the issue is and how to trigger it easily in jaunty? the other option is to close this bug and open new ones for issues still there

Mark Ellse (markellse) wrote :

1. The bug. When an an Ubuntu machine is connected to a Windows peer-to-peer network, the File Browser will browse network (network:///) showing the workgroups (smb:///) but it will not reliably browse within the workgroups (smb://workgroup/).
2. How to trigger in Jaunty. Connect a Jaunty machine to a window peer-to-peer network.
3. Associated information:
     Can connect to hosts by smb://<IP address>, but not by smb://workgroup/hostname.
     But can connect to printers by BOTH smb://<IP address>, and by smb://workgroup/hostname.
     Also present with earlier versions of Ubuntu.
     May be a gvfs problem, but afflicts Ubuntu and should be within Ubuntu bugs.
     May be the way that File Browser interrogates Windows master browser (known to be flaky even for Windows machines).
     Very rapid return of 'Unable to browse location. Failed to return share list from server' by File browser, whereas when browsing workgroups effectively it takes time to retrieve the information. Possibly something is telling File browser that there is nothing with the hostname/IP translations.
     But SMB4K browses within workgroups reliably.
4. I'm for leaving it here since the core issue (1. above) is clear and adequately described.

benbruscella (benbruscella) wrote :

Registering for notifications for this fix.

Upgraded from 8.04 to 9.04 and cannot browse by name. Windows cannot see the ubuntu box, and ubuntu cannot see the windows box.

Worked fine in 8.04

Mark Ellse (markellse) wrote :

I'm still using 8.04 and am running 9.04 on test. Doesn't work for me in either version.

johnsdagg (johndaggett) wrote :

ubuntu network browsing on a windows peer-to-peer network worked for me in 7.04 and 7.10.

did not/does not work for me in 8.10 nor 9.04.

i'm running 9.04 now and the only way i can browse to my windows shares is to set the windows boxes to static IPs and then enter those IPs in the ubuntu hosts file.

Scott (d-scott-carroll) wrote :

I am having the same issue. SMB4K will browse the windows network reliably, but Dolphin will not. I am able to mount a windows share just fine using cifs. Konqueror fails the same way that Dolphin does. I am using a pretty much vanilla Jaunty install.

I have seen this work in Jaunty when it was set up to dual boot. This machine happens to be my laptop which is running Kubuntu dedicated.

adonet (jeroen-adolfse) wrote :

I'm having the same problems in Ubuntu 9.04 and in LInux Mint 7 (based on 9.04) I can't connect to any smb share on windows machines or on networkdrives.

Brad Needham (fishrcynic) wrote :

not an ubuntu issue - but interesting to note- a mixed xp pro - xp media center "workstations" with a win 2000 server and a win 2003 server - required wins server to be used to allow "workgroup" consistent connectivity (slightly simpler than
dns as servers are not internet connected but some workstations are - dhcp from router). Could be chasing our collective tails.

adonet (jeroen-adolfse) wrote :

Why does my freecom networkdrive (which isn't running any windows at all) and my networkprinter that's just connected to the router not show up in jaunty (9.04) and does in Hardy (8.04) and Intrepid (8.10)?
That suggests that it is not (only) a windows problem.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gvfs (Ubuntu):
status: Incomplete → New
adonet (jeroen-adolfse) wrote :

Allthough I'm not really a newby (3 years of Ubuntu now) This is too complicated for me.

M Angeles (neysa-angeles) wrote :

Not sure if relevant, but some timing information:

I installed 9.04 on my netbook about a month ago (July 2009) and I was able to browse and read files from shares and Windows drives on my home network which includes XP and Vista machines. I last tested it (ability to browse Windows files) to work about 10 days ago (July 28 or so). Today (Aug 8), I tried to look for the Windows drives from the netbook and now this bug now affects my netbook. I can see the windows PC names, but received the error "Unable to mount location. Failed to retrieve share list from server". Strangely, I was able to browse 1 PC (on XP) and not another (on Vista) when I had been able to browse both previously.

Reinstall of 9.04 on Aug. 8 using the latest 9.04 download resulted in more consistent behaviour in that I now receive the same said error message regardless of the XP or Vista pc I am trying to browse. I did successfully connect to both xp and Vista pc's using the smb://<ip.address> workaround as noted in this bug id.

Am an Ubuntu noob so apologies if post is unclear.

Mark Ellse (markellse) wrote :

Recent experience with the network leads me to believe that this is, at least in part, a Windows Browser-Master problem.
Windows is known to have trouble (some say it's broken) with browsing peer-to-peer networks. One computer in the network takes the role of being a browser master. There is a defined hierarchy of who does it - generally the machine that is on longest but has the more recent operating system. The browser-master is the machine that stores a list of host names and their ip addresses, enabling browsing of the network. I think that Linux machines on a Windows network rely on the Browser-Master for browsing.

Setting up a Windows computer as a broswser-master is inaccurately and incompletely documented and supported by Microsoft, who really you to have a Windows server. My experience that the process of a browser election can be completely confused if other machines are on the network, leading to unreliable browsing with both Windows and Linux. In particular it may be that a non-Windows DHCP server inhibits Windows machines from being browser-masters.

Browsing problems on our network seem to have disappeared since we've installed an SME server (www.contribs.org) AS A DOMAIN/WORKGROUP CONTROLLER. This has resolved our browsing problems.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of GVFS is available in both Lucid and Maverick and we are wondering if this is still reproducible in any of those versions, May you please test and give us of feedback about it? Thanks in advance.

Changed in gvfs:
status: New → Incomplete
Changed in gvfs (Ubuntu):
status: New → Incomplete
Brad Needham (fishrcynic) wrote :

2 upgrades amd64 lucid
1 fresh install x86 lucid
1 fresh install amd64 lucid
1 8.04 server
1 xp mce
2 xp home

without wins - same old intermittent nautilus / networking
(xp reports master browser issues interestingly enough)

will try to attempt this from

http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/NetworkBrowsing.html#browse-force-master

Forcing Samba to Be the Master

Who becomes the master browser is determined by an election process using broadcasts. Each election packet contains a number of parameters that determine what precedence (bias) a host should have in the election. By default Samba uses a low precedence and thus loses elections to just about every Windows network server or client.

If you want Samba to win elections, set the os level global option in smb.conf to a higher number. It defaults to 20. Using 34 would make it win all elections over every other system (except other Samba systems).
 ---------------------------------------------------------
will try making the ubuntu machines all 34 to see what happens
(maybe ubuntu needs to win the elections to fix the mixed os issue)

(works good with a wins server still)

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn how to do this at https://wiki.ubuntu.com/Bugs/Upstream/GNOME Thanks in advance!

Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Mark Ellse (markellse) wrote :

1. Apologies for the slow reply to this.
2. Since adding an SMEserver (www.contribs.org) to the network, the network
browsing problems have disappeared. I think that this is because SMEserver
acts as a WINS server by default. Adding the SME server coincided with an
upgrade to Ubuntu Jaunty on our network. So it may be that the upgrade to
Jaunty solved the problem, but I personally think that it was the WINS
server that solved the browsing problem.
3. You will see that I am not, now, able to report reliably that the problem
has been solved for peer-peer networks which mix Ubuntu and Windows machines
without a WINS server. Cheers, Mark

johnsdagg (johndaggett) wrote :

I'm not a Linux expert but I believe I've stumbled upon something that may help others debug/solve this problem - if you open FireStarter, go to Preferences/Advanced Options and UNCHECK "Block broadcasts from external network" the problem goes away.

Doesn't that mean that this is really an IPTABLES problem? That IPTABLES is accidentally blocking LAN Netbios broadcasts? That IPTABLES is mistakenly trreating LAN broadcasts as External network broadcasts?

It's not Nautilus. It's not Samba. It's IPTABLES.

Am I wrong?

tags: added: udd-find
Changed in gvfs (Debian):
status: Unknown → New

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, according to this report, you are not using the most recent version of this package for your Ubuntu release. Please upgrade to the most recent version and let us know if you are still having this issue. Thanks in advance.

Mark Ellse (markellse) wrote :

I am now running both the current Luicid and Precise distributions. With neither of them am I having any browsing problems at thee moment. At the same time staff are bringing in some Win8 machines and finding that these browse the net unreliably.
My experience is that Windows browsing of Windows networks is flaky and unreliable too.

is it still related to the debian gvfs package?

Changed in gvfs (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.