Cannot browse/mount Windows Server 2003 shares

Bug #215570 reported by Bálint Magyar on 2008-04-11
10
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

Ubuntu Hardy Beta with all updates as of date, upgraded from Gutsy.

I'm trying to reach SMB shares provided by a server running Windows Server 2003 (Active Directory login), through Nautilus. I get the "Failed to mount Windows share" error dialog, and an empty listing. It does not ask for my password, it's not in the keyring. smb://serverroot/ gives me a list of the shares as expected, trying to enter them results in the error.

Using "File > Connect to Server..." in Nautilus and filling in the login info results in the same error when pressing "Connect."

gnomevfs-ls and smbclient list the files correctly, gvfs-mount results in "Error mounting location: Failed to mount Windows share".

Browsing SMB shares provided by Samba on a Gentoo-based server works fine.

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid
Bálint Magyar (balintm) wrote :

Removed the duplicate mark as the other bug was getting crowded.

Pedro Villavicencio (pedro) wrote :

please do not unmark bugs marked as duplicate, if you don't want to get emails unsubscribe of the master one rather, thanks.

Steve Langasek (vorlon) wrote :

unmarking as a duplicate. This is not the same bug as 209520, which only affects authentication to older servers with weak encryption.

Changed in gvfs:
status: Invalid → New
Bálint Magyar (balintm) wrote :

Crossposting my relevant info from bug #209520:

"Updated the gvfs and samba related packages from hardy-proposed [on 24th June 2008]. Trying to reach a Windows Server 2003 share in an Active Directory domain environment through Nautilus' "Connect to Server..." resulted in the following message box after supplying the login info:

"Sorry, couldn't display all the contents of "smb": The specified location is not mounted"

Upon reloading the same Nautilus window, it produced the original "Unable to mount" message. Both before and after the update, connecting to a share on the server with smbclient works as intended (using the -U and -W arguments to specify login info).

I have talked about this to Sebastien Bacher earlier this month, but I guess it should be made public that I have talked to my supervisor at work about this and we can provide remote access to a Hardy box in a Windows Server 2003 domain environment for testing purposes. I would like to ask the developers to contact me if this will be needed and we will discuss the details in private."

As of today, browsing Windows 2003 shares works (i.e. it lists the available shares on the server correctly), actually listing the contents of the shares and mounting produces the above symptoms.

Antony Jones (wrh) wrote :

I would like to add my support to this bug as an ongoing, persistient, and irritating problem, which blocks my productivity in my day job.

Same situation, our server is Active Directory/Windows Server 2003.

Antony Jones (wrh) wrote :

This is now working after upgrading to Ubuntu 8.10. Thanks!

Mark Ellse (markellse) wrote :

Please see the bug below showing similar behaviour on Intrepid, together with some steps to isolate the problem.

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/316862

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty?

Sebastien Bacher (seb128) wrote :

did anybody try on jaunty?

Changed in gvfs (Ubuntu):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gvfs (Ubuntu):
status: Incomplete → Invalid

I'm running Jaunty right now and can confirm this bug still exists. I have two machines - one a Windows Server 2003 R2 machine, the other running Debian 5. Samba shares on the Debian machine are accessable no problem, but I cannot browse to shares on the Windows Server 2003 machine. The symptoms are exactly as described above.

Mark Ellse (markellse) wrote :

Recent experience with the network leads me to believe that this is, at least in part, a Windows Browser-Master problem.
Windows is known to have trouble (some say it's broken) with browsing peer-to-peer networks. One computer in the network takes the role of being a browser master. There is a defined hierarchy of who does it - generally the machine that is on longest but has the more recent operating system. The browser-master is the machine that stores a list of host names and their ip addresses, enabling browsing of the network. I think that Linux machines on a Windows network rely on the Browser-Master for browsing.

Setting up a Windows computer as a broswser-master is inaccurately and incompletely documented and supported by Microsoft, who really you to have a Windows server. My experience that the process of a browser election can be completely confused if other machines are on the network, leading to unreliable browsing with both Windows and Linux. In particular it may be that a non-Windows DHCP server inhibits Windows machines from being browser-masters.

Browsing problems on our network seem to have disappeared since we've installed an SME server (www.contribs.org) AS A DOMAIN/WORKGROUP CONTROLLER. This has resolved our browsing problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers