Ubuntu

nautilus does not display samba shares for machines inside an ADS network.

Reported by Renzo Bagnati on 2008-03-26
276
This bug affects 9 people
Affects Status Importance Assigned to Milestone
The Dell Mini Project
Undecided
Unassigned
gvfs
Fix Released
High
gvfs (Ubuntu)
High
Ubuntu Desktop Bugs
Hardy
High
Steve Langasek
Intrepid
High
Ubuntu Desktop Bugs
Jaunty
High
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs
Intrepid
Low
Unassigned
Jaunty
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Using hardy beta, when I browse with nautilus other machines in an Active Directory (ADS) network, some of them do not show their shared folders.
The ADS integration of the hardy box was done using winbind, kerberos and PAM libraries, essentially as described here:
https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto
The network contains mostly windows clients, but also several linux boxes, which were joined to the ADS domain with the command: 'net ads join'.
Machines running windows XP, windows 2003 and samba show '0 objects' in nautilus, but after inserting the complete path (eg.: smb://server/share) the folders can be accessed after the password prompt.
Machines running windows 2000 show their folders regularly.

Here is a detailed description of what happens:

Case 1 ---------------------------------------------------------------------------------
Browsing from hardy-beta a machine running ubuntu-gutsy server.

In a terminal window:

renbag@vm-hardy:~$ smbclient -L gutsy-server
Password: (password inserted here)
Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC IPC Service (gutsy-server (Samba 3.0.26a, Ubuntu))
 share Disk gutsy-server_share
Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]

In Nautilus:

Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines are displayed;
Double-click on the 'gutsy-server' icon --> after a while, Nautilus returns '0 objects', without asking for a password;
Insert the full address (smb://gutsy-server/share) --> a password is requested and the share content is displayed.

Case 2 ---------------------------------------------------------------------------------
Browsing from hardy-beta a machine running Windows XP

In a terminal window:

renbag@vm-hardy:~$ smbclient -L XP-ACQ
Password: (password inserted here)
Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC Remote IPC
 Data Disk
Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

In Nautilus:

Same behaviour as in case 1.
smb://XP-ACQ --> '0 objects';
smb://XP-ACQ/Data --> content displayed after password.

Case 3 ---------------------------------------------------------------------------------
Browsing from hardy-beta a machine running Windows 2000

In a terminal window:

renbag@vm-hardy:~$ smbclient -L TF-2000
Password: (password inserted here)
Domain=[LAB] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC Remote IPC
 Data Disk
Domain=[LAB] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

In Nautilus:

Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines are displayed;
Double-click on the 'TF-2000' icon --> All the shared folders are displayed, without asking for a password;
Double-click on the 'Data' folder icon --> a password is requested and the content is displayed.
(This is the correct and the expected behaviour).

Using ubuntu-gutsy boxes, with exactly the same samba configuration (smb.conf), to browse the same machines I never observed Nautilus return '0 objects' as in case 1 and 2.
Such a behaviour in hardy will make a normal user think that browsing an ADS network does not work at all.

Renzo Bagnati (renbag) wrote :
Mike Seeley (mseeley) wrote :

I have the Exact same Problem.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=524485

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Sebastien Bacher (seb128) wrote :

did you get asked for a password when browsing those shares in the previous version of nautilus?

Renzo Bagnati (renbag) wrote :

Yes, when using nautilus in gutsy a password is requested for browsing the machines in cases 1 and 2, but not in case 3.
I checked it also with a gutsy live CD, because the presence of gnome-keyring does make it difficult to say if browsing a share requires or not a password.
So the problem in hardy is that nautilus does not ask for it. In case 3 it shows the shares because they are browseable without password.

Changed in gvfs:
status: Unknown → New
Mike Seeley (mseeley) wrote :

Did the same steps as Renzo and I was able to recreate and confirm his findings.

darkrain42 (darkrain42) wrote :

I believe this bug is due to the fact that gvfs does not do any authentication for browsing a computer's shares (the smb-browse backend) whereas it does do authentication for connecting to a share (the smb backend).
I've produced a fairly hacky patch that grafts authentication into the smb-browse backend. It works for me.

Renzo Bagnati (renbag) wrote :

I have recompiled gvfs sources with Paul's patch and indeed it works inside my ADS network.
Tested with nautilus in all the cases I have reported and found no problems. A password prompt is displayed when needed, and all the machines can be browsed.
Now I really hope that this bug can be solved before the final release of hardy, otherways it will make it difficult to use hardy inside many networks that require browsing authentication. I think also that this bug should have a high priority.

wvengen (wvengen) wrote :

I've just applied the patch, and I can now browse using nautilus; great! Reinstalling the old packages breaks it again.

Nikolaus Filus (nfilus) wrote :

I think this bug is also responsible for not beeing able to see or browse a home share as a home share is only visible
if listing of shares is authenticated. This bug is reported upstream as
http://bugzilla.gnome.org/show_bug.cgi?id=520551

Sebastien Bacher (seb128) wrote :

the issue is not a nautilus one

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
Renzo Bagnati (renbag) wrote :

Acquiring a kerberos ticket from an AD server, using pam_winbind at login (or using kinit in a shell), allows a user to browse samba shares with its cached credentials.
This is described here:
https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto#head-a1da1a136c89873cbd7c7a1e1fbd75d621d18c9a

Maybe gvfs expects to find this or other authentications, but in any case this behaviour is different from what happened with gnomevfs in previous releases. Users should be aware of this.
I still think that a gvfs patch is needed to ask for a password when it is required, indipendently of kerberos tickets.

Sebastien Bacher (seb128) wrote :

the kerberos issue seems to be a different one, the issue described there is that smb browsing doesn't ask for credentials and those are sometime required

Changed in gvfs:
importance: Medium → High
Renzo Bagnati (renbag) wrote :

Sebastien: I found no issues with kerberos, I was only pointing out that acquiring a ticket at login allows subsequent browsing of password protected shares, because of the credentials already acquired. Infact this is also true after using the package likewise-open to join the AD domain, probably because it does the same type of authentication.

Steve Langasek (vorlon) on 2008-04-25
Changed in gvfs:
milestone: none → ubuntu-8.04.1
BeerSeller (levko-lb) wrote :

To darkrain42:
 Thank you very much for the patch

lic (madman-lic) wrote :

To darkrain42: your patch just super, thanks to great !!!!
To BeerSeller: Thanks showed that the right path and helped him pass

Pablo Estigarribia (pablodav) wrote :

I have the same problem, I can't see anything inside a windows machine with smb://machine
It doesn't display anything inside. I have the latest packages for Hardy

Amar (achandarana) wrote :

I think Darkrains patch will solve my problem. However, I'm new to linux and ubuntu, I would be grateful if someone can advise me on how to apply this patch.

Can anyone explain how to apply this patch? Thanks!

Renzo Bagnati (renbag) wrote :

To apply the patch you have to recompile gvfs from source. Instructions on how to do it can be found here:
http://www.debian.org/doc/manuals/apt-howto/ch-sourcehandling.html

After dowloading the sources you have to apply the gvfs.patch using the 'patch' command ('man patch', for instructions). However, some manual editing of the patch file may be needed, because it was made for an older gvfs version. But it should work also with the latest version.

David Horn (dhorn2000) wrote :

I just built with the latest gvfs trunk, and applied the patch (no changes required to patch) Works great. Thank you.

For those that want to try your hand at building this yourself, I kept track of what I did to build:

1)Read gnome.org developer instructions. You need Subversion installed to start.
2)Get gvfs trunk from subversion using: "svn co http://svn.gnome.org/svn/gvfs/trunk gvfs"
3)download patch -- direct link: http://launchpadlibrarian.net/13103721/gvfs.patch
4)backup original daemon/gvfsbackendsmbbrowse.c and /usr/lib/gvfs/gvfsd-smb-browse (source and binary)
5)download and apply above patch to the daemon/gvfsbackendsmbbrowse.c source file (i.e. "man patch" if unsure)
6)run ./autogen.sh --prefix=/usr/local in gvfs source (as per gnome.org dev instructions)
7)watch autogen/configure output closely as you will have errors unless you have built gvfs or gnome before
8)get all build dependancies (quite a few, be patient and repeat autogen {steps 6-8} as needed)
9)make sure that configure is building samba (configure output should say "Samba support: yes" at end. If this is not set to yes, you need the package "libsmbclient-dev" (e.g. sudo apt-get install libsmbclient-dev)
10)after successful compile, copy the newly built "gvfsd-smb-browse" file from the daemon/.libs/ directory to the expected location (/usr/lib/gvfs) If copy fails, you will need to be root, delete original file, then copy newly built one
11)Reboot
12) Enjoy the fix!

And now you have no trouble accessing password-protected shares?

MicioMax (max-veneto) wrote :

I can confirm it. With the patch applied I can browse my share as it happened in Gutsy, a password is requested when needed. Without the patch, password protected folders are simply not shown, even if I can connect to them entering the full path manually.

thanos (agelatos) wrote :

Hi

When can we know for sure if a fix for this will go to the hardy mainstream? Otherwise, can the person that built the patched gvfs backend post the binary somewhere?

Thanks a lot
Thanos

thanos (agelatos) wrote :

Being horribly impatient, I've compiled it myself following instructions from comment {https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/207072/comments/21}. Seems that it now works and my problems are solved.

If there is popular request I can provide the binary, even here, it is only 42KB gzipped.

Steve Langasek (vorlon) on 2008-05-08
Changed in nautilus:
status: New → Invalid
Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → High
milestone: none → ubuntu-8.04.1
status: New → Triaged
Steve Langasek (vorlon) on 2008-05-08
Changed in gvfs:
milestone: ubuntu-8.04.1 → none
Alan Hoffman (alan426) wrote :

Yes please!!!!!

Jim McKean (jimmckean) wrote :

Oh yeah!

thanos (agelatos) wrote :

Hi

Attached is the 42K gzip'ed executable compiled for i386 32bit Hardy ONLY. It is virus free and when gunzipped has the MD5SUM of 77081f6e6dcc42448c5de355132ad582
Should be copied as per instructions in #21 (steps 10,11), and works for me up to now (no updates pending).

*** HIGH RISK DISCLAIMER ***
use at your own risk, no guarantees either expressed or implied. May fit particular purpose. Do not wish to be contacted and will reject any communications with regards to this executable. Do not use if MD5 does not match.
*** HIGH RISK DISCLAIMER ***

thanos (agelatos) wrote :

Added screenshot verifying MD5SUM and showing size of executable.

cRoW2k (crow2k) wrote :

Work for me, thanks :)

Ondřej Cífka (ondra-cifka) wrote :

I can confirm the bug but the patch doesn't work for me (I try to go to smb://192.168.0.2/shared, it prompts me for the username and password and then it says 'Couldn't display "smb://192.168.0.2/shared/". Error: Failed to mount Windows share
Please select another viewer and try again.').

  • unnamed Edit (1.7 KiB, text/html; charset=ISO-8859-2)

Some things to check:

1. Make sure that the executable is replaced and no "Update Manager" has
done any updates.
2. Verify MD5 of the executable I've provided vs. the executable in the
final location

File size in bytes: 108656
File name: gvfsd-smb-browse

$ file gvfsd-smb-browse
gvfsd-smb-browse: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped

File MD5: 77081f6e6dcc42448c5de355132ad582

3. Reboot machine

If all this is done, then it seems you have an updated/predated gvfs....

On Tue, May 20, 2008 at 5:20 PM, Ondřej Cífka <email address hidden> wrote:

> I can confirm the bug but the patch doesn't work for me (I try to go to
> smb://192.168.0.2/shared, it prompts me for the username and password and
> then it says 'Couldn't display "smb://192.168.0.2/shared/". Error: Failed
> to mount Windows share
> Please select another viewer and try again.').
>
> --
> nautilus does not display samba shares for machines inside an ADS network.
> https://bugs.launchpad.net/bugs/207072
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--

Thanos

thanos (agelatos) wrote :

With ref to comment #31, it seems that either

a) the instructions from #21 are not followed - please retry
b) the machine is not updated or is updated with newer version of gvfs....

Some things to check:

1. Make sure that the executable is replaced and no "Update Manager" has done any updates.
2. Verify MD5 of the executable I've provided vs. the executable in the final location

File size in bytes: 108656
File name: gvfsd-smb-browse

$ file gvfsd-smb-browse
gvfsd-smb-browse: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped

File MD5: 77081f6e6dcc42448c5de355132ad582

3. Reboot machine

Ondřej Cífka (ondra-cifka) wrote :

I have already retried. The two files are the same (I also compared them via cmp). My gvfs version is 0.2.3-0ubuntu5. And yes, the update manager has done an update to nautilus (installed version: 1:2.22.2-0ubuntu6).

Just to let you know I've experienced this bug on two Hardy machines in my home. I've also got XP, Vista machines that can see and access all smb shares.

My smb.conf is very similar to the guide outlined here: http://www.ubuntugeek.com/howto-setup-samba-server-with-tdbsam-backend.html

Nautilus fails at browsing any shares. Although, I can mount a non authenticated share via terminal.

In reply to thanos,

Thanks for posting the patch. I verified md5 sum and I've renamed the old executable to gvfsd-smb-browse.bak and copied your patched one into /usr/lib/gvfs and rebooted. I've got a different problem now. Now when I try to browse the network I get this error: Failed to execute child process "/usr/lib/gvfs/gvfsd-smb-browse" (Permission denied).

Apparently I screwed up the permissions along the way. Not sure how. I did everything as root, renamed old file and copied new one to the path. I do notice when I do a list in terminal it's the only file in /usr/lib/gvfs that isn't highlighted green.

Any feedback would be appreciated.

obscure detour

darkrain42 (darkrain42) wrote :

obscure_detour:
The file you installed is not marked as executable. As root, do:
# chown root:root /usr/lib/gvfs/gvfsd-smb-browse
# chmod 755 /usr/lib/gvfs/gvfsd-smb-browse

and that will give the file the appropriate permissions and ownership.

Ondřej Cífka:
Your problem with mounting smb://192.168.0.2/shared/ may be unrelated to the patch, as the patch should only affect the listing of shares (so smb://192.168.0.2), not actually connecting to a share.

thanos (agelatos) wrote :

Apologies for the omission, it was too obvious for me that the file should become chown'ed by root:root and executable...

-rwxr-xr-x 1 root root 108656 2008-05-08 12:06 /usr/lib/gvfs/gvfsd-smb-browse

Ondřej Cífka (ondra-cifka) wrote :

#36: So that's the problem... For me, the listing of shares is correct, but their contents are not displayed. Is that another bug? I can connect to the share from Windows and Gutsy with no problems.

Thank you darkrain42 and thanos. I apologize as I'm not as experienced as the rest :) I'll try it and comment my results.

Cheers,

obscure detour

Well it fixed it for the most part. Thank you thanos for uploading the patched file. I am able to access all my shares using nautilus. However, I still have to type in the share path.

Simply browse to "Network" and then to "Windows Network" it just thinks and errors out with; "Cannot open smb:///" or if you actually do get it to browse into "Windows Network" and click on the domain, it errors out with; "There is not a known application for this file type". Nautilus also errors out if I type in "smb://".

If I simply type "smb://host/sharename" host being either the hostname or the ip address and sharename it works perfectly. Just like Gusty :) Nautilus asks me for auth, and off we go.

Thanks again.

obscure detour

Changed in gvfs:
status: New → Confirmed
Steve Langasek (vorlon) on 2008-06-20
Changed in gvfs:
milestone: ubuntu-8.04.1 → none
status: Triaged → Fix Committed
Steve Langasek (vorlon) on 2008-06-20
Changed in gvfs:
milestone: none → ubuntu-8.04.1
Steve Langasek (vorlon) on 2008-06-20
Changed in gvfs:
status: Fix Committed → In Progress
Steve Langasek (vorlon) on 2008-06-27
Changed in gvfs:
milestone: ubuntu-8.04.1 → none
FAJALOU (fajalou) on 2008-12-05
Changed in nautilus:
status: Invalid → In Progress
Martin Pitt (pitti) on 2008-12-05
Changed in nautilus:
status: In Progress → Invalid
Changed in gvfs:
status: Confirmed → In Progress
Changed in gvfs:
status: In Progress → Fix Released
Changed in gvfs:
status: Triaged → Fix Committed
Changed in gvfs:
status: Fix Committed → Fix Released
Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: New → Confirmed
Martin Pitt (pitti) on 2009-01-23
Changed in gvfs:
status: Confirmed → Fix Committed
Changed in nautilus:
status: New → Fix Committed
Steve Langasek (vorlon) on 2009-01-24
Changed in gvfs:
milestone: none → ubuntu-8.04.3
Changed in nautilus:
status: Invalid → Confirmed
Changed in gvfs:
status: Fix Committed → Fix Released
166 comments hidden view all 246 comments
Laubstein (laubstein) wrote :

Today I received the updates to gvfs (1.0.2-0ubuntu2) and, finally, now I can browse the shares \o/ (nearly 1 year later).

Thanks all the patcher's!

Turbo (axelhc) wrote :

Hi everyone.

I'm very happy! This annoying bug was finally patched. At home is harder to try but in my work place I have a full patched Ubuntu 8.10.

This morning I patched and rigth away tried to navigate several XP computer with success after Ubuntu ask me for the Domain user & pass. So far so good BUT when you try to add a new printer by navegating the SMB shares, THE PRINTERS IN XP ARE NOT VISIBLE... Quite strange as the mecanism should be the same. I ask you all to try this process and confirm.

Regards.

Turbo.

PD: If I get the chance, will try to post images.
;-)

Matthijs ten Kate (igadget) wrote :

Sorry guys, but it's still not working in our situation (connecting from a fully patched 8.10 box to our IBM iSeries running i5/OS version 6r1m0 with i5/OS NetServer).

When I try to browse the server using smb://server in nautilus, I get the following error:

Could not display "smb://server".
Error: Failed to retrieve share list from server
Please select another viewer and try again.

See attached screenshot.

Connecting from an XP box works flawlessly.

Connecting from the same 8.10 box to an Ubuntu 8.04.2 server running Samba, it works fine.

I can imagine that our problem is not fully related to the original bug since the i5/OS NetServer software wasn't compiled by our friend from Redmond, so if I need to file a new bug for our situation, please let me know.

On Mon, Mar 02, 2009 at 03:40:39PM -0000, Matthijs ten Kate wrote:
> I can imagine that our problem is not fully related to the original bug
> since the i5/OS NetServer software wasn't compiled by our friend from
> Redmond, so if I need to file a new bug for our situation, please let me
> know.

Unless your NetServer is part of an AD realm and you've also configured your
Ubuntu workstation for AD, yes, your bug is unrelated and you should file a
new bug.

But this may be bug #209520.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Sebastien Bacher (seb128) wrote :

the feedback has been good on intrepid and jaunty let's upload to hardy now

Sebastien Bacher (seb128) wrote :

the update has been moved to intrepid-updates

Changed in nautilus (Ubuntu Intrepid):
importance: Undecided → Low
status: Fix Committed → Fix Released
Changed in nautilus (Ubuntu Hardy):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
1 comments hidden view all 246 comments
FAJALOU (fajalou) wrote :

Sebastien,
           I tried to implement your .debdiff following the instructions from here:
https://wiki.ubuntu.com/UbuntuPackagingGuide/BuildFromDebdiff?highlight=(debdiff)
And after following those steps I ended up with five different (related) nautilus.deb s.
Now they all have different parts ie one is nautilus, one debug, data, extensions, dev, so I just went and installed all of them. I then attempted to restart Nautilus, which went smoothly, but when I opened up my network, and going to a computer, it still does not show things inside that computer. It is interesting though, because smbtree also does not show the things, which makes me wonder.......

On the other hand, when I try to connect to a computer via ip address (smb://192.168.1.100/) the same thing as above occurs. It could possible be that I configured the .deb s wrong, but I don't think I did. Anyways, any suggestion would be appreciated!
Thanks.

Martin Pitt (pitti) wrote :

Accepted gvfs into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gvfs (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in nautilus (Ubuntu Hardy):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted nautilus into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) on 2009-04-27
tags: removed: verification-done
Renzo Bagnati (renbag) wrote :

Sebastien,

looks like that in the current gvfs packages in hardy-proposed the 95_svn_change_fix_smb_browsing.patch was not really applied. The patch file in the source contains a typo:

--- gvfs-1.0.2.orig/debian/patches/91_svn_change_fix_smb_browsing.patch
+++ gvfs-1.0.2/debian/patches/91_svn_change_fix_smb_browsing.patch

should be:

--- gvfs-1.0.2.orig/debian/patches/95_svn_change_fix_smb_browsing.patch
+++ gvfs-1.0.2/debian/patches/95_svn_change_fix_smb_browsing.patch

Sebastien Bacher (seb128) wrote :

Thank you for noticing I uploaded a fixed version

Martin Pitt (pitti) wrote :

Accepted gvfs into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Renzo Bagnati (renbag) wrote :

I have tested the gvfs and nautilus packages in hardy-proposed. Here are the problems I found (they are essentially the same described some time ago in the upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=524485#c57

In virtualbox running ubuntu 8.04.2:

When the machine is not joined to an AD domain (LAB), opening the Network Servers icon puts me in network:///, showing the "Windows Network" icon.
Clicking on "Windows Network" I enter smb:/// but nautilus reports: 0 objects
Inserting manually smb://LAB/ in the location bar I am asked for a password and after inserting the credentials of a domain user I can access the list of the machines. Share browsing can be done without problems.

When the machine is joined to an AD domain (LAB) and I login as a local user the situation is as described above.

When the machine is joined to AD domain (LAB) and I login as a domain user (with kerberos ticket), opening the Network Servers icon puts me directly in smb://LAB. Share browsing can be done without problems (but this was also possible without the patched gvfs).

So, with the proposed packages there are problems in browsing the Windows Network (smb:///) with machines not joined to an AD domain or in the absence of kerberos tickets. From the normal user point of view, this situation is probably worse than before.

Martin Pitt (pitti) on 2009-05-11
tags: added: regression-proposed verification-failed
removed: verification-needed
Sebastien Bacher (seb128) wrote :

could you try if the new issue is there in jaunty too?

Download full text (4.2 KiB)

yep, I have 9.04 installed so will try to run tests today and will let you
know

2009/5/11 Sebastien Bacher <email address hidden>

> could you try if the new issue is there in jaunty too?
>
> --
> nautilus does not display samba shares for machines inside an ADS network.
> https://bugs.launchpad.net/bugs/207072
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Fix Released
> Status in “gvfs” source package in Ubuntu: Fix Released
> Status in “nautilus” source package in Ubuntu: Invalid
> Status in gvfs in Ubuntu Hardy: Fix Committed
> Status in nautilus in Ubuntu Hardy: Fix Committed
> Status in gvfs in Ubuntu Intrepid: Fix Released
> Status in nautilus in Ubuntu Intrepid: Fix Released
> Status in gvfs in Ubuntu Jaunty: Fix Released
> Status in nautilus in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: nautilus
>
> Using hardy beta, when I browse with nautilus other machines in an Active
> Directory (ADS) network, some of them do not show their shared folders.
> The ADS integration of the hardy box was done using winbind, kerberos and
> PAM libraries, essentially as described here:
> https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto
> The network contains mostly windows clients, but also several linux boxes,
> which were joined to the ADS domain with the command: 'net ads join'.
> Machines running windows XP, windows 2003 and samba show '0 objects' in
> nautilus, but after inserting the complete path (eg.: smb://server/share)
> the folders can be accessed after the password prompt.
> Machines running windows 2000 show their folders regularly.
>
> Here is a detailed description of what happens:
>
> Case 1
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running ubuntu-gutsy server.
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L gutsy-server
> Password: (password inserted here)
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
> Sharename Type Comment
> --------- ---- -------
> IPC$ IPC IPC Service (gutsy-server (Samba 3.0.26a, Ubuntu))
> share Disk gutsy-server_share
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
>
> In Nautilus:
>
> Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines
> are displayed;
> Double-click on the 'gutsy-server' icon --> after a while, Nautilus returns
> '0 objects', without asking for a password;
> Insert the full address (smb://gutsy-server/share) --> a password is
> requested and the share content is displayed.
>
> Case 2
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running Windows XP
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L XP-ACQ
> Password: (password inserted here)
> Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
> Sharename Type Comment
> --------- ---- -------
> IPC$ IPC Remote IPC
> Data Disk
> Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
>
> In Nautilus:
>
> Same behaviour as in case 1.
> smb://XP-ACQ --> '0 objects';
> smb://XP-ACQ/Data --> content displayed after password.
>
...

Read more...

Renzo Bagnati (renbag) wrote :

No, the issues of comment 220 are not present in jaunty and in intrepid. They are specific of hardy and of the 95_svn_change_fix_smb_browsing.patch, since reverting to the version of gvfs in hardy-updates restores the ability to browse the smb:/// Windows Network (but not, of course, the domain shares).

Martin G Miller (mgmiller) wrote :

I maintain 2 networks with mixed ubuntu / Windows XP SP2 machines and this problem has not been resolved for me. All of my Ubuntu machines whether they are clean installs of 8.04 or 8.10 or 9.04, 32 or 64 bit or upgrades from earlier versions all exhibit the failure to display or browse smb shares. The only fix is to edit etc/samba/smb.conf:
# What naming service and in what order should we use to resolve host names
# to IP addresses
 ; name resolve order = lmhosts host wins bcast

remove the leading ; from the name resolve order line and change the order of the entries to read:
   name resolve order = lmhosts wins bcast host

Save the file, log off and back on.

This change fixes the problem for all my machine in both networks.
The problem remains unresolved in Jaunty unless I do this. This problem appeared suddenly in September of 2008 on 8.04 machines that had been working normally and has persisted through 8.10 and now 9.04.

Download full text (4.5 KiB)

Is there a need to test it on 8.10 then?

2009/5/11 Renzo Bagnati <email address hidden>

> No, the issues of comment 220 are not present in jaunty and in intrepid.
> They are specific of hardy and of the
> 95_svn_change_fix_smb_browsing.patch, since reverting to the version of
> gvfs in hardy-updates restores the ability to browse the smb:/// Windows
> Network (but not, of course, the domain shares).
>
> --
> nautilus does not display samba shares for machines inside an ADS network.
> https://bugs.launchpad.net/bugs/207072
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gvfs: Fix Released
> Status in “gvfs” source package in Ubuntu: Fix Released
> Status in “nautilus” source package in Ubuntu: Invalid
> Status in gvfs in Ubuntu Hardy: Fix Committed
> Status in nautilus in Ubuntu Hardy: Fix Committed
> Status in gvfs in Ubuntu Intrepid: Fix Released
> Status in nautilus in Ubuntu Intrepid: Fix Released
> Status in gvfs in Ubuntu Jaunty: Fix Released
> Status in nautilus in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: nautilus
>
> Using hardy beta, when I browse with nautilus other machines in an Active
> Directory (ADS) network, some of them do not show their shared folders.
> The ADS integration of the hardy box was done using winbind, kerberos and
> PAM libraries, essentially as described here:
> https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto
> The network contains mostly windows clients, but also several linux boxes,
> which were joined to the ADS domain with the command: 'net ads join'.
> Machines running windows XP, windows 2003 and samba show '0 objects' in
> nautilus, but after inserting the complete path (eg.: smb://server/share)
> the folders can be accessed after the password prompt.
> Machines running windows 2000 show their folders regularly.
>
> Here is a detailed description of what happens:
>
> Case 1
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running ubuntu-gutsy server.
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L gutsy-server
> Password: (password inserted here)
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
> Sharename Type Comment
> --------- ---- -------
> IPC$ IPC IPC Service (gutsy-server (Samba 3.0.26a, Ubuntu))
> share Disk gutsy-server_share
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
>
> In Nautilus:
>
> Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines
> are displayed;
> Double-click on the 'gutsy-server' icon --> after a while, Nautilus returns
> '0 objects', without asking for a password;
> Insert the full address (smb://gutsy-server/share) --> a password is
> requested and the share content is displayed.
>
> Case 2
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running Windows XP
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L XP-ACQ
> Password: (password inserted here)
> Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
> Sharename Type Comment
> --------- ---- -------
> IPC$ IPC Remote IPC
> Dat...

Read more...

Sebastien Bacher (seb128) wrote :

the name resolution issue is a different one, could you open a new bug?

Changed in gvfs (Ubuntu Hardy):
milestone: ubuntu-8.04.3 → none
milestone: none → ubuntu-8.04.3
Steve Langasek (vorlon) wrote :

rolling this back to 'triaged' since the fix in hardy-proposed seems to not work. I'm uploading a new gvfs package to hardy-proposed with this patch reverted, and trying to fix bug #216104.

Changed in gvfs (Ubuntu Hardy):
status: Fix Committed → Triaged
Martin G Miller (mgmiller) wrote :

I have now helped a friend install 32 bit Jaunty on his office network. All work stations are clean installs of Jaunty that need to browse his file server which is Windows server 2003. He also has some printers attached to and shared by his Ubuntu work stations that need to print from the file server. With a stock install, all the network browsing issues are present, as well as many intermittent shared printing failures. If I edit smb.conf as I noted earlier, to change the resolve order, every thing works correctly. This now confirms that every machine I have installed on 3 separate networks in 3 different towns all exhibit this problem. A total of more than 12 machines. None of them work correctly out of the box.

One piece of the puzzle is that both of the ISP's involved with all these machines are using DNS redirection. The problem I originally had coincided exactly with the day my ISP started using redirection on my 2 networks. This does not seem to affect the kde network browser and does not affect the network browser in Windows XP pro SP2 or Windows Server 2003. It does adversely affect network browsing in Nautilus.

Something about DNS redirection causes network browsing failures in Nautilus.

On Thu, Jun 18, 2009 at 01:27:49PM -0000, Martin G Miller wrote:

> Something about DNS redirection causes network browsing failures in
> Nautilus.

That is unrelated to this bug report.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

The proposed fix was pulled from hardy-proposed, but Steve made it available again on his PPA at http://ppa.launchpad.net/vorlon/ppa/ubuntu for further confirmation of the regression.

Using gvfs and gvfs-backends 0.2.5-0ubuntu8~ppa1 from there, along with nautilus 2.22.5.1-0ubuntu1 from hardy-updates, I get exactly the same results described by Renzo Bagnati in comment 220. The Ubuntu machine is up-to-date and joined to an AD using likewise-open.

I also experience the same behavior using nautilus 2.22.5.1-0ubuntu2 from hardy-proposed.

Steve Langasek (vorlon) wrote :

As requested by Martin, here are the steps to reproduce the regression:

1.Install Ubuntu 8.04.2 on one system.
2. Install the samba package on a second system (virtual machine or otherwise - just make sure it shares a broadcast domain with your hardy desktop test system). Make sure that this host has a different name from the 8.04.2 desktop system.
3. Open the Windows network (Places -> Network).
4. Click on 'Windows Network'.
5. Verify that 'WORKGROUP' is displayed.
6. Click on 'WORKGROUP' and verify that the samba server is shown.
7. Install gvfs and gvfs-backends from http://ppa.launchpad.net/vorlon/ppa/ubuntu on the 8.04.2 system.
8. Log out of the system and log back in.
9. Repeat steps 3 and 4.
10. Verify that 'WORKGROUP' is *not* displayed.
11. Manually open a nautilus window to 'smb://WORKGROUP'. Verify that you are prompted for a password.
12. Debug
13. Profit!

I unfortunately haven't been able to run this test case myself because I don't have a hardy desktop to run it from; if any of this doesn't work as described, please shout.

Martin Pitt (pitti) wrote :

Just in case it's useful, I reproduced the regression with a hardy chroot, using only command line tools:

 1. Install samba on outside system

 2. Kill all gvfs stuff (outside and inside chroot):

   $ ps ux|grep gvfs|awk '{print $2}'|xargs kill

 3. Mount gvfs smb and list it in hardy chroot:

    $ dchroot -c hardy
    [hardy] $ dbus-launch bash
    [hardy] gvfs-mount smb:
    [hardy] $ gvfs-ls smb://
    WORKGROUP

 4. Now install gvfs and gvfs-backends from http://ppa.launchpad.net/vorlon/ppa/ubuntu in hardy chroot

 5. Re-do step 2 and 3; gvfs-ls will print nothing

Martin Pitt (pitti) wrote :

Sebastien and Steve are working on this. This might also need a samba upgrade, since current testing showed that the gvfs patch uses some libsmbclient features which apparently didn't work yet in hardy's samba version. So either these need to be backported or we need to change the gvfs patch to get along with hardy's libsmbclient version.

Changed in gvfs (Ubuntu Hardy):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Sebastien Bacher (seb128)
status: Triaged → In Progress
Steve Langasek (vorlon) on 2009-07-15
Changed in gvfs (Ubuntu Hardy):
assignee: Sebastien Bacher (seb128) → Steve Langasek (vorlon)
milestone: ubuntu-8.04.3 → ubuntu-8.04.4
Steve Langasek (vorlon) wrote :

As with so many other bugs, the solution is trivial once the problem can be pinpointed. Here is the debdiff for hardy-proposed, fixing this bug at last.

The new patch indicates a bug in daemon/libsmb-compat.h which is still present upstream in the latest version, so ideally the patch should be forwarded upstream; but given that this is a compat header for older versions of samba (hardy and earlier), it's not worth applying the patch separately to karmic.

Steve Langasek (vorlon) on 2009-07-15
Changed in nautilus (Ubuntu Hardy):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-07-15
tags: removed: qa-jaunty-desktop regression-proposed verification-failed
Download full text (4.5 KiB)

it really would be nice to able to configure the Domain-Server or Workgroup
of a MS-Net when you install Ubuntu or be able to search it automatically.

You must fiddle around with config files to get the correct name.

Older versions had a configuration (The old network manager) to setup this.

I also have that problem with Nautilus.

2009/7/15 Martin Pitt <email address hidden>

> ** Tags removed: qa-jaunty-desktop regression-proposed verification-
> failed
>
> --
> nautilus does not display samba shares for machines inside an ADS network.
> https://bugs.launchpad.net/bugs/207072
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in gvfs: Fix Released
> Status in “gvfs” package in Ubuntu: Fix Released
> Status in “nautilus” package in Ubuntu: Invalid
> Status in gvfs in Ubuntu Hardy: In Progress
> Status in nautilus in Ubuntu Hardy: Fix Released
> Status in gvfs in Ubuntu Intrepid: Fix Released
> Status in nautilus in Ubuntu Intrepid: Fix Released
> Status in gvfs in Ubuntu Jaunty: Fix Released
> Status in nautilus in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: nautilus
>
> Using hardy beta, when I browse with nautilus other machines in an Active
> Directory (ADS) network, some of them do not show their shared folders.
> The ADS integration of the hardy box was done using winbind, kerberos and
> PAM libraries, essentially as described here:
> https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto
> The network contains mostly windows clients, but also several linux boxes,
> which were joined to the ADS domain with the command: 'net ads join'.
> Machines running windows XP, windows 2003 and samba show '0 objects' in
> nautilus, but after inserting the complete path (eg.: smb://server/share)
> the folders can be accessed after the password prompt.
> Machines running windows 2000 show their folders regularly.
>
> Here is a detailed description of what happens:
>
> Case 1
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running ubuntu-gutsy server.
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L gutsy-server
> Password: (password inserted here)
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
> Sharename Type Comment
> --------- ---- -------
> IPC$ IPC IPC Service (gutsy-server (Samba 3.0.26a, Ubuntu))
> share Disk gutsy-server_share
> Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]
>
> In Nautilus:
>
> Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines
> are displayed;
> Double-click on the 'gutsy-server' icon --> after a while, Nautilus returns
> '0 objects', without asking for a password;
> Insert the full address (smb://gutsy-server/share) --> a password is
> requested and the share content is displayed.
>
> Case 2
> ---------------------------------------------------------------------------------
> Browsing from hardy-beta a machine running Windows XP
>
> In a terminal window:
>
> renbag@vm-hardy:~$ smbclient -L XP-ACQ
> Password: (password inserted here)
> Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
> Sharename Type Comment
>...

Read more...

Renzo Bagnati (renbag) wrote :

Thank you very much, Steve, for fixing this bug.
I have applied your patch by recompiling gvfs from source and now the browsing of the network and of the shares is working as expected.
However I'm still experiencing a known issue with nautilus: double clicking the first time on a share icon does not open a new window, I have to double click again a second time to actually open it. This should have been fixed by the 91_svn_change_new_mounts_correctly_displayed.patch reported here: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/251809/comments/47
Looking at the changelogs of the nautilus version in hardy I did not find a mention to this patch. From what I'm seeing, looks like it was not applied.
This issue was described in comments #47 to #50 of the upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=524485#c50

On Wed, Jul 15, 2009 at 09:38:57AM -0000, Renzo Bagnati wrote:
> However I'm still experiencing a known issue with nautilus: double
> clicking the first time on a share icon does not open a new window, I
> have to double click again a second time to actually open it. This should
> have been fixed by the 91_svn_change_new_mounts_correctly_displayed.patch
> reported here:
> https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/251809/comments/47
> Looking at the changelogs of the nautilus version in hardy I did not find a
> mention to this patch. From what I'm seeing, looks like it was not applied.

That patch is applied in nautilus 1:2.22.5.1-0ubuntu2, which is newly
accepted into hardy-updates.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Renzo Bagnati (renbag) wrote :

Sorry for not having noticed in the changelogs that the patch was introduced in nautilus 1:2.22.5.1-0ubuntu2
I was already using it with all hardy-updates. However, since I was still seeing that behaviour, I tried to build nautilus from source. This is the relevant output of dpkg-buildpackage:

...
Applying patch 90_from_svn_dont_allow_recursive_copies.patch
patching file libnautilus-private/nautilus-file-operations.c
Hunk #1 succeeded at 3352 (offset 131 lines).
Hunk #2 succeeded at 3412 (offset 131 lines).
Hunk #3 succeeded at 3974 (offset 131 lines).

Applying patch 91_svn_change_new_mounts_correctly_displayed.patch
patching file debian/patches/91_svn_change_new_mounts_correctly_displayed.patch

Applying patch 99_ltmain_as-needed.patch
patching file ltmain.sh
...

The 91_svn_change_new_mounts_correctly_displayed.patch file actually patches itself, instead of the file which was supposed to (nautilus-mime-actions.c).

Steve Langasek (vorlon) wrote :

ok, setting this back to 'in progress' for nautilus.

Changed in nautilus (Ubuntu Hardy):
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Seb uploaded a fixed nautilus package to the queue. Stalling until
8.04.3 is released.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Martin Pitt (pitti) wrote :

Accepted nautilus into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gvfs (Ubuntu Hardy):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted gvfs into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Renzo Bagnati (renbag) wrote :

After installing the latest gvfs and nautilus from hardy-proposed, I can say that all is working well now, like in intrepid and jaunty.
Thanks again to all the developers!

Steve Langasek (vorlon) on 2009-07-20
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 0.2.5-0ubuntu8

---------------
gvfs (0.2.5-0ubuntu8) hardy-proposed; urgency=low

  * Reintroduce patch 95_svn_change_fix_smb_browsing.patch.
  * debian/patches/97_fix_smb_compat.patch: Fix daemon/libsmb-compat.h
    to allow *un*setting the anonymous auth variable, in addition to
    setting it. LP: #207072.

 -- Steve Langasek <email address hidden> Thu, 25 Jun 2009 21:54:50 +0000

Changed in gvfs (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.22.5.1-0ubuntu3

---------------
nautilus (1:2.22.5.1-0ubuntu3) hardy-proposed; urgency=low

  * debian/patches/91_svn_change_new_mounts_correctly_displayed.patch:
    - correctly apply now (lp: #207072)

 -- Sebastien Bacher <email address hidden> Thu, 16 Jul 2009 12:40:50 +0200

Changed in nautilus (Ubuntu Hardy):
status: Fix Committed → Fix Released
Changed in gvfs:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 246 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.