Remote Samba shares not showing up in Nautilus through network:///

Bug #193232 reported by Ricardo L. Febrero on 2008-02-19
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
High
nautilus (Fedora)
Fix Released
High
nautilus (Ubuntu)
Low
Unassigned
Declined for Hardy by Sebastien Bacher

Bug Description

I'm having the same problems as in this closed bug:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/26933
The thing is that I open Nautilus, browse my Samba Network and it's empty. I can connect directly to the server, but it does not get listed. Also, sometimes they show up, but when I click on a Samba service, for example, to IP 192.168.0.2, a message tells me that I have to open it with some program, because it's not a link!! (WTF). Then, it gets previewed as a text file.

I'm using Ubuntu Gutsy, 32bit for clients; server is a SuSE 10.2, Samba. Windows Vista clients get it listed when I browse the network.
We're trying to switch to Linux in the company I work for, but we're having trouble with Samba, so people's getting a bit angry.

Sometimes servers get listed, then I try to connect to them, but it's impossible, because I'm not asked any password, nor user. It just gets empty again.
I'm going to try to debug it someway (please, tell me how), and post some screenshots.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does using a command line client, smb for example, work correctly? Could you try on hardy using the new gvfs nautilus?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

Yes, command line client works fine. I have to try the new nautilus, I
haven't heard about gvfs before. I'm telling you. Good work, anyways.
Thanks!!

2008/2/20, Sebastien Bacher <email address hidden>:
> Thank you for your bug. Does using a command line client, smb for
> example, work correctly? Could you try on hardy using the new gvfs
> nautilus?
>
> ** Changed in: nautilus (Ubuntu)
> Importance: Undecided => Low
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
> Status: New => Incomplete
>
> --
> Remote Samba shares not showing up in Nautilus through network:///
> https://bugs.launchpad.net/bugs/193232
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Néstor Amigo Cairo
+34 687 96 74 81
<email address hidden>

drose (ditmar-rose) wrote :

I have the same or at least similar problem : I use Nautilus to browse a WindowsXP share. The UbuntuServer and the WindowsXP-Laptop are shown in Nautilus. But when i open the WindowsXP then no shared directories are displayed. It looks like the WindowsXP has not shared any ressource. But i can browse them by using an other Windows-PC.

I am using HARDY Alpha 6 with latest updates (8th. of march 2008). The WindowsXP-Laptop has a (ADP?) domain account as well as a local account.

I don´t know how to use the command line client to find more information about the problem.

Sebastien Bacher (seb128) wrote :

does it work using smbclient on a command line or does it has the same issue?

renbag (renbag) wrote :

I am experiencing a similar problem with hardy installed in a virtual machine and with up-to-date packages.
When I try to browse machines in a mixed environment some of them do not show any shared folders in nautilus.
The network is using ADS and is controlled by a windows 2003 server.
Machines running windows XP, windows 2003 and samba show '0 objects' in nautilus, but after inserting the complete path (eg.: smb://server/share) the folders can be accessed after the password prompt.
Machines running windows 2000 show their folders regularly.
I have observed the same behaviour using a hardy-alfa6-live CD, without any editing of smb.conf or other configurations.
In the same network environment there are several machines, running ubuntu gutsy and debian etch, which do not have similar problems.

FaberfoX (faberfox) wrote :

I just wanted to confirm this bug on a fresh install of alpha6 and after all patches. Both network:/// and smb:/// show no servers. Network has 1 pc running vista, 1 running WHS + another laptop running gutsy. smbtree returns the full workgroup list after entering password. smb://server/share works and shows contents properly.

Sebastien Bacher (seb128) wrote :

are those shares in the same workground as the hardy box?

renbag (renbag) wrote :

I suppose you mean "workgroup".
In my case, when using the hardy-alfa6-live CD the box was not in the same workgroup as the others.
However, the virtual machine running up-to-date hardy was integrated in the same domain of all other network machines (including those running gutsy and debian, which do not show the bug). The ADS integration was done using winbind, kerberos and PAM libraries, essentially as described here:
https://help.ubuntu.com/community/ActiveDirectoryWinbindHowto

drose (ditmar-rose) wrote :

Updated to Hardy Beta : bug is confirmed.
Tried commandline and got :

drose@UbuntuServer:~$ smbclient -L w4de3rsy0001173 -Ugast
Password:
Anonymous login successful
Domain=[EZNORD] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Sharename Type Comment
 --------- ---- -------
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine w4de3rsy0001173. Error was NT_STATUS_ACCESS_DENIED
Error returning browse list: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[EZNORD] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Server Comment
 --------- -------

 Workgroup Master
 --------- -------

That shows it is a Samba problem, not a nautilus problem ? The anonymous login seems to be successful. But no shares or workgroup members where listed.

All samba shares on UbuntuServer where created with standard Ubuntu dialogs. That should work like "plug and play" to windows users.

drose (ditmar-rose) wrote :

Commandline with smbtree :

drose@UbuntuServer:~$ smbtree -N

EZNORD
 \\W4DE3RSY0001173 Ditmar Rose Tel:-650
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine W4DE3RSY0001173. Error was NT_STATUS_ACCESS_DENIED
 \\UBUNTUSERVER UbuntuServer server (Samba, Ubuntu)
  \\UBUNTUSERVER\PDF PDF
  \\UBUNTUSERVER\IPC$ IPC Service (UbuntuServer server (Samba, Ubuntu))
  \\UBUNTUSERVER\ServerShare
  \\UBUNTUSERVER\print$ Printer Drivers

Sebastien Bacher (seb128) wrote :

those comments from different users are not clear, does browsing the network using the samba tools without password work correctly? are you in the same workgroup than the other boxes?

drose (ditmar-rose) wrote :

My Ubuntu is in the same WorkGroup like the other PC i use (called EZNord)
smbclient and smbtree both showed a error " NT_STATUS_ACCESS_DENIED".

I could not determine if this error is due to password poblem of samba or not. But because i activated guest accounts on my windows computers ubuntu should be able to browse the shares even without a password. Thats the normal operation if i use a windows client.

drose (ditmar-rose) wrote :

There is already a genome/nautilus bug which adresses the same error : http://bugzilla.gnome.org/show_bug.cgi?id=522494

renbag (renbag) wrote :
Download full text (4.7 KiB)

In my situation, being or not in the same workgroup does not make a difference.
In any case here are some detailed descriptions of what happens. As I wrote in comment 8, I have a virtual machine running hardy-beta, which is in the same worgroup (or Domain) of all other network machines. This is a large network, with mostly windows clients, but also with several MacOsX and linux boxes. All linux boxes were joined to the ADS domain with the command: 'net ads join'. The relative smb.conf file is like this:

[global]
        workgroup = LAB
        realm = XXXLAB.IT
        netbios name = %h
        server string = %h (Samba %v, Ubuntu)
        security = ADS
        password server = dhcserv1.xxxlab.it
        username map = /etc/samba/domain_users.map
        restrict anonymous = 2
        client NTLMv2 auth = Yes
        client lanman auth = No
        client plaintext auth = No
        log file = /var/log/samba/log.%m
        os level = 0
        preferred master = No
        local master = No
        domain master = No
        idmap domains = LAB
        idmap config LAB: default = yes
        idmap config LAB: backend = rid
        idmap config LAB: range = 100000-1000000
        template shell = /bin/bash
        winbind enum users = Yes
        winbind enum groups = Yes
        winbind use default domain = Yes
        winbind offline logon = Yes
        invalid users = root

Case 1 ---------------------------------------------------------------------------------
Browsing from hardy-beta a machine running ubuntu-gutsy server.

In a terminal window:

renbag@vm-hardy:~$ smbclient -L gutsy-server
Password: (password inserted here)
Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]

 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC IPC Service (gutsy-server (Samba 3.0.26a, Ubuntu))
 share Disk gutsy-server_share
Domain=[LAB] OS=[Unix] Server=[Samba 3.0.26a]

 Server Comment
 --------- -------
 gutsy-server gutsy-server (Samba 3.0.26a, Ubuntu)

 Workgroup Master
 --------- -------
 LAB

In Nautilus:

Open Network --> Double-click on the 'LAB' icon (Domain) --> All machines are displayed;
Double-click on the 'gutsy-server' icon --> after a while, Nautilus returns '0 objects', without asking for a password;
Insert the full address (smb://gutsy-server/share) --> a password is requested and the share content is displayed.

Case 2 ---------------------------------------------------------------------------------
Browsing from hardy-beta a machine running Windows XP

In a terminal window:

renbag@vm-hardy:~$ smbclient -L XP-ACQ
Password: (password inserted here)
Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Sharename Type Comment
 --------- ---- -------
 IPC$ IPC Remote IPC
 Data Disk
 ADMIN$ Disk Remote Admin
 C$ Disk Default share
Domain=[LAB] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

 Server Comment
 --------- -------

 Workgroup Master
 --------- -------

In Nautilus:

Same...

Read more...

Sebastien Bacher (seb128) wrote :

this bug seems to have a collection of different usecases, configurations and issues, that's not really manageable now

renbag (renbag) wrote :

I have reported a new bug, describing exactly the problem in my usecase:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/207072

drose (ditmar-rose) wrote :

Updated Hardy at 28th. of March and Nautilus worked fin in browsing the share of my Windows PC. Then opend a Windows share leads to a password dialog. After entering my WindowsXP Account i got access to the share.

This Bug could be closed (at least for me).

Markus Korn (thekorn) wrote :

Added the upstream bug mentioned in comment #13

Markus

Darlan Cavalcante (darcamo) wrote :

I still have this bug (09 April) - hardy with latest updates.
Shares are not shown in nautilus, but if i put
smb://computer_IP/share
it works.

Tarık Gandur (ghanthar) wrote :

Hardy with latest updates (11 April) having same problem. Browsing printers also do not work. pyNeighborhood works. After mounting with pyNeighborhood I can see the directory and browse it.

Description of problem:
Every time I try to browse an SMB server I get a blank window instead of a list
of shares. If I know the share beforehand I can type smb://SERVER/SHARE and it
works. But as a user I'm stuck if I don't know the name of the share.

Version-Release number of selected component (if applicable):
This is a Fedora 9 Preview Live USB system with the following packages:
nautilus-2.22.2-1.fc9.i386
gvfs-fuse-0.2.3-3.fc9.i386
gvfs-0.2.3-3.fc9.i386
gtk2-2.12.9-5.fc9.i386
samba-common-3.2.0-1.pre2.8.fc9.i386
samba-winbind-3.2.0-1.pre2.8.fc9.i386

How reproducible:
Try browsing an SMB server without specifying a share like this: "smb://server".
 You will get a blank window instead of a list of shares.

Raddictus (raddictus) wrote :

Same problem for me:

1. smb://computer_ip_or_name: not work, blank screen, authentication dialog not appears.
2. smb://computer_ip_or_name/some_share_folder: ok, it work!

This fails on Ubuntu Hardy 8.04 RC all automatic updates to April 22, Ubuntu Gutsy machines work fine on same network.

Sebastien Bacher (seb128) wrote :

setting the bug to triage because there is an upstream task but it seems to describe random issues and it not really workable now, users having an issue which seems different of the one described on bugzilla should open a new bug rather

Changed in nautilus:
status: Incomplete → Triaged
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
status: Unknown → New

Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Could you please confirm that firewall is disabled on your system or at least
allows incoming Samba traffic? The SMB protocol is based on sending broadcasts
to get list of available machines in the network and also to connect to them if
not reachable via usual resolver ways (hosts, dns).

Changed in nautilus:
status: Confirmed → Incomplete

I disabled ip6tables, iptables and changed SELinux to permissive mode but
nothing. It still shows a blank page with "0 elements" in the status bar.
Going directly to a share still works but I can't get a list of shares.

I don't think this is a firewall thing since Fedora 8 LiveUSB worked fine and I
didn't disabled the firewall back then.

Cheers.

Changed in nautilus:
status: Incomplete → Confirmed

Changing to rawhide since this is happening with a Fedora 10 Alpha LiveCD too.

In fact it is getting worse. I can't even mount the share even if I specify the right URL: "smb://server/share". This at least used to work with Fedora 9 but not anymore.

It seems the firewall is disabled and I changed SELinux to permissive mode but yet it didn't work.

Because of this problem I'm stuck with Fedora 8 at work, I can't upgrade to Fedora 9 and it seems I won't be able to upgrade to Fedora 10.

I hope this can be fixed soon.

Changed in nautilus:
status: Confirmed → In Progress

Can you try again with gvfs 0.99.8 ? It has a number of smb-related fixes.

Hi, Unfortunately I don't have a Rawhide machine at work but I'll sure test the next beta version using a LiveCD as soon as it's released.

Thanks.

I decided to upgrade my personal laptop to Rawhide and bring it to my office. Unfortunately this bug doesn't seem to be fixed. The only thing that got fixed was http://bugzilla.gnome.org/show_bug.cgi?id=547597 because using Fedora 10 Alpha Live CD it got worse, it wouldn't even browse the known shares.

So, Rawhide is back to where Fedora 9 was: I can browse known shares if I know the name beforehand but I CAN'T get a list of available shares on a server.

Sergiu Bivol (sergiu-bivol) wrote :

This is way too ugly...
Let me summarize:
1. Browsing SMB password-protected shares does not work in Hardy - there is no password prompt any more. It used to work in Gutsy.
2. This extremely retarded regression is being actively reported by lots of users on any bugzilla that exists on the Internet.
3. NOBODY seems to care about this. No blueprints to say "We will fix this in the upcoming release" or "We do not intend to fix this bug". This bug is common to any distribution using Gnome 2.22
4. KDE (any version) works just fine, under any circumstances.

It would be EXTREMELY nice if a person with authority would say something about this bug. So that Linux users could hope for any change.

renbag (renbag) wrote :

The bug you're talking about has been better described and triaged here:
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/207072
http://bugzilla.gnome.org/show_bug.cgi?id=524485
Some effort by ubuntu developers has been made, although not (yet) successfull.

I can reproduce this on my home network. Firewall is definitely off, and avahi-discover lists the windows shares, so at least *some* form of server announcement is getting through.

Taking this off the blocker list. As comment 7 states things work about as well as they did in F9, so we didn't regress. We have another patch in the queue to improve the SMB situation, but it is too invasive to land at this point. It will go into testing after GA.

1. LiveCD doesn't have a firewall enabled.
2. The nf_conntrack_netbios_ns module should allow browsing to work even with the firewall enabled. Make sure /etc/sysconfig/iptables-config has IPTABLES_MODULES="nf_conntrack_netbios_ns" specified.

But I agree that I've not had luck with browsing in Nautilus either. In my case, though, I had assumed it was because the samba servers on my local LAN were using hidden shares (share$).

This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

(In reply to comment #11)
> This bug appears to have been reported against 'rawhide' during the Fedora 10
> development cycle.
> Changing version to '10'.
>
> More information and reason for this action is here:
> http://fedoraproject.org/wiki/BugZappers/HouseKeeping

i'm running f10 and i can't still see the shares unlike in 8
if i put smb://host/share/c$ then i'll get the prompt and browse the share
but it'll mount the share

gvfs-1.0.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-2.fc10

Please test the updated packages, read the notes posted in the link above and report any issues.

This doesn't resolve the problem of not seeing the contents of a share, for me. I can connect, as I have been able to for a while, but the Nautilus window still shows '0 items'.

When I ran with the debug settings, it appears files and directories are being seen but they're still not visible.

updated to both gvfs-1.0.3-2.fc10 and nautilus-2.24.2-2.fc10
same experience
just as to mention it again.

when i click on the network icon i can see all the computers/servers in our domain
if i click one windows computer i don't see the c$ and it does prompt me for username and password
i don't see any and the count is 0
where as in the pass i'll see the c$ then just input my credentials and i'm it
(that's the beauty i love about fedora)

Historically, share names that end in $ are supposed to be "hidden". Windows doesn't show hidden shares (at least it never used to, unless that has changed in recent versions). Maybe Nautilus is emulating this behavior for hidden shares?

Can you try creating a share that doesn't end in $ and see if that shows up?

gvfs-1.0.3-2.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update gvfs'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10848

Changed in nautilus:
status: In Progress → Fix Committed

charles,

you are correct, any shares with $ are meant to be hidden in windows
but to my surprise when i started using f8 in our windows network i can see the c$
i just double click on it and a prompt will pop up and i'll input my credentials and i'll see the whole c$
i think it's the same on f9 but i'll verify that on monday at work on our domain
i'll try creating a share not hidden
thanks

>ruxbo

To clarify, in my case the shares showing blank windows are on a NAS device running Samba 2.x. This update does not fix that problem.

(In reply to comment #20)
> To clarify, in my case the shares showing blank windows are on a NAS device
> running Samba 2.x. This update does not fix that problem.
That's a different issue - bug 443047 and the proposed fix is outside gvfs.

(In reply to comment #16)
> if i click one windows computer i don't see the c$ and it does prompt me for
> username and password
> i don't see any and the count is 0
> where as in the pass i'll see the c$ then just input my credentials and i'm it
> (that's the beauty i love about fedora)

I confirm that invisible $-postfix shares should be displayed however access to them might be restricted to super user group at the smb server side.

Ruxbo, your comment is not completely clear to me - does it mean that you can correctly see the list of shares once you authenticate?

tomas,

when i click on a machine on the network, it doesn't prompt me for username and password
previously in f8 it'll promt me for the username and password then i'll see the c$
i just noticed in f9 it's the same as f10 when i click on the machine ont he network it doesn't prompt me for the username and password
hope that helps
thanks

>oliver

gvfs-1.0.3-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-3.fc10

gvfs-1.0.3-3.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update gvfs'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11176

i've picked up the new update and happy to say that i can get to the c$ and admin$ shares
click on network, it's populated with the machines in the domain
click on a machine, prompt me for credentials hit enter and i see c$ and admin$
click on c$ and i'll be ask for credentials again then i'll see the whole c dir

though in the past versions (f8) i only get to enter my credentials once
click on a machine, prompts for credentials and i'll see c$
click on c$ and i'll see the whole dir

hope that helps
thanks

>oliver

by the way it still mounts the c$ which it shouldn't be
and i can see the c$ under Places menu
can that be fix?
thanks

>oliver

The hidden (C$) shares are displayed by design and I suggest not to hide them as it might make users confused (think of enterprise customers).

gvfs-1.0.3-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gvfs-1.0.3-4.fc10

updated to gvfs-1.0.3-4.fc10
still the same
i can get to the shares but it's mounting it, is that by design?

in the past i can get to the share with out mounting them and still i can browse to it's contents
thanks

>oliver

(In reply to comment #30)
> updated to gvfs-1.0.3-4.fc10
> still the same
> i can get to the shares but it's mounting it, is that by design?
>
> in the past i can get to the share with out mounting them and still i can
> browse to it's contents
> thanks
Yes, that's by design. The philosophy of vfs mounts has changed since gnome-vfs and in order to access the data, you have to mount the share first. The same with "hidden" $ mounts - no decision has been made, we're trying to be consistent with previous versions and existing linux users. But don't expect completely same behaviour like in Windows.

So, from your previous posts I understand the original issue of this bug has been fixed, I'm in favor of closing this bug.

gvfs-1.0.3-4.fc10 has been pushed to the Fedora 10 stable repository. If problems still persist, please make note of it in this bug report.

Changed in nautilus:
status: Fix Committed → Fix Released
Mark Ellse (markellse) wrote :

Please see the bug below showing similar behaviour on Intrepid, together with some steps to isolate the problem.

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/316862

Changed in nautilus:
importance: Unknown → High
status: New → Expired
Omer Akram (om26er) wrote :

closing this bug since the upstream bug was closed as expired after a fix confirmation. since we dont know when it got fixed i am marking this bug as invalid. if anyone still face this issue with nautilus 2.32 please feel free to open this bug again

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Invalid
Changed in nautilus (Fedora):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.