Hardy: Unable to scan Floppy Drive for media changes

Bug #197954 reported by Pelládi Gábor on 2008-03-03
44
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Expired
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I found this bug in an updated (2008-03-03) Ubuntu Hardy amd64.
When I try to access the floppy drive from the "places" menu, I get the following error:

Unable to scan Floppy Drive for media changes
Cannot invoke CheckForMedia on HAL: org.freedesktop.DBus.Error.UnknownMethod: Method "CheckForMedia" with signature "" on interface "org.freedesktop.Hal.Device.Storage.Removable" doesn't exist

Nautilus does not appear, as expected. From Places/Computer, clicking on Floppy drive does nothing.

Sergio Zanchetta (primes2h) wrote :

I confirm the bug with Hardy 32 bit updated running in Virtualbox.

The only difference is that when I click on Floppy drive from Places->Computer come up "Impossible to mount position(or something like this)" "No media in the drive"

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=520856

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
milestone: none → ubuntu-8.04
status: Confirmed → Triaged
Changed in gvfs:
status: Unknown → New
Peter Anselmo (peter-anselmo) wrote :

I also got the exact same error. A Screenshot is attached for additional reference.

Sebastien Bacher (seb128) wrote :

could you try if you still get the issue using yesterday updates?

Pelládi Gábor (pelladigabor) wrote :

I still get the issue.

Hi,
I just installed all available updates, and the error
message is the same.

If it helps at all, the floppy drive is a Samsung,
connected to a MSI mobo, and an Intel Processor.

--- Sebastien Bacher <email address hidden> wrote:

> could you try if you still get the issue using
> yesterday updates?
>
> --
> Hardy: Unable to scan Floppy Drive for media changes
> https://bugs.launchpad.net/bugs/197954
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>
> Status in gvfs: New
> Status in Source Package "gvfs" in Ubuntu: Triaged
>
> Bug description:
> I found this bug in an updated (2008-03-03) Ubuntu
> Hardy amd64.
> When I try to access the floppy drive from the
> "places" menu, I get the following error:
>
> Unable to scan Floppy Drive for media changes
> Cannot invoke CheckForMedia on HAL:
> org.freedesktop.DBus.Error.UnknownMethod: Method
> "CheckForMedia" with signature "" on interface
> "org.freedesktop.Hal.Device.Storage.Removable"
> doesn't exist
>
> Nautilus does not appear, as expected. From
> Places/Computer, clicking on Floppy drive does
> nothing.
>

      ____________________________________________________________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

Pelládi Gábor (pelladigabor) wrote :

Oh I forgot to say, that the error dialog also appears on a desktop computer that doesn't even have a floppy drive. According to the GNOME bug tracker, hal 0.5.10, which Hardy ships, doesn't contain this method.

Sebastien Bacher (seb128) wrote :

hardy has a git snapshot since yesterday but you said it was still doing the same error?

exploder (dcosner) wrote :

I also reported this bug in another bug report. The floppy drive still will not work for me either. I am updated to 3/8/08.

Pelládi Gábor (pelladigabor) wrote :

Sebastien: I am using a fully updated Hardy. It contains all the updates, even the ones after Alpha 6. It is still doing the same error.

exploder (dcosner) wrote :

Still have the problem, fully updated to 3/11/08.

Andrew (keen101) wrote :

Cannot invoke CheckForMedia on HAL: org.freedesktop.DBus.Error.UnknownMethod: Method "CheckForMedia" with signature "" on interface "org.freedesktop.Hal.Device.Storage.Removable" doesn't exist

I have this problem too.

Running Hardy Heron Alpha Release (I think 6)

Fully updated 201 updates as of 03/13/08

The problem is still here with Hardy Beta.

IMHO, the importance must be set to High or, at least, Medium. If you are unabled to use the floppy disk (which is still very used around the world), the Ubuntu quality "feeling" decreases dramatically.

Sebastien Bacher (seb128) wrote :

ricardo, would be easier if somebody having a working floppy drive could work on the issue though

Hi, Sebastien. I've a working floppy drive, but I haven't the technical knowledges to work on the problem. But I'll happily help with anyone who can in order to get this bug fixed.

Andrew (keen101) wrote :

on almost every other ubuntu release the floppy support seems to die.

Pelládi Gábor (pelladigabor) wrote :

This particular bug was fixed a day after beta release. The error message does not appear any more. I tested it on a machine that does not have a floppy drive, but I am going to test the issue on another machine that has, and report back with the results.

Interesting. It seems the bug has been fixed, because now I can access to a floppy disk. However, it has a nasty side effect. When I unmount the floppy disk, the floppy drive is not named "Floppy drive" anymore: it's named "1,5 MB Media".

I attach two screenshots to illustrate the problem.

Pelládi Gábor (pelladigabor) wrote :

The floppy is working on today's (2008-03-25) daily snapshot live cd.

Changed in gvfs:
status: Triaged → Fix Released

This is a screenshot to show how Places menu looks like BEFORE I insert a floppy disk in drive and click on Places->Floppy to mount it.

It's in Spanish: "Disquete" means "Floppy disk".

This is a screenshot to show how Places menu looks like AFTER I unmount the floppy disk I previously mounted clicking on Places->Floppy.

To reproduce:

1. Insert a floppy disk in the drive.
2. Click on it to mount it.
3. Unmount it (with right-click and selecting "Unmount").

Expected behavior:

The floppy disk icon says "Disquete", like in the beginning (i.e. before you mount any floppy disk).

Actual behaviour:

The floppy disk icon still says "Soporte de 1,5 GiB", as it says before unmount it.

[It's in Spanish: "Soporte de 1,5 GiB" means "1,5 GB Media", and "Disquete" means "Floppy disk".]

Sebastien Bacher (seb128) wrote :

could you open a new bug about the label issue?

Sure, Sebastien. I've posted a new bugreport, bug 206860.

Sebastien, I've created another bugreport for another issue; this time is about the lack of an error message when you click on Places->Floppy Drive and no disk is in the drive. It's the bug 206856.

Sergio Zanchetta (primes2h) wrote :

Unfortunately this bug still occours for me on yesterday (2008-03-27) daily snapshot live cd.

Changed in gvfs:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the current daily cd works correctly

Changed in gvfs:
status: Confirmed → Fix Released
stonehenge (wrecche) wrote :

I am still receiving the error when trying to access the floppy, as of Saturday 19'th April 2008. I've run full updates and still the error returned is -

Cannot invoke CheckForMedia on HAL: org.freedesktop.DBus.Error.UnknownMethod: Method "CheckForMedia" with signature "" on interface "org.freedesktop.Hal.Device.Storage.Removable" doesn't exist

and trying to access it from Nautilus I receive "No media in the drive" error.

exploder (dcosner) wrote :

The original bug is still present in the Hardy Final Release 32 bit.

Alwyn (alwynburger) wrote :

I have the same problem. I can format a new stiffy from within Terminal (gfloppy) but cannot access it from "Places"/"floppy drive". When I use the following command (sudo mount /dev/fd0 -t auto /media/floppy) inside Terminal the floppy will mount and it is now possible to use it but appears as "floppy0" under "Places" and on the desktop.

Anyone (frankleontius) wrote :

Unfortunately, I viewed around the Web that this problem still exists in Intrepid Ibex (64 and 32 bit) too.

marco (mrcd) wrote :

just wanted to say thanks to Dam.dallatana e Sergio zanchetta
grandi ..erano settimane che dovevo" switchare" con windows per usare il ploppy disk!!!!
ciao!

Changed in gvfs:
importance: Unknown → Medium
Albert Pool (albertpool) wrote :

Bug is still there in Maverick and Natty.

Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.