File chooser not working in current folder

Bug #181788 reported by Tim Kornhammar on 2008-01-10
148
This bug affects 23 people
Affects Status Importance Assigned to Milestone
File Roller
Invalid
Medium
GTK+
Fix Released
Medium
One Hundred Papercuts
Undecided
Unassigned
file-roller (Ubuntu)
Low
Ubuntu Desktop Bugs
Lucid
Low
Ubuntu Desktop Bugs
gtk+2.0 (Ubuntu)
Low
Canonical Desktop Team
Lucid
Low
Canonical Desktop Team

Bug Description

Binary package hint: deluge-torrent

If I donwload a .torrent and are about to choose directory and that default/last directory was on my extern drive I can't choose that directory.

To solve (for me):
Go back one directory and click on the folder in the folderstructure or I can't choose that directory to save the torrent in. If I press on the "quick" folders above it does not work either, it has to be a click on the directory for it to work.

Related branches

Andrew Resch (andar) wrote :

This seems like it may be a GTK bug and not a Deluge bug.

Tim Kornhammar (tim-kornhammar) wrote :

I couldn't decide what it was, I was in on Gnome, Nautilus or something similar but I guessed. Should I move it to GTK instead?

Andrew Resch (andar) on 2008-02-02
Changed in deluge-torrent:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Your description is not clear and lacks details. What version of Ubuntu do you use? Why can't you choose that directory? Do you get an error dialog? Which one? Could you describe easy steps to trigger the issue?

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Tim Kornhammar (tim-kornhammar) wrote :

I use Ubuntu Gutsy Gibbon (7.10).

I can only guess why, the last directory used gets listed. I can't choose that directory if it is on an external drive. I have to activly choose a directory to be able to select that directory as my target. My workaround is that I select the previous directory and then click on the folder in the folderstructure. It can't be done if you only use the "history" or whatever that is above the directory tree.

I don't get an error, nothing happens. I've tried to see if the console spits something out but it doesn't.

My way of reproducing:
Using Deloge-torrent.
Loading torrent.
Last dir is on the external, so just OK.
Nothing happens.

Workaround:
Press on parent directory.
Choose the directory from the tree.
Press OK.

Sebastien Bacher (seb128) wrote :

the description is not clear but that doesn't look like a gtk bug or other applications would have similar issues

Changed in gtk+2.0:
status: Incomplete → Invalid
Changed in deluge-torrent:
status: Invalid → New
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in deluge-torrent:
status: New → Incomplete

I've seen this bug in file-roller too.
http://bugzilla.gnome.org/show_bug.cgi?id=556376

Pedro Villavicencio (pedro) wrote :

reassigning to file-roller and linking the upstream report, thanks.

Changed in gtk+2.0:
status: Invalid → Triaged
Changed in fileroller:
status: Unknown → New
Hew (hew) wrote :

This isn't a deluge-specific issue. I've experienced this myself with the file chooser in many applications. Linked more relevant upstream report.

Changed in deluge-torrent:
importance: Undecided → Low
status: Incomplete → New
Changed in gtk+2.0:
status: New → Triaged
Changed in gtk:
status: Unknown → Confirmed
Changed in gtk+2.0:
assignee: nobody → desktop-bugs
atreju (atreju-tauschinsky) wrote :

This bug is indeed quite annoying. I have built a version using the upstream patch from http://bugzilla.gnome.org/show_bug.cgi?id=516714 available in my ppa:
https://edge.launchpad.net/~atreju-tauschinsky/+archive/ppa/
That version works fine for me, maybe someone else can test it as well?
Attached also a debdiff of this change.

Changed in gtk+2.0 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Confirmed
Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

thank you for your work there but unsubscribing the sponsor team for now we want to get the patch reviewed by the GNOME upstream before using it there

I believe bug #388074 is a duplicate of this bug, although they are described differently.

Changed in hundredpapercuts:
milestone: none → round-10
status: New → Confirmed
blackoso (oaktown-pepe) on 2009-06-23
Changed in gtk+2.0 (Ubuntu):
status: Triaged → New
Hew (hew) on 2009-06-23
Changed in gtk+2.0 (Ubuntu):
status: New → Triaged
Steve Dodd (anarchetic) wrote :

I think gnome-bugs #540788 (<http://bugzilla.gnome.org/show_bug.cgi?id=540788>) is related, if not exactly the same. If anybody's grovelling around in the code, could they take a peek at this as well?

From my comment on gnome-bugs:

"This bug drives me nuts on a fairly regular basis, I think the usual scenario
is when you want to save a file in the parent directory of the default
directory (the one which is displayed when the file selector is first shown):
clicking on the parent in the path bar (is that the right terminology?) changes
directory but leaves the subdir selected, so clicking save changes to the
subdir instead.

However, this doesn't happen consistently - it's only a problem if the focus is
on the file list and not the file name entry box, and I don't understand why
this is sometimes different. Is it something to do with the application
behaviour?"

xtknight (xt-knight) wrote :

So I know GNOME hasn't looked at the bug, but can't we get it into Karmic anyway until there is an "official" fix? I don't think we need GNOME to tell us that this fix is kosher. The bug is simply annoying and needs to be eradicated! When they implement it in their upstream is irrelevant to the Ubuntu operating system as a whole. And frankly if they've got a more "proper" fix for it, that's great, it can be implemented later. For now, let's put a bandaid over this papercut. It has been haunting the userbase for the past few versions of Ubuntu.

Here is a debdiff for Karmic based on the above patch. I have not tested it yet, but it looks very similar to a patch I came up with.

Sebastien Bacher (seb128) wrote :

> Here is a debdiff for Karmic based on the above patch. I have not tested it yet, but it looks very similar to a patch I came up with.

Uploading non tested changes to a basis component as gtk is just not the way to do things no

Przemek K. (azrael) wrote :

Bug #390306: "file-roller extracts files to wrong directory when choosing a parent directory of the current one" might be related.
I reported it upstream as http://bugzilla.gnome.org/show_bug.cgi?id=586565

xtknight (xt-knight) wrote :

Any hopes that this annoying usability bug will get patched in Karmic?

At least in Karmic Alpha6 (amd64), this bug is still found at least when using file-roller. I consider this bug actually quite fatal usability problem (and it has survived for years now...). How on earth user could possibly know that in order to get his/her files extracted to default location (usually /home/hername) he/she has to go up one directory and then back again? There is absolutely no feedback, it just does nothing when you hit "Extract".

Importance should definitely be "low" for severe usability problems like this.

Sorry, I meant "should definetly NOT be "low" for..."

tags: added: usability
Changed in hundredpapercuts:
milestone: round-10 → r2
Changed in gtk+2.0 (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.19.7-0ubuntu2

---------------
gtk+2.0 (2.19.7-0ubuntu2) lucid; urgency=low

  * debian/patches/063_treeview_almost_fixed.patch:
    - change by Michael Vogt to add an ubuntu-almost-fixed-height-mode property,
      the change is required for software-center, adding as an ubuntu specific
      change for now until somebody comment on the upstream bug (lp: #514879)
  * debian/patches/064_initial_fileselector_select.patch:
    - change by Cody Russell to fix the default action not working in the
      gtkfileselector until you selected a directory (lp: #80755, #181788)
 -- Sebastien Bacher <email address hidden> Mon, 22 Mar 2010 14:23:46 +0100

Changed in gtk+2.0 (Ubuntu Lucid):
status: Triaged → Fix Released
Vish (vish) on 2010-03-23
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

My #1 papercut bug fixed, all praise you wizards! Hopefully upstream will also reach some conclusion.

co0lingFir3 (coolingfire) wrote :

Am I the only one who still (or again) has this bug in Lucid? Did work fine in Karmic though.

Vish (vish) wrote :

Not a bug in file-roller. Fix has landed in gtk+

Changed in file-roller (Ubuntu):
status: Triaged → Invalid
Changed in file-roller (Ubuntu Lucid):
status: Triaged → Invalid
Changed in gtk:
status: Confirmed → Fix Released
Changed in file-roller:
importance: Unknown → Medium
status: New → Unknown
Changed in gtk:
importance: Unknown → Medium
Changed in file-roller:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.