submenu items selection doesn't work correctly

Bug #121796 reported by Bogdan Butnaru on 2007-06-22
142
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
gtk+2.0 (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gimp

Hello! I'm using Gutsy (after updating from Dapper through all versions).

The right-click "Open With" menu for image files (at least for JPEGs) has four consecutive [Open with "GIMP Image Editor"] options, neither of which works. (I remember sometimes one of them works, but today neither does.)

I can start the GIMP normally from the "Applications" menu.

Related branches

Justin Payne (neolithium82) wrote :

Hi,
Thanks for taking the time to file this bug report. While this bug could have been confirmed last night, as I was encountering the same right click error with Gutsy, I recently tested this once again with right clicking on an image and selecting 'Open With Gimp' and the program loaded as it should.

I suspect that this is related to the xsane bug located here https://bugs.launchpad.net/bugs/121840
Please run an update and confirm back if the problem presists, along with any debugging errors that may help isolate the problem- there is a help guide for debugging available here https://wiki.ubuntu.com/DebuggingProcedures

Thank you again for submitting the bug,
Regards, Justin

Changed in gimp:
assignee: nobody → jbeerwart
status: New → Incomplete
Bogdan Butnaru (bogdanb) wrote :

I have just completed a dist-upgrade (and, indeed, xsane was updated), but GIMP still won't start from the right-click menu. I remind you that I GIMP starts normally from the Applications menu, and I can open the images with drag-and-drop just fine.

On the other hand, even if the GIMP would start, there's still the problem with the multiple (four, right now) entries in the right-click menu. I suspect the install scripts of the package have some kind of bug. (I didn't notice this with anything but GIMP, but it could also be a bug in whatever package manages the right-click menu. BTW, I'm using Gnome for everything.)

I've looked at the debug suggestions, but I can't find anything that applies to my case. The problem is that GIMP doesn't start only when I use the right-click menu of a file, so I can't attach any debuggers and such. GIMP starts normally when I start it myself, with only these warnings:

Executable not found: '/usr/lib/gimp/2.0/plug-ins/psd_save'
Executable not found: '/usr/lib/gimp/2.0/plug-ins/gifload'
Executable not found: '/usr/lib/gimp/2.0/plug-ins/tiff'
Executable not found: '/usr/lib/gimp/2.0/plug-ins/psd'
Executable not found: '/usr/lib/gimp/2.0/plug-ins/gif'

But it behaves the same for all kinds of files, including---which bugs me---JPEGs. I have started Nautilus from a command line so I can see its messages (I assume it's responsible for the right-click menu), and it doesn't display anything when I use the right-click menu. Nothing happens, apparently. I've checked the logs, too, I didn't see anything remotely relevant.

Any idea where Nautilus keeps it's right-click menu "settings", so I can check what's going on?

Justin Payne (neolithium82) wrote :

Hi Bogdan,
I'm curious to see if this is still an issue after the latest round of Gutsy updates; as I haven't been able to reproduce the described problem and there haven't been any additional reports of it. Hopefully this was something that had been resolved in the last day or two; though I'll leave the bug open for the time being pending more information.

Regards,
Justin

Bogdan Butnaru (bogdanb) wrote :

Hello Justin,

Yes, I've kept up with the updates and it's still happening. Note that I don't think this is a problem with the GIMP itself, it works correctly when I start it from the command line or the application menu. It's very likely a problem with the way it registers itself to Nautilus' open-with list.

(The fact that I have four different entries is a good hint...)

Regards, Bogdan

Changed in gimp:
importance: Undecided → Low
Bogdan Butnaru (bogdanb) wrote :

Hello again!

I've been scouring the web and the various /usr/share/mime* directories on my computer, and I can't figure out where is Nautilus keeping the file that tells it "JPEGs can be opened with application X". Anyone can point me to it, so I can take a look and see what's wrong?

Saivann Carignan (oxmosys) wrote :

It does'nt work better with a HTML document than a JPEG or PNG file.

If there's a Open With.. submenu , it always fail to open.

*I work with nautilus logued at root with gksudo*

antok.tm (antok-elect-eng) wrote :

Surely it is "Open with..." submenu bug. At the first time I tried it (right after boot), it works. But it's not working after the second try. Not only gimp, but any other apps are also affected. I've tried it on .txt, .png, and apps like Kate, or F-spot doesn't load whenever it's called via the "Open with ... " submenu. Remember, it won't happen on the first or second try. Try to reproduce the bug using multiple apps opening one file.

MMarking (cpt-mocha) wrote :

This is a problem in Feisty as well. Surprised no one reported it yet. I have tons of duplicate entries for programs and only one or 2 of them work. Mostly I have duplicates for video files, basically it was any type of file where I added a custom program.

Changed in gimp:
status: Incomplete → New
Saivann Carignan (oxmosys) wrote :

I didn't have the duplicate problem, but I had the "not working open with.. menu" problem with Gusty tribe 2 and 3 only. I just upgraded to Gutsy tribe 4 and the problem is not fixed, any HTML or JPG file can be opened on any programd listed under "open with.."

Saivann Carignan (oxmosys) wrote :

CORRECTION :

I didn't have the duplicate problem, but I had the "not working open with.. menu" problem with Gusty tribe 2 and 3 only. I just upgraded to Gutsy tribe 4 and the problem is NOW fixed, any HTML or JPG file can be opened on any programd listed under "open with.."

Bogdan Butnaru (bogdanb) wrote :

I still have the "not working" issue even after the latest upgrades. (But I also have multiple entries, so that might contribute.)

Gutsy updated August 14th.
1. I can confirm this problem with 'Open with Other Application... ' not working with the Gimp
2. I can confirm that Gimp runs fine otherwise, no errors when started from a terminal
3. I can confirm comment# 6 that 'Open with Other Application... ' works from Nautilus running as sudo if Gimp is not already running.
but,
If Gimp is already running, and I'm running nautilus as sudo, it fails silently to open my image file from the 'Open with' menu.

4. I have also seen this in Feisty.

Could my bug# 132439 be a duplicate of this?

If this bug is a duplicate of Bug #131837 and Bug #132896 then it should be assigned to nautilus and not gimp. If you agree please reassign this bug to nautilus (Ubuntu).

Sebastien Bacher (seb128) wrote :
Changed in gimp:
importance: Low → High
Changed in nautilus:
status: New → Triaged
assignee: jbeerwart → desktop-bugs
Sebastien Bacher (seb128) wrote :

bug #125461 might be the same issue

Changed in nautilus:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

The bug seems to be a gtk one as described on #132372

Jamie Strandboge (jdstrand) wrote :

This right click behavior is not Gimp specific; it affects right click context menus (eg I saw it first in evolution). Seems to be related to themes. See Comments in (the duplicate) Bug 133071.

Specifically, Human and Outdoors are affected, but some other themes are not. I started playing around with this and found that if I chose the Human theme, then clicked Customize and chose the Mist icon set (and leaving everything else as Human), then right click context menus work fine again.

Jamie Strandboge (jdstrand) wrote :

I misspoke. Changing to the Mist icon set does make it work again, but only once. Apparently some sort of reload happens and allows it to work.

That said, I have found that the Clearlooks theme does work consistently. Then I chose 'Human', clicked 'Customize' and chose the 'Clearlooks' controls. It still works consistently.

Here is my testing:

1. open evolution

2. right click in an email, then unclick (the context menu is still floating there). Go to 'Create Rule from Message', and select 'Filter on Subject'. If it is working right, the dialog pops up (at which point you can click Cancel). If not, nothing happens.

3. repeat step 2 in a different email

With Clearlooks theme, can do steps 2 and 3 over and over and it is fine. If change to Human theme, can do step 2 once, but then step 3 fails (and all other attempts at right click context menus). If using Human theme, but change controls to Clearlooks, can do steps 2 and 3 over and over.

The Outdoors theme is also affected, and presumably others.

I can confirm that changing to clearlooks also makes nautilus right click "open with " (other apps) menu work

it defiantly looks like a theme problem, or some difference with the themes that highlights this bug

Yes I confirm it work ...

I have also been through all the different tests that Jamie mentioned and had the same result. Nice work Jamie getting this nailed a bit more precisely.

Changed in nautilus:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

Fixed upstream.

Changed in gtk+2.0:
status: Triaged → Fix Committed

This comment may not be useful anymore, but I've just noticed that if I click on each part of the menu, instead of waiting for the hovering mouse to activate the submenu, then it works opening a picture with Gimp from the context menu.

Sebastien Bacher (seb128) wrote :
Download full text (5.4 KiB)

gtk+2.0 (2.12.0-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    GtkTooltips
    - All widgets have been ported to the new tooltips code
    - Tooltips are disabled in touchscreen mode
    GtkBuilder
    - Support custom tabs in GtkPrintUnixDialog
    Bugs fixed:
    - 459561 critical warnings with custom tooltips
    - 461648 GdkWindowQueueItem::serial overflow
    - 463773 Openoffice and flash run into a deadlock when used with KDE
    - 468801 thunar segfaults when selecting targa image (LP: #127574)
    - 473441 [patch] Ungrab windows when gdk_window_destroy() is calle...
    - 473954 gnome-background-properties: crash on drag-n-drop to "Add...
      (LP: #128931)
    - 461945 totem outputs errors in terminal (LP: #129438, #130329)
    - 348493 _gdk_quartz_copy_to_image needs implementing for pixmaps
    - 405868 Missing implementation of gdk_window_get_geometry()
    - 441219 Do not allow moving cursor to separators
    - 447214 rename the tips_data_list field back
    - 451202 New tooltips API has too long default timeout (LP: #133919)
    - 451397 Use new tooltip API in gtk+
    - 452225 check and option mark drawing is a mess of inconsistency
    - 457642 tooltips on notebook's tab labels
    - 458088 Improve mouse cursor for paned widgets
    - 458102 GtkScrolledWindow doesn't redraw when gtk-scrolled-window...
    - 458280 remove set-toolip handler from menutoolbutton
    - 458298 broken cursor movement with inline selection
    - 459459 Missing implementation of gdk_window_set_decorations() an...
    - 459515 gtk_menu_key_press() buglets
    - 459566 update testtooltips
    - 459667 Missing implementation of gdk_window_set_keep_above and g...
    - 460272 GtkFrame publishes incorrect defaults for "label-xalign"
    - 460534 No expose events if input swamps main loop with scrolled ...
    - 461225 gtk_tree_view_set_tooltip_cell() documentation: cell
     -463907 'Recent Documents' is broken in gnome-panel 2.19.5 (LP: #131266)
     -464528 gdk_rectangle_union() and gdk_rectangle_intersect() shoul...
    - 465039 "keynav-failed" signal not emitted when treeview has just...
    - 467003 tooltips do not pick up theme changes
    - 467117 Documentation for the GtkPaned key binding signals
    - 467414 gtkcupsutil.c won't build with cups 1.3
    - 468055 Incorrect compose mapping for capital U with macron (LP: #113721)
    - 468245 Tooltip timer doesn't get reset when mouse leaves into ot...
      (LP: #135076)
    - 469214 Recently used blocks side-panel browsing until loaded
    - 469374 menu accelerators don't work
    - 469395 make dist failure
    - 471132 Highlighting a suggestion with the keyboard changes the U...
      (LP: #134304)
    - 471215 Cursor drawing broken
    - 472974 gtk-builder-convert doesn't set correctly the tab label f...
    - 472981 make gtk-builder-convert not remove some empty properties
    - 356630 Print to file dialog suggests "output.pdf" even for ps ou...
    - 447883 PATCH Documentation about SVN in HACKING and README.cvs-c...
    - 459340 GtkContainer API documentation refers deprecated gtk_widg...
    - 459732 build system: cups detection with only cups-config might ...
    - 460207 there a...

Read more...

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.