keyboard layout indicator cannot be hidden

Bug #519372 reported by Alexey Kotlyarov on 2010-02-09
134
This bug affects 23 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Declined for Maverick by Sebastien Bacher
Lucid
Low
Ubuntu Desktop Bugs

Bug Description

In Karmic, keyboard indicator was a panel applet which I could remove from the panel to save space. Currently in Lucid, it is an icon in the notification area and cannot be hidden, even through the keyboard preferences dialog.

ProblemType: Bug
Architecture: i386
Date: Tue Feb 9 19:14:14 2010
DistroRelease: Ubuntu 10.04
Package: gnome (not installed)
ProcEnviron:
 LANGUAGE=ru_RU.UTF-8
 PATH=(custom, user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: meta-gnome2
Uname: Linux 2.6.32-12-generic i686

affects: meta-gnome2 (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Chris Coulson (chrisccoulson) wrote :

The status icon is from gnome-settings-daemon, so reassigning there.

The status icon hides automatically when you disable multiple keyboard layouts. That seems sane enough, unless you want multiple keyboard layouts with the status icon (although, I don't know how you switch layouts then)

affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)

В Птн, 12/02/2010 в 13:37 +0000, Chris Coulson пишет:
> The status icon is from gnome-settings-daemon, so reassigning there.
>
> The status icon hides automatically when you disable multiple keyboard
> layouts.
I know, but I reassigned Caps Lock light to show the layout and Caps
Lock key to switch (no one uses mouse to switch anyway), so this is
duplication. And surely this won't add much to lots of options under
"Layout options" (esperanto, euro sign, japanese keyboard options)?

I have the same issue. I'd rather not see the indicator because I only have two layouts configured that switch with caps-lock/shift and it's pretty obvious which one I have enabled as soon as I type.

It would be a good start if I could turn it off via gconf-editor. There is currently a configuration section for the indicator in gconf-editor, but no flag to turn it off.

Chris Coulson (chrisccoulson) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in gnome-settings-daemon (Ubuntu):
status: New → Triaged
Changed in gnome-settings-daemon:
status: Unknown → Fix Released
Chris Coulson (chrisccoulson) wrote :

This is fixed upstream now

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Committed

Accepted gnome-settings-daemon into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I've tried it and it does work in principle. I did

gconftool-2 -s /desktop/gnome/peripherals/keyboard/general/disable_indicator -t bool true

then logged out and back in and the layout indicator was gone.

However there is no schema for the key, it has to be created manually and cannot be discovered by searching initially. Furthermore apparently g-s-d doesn't listen to the gconf notification, so there is no immediate effect when toggling the key. It seems to require a log-out/restart.

Martin Pitt (pitti) on 2010-04-30
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.30.1-0ubuntu1

---------------
gnome-settings-daemon (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version (LP: #571250):
    - Introduce gconf key that allows hiding the indicator (LP: #519372)
  * Refreshed 90_autoreconf.patch
  * Dropped patches merged upstream:
    - 08_multi_keyboard_layouts.patch
    - 09_indicator-display.patch
 -- Chris Coulson <email address hidden> Wed, 28 Apr 2010 10:46:53 +0100

Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.30.1-0ubuntu1

---------------
gnome-settings-daemon (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version (LP: #571250):
    - Introduce gconf key that allows hiding the indicator (LP: #519372)
  * Refreshed 90_autoreconf.patch
  * Dropped patches merged upstream:
    - 08_multi_keyboard_layouts.patch
    - 09_indicator-display.patch
 -- Chris Coulson <email address hidden> Wed, 28 Apr 2010 10:46:53 +0100

Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Fix Committed → Fix Released
Tanmoy (tanmoylaskar) wrote :

So I don't understand - this says "fix released" on May 5th, but I am using gnome-settings-daemon - 2.30.1-0ubuntu1, so why do I still have this problem? I had to use "gconftool-2 -s /desktop/gnome/peripherals/keyboard/general/disable_indicator -t bool true" to get this to work.

Any ideas?

Artem Gabrielyan (synthakai) wrote :

thanks for the fix. I was just about to start recompiling the package by myself :)

Changed in gnome-settings-daemon:
importance: Unknown → Medium
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → New
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Released

What is the gconf key to hide the indicator? I'm looking through the changes (http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/gnome-settings-daemon/maverick/revision/101#plugins/keyboard/gsd-keyboard-xkb.c), and it seems to be "/desktop/gnome/peripherals/keyboard/general/disable_indicator". But when I look at "/desktop/gnome/peripherals/keyboard/general" in gconf-editor, there is no "disable_indicator" key.

Also, manually creating the key with "gconftool-2 -s /desktop/gnome/peripherals/keyboard/general/disable_indicator -t bool true" then logging out and back in like marmuta said doesn't seem to work.

Sorry for the unexplained status update. The thing is, the key doesn't
work for Maverick anymore - the indicator is shown even after setting
it.

disable_indicator key doesn't work anymore as of Maverick. Please fix.

2Alex: please add as affects Maverick

majesty (majesty-nashemisto) wrote :

I confirm that setting a key do not work for Maverick.

Suave (suave-swerve) wrote :

Same here - just installed Maverick and the language bar icon remains after setting disable value to true. Is this being worked on?

Suave (suave-swerve) wrote :

Note: selecting Keyboard Preferences > Layouts > Reset to Defaults removed the icon for me, for some reason.

Rocko (rockorequin) wrote :

@Suave: That's because resetting to defaults removes all but the default keyboard. The indicator isn't shown if there is only one keyboard layout.

Suave (suave-swerve) wrote :

I realised that - was hoping no one would notice. :D

The fix in gconf-editor definitely doesn't work either way. Is this being worked on? I really prefer not to have icons on the desktop that I don't need, and this would definitely be an example of one of those!

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

Don't reopen closed bug, the new version issue is a diffrent one and should get a new report

Changed in gnome-settings-daemon (Ubuntu):
status: New → Triaged
summary: - Regression: keyboard layout indicator cannot be hidden
+ keyboard layout indicator cannot be hidden
Changed in gnome-settings-daemon (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released

Note to anyone reading this: The new bug can be found here:

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/631989

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.