Notification Area on second screen's panel doesn't work

Bug #128735 reported by Johnathon on 2007-07-27
96
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: gnome-panel

This bug is exactly the same as #12696, Still having this problem in an up-to-date Feisty Fawn install. Opening extra ticket as requested.

Will be able to run debug(s) when I get back in the office on Wednesday. (1st Aug 07)

Text from other report:
I have a dual head screen (two graphic cards and no xinerama, so my displays are
:0.0 and :0.1).
Gnome panel correctly manage those two displays except for the notification area:
it's ok for application launched on :0.0 that handle notification area (tested
with rhythmbox, gaim and gdesklets)
but when I launch them from :0.1, no icon appears in the notification area.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's known upstream, http://bugzilla.gnome.org/show_bug.cgi?id=346162

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in gnome-panel:
status: Unknown → New
Johnathon (kirrus) wrote :

With our experience of this bug, we have 1 graphic card running dual-head, but have experienced it across 2 graphics chips as well.

Miek Gieben (miek) wrote :

Exactly the same problem here, also running in a dual head setup. Gnome 2.18.1 Ubuntu Feisty. Notification area only works on display :0.0 and not in :0.1.

Gareth Bult (gareth-encryptec) wrote :

Same problem here, also reported on gnome.bugs.org.

Long running problem - are they ever going to fix it?

Sounds trivial but it's pretty critical in terms of usability for multi-screen users ..

ChrisGibbs (chris-t-gibbs) wrote :

Same problem here.

Ubuntu 7.10

NVIDIA 8800GTS

Monitors :0.0 & :0.1

I have been reading and it has been an issue for a while. Is there any work around?

Changed in gnome-panel:
status: New → Confirmed
Azelphur (azelphur) wrote :

I'm also suffering from this bug, and it's been over a year now :(

Azelphur (azelphur) wrote :

Workaround:
It appears that you need to run one instance of a panel for each screen. This rules out:
gnome-panel
kicker (KDE's panel)
xfce4-panel

As none of them allow multiple instances.
However fbpanel appears to allow this, i have a notification area on each screen using fbpanel. I also had a notification area on each screen by running gnome-panel and kicker :p

So this is definatly a bug in the panels, they are all affected. Looks like a --only-current-screen switch is desperately needed (just like in compiz fusion)

Azelphur (azelphur) wrote :

AWN also doesn't suffer from this bug. Same as fbpanel, one instance for each screen.

Octavio Alvarez (alvarezp) wrote :

Still present in Jaunty.

Ken Foskey (foskey) wrote :

This is really bad with skype that leaves a trailing program live and signed on that is not obvious to the user at all. You cannot restart skype because it creates a new instance.

Azelphur (azelphur) wrote :

Can some sort of priority be assigned to this bug? The original report is 6 years old now ( http://bugzilla.gnome.org/show_bug.cgi?id=115704 ), and gnome-panels multi x screen support gets worse with every release, and the developer refuses to fix any of it. It's going to become unusable at this rate.

aefaradien (sen-aefaradien) wrote :

Second what #11 said, this has been going on for *ages* now, and is really quite limiting and annoying. Can someone please assign this defect to a dev so it can get fixed?

thanks!

Octavio Alvarez (alvarezp) wrote :

Or if someone can shed some light on where in the code might the problem lie, and what might be the source of the problem.

This might help some of us try and dive in the code to take a look and suggest or even fix something.

Changed in gnome-panel:
status: Confirmed → Invalid
Azelphur (azelphur) wrote :

There's a patch for this available upstream now, can someone cherry pick it?
https://bugzilla.gnome.org/show_bug.cgi?id=621584

Sebastien Bacher (seb128) wrote :

> There's a patch for this available upstream now, can someone cherry pick it?

if you follow this bug you will see that the bug watch has been updated 8 hours ago to reflect the correct bug number so this is being watched, if you read the upstream bug you will also see that the change is being reviewed and doesn't apply to the current stable version of the code, the maintainer asked for it in comment #2

short reply: we will consider backporting the change but there is no need to rush there, better to have it reviewed and validated by the people writing the code and having a version we can use for that

Changed in gnome-panel:
status: Invalid → Fix Released
Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-panel (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.30.2-0ubuntu1

---------------
gnome-panel (1:2.30.2-0ubuntu1) maverick; urgency=low

  * New upstream version:
    Panel
    - Make sure that newly-created panels become unhidden
    Notification Area Applet
    - Fix issues with old-style multiscreen setups (lp: #128735)
    Misc
    - Link the clock applet with libm
  * debian/gnome-panel.preinst: set debhelper token
  * debian/patches/90_git_new_unhidden.patch:
    - dropped, the fix is in the new version

  [ Martin Pitt ]
  * Remove transitional code that is only relevant for upgrading from old
    Ubuntu releases to lucid:
    - Remove debian/indicator-applet.desktop, debian/add-indicator-applet.py,
      debian/fusa-applet.note.in, debian/migrate-fusa-config.py
    - debian/gnome-panel.install, debian/rules: Remove installation of above
      files.
    - Remove debian/gnome-panel.preinst, no relevant code any more
    - Remove debian/patches/20_fusa_migration_note_i18n.patch
    - Add debian/gnome-panel.preinst: Clean up indicator-applet.desktop and
      /usr/share/gconf/defaults/25_gnome_panel_indicator_applet on upgrade.
 -- Sebastien Bacher <email address hidden> Wed, 23 Jun 2010 10:26:28 +0200

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released

gnome-panel - 1:2.30.2-0ubuntu1
>    - Fix issues with old-style multiscreen setups (lp: #128735)

Thanks for the patch.
But does the wording mean there is a "new-style" multiscreen setup I'm
missing out? :-)

Sebastien Bacher (seb128) wrote :

dunno, I don't have a multiscreen configuration to try that on

Sebastien Bacher (seb128) wrote :

Accepted gnome-panel into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
aefaradien (sen-aefaradien) wrote :

Very pleased to see that after a long wait, the notification area on my second monitor now has icons in it!

Pedro Villavicencio (pedro) wrote :

I've been using the package for a couple of days already and did not noticed any regression, also a reporter already confirmed that it indeed fixes the issue, Marking this as verification done, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.30.2-0ubuntu0.1

---------------
gnome-panel (1:2.30.2-0ubuntu0.1) lucid-proposed; urgency=low

  * New upstream version
    Panel
    - Make sure that newly-created panels become unhidden
    Notification Area Applet
    - Fix issues with old-style multiscreen setups (lp: #128735)
    Misc
    - Link the clock applet with libm
  * debian/patches/70_relibtoolize.patch:
    - new version update
  * debian/patches/90_git_new_unhidden.patch:
    - dropped, the fix is in the new version
 -- Sebastien Bacher <email address hidden> Wed, 23 Jun 2010 13:44:37 +0200

Changed in gnome-panel (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in gnome-panel:
importance: Unknown → Medium
AmenophisIII (amenophisiii) wrote :

i have an updated maverick installation which i just hooked up to a second monitor and tried to manually "duplicate" my bottom panel on the 2nd monitor.
indicator applets seems to work well == all icons are on both panels.
window list seem to work ok (only windows located on the monitor where the panel is are shown).
but the notification area on the secondary screens remains empty.
my gnome-panel version is 1:2.30.2-1ubuntu3.
the only major difference: i use a single integrated graphics card (mobile intel series 5 8086:0046).
is my impression wrong that the NA should work in this setup?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.