[enhancement] Ubuntu needs a way to set mouse wheel scrolling speed

Bug #124440 reported by Jim Hutchinson
678
This bug affects 150 people
Affects Status Importance Assigned to Milestone
GTK+
New
Undecided
Unassigned
Mir
Fix Released
Wishlist
Andreas Pokorny
Unity
Invalid
Undecided
Unassigned
gnome-control-center
Unknown
Unknown
gnome-control-center (Ubuntu)
Wishlist
Unassigned
gtk+3.0 (Ubuntu)
Wishlist
Unassigned
mir (Ubuntu)
Wishlist
Unassigned
ubuntu-system-settings (Ubuntu)
Wishlist
Unassigned

Bug Description

This has been driving me nuts for a while now. The scroll wheel on my desktop mouse (it's an MS wireless optical mouse model 1008) scrolls rather fast. Instead of moving a few lines, it scrolls half a page or more with a very gentle scroll. The bluetooth mouse I use with my laptop does not do this so it's probably somewhat hardware specific. However, I'm wondering if there is a way to modify the speed or sensitivity. I found an answer here from about a year ago (https://answers.launchpad.net/ubuntu/+question/1339) that suggests there isn't a way but I'm wondering if anything has changed since then. I've also skimmed through synaptic but didn't see anything promising (like gsynaptic for touchpads).

Thanks.

See https://answers.launchpad.net/ubuntu/+question/9200 for more information.

Related branches

Revision history for this message
Pascal De Vuyst (pascal-devuyst) wrote :

Assigning to gtk+2.0.

Revision history for this message
Pascal De Vuyst (pascal-devuyst) wrote :

This issue is known upstream (see bug watch).

Changed in gtk+2.0:
importance: Undecided → Medium
status: New → Confirmed
Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Medium → Wishlist
Changed in gtk:
status: Unknown → Confirmed
Revision history for this message
Matvei Fisenko (2matvei) wrote :

Bug is not fixed, and it is very VERY annoying.
People can not switch to Ubuntu because of this bug, which was mentioned in 2002 year!

Revision history for this message
Jim Hutchinson (jphutch) wrote :

It's also really annoying with the compiz desktop "wall" in gutsy. You can't switch to the next desktop as it moves 4 desktops at a time (at least in my case). I see no work around in compiz or gtk.

Revision history for this message
Götz Christ (g-christ) wrote :

That's a strange 'bug'. after 5 years and nothing.
What config file must I change to manipulate the scroll speed?

Revision history for this message
klap-in (klap-in) wrote :

I have here a IBM mouse ( MO09BO ) that hasn't a wheel but a kind of switch. When you move the switch forward/backward it give immediately pulses to the computer, all the time you move it forward/backward. When you leave it, the pulses stop. But all the programs react to fast on it, so it will be great when I can manipulate the 'scroll' speed.

Revision history for this message
Adrian Macneil (amacneil) wrote :

bump++

YES can we PLEASE have a setting for the scroll speed?!

I just bought a new ms mouse and one click scrolls like half a page. I was very surprised to find that there is not even a hidden setting!
Luckily firefox lets you override it, but it is very annoying in other apps.

And while someone's digging around in the gtk scroll code, smooth scrolling like firefox does would be nice ;)

Revision history for this message
Adrian Macneil (amacneil) wrote :

P.S.
In case anyone cares, the firefox setting is found by typing "about:config" in the location bar, then changing "mousewheel.withnokey.sysnumlines" to false, and messing with "mousewheel.withnokey.numlines"

This should be more important than "Wishlist"

Changed in gtk+2.0:
status: Confirmed → Triaged
Revision history for this message
fyo (fyo) wrote :

There are multiple issues here that make the "Wishlist" importance a mistake, IMHO.

If you read the link for more information in the bug description, you'll see that the problem isn't just adjusting wheel sensitivity... the very real problem is that many wireless mice (all MS Wireless?) report MULTIPLE EVENTS on each unit scroll if the system is ever booted into Windows. The mouse should only report two events (one press, one release), but instead reports multiple such.

That makes it *impossible* to scroll only one unit in any application that does not have a scroll sensitivity *divisor*, which exactly ZERO applications do that I'm aware of.

There are two possible solutions to this:

- Implement proper sensitivity adjustment accessible in Gnome.

or, better,

- Figure out what the hell is going on with the mouse/transceiver and send commands to it to fix it.

This is essentially a driver issue and should be handled as such (option 2). That doesn't exclude ALSO implementing option 1, but option 1 is properly set to "Wishlist", whereas the real issue here is the faulty driver for oddly-behaving wireless mice. It *appears* that booting into Windows causes some sort of hardware level sensitivity to be changed, resulting in multiple events per unit scroll.

The "workaround" is to unplug the transceiver (which appears to reset it to the sane 1 press + 1 release per unit scroll), but one cannot expect dual-booters to unplug their wireless transceiver every single time they boot into Windows.

Revision history for this message
Ken Nelan (kjnelan) wrote :

I had the same problem with the scroll wheel (as well as the back and forward buttons on the sides of my mouse) and am wondering if it's not more of a configuration error in xorg.conf?

Many of the mice on the market today use more than 5 buttons in fact, my mouse is a standard Microsoft wireless laser mouse 5000 and it has 9 buttons (Right, Left, Back, Forward, scroll up, scroll down, press scroll button, move scroll button left, move scroll button right, = 9). I used a different mouse for a test to see if this could really be the case. I had an old GE Optical Mouse WK2803 (wired to usb) and it has 7 buttons. (Right, Left, Back, Forward, scroll up, scroll down, press scroll button in = 7)

When I changed my xorg.conf to look like the snip below, everything worked perfectly. Even the number of scroll lines seemed to immediately change to the default of 3 per scroll.

begin copy

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ExplorerPS/2"
        Option "Buttons" "9" <-- for my GE mouse, I changed this to 7 and everything worked again.
        Option "ZAxisMapping" "4 5"
        Option "ButtonMapping" "1 2 3"
        Option "Emulate3Buttons" "false"
EndSection

end copy

Could it possibly be that simple as putting in the correct number of buttons in the xorg.conf and not a bug at all?

Thank you for your time.

Revision history for this message
Patrick (patrick-dcruze) wrote :

There may very well be multiple problems at play here. Certainly using the correct InputDevice section in the xorg.conf file may eliminate one of more of these problems. But it seems there's a fundamental problem with MS wireless mice _if_ you dual-boot into Windows.

fyo has posted an accurate assessment (see 2 posts above) of the situation so I won't bother repeating it. But it sounds like a kernel usb inputdev developer may need to reset the MS usb wireless transceiver.

Revision history for this message
Vish (vish) wrote :

 Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

But as fyo has commented, there is no easy/quick fix.

 A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

 For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

 Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Revision history for this message
antistress (antistress) wrote :

maybe Bug #61561 is related ?

Vish (vish)
affects: hundredpapercuts → null
Revision history for this message
dmitry.chirkin@gmail.com (dmitry-chirkin) wrote :

I think the option is realy needed because in my case it not MSmouse-speciefec issue.

I have a macbook with osx and ubuntu machine.
They are connected with Synergy. And macbook is server for synergy.

The scroll speed is insane even if i use touchpad.

I'm understand that this can be a Synergy bug but if we have such adjustment in Control Center it will solve my problem.

Sorry for my bad english.

Revision history for this message
Nowaker (nowaker) wrote :

Indeed. Three lines of scroll is to less for me. This should be configurable via anything - xorg or Gnome, but configurable. For now, there is no way to change it.

Revision history for this message
Xebec (vkleban) wrote :

It kinda did not bother me before, since I used Firefox, which had its own config. Since I swatched to Chrome, I really want this problem to be fixed.

Revision history for this message
Adam (adam-jackman) wrote :

I have a Microsoft Wireless 5000 mouse and this issue makes it nearly impossible to use the wheel fro scrolling. I do dual boot for games, so I will have a look from the windows side for a resolution too.

Revision history for this message
chriz (christian-seipel) wrote :

I'm having a Microsoft Wireless 6000 mouse and have the same issue as Adam. After shutting down windows and boot into ubuntu the mouse wheel is unusable for scrolling.

But in my case I found a solution. After booting ubuntu I'm pulling out the wireless USB receiver of the mouse an plug it in after some seconds. This helps getting the normal scrolling speed back in my case.

Revision history for this message
Lifyre (lifyre) wrote :

I can confirm that removing the USB reciever and replacing it on a Microsoft Wireless 6000 fixes the issue. The scroll rate is 10 times faster before doing this fix.

Changed in gtk:
importance: Unknown → Wishlist
Revision history for this message
Daniel Ferguson (dferguson) wrote :

+1 to dmitry's comment above.

Using OSX as a synergy server and gnome as a client - using the two finger scroll gesture on the MacBook touch pad sends a large number of scroll events to gnome.

Definitely something that could be fixed on synergy but having a sensitivity setting would fix it for every situation.

Revision history for this message
Alpha Crasher (ah734) wrote :

Pascal and company,

The only wish-list the lack of scroll wheel adjustment belongs on is Microsoft's wish-list - as in they wish it never happens.

If you want people, end users, to migrate to Linux, then the LAST thing you want is to make the controls uncomfortable.

This would put mouse, mouse wheel and touch pad control adjustment at the TOP of the DROP EVERYTHING and DO YESTERDAY list.

Given that a Microsoft memo identified Linux as the single biggest threat it faces, and that OpenOffice does virtually everything that MS Office does, but for free, I wonder how much Microsoft would be willing to offer me in cash, foreign property and cash or even jobs for my family members or a future job for myself if I were in a position to hold back or delay the development of the crucial FUNDAMENTALS that end-users expect in an operating system such as comfort adjustment of keyboards and mice?

How much would Microsoft be willing to pay me if I could hold on to my position of steering development efforts away from anything that would make Debian, the most widely distributed version of Linux with it's default Gnome desktop, INSTANTLY more user friendly?

Is this a far-fetched idea, not really, just ask yourself 3 questions: 1) how many decades have mice, scroll wheels and touch pads been around?, 2) How many computers don't have both a keyboard and a mouse?, and 3) How is it possible a simple mouse-wheel adjustment has not been implemented in Gnome?

If you have any doubts as to the effect of the lack of user-friendliness, you need look no further than Ubuntu and Fedora. The sole reason that these distributions exist and have gained in popularity is the lack of user-friendliness of other distributions because end-users will invariably choose a user-friendly installation.

No Fyo, this is NOT a hardware issue as nobody in their right mind expects hardware manufacturers to fabricate hardware for Linux which has less than 3% of the market. While comfort and ease of use by itself will not grow that market share, lack of it certainly will keep it from increasing. Daniel has it right.

Revision history for this message
dinamic (dinamic6661) wrote :

i hate this bug, i'm using Chrome and it's a pain to scroll long pages.

Revision history for this message
fsando (fsando) wrote :

I don't need this often but when I need it I'm seriously surprised that it's not there.

Is the reason it's missing that xorg makes it too complicated to implement? If that's the case we must hope really hard for Unity.

Revision history for this message
Gleb Mazovetskiy (glex-spb) wrote :

This bug definitely accounts for over 30% of my productivity loss after moving to Ubuntu
Scrolling through reports, web pages, and conversation threads is way too difficult

Revision history for this message
Pavlo Verba (pavlo.s.verba) wrote :

Neat. According to Matvei Fisenko, this bug is nine years old now.

Revision history for this message
Eren Tantekin (eren-tantekin) wrote :

The function that determines the scroll rate is in gtk/gtkrange.c

/**
 * _gtk_range_get_wheel_delta:
 * @range: a #GtkRange
 * @direction: A #GdkScrollDirection
 *
 * Returns a good step value for the mouse wheel.
 *
 * Return value: A good step value for the mouse wheel.
 *
 * Since: 2.4
 **/

Here, the scroll rate is determined dynamically by a smart (not so much?) algorithm:
delta = pow (adj->page_size, 2.0 / 3.0);

I don't want to offend the gtk developer that implemented this algorithm there. Obviously it may have temporarily solved the users complaining about too fast/too slow scrolling, but now it is time to make the scroll rate modifiable by the user.

Of course, implementing a new scrolling algorithm from scratch (with smooth scrolling) must be a priority too, since Ubuntu will possibly be coming to smartphones/tablets. But that rather than waiting for that, this problem can be fixed by a simple gtk patch which will read the scroll rate from a config file.

Curtis Hovey (sinzui)
no longer affects: null
Changed in gtk:
status: Confirmed → Fix Released
Revision history for this message
Pavlo Verba (pavlo.s.verba) wrote :

Why this have been marked as "Fix Released"? I do not see anyone ever mentioning a real fix.

The problem mentioned in the Question #9200 is mice manufactured by Microsoft scrolling too fast. Even if it can be solved, which it is not, there is no generic way to manipulate scroll speed for non-Microsoft mice.

Please re-open.

Revision history for this message
Adam Niedling (krychek) wrote :

They closed the bug upstream as fixed. I think they just made the scrolling a bit faster but they didn't make a way for us to set the scroll speed. So the upstream bug wasn't really the same as the downstream one.
And the scroll speed is still too slow compared to windows.

Adam Niedling (krychek)
summary: - gnome needs a way to manipulate scroll speed
+ Ubuntu needs a way to set mouse scrolling speed
Gerry Boland (gerboland)
Changed in unity-2d:
status: New → Invalid
Omer Akram (om26er)
Changed in unity:
status: New → Invalid
Changed in gtk+2.0 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Revision history for this message
fariazz (fariazz) wrote : Re: Ubuntu needs a way to set mouse scrolling speed

Is there still no way for the user to adjust the wheel speed?

Revision history for this message
Aleve Sicofante (sicofante) wrote :

Some people wonder why I sometimes say Ubuntu is half-finished. This and the sorry state of gpointing-device-settings is the best proof.

If there's no way to properly set/use mice and touchpads on many desktops/laptops, there's no way Ubuntu can gain more users. No amount of Unity improvements and shiny lenses and scopes will overcome a simple showstopper like this. Ever.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I totally agree. Unfortunately it's a problem we have inherited from Gnome 3.x. So many configuration options are hidden.

If you can't find what you need in gnome-control-center then open a terminal and run "synclient" which will show you many settings for touchpads at least. Also, for any input device type you can run:
    xinput list-props N
where N is a number shown by running "xinput" by itself. You can also use xinput to customize settings.

If you want to make such a command set on log in, you can add it as a startup program in "gnome-session-properties".

62 comments hidden view all 108 comments
Revision history for this message
In , Yorick Henning (p-yorick) wrote :

Fairly straightforward. This needs to be fixed. I have mice that scroll pages at the barest touch (and are therefore unusable without xinput hackery) and other mice that require four or five turns of the wheel to scroll down a paragraph (and are therefore equally as unusable).

This has been a problem in Gnome for *over a decade*. https://bugzilla.gnome.org/show_bug.cgi?id=89259

Somebody *please* just implement it.

61 comments hidden view all 108 comments
Revision history for this message
Yorick Henning (p-yorick) wrote :

This still hasn't been fixed? This is embarrassing. I bought a new mouse, and not only can I not use the scroll wheel effectively in Ubuntu (I need to spin it four or five times to move a paragraph), the mouse cursor traverses my 2560-pixel wide desktop in under 2cm of tabletop movement on the minimum available speed setting.

I get it, first world problems - but this is elementary for a desktop UI system. The fact that this hasn't been implemented in a *decade of Ubuntu development* is shamefully irresponsible.

I'm annoyed but capable of going and hacking my RCs in order to get xinput to fix this, but most Ubuntu users *cannot* be expected or even *able* to put up with this to get their *mouse to work properly*.

Revision history for this message
Chris (cmavr8) wrote :

Yorick, I completely agree with you.

I wonder which is the correct way to try to elevate this issue and let devs know it's important. Should I refer people affected to this bug and have them subscribe? Or should we open an idea at http://brainstorm.ubuntu.com and vote there?

Chris

Revision history for this message
IKT (ikt) wrote :

Well currently the bug has 4 statuses:

Fix Released
Invalid
Invalid
Triaged

Both Fix Released and Triaged have importance set to "wishlist", along with this not being an ubuntu issue, but a gnome issue, the chances of this getting fixed or implemented by Canonical are close to zero, you would be better off attempting to throw money at a developer, (most likely a gnome developer) to implement this.

Just my 2c.

Revision history for this message
G9283 (b8732-deactivatedaccount) wrote :

I don't understand. Is this fixed? It says Fix Released.

How do I set the scroll speed?

Revision history for this message
IKT (ikt) wrote :

@G9283

Click on: gnome-bugs #89259

Benjamin Otte (Company) [developer] 2012-03-07 00:55:03 UTC

I was just reading git logs for this, and I've not heard anybody complain about
scroll wheel performance forever, so I consider this closed.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I believe the front-end for this should live in gnome-control-center (and probably needs to be fixed by GNOME if it's going to be implemented). Updating this bug's projects to match that.

affects: gtk+2.0 (Ubuntu) → ubuntu
affects: ubuntu → gnome-control-center (Ubuntu)
Revision history for this message
Adam (adam-jackman) wrote : Re: [Bug 124440] Re: Ubuntu needs a way to set mouse scrolling speed

People have stoppef complaining because there has been no change for so
long.

I ended up changing a perfectly good mouse to resolve the issue.

Adam
On 2 Mar 2013 03:22, "IKT" <email address hidden> wrote:

> @G9283
>
> Click on: gnome-bugs #89259
>
> Benjamin Otte (Company) [developer] 2012-03-07 00:55:03 UTC
>
> I was just reading git logs for this, and I've not heard anybody complain
> about
> scroll wheel performance forever, so I consider this closed.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/124440
>
> Title:
> Ubuntu needs a way to set mouse scrolling speed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/124440/+subscriptions
>

Revision history for this message
Michi Henning (michihenning) wrote : Re: Ubuntu needs a way to set mouse scrolling speed

Who the hell decided to close this? Ubuntu is unusable with some brands of mice. And we go and just put it into the "I don't care basket"?

Who is in charge of this project? Can we please talk about this? <email address hidden>

Revision history for this message
Adam Niedling (krychek) wrote :

Michi: change the importance of this bug if you can.

Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Wishlist
Changed in gtk:
importance: Wishlist → Unknown
status: Fix Released → Unknown
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
no longer affects: unity-2d
no longer affects: gtk (Ubuntu)
54 comments hidden view all 108 comments
Revision history for this message
In , Adam Niedling (krychek) wrote :

This bug is recently getting lots of attention at the downstream bug report:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/124440

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
In , Ondrej Holy (oholy) wrote :

*** Bug 697404 has been marked as a duplicate of this bug. ***

Changed in mir:
importance: Undecided → Wishlist
status: New → Triaged
Markus Kühne (m-kuehne)
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Markus Kühne (m-kuehne)
Adam Niedling (krychek)
tags: added: saucy
summary: - Ubuntu needs a way to set mouse scrolling speed
+ [feature] Ubuntu needs a way to set mouse scrolling speed
tags: added: feature
summary: - [feature] Ubuntu needs a way to set mouse scrolling speed
+ [enhancement] Ubuntu needs a way to set mouse scrolling speed
tags: added: enhancement
removed: feature
Adam Niedling (krychek)
tags: added: trusty
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Revision history for this message
In , teppot (teppot-deactivatedaccount) wrote :

Confirmed with gnome-control-center 3.14.1 on Fedora 21.

Changed in gnome-control-center:
status: New → Confirmed
Changed in gtk:
status: New → Confirmed
Revision history for this message
In , Theo-dev-5 (theo-dev-5) wrote :

Confirmend with gnome-control-center 3.16. on Arch.

Is there a reason why this hasn't been implemented in gnome (e.g. conflicts with guidelines) or did just nobody implement this? I there is a chance to get a patch into upstream I would do some work in this regards.

Revision history for this message
In , Andre Klapper (a9016009) wrote :

Silence means that nobody works on this. :) More info if you're interested to contribute code: https://wiki.gnome.org/Git/Developers

information type: Public → Private
information type: Private → Public
29 comments hidden view all 108 comments
Revision history for this message
Timo Palomaa (timppis) wrote : Re: [enhancement] Ubuntu needs a way to set mouse scrolling speed

@68: What just started happening? Doesn't that sound like a driver issue? This bug is mostly about normally behaving scroll wheels, but people including me would just like if the "lines per scrolled distance" would be adjustable (I think most people find it be too small/slow by default... but I guess in some cases it's the opposite).

This is mainly a Gnome issue, but nothing stops Ubuntu from fixing this. Apparently it has been just accepted as a norm everywhere except in KDE (?) that default scroll speed is what it is or alternatively not a single developer has ever used a mouse produced after the invention of the scroll wheel.

30 comments hidden view all 108 comments
Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

This needs implementing in libinput first if it's going to be added to the UI.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

It doesn't actually need to be a configuration option, but it's a property of the hardware. You'll need to file a bug against systemd or libinput at bugzilla.freedesktop.org for the angle of the scroll wheel to be tagged properly.

See those articles for details:
http://who-t.blogspot.com.au/2015/01/providing-physical-movement-of-wheel.html
http://cgit.freedesktop.org/systemd/systemd/commit/?id=011c703495fb564a49dea44b424445241cd58634

Feel free to post the bug URL here for others to follow.

30 comments hidden view all 108 comments
Revision history for this message
Timo Palomaa (timppis) wrote :
Changed in gnome-control-center:
status: Confirmed → Unknown
Changed in gtk:
status: Confirmed → Unknown
Revision history for this message
Bernhard Zürn (bernhard-zuern) wrote :

Is it still gnome control center in unity ? Perhaps thsi "Bug" should go into another project/tracker ? What are the Parameters to be changed, so that we can write a small GUI-App to manage them ?

30 comments hidden view all 108 comments
Revision history for this message
In , Yorick Henning (p-yorick) wrote :

Hardware support for 15 degrees v. 20 degrees is not the same thing as a user-configurable sensitivity multiplier and/or acceleration factor. KDE, Windows, and Mac OS all support this as an option.

Add another two years onto this being a basic, unsupported feature I guess.

Revision history for this message
In , Andre Klapper (a9016009) wrote :

@steppres: For random offtopic operating system comments please use some forum or blog instead of GNOME Bugzilla. Thanks!

Adam Niedling (krychek)
tags: added: wily
30 comments hidden view all 108 comments
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision 3037, scheduled for release in mir, milestone 0.18.0

Changed in mir:
status: Triaged → Fix Committed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

A fix was committed to Mir. Is it *the* fix we need for this though?

Changed in mir:
assignee: nobody → Andreas Pokorny (andreas-pokorny)
milestone: none → 0.18.0
30 comments hidden view all 108 comments
Revision history for this message
In , Andre Klapper (a9016009) wrote :

*** Bug 757100 has been marked as a duplicate of this bug. ***

29 comments hidden view all 108 comments
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.3 KiB)

This bug was fixed in the package mir - 0.18.0+16.04.20151216.1-0ubuntu1

---------------
mir (0.18.0+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.18.0 (https://launchpad.net/mir/+milestone/0.18.0)
    - ABI summary: Only servers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 36
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI unchanged at 11
      . Mirprotobuf ABI unchanged at 3
      . Mirplatformgraphics ABI bumped to 7
      . Mirclientplatform ABI unchanged at 3
      . Mirinputplatform ABI added. Current version is 4
    - Enhancements:
      . Use libinput by default, and remove the android input stack
      . Add x11 input probing
      . Add alternative buffer swapping mechanism internally, available with
        --nbuffers 0
      . Automatic searching and selection of input platforms
      . Better support for themed cursors
      . Add demo client that uses multiple buffer streams in one surface
      . Improve fingerpaint demo to use touch pressure
      . Allow for configuring cursor acceleration, scroll speed and left or
        right handed mice
      . Allow for setting a base display configuration via client api
      . Various nested server multimonitor fixes and stability improvements
      . Remove DepthId from the SurfaceStack
    - Bug fixes:
      . Unit test failures in Display.* on Android (LP: #1519276)
      . Build failure due to missing dependency of client rpc code on mir
        protobuf (LP: #1518372)
      . Test failure in
        NestedServer.display_configuration_reset_when_application_exits
        (LP: #1517990)
      . CI test failures in various NesterServer tests (LP: #1517781)
      . FTBFS with -DMIR_PLATFORM=android (LP: #1517532)
      . Nesting Mir servers with assorted display configs causes lockup
        (LP: #1516670)
      . [testsfail] RaiseSurfaces.motion_events_dont_prevent_raise
        (LP: #1515931)
      . CI test failures in GLMark2Test (LP: #1515660)
      . Shells that inject user input events need to agree with the system
        compositor on the clock to use (LP: #1515515)
      . mircookie-dev is missing nettle-dev dependency (LP: #1514391)
      . Segmentation fault on server shutdown with mesa-kms (LP: #1513901)
      . mircookie requires nettle but libmircookie-dev doesn't depend on it
        (LP: #1513792)
      . libmircookie1 package does not list libnettle as dependency
        (LP: #1513225)
      . display configuration not reset when application exits (LP: #1511798)
      . unplugging external monitor causes nested server to throttle client
        (LP: #1511723)
      . 1/2 screen on external monitor (LP: #1511538)
      . unity-system-compositor crash, no interaction on windowed mode
        (LP: #1511095)
      . [regression] arm64/powerpc cross compile doesn't build any more
        (LP: #1510778)
      . mir_connection_get_egl_pixel_format() crashes if libEGL is loaded
        RTLD_LAZY (LP: #1510218)
      . [multimonitor] nested server surface positioning incorrect
        (LP: #1506846)
      . unity-system-compositor fails to build against lp:mir r3027
   ...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Kevin DuBois (kdub)
Changed in mir:
status: Fix Committed → Fix Released
Revision history for this message
Luis Felipe Marzagao (dulinux) wrote :

This solution works for me:

sudo apt-get install imwheel zenity

Create a bash script and insert this:

#!/bin/bash
# Version 0.1 Tuesday, 07 May 2013
# Comments and complaints http://www.nicknorton.net
# GUI for mouse wheel speed using imwheel in Gnome
# imwheel needs to be installed for this script to work
# sudo apt-get install imwheel
# Pretty much hard wired to only use a mouse with
# left, right and wheel in the middle.
# If you have a mouse with complications or special needs,
# use the command xev to find what your wheel does.
#
### see if imwheel config exists, if not create it ###
if [ ! -f ~/.imwheelrc ]
then

cat >~/.imwheelrc<<EOF
".*"
None, Up, Button4, 1
None, Down, Button5, 1
Control_L, Up, Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L, Up, Shift_L|Button4
Shift_L, Down, Shift_L|Button5
EOF

fi
##########################################################

CURRENT_VALUE=$(awk -F 'Button4,' '{print $2}' ~/.imwheelrc)

NEW_VALUE=$(zenity --scale --window-icon=info --ok-label=Apply --title="Wheelies" --text "Mouse wheel speed:" --min-value=1 --max-value=100 --value="$CURRENT_VALUE" --step 1)

if [ "$NEW_VALUE" == "" ];
then exit 0
fi

sed -i "s/\($TARGET_KEY *Button4, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button4, and write new value.
sed -i "s/\($TARGET_KEY *Button5, *\).*/\1$NEW_VALUE/" ~/.imwheelrc # find the string Button5, and write new value.

cat ~/.imwheelrc
imwheel -kill

# END OF SCRIPT FILE

Now run the script and set you desired mouse wheel speed.

Thanks to: http://www.nicknorton.net/?q=node/10

Adam Niedling (krychek)
tags: added: xenial
Changed in mir (Ubuntu):
importance: Undecided → Wishlist
no longer affects: hundredpapercuts
Revision history for this message
Tim Lunn (darkxst) wrote :

Adding a UI element for a few hardware specific issues does not seem like a good idea, especially when I can guarantee upstream won't take those patches. Likely they can be fixed for the specific devices by udev rules or similar.

Marking gnome-control-center invalid

Changed in gnome-control-center (Ubuntu):
status: Triaged → Invalid
Revision history for this message
Adam (adam-jackman) wrote : Re: [Bug 124440] Re: [enhancement] Ubuntu needs a way to set mouse scrolling speed

It hardly seems invalid. Not everyone likes the default mouse speed.

My father, who is in his mid seventies, likes to slow the mouse so it is to
his pace. Others like it a lot faster so they only have to move the mouse
or across the touchpad a small amount .

I am aware that this is a bigger issue for certain cases of multi boot
users, but it it is not a simple issue.

One size does (speed) does not fit all.
On 5 May 2016 07:31, "Tim" <email address hidden> wrote:

> Adding a UI element for a few hardware specific issues does not seem
> like a good idea, especially when I can guarantee upstream won't take
> those patches. Likely they can be fixed for the specific devices by udev
> rules or similar.
>
> Marking gnome-control-center invalid
>
> ** Changed in: gnome-control-center (Ubuntu)
> Status: Triaged => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/124440
>
> Title:
> [enhancement] Ubuntu needs a way to set mouse scrolling speed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/124440/+subscriptions
>

summary: - [enhancement] Ubuntu needs a way to set mouse scrolling speed
+ [enhancement] Ubuntu needs a way to set mouse wheel scrolling speed
Revision history for this message
Michi Henning (michihenning) wrote :

I couldn't agree more. With some high-resolution gaming mice are completely unusable without the adjustment.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I agree, it's a perfectly valid request...

Just realistically it probably won't get fixed in Unity7's 'gnome-control-center (Ubuntu)' as that gets replaced by Unity8's 'ubuntu-system-settings (Ubuntu)'.

More more importantly; see comment #51 where I pointed out that Linux is so eclectic that it's probably not feasible to ever fix this in an X11-based system, except separately for each class of GUI toolkit. Even with the introduction of Unity8 it will be similarly difficult, made easier only in that we control and author the low-level input system (Mir).

Revision history for this message
Adam (adam-jackman) wrote :

This isn't the first time this fault has been closed and reopened. Is
there any way this can be prevented?

Sadly I have no coding ability to develop a solution.
On 5 May 2016 08:26, "Daniel van Vugt" <email address hidden>
wrote:

> ** Also affects: ubuntu-system-settings (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Summary changed:
>
> - [enhancement] Ubuntu needs a way to set mouse scrolling speed
> + [enhancement] Ubuntu needs a way to set mouse wheel scrolling speed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/124440
>
> Title:
> [enhancement] Ubuntu needs a way to set mouse wheel scrolling speed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/124440/+subscriptions
>

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I also forgot... you can make the wheel less sensitive now:

1. Find out the device name of your mouse running 'xinput'

2. Slow down the scrolling speed like with my mouse:
   xinput set-prop 'Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)' 'Evdev Scrolling Distance' 5 5 5

The default values are 1 1 1. It seems higher is slower.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Revision history for this message
Dirk Mcbratney (djmcbratney) wrote :

We just need a proper mouse settings tool. In Windows, I can reassign buttons freely on my seven-button mouse through the GUI. A third-party GUI from Logitech, but a GUI nonetheless. In Ubuntu, I have to run an xinput script (manually, since Gnome's hotplug command line in dconf no longer works) to reassign everything and can't even assign the wheel tilt to back/forward doing that (changing the button map gets me two backs or forwards each click and still scrolls at the same time.)

But a simple scroll speed slider in Mouse and Touchpad would certainly have been a lot nicer than having to add another line to the script.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I can only guess that the Ubuntu Desktop team has not been motivated to add such new configuration features because of the pending switch to Unity8.

The good news is that Unity8 frees us from the link to upstream Gnome/GTK that Unity7 is subject to. So in theory we will have more freedom to add custom configuration options more rapidly in future.

That does not however explain or excuse us for failing to add this feature in the previous 9 years since this bug was logged.

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Revision history for this message
Dirk Mcbratney (djmcbratney) wrote :

Much thanks for the workaround, in any case. xinput's obviously not really an enduser-focused tool, and the property number for evdev scrolling distance has changed to three different ones in the couple of days I've been using it. But it's nice to get basic functionality out of this mouse. I also have to think there's been a change of defaults somewhere in this case, since I'd actually used this mouse on a previous Ubuntu install....

I certainly hope Unity 8 will address some of these basic issues lying around, but again ... upstream or not, this is a bug that's existed for nine years. I don't expect a quick resolution for the same problem.

Revision history for this message
clel (clel) wrote :

Still not implemented? This is probably an UI issue since KDE has this setting.

I consider this basic, my mouse scrolls pretty slow and I cannot change it.

18 comments hidden view all 108 comments
Revision history for this message
In , clel (clel) wrote :

To me it seems an UI specific issue, since other desktop enviroments (KDE as stated above) have this feature.

Also I don't think this can be considered as fixed since I don't think there is the "one" scroll speed that just needs to be set correctly in specific drivers.
This is the argument @steppres was making and he underlines this by stating examples of other operating systems. So I don't think this comment is offtopic.

17 comments hidden view all 108 comments
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

There is a setting for this in Unity8 now. It's the second (unnamed) scrollbar under:
System Settings > Mouse & Touchpad > Mouse

However there are two bugs related to that scroll bar:
  1. It's not yet labelled (bug 1569227)
  2. It doesn't go high enough (missing fix: https://code.launchpad.net/~vanvugt/ubuntu-system-settings/fix-1607240/+merge/301606)

Revision history for this message
clel (clel) wrote :

Thanks for the update. Nice this is probably finally implemented.

Revision history for this message
Aleksey (evenfrost) wrote :

Would love to see similar feature in Gnome as it will be default desktop for Ubuntu soon.

Adam Niedling (krychek)
tags: added: bionic
Revision history for this message
clel (clel) wrote :

Can someone responsible for this (is there anyone?) please update this to reflect the current state?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed, gnome-control-center is where such a setting would live. So I am reopening that task at least to avoid people logging duplicate bugs.

However, keep in mind that mouse wheel ticks are emitted as button click events which have no "size" that can be controlled from a central location. This means each toolkit needs to implement the setting separately. If it was implemented for GTK-3 then that's no guarantee that the setting would be honoured in Chrome or Firefox because they have their own separate toolkits.

Changed in gnome-control-center (Ubuntu):
assignee: Markus Kühne (m-kuehne) → nobody
status: Invalid → Confirmed
Adam Niedling (krychek)
tags: added: cosmic
14 comments hidden view all 108 comments
Revision history for this message
In , clel (clel) wrote :

Unfortunately I thought this was all to be implemented inside the desktop environment itself for a long time.

But apparently this is really on the libinput side as @Bastien Nocera already mentioned in comment #6 and #7. So I created an issue on the bugtracker of libinput: https://gitlab.freedesktop.org/libinput/libinput/issues/185

13 comments hidden view all 108 comments
Revision history for this message
clel (clel) wrote :

According to https://bugzilla.gnome.org/show_bug.cgi?id=692666#c6 this should be addressed in libinput. So I went ahead an created an issue there: https://gitlab.freedesktop.org/libinput/libinput/issues/185

Revision history for this message
Adam Niedling (krychek) wrote :

Get money to fix this bug or raise the bounty so it will get more tempting for someone to get it done:

https://www.bountysource.com/issues/3848890-enhancement-ubuntu-needs-a-way-to-set-mouse-wheel-scrolling-speed

Adam Niedling (krychek)
tags: added: disco
Adam Niedling (krychek)
tags: added: eoan
Changed in gtk:
importance: Medium → Undecided
status: Unknown → New
Changed in gnome-control-center:
importance: Medium → Unknown
Changed in gnome-control-center:
importance: Unknown → Medium
Adam Niedling (krychek)
tags: added: groovy
Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Won't Fix
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
tags: removed: cosmic disco eoan saucy trusty wily
13 comments hidden view all 108 comments
Revision history for this message
lotuspsychje (lotuspsychje) wrote :
Revision history for this message
Tom Reynolds (tomreyn) wrote :

For gnome-control-center, this bug report was watching https://bugzilla.gnome.org/show_bug.cgi?id=692666 so far. While still relevant, the Gnome Project has stopped using this bug tracker and has since shifted to their Gitlab instance for bug tracking.

A closely related upstream bug report, which should have higher relevance for Ubuntu (after shifting to XWayland), is https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1016, so I've updated the remote watch for gnome-control-center.

Changed in gnome-control-center:
importance: Medium → Unknown
Displaying first 40 and last 40 comments. View all 108 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.