Comment 10 for bug 124440

I had the same problem with the scroll wheel (as well as the back and forward buttons on the sides of my mouse) and am wondering if it's not more of a configuration error in xorg.conf?

Many of the mice on the market today use more than 5 buttons in fact, my mouse is a standard Microsoft wireless laser mouse 5000 and it has 9 buttons (Right, Left, Back, Forward, scroll up, scroll down, press scroll button, move scroll button left, move scroll button right, = 9). I used a different mouse for a test to see if this could really be the case. I had an old GE Optical Mouse WK2803 (wired to usb) and it has 7 buttons. (Right, Left, Back, Forward, scroll up, scroll down, press scroll button in = 7)

When I changed my xorg.conf to look like the snip below, everything worked perfectly. Even the number of scroll lines seemed to immediately change to the default of 3 per scroll.

begin copy

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ExplorerPS/2"
        Option "Buttons" "9" <-- for my GE mouse, I changed this to 7 and everything worked again.
        Option "ZAxisMapping" "4 5"
        Option "ButtonMapping" "1 2 3"
        Option "Emulate3Buttons" "false"
EndSection

end copy

Could it possibly be that simple as putting in the correct number of buttons in the xorg.conf and not a bug at all?

Thank you for your time.