Ubuntu

Port compiz to gsettings and consequently remove unity-2d

Reported by Didier Roche on 2012-08-10
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
compiz (Ubuntu)
High
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
lightdm (Ubuntu)
Undecided
Unassigned
metacity (Ubuntu)
Undecided
Unassigned
nux (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Porting compiz and so unity to gsettings has a lot of consequences:
- compiz:
  * remove the conffile for 2nd (autologin) fallback mechanism
  * build with gsettings support
  * add migration scripts
  * add xml files for the g-c-c integration (we used the metacity ones before)
- unity :
  * gconf -> gsettings patches (2)
  * rebuild with the new gsettings compiz
  * add transitional packages for all unity-2d packages
  * add migration scripts
- nux:
  * remove the X11 Xsession.d detection script
- gnome-control-center:
 * should be ported in both the keyboard part by reverting the gsettings revert patch
 * in the unity background configuration panels to support gsettings
 * in the display configuration panels to support gsettings
- gnome-settings-daemon to drop the gsettings revert patch:
- metacity should be updated to >> 2.34.2 (gsettings integration, shared with compiz). Sync back with debian, demote to universe -> this forces us to drop a lot of patches to make unity-2d running
- consequently, dropping unity-2d because of metacity patches won't be ported, and unity-2d isn't maintained to port from gconf to gsettings:. Removal from the archive
- lightdm to transition people from unity-2d to unity-3d session
- unity-greeter to drop hardware detection capability for nux
- gnome-session to drop the unity-2d session and recommends
- release-upgrader in precise to detect if the card can't run unity-3d, and if so, show a warning to tell to stay on the LTS
- ubuntu-desktop seed to remove dep on unity-2d

People forcing the upgrade or installing on a machine without hardware acceleration will then use unity with llvmpipe.

---------------
WHAT IS REMAINING:

ubuntu-release-upgrade -> we will deal that with mvo later on.

all above components that are fix commited (apart unity):
- bzr pull the vcs, release and dput it
- metacity to sync with debian

Unity: Packaging branches lp:~didrocks/unity/gsettings-transition -> continued at lp:~timo-jyrinki/unity/gsettings-transition2
- build with latest compiz, check compiz version for build-dep (already bumped, but check if not shipped in a new tarball)
- check that I ship correctly the .convert script and bump if needed the dep from unityc-ommon to compiz-gnome (already bumped, but check if not shipped in a new tarball)

Compiz: packaging branches lp:~timo-jyrinki/compiz/ubuntu_quantal_trunk (against trunk) -> pushed to lp:ubuntu/compiz now / lp:~timo-jyrinki/compiz/ubuntu_quantal (merged in all the branches not yet in trunk, and additional changes)
- merge all the gsettings branches to lp:compiz

MISC:
- PPA including all of above: https://launchpad.net/~timo-jyrinki/+archive/prerelease

TESTING THE MIGRATION:

1. have the old g-c-c, change unity values in it (launcher size, hide mode…), change keybindings (a lot of them in different categories, launcher, navigation… like changing workspace keys)
2. install new g-c-c (lp:~ubuntu-desktop/gnome-control-center/ubuntu), compiz, unity with all the settings migration
3. logout/login
4. check that the keys are transitionned to the new system: launcher size/hide mode are the changed values and corresponds and the values are shown in the new g-c-c. Same thing with the changed keybidings.

Didier Roche (didrocks) on 2012-08-10
Changed in compiz (Ubuntu):
status: New → In Progress
Changed in gnome-control-center (Ubuntu):
status: New → Fix Committed
Changed in gnome-session (Ubuntu):
status: New → Fix Committed
Changed in lightdm (Ubuntu):
status: New → Fix Committed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Fix Committed
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity-greeter (Ubuntu):
status: New → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-08-10
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
Changed in metacity (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2012-08-10
description: updated
Omer Akram (om26er) on 2012-08-10
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in compiz:
importance: Undecided → High
milestone: none → 0.9.8.0
status: New → Confirmed
Didier Roche (didrocks) on 2012-08-14
description: updated
Didier Roche (didrocks) on 2012-08-15
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 3.2.0-0ubuntu2

---------------
nux (3.2.0-0ubuntu2) quantal; urgency=low

  * debian/50_check_unity_support,
    debian/nux-tools.install:
    - remove unity-2d check while logging, which was the second attempt to
      fallback to it if the first didn't catch it (autologin mode). Now that
      unity-2d is deprecated because of the gsettings transition (LP: #1035261)
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 08:30:11 +0200

Changed in nux (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.0-0ubuntu2

---------------
unity-greeter (12.10.0-0ubuntu2) quantal; urgency=low

  * debian/patches/run_unity_support_test.patch:
    - removed, we only support unity-3d now and fallback with llvmpipe
      if there is no GL acceleration (LP: #1035261)
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 08:39:47 +0200

Changed in unity-greeter (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.3.2-0ubuntu3

---------------
lightdm (1.3.2-0ubuntu3) quantal; urgency=low

  [ Christopher James Halse Rogers ]
  * debian/patches/05_add_xserver_core_option.patch:
    - Pass '-core' to the X server, which will cause it to dump core when
      crashing. This will trigger apport, so we'll get more reliable crash
      reports from X server crashes.

  [ Didier Roche ]
  * debian/patches/01_transition_ubuntu2d_ubuntu_desktop.patch:
    - unity-2d is not supported anymore and won't be port to gsettings,
      transition people using the 2d session to the 3d one. llvmpipe
      will be use if no hardware acceleration is available (LP: #1035261)
  * debian/patches/01_transition_gnome_ubuntu_desktop.patch:
    - removed, not needed anymore

  [ Scott Kitterman ]
  * Add lightdm-kde-greeter as an alternate recommends for lightdm
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 08:41:55 +0200

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.5.5-0ubuntu2

---------------
gnome-session (3.5.5-0ubuntu2) quantal; urgency=low

  * debian/patches/50_ubuntu_sessions.patch,
    debian/patches/52_xdg_current_desktop.patch:
    - remove ubuntu-2d session. unity-2d is not supported anymore and people
      will be transitionned to the 3d session. llvmpipe is used if no hardware
      acceleration is available. (LP: #1035261)
  * debian/control:
    - remove unity-2d recommends
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 08:46:51 +0200

Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.2.0-0ubuntu2

---------------
unity (6.2.0-0ubuntu2) quantal; urgency=low

  * debian/control:
    - create unity-2d transitional packages. Removing unity-2d as it is now
      not supported and won't be transitionned to the necessary gsettings
      changes (part one of LP: #1035261)
    - change some description wording to remove -2d
  * debian/*preinst:
    - removed, useless now
  * debian/profile_upgrade*, debian/unity-common.install:
    - remove old profile upgrade content
 -- Didier Roche <email address hidden> Mon, 13 Aug 2012 12:10:54 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.280

---------------
ubuntu-meta (1.280) quantal; urgency=low

  * Refreshed dependencies
  * Added fonts-freefont-ttf to desktop
  * Removed unity-2d from desktop:
    it would need to be ported to gsettings to continue being installable.
    However it's unsupported now. Every 2d users are being transitionned to
    the 3d session. People without graphical acceleration will then use
    llvmpipe (LP: #1035261)
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 09:17:55 +0200

Changed in ubuntu-meta (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2012-08-15
description: updated
Didier Roche (didrocks) wrote :

unity-2d source and remaining binary packages (not transitionned as they were transitional packages removed):

$ ./remove-package -m "removing unity-2d from the archive. (LP: #1035261)" -s quantal unity-2d
Removing packages:
 unity-2d 5.12.0-0ubuntu3 in quantal
  unity-2d-launcher 5.12.0-0ubuntu3 in quantal amd64
  unity-2d-launcher 5.12.0-0ubuntu3 in quantal armel
  unity-2d-launcher 5.12.0-0ubuntu3 in quantal armhf
  unity-2d-launcher 5.12.0-0ubuntu3 in quantal i386
  unity-2d-launcher 5.12.0-0ubuntu3 in quantal powerpc
  unity-2d-places 5.12.0-0ubuntu3 in quantal amd64
  unity-2d-places 5.12.0-0ubuntu3 in quantal armel
  unity-2d-places 5.12.0-0ubuntu3 in quantal armhf
  unity-2d-places 5.12.0-0ubuntu3 in quantal i386
  unity-2d-places 5.12.0-0ubuntu3 in quantal powerpc
Comment: removing unity-2d from the archive. (LP: #1035261)
Remove [y|N]? y
1 package successfully removed.

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2012-08-15
description: updated
Changed in unity (Ubuntu):
status: Fix Released → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-08-15
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8+bzr3249-0ubuntu3

---------------
compiz (1:0.9.8+bzr3249-0ubuntu3) quantal; urgency=low

  * Remove unity-2d 2nd fallback mechanism for autologin as unity-2d
    is now deprecated: (part one of LP: #1035261)
    - debian/65compiz_profile-on-session,
      debian/compiz-gnome.install:
      remove conffile and don't install it
    - debian/compiz-gnome.maintscript:
      remove it on upgrade
 -- Didier Roche <email address hidden> Wed, 15 Aug 2012 14:58:39 +0200

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-08-15
Changed in compiz (Ubuntu):
status: Fix Released → Triaged
Didier Roche (didrocks) on 2012-08-16
description: updated
Didier Roche (didrocks) on 2012-08-17
description: updated
Didier Roche (didrocks) on 2012-08-17
description: updated
description: updated
Didier Roche (didrocks) on 2012-08-17
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu10

---------------
gnome-control-center (1:3.4.2-0ubuntu10) quantal-proposed; urgency=low

  * debian/patches/clutter_init.patch
    - added missing include for config.h to get the HAVE_CLUTTER defines
 -- Ken VanDine <email address hidden> Thu, 23 Aug 2012 16:09:35 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.2.0-0ubuntu3

---------------
unity (6.2.0-0ubuntu3) quantal-proposed; urgency=low

  * debian/control:
    - updated compiz gsettings version

  [ Didier Roche ]
  * Backports:
    - the remaining part of the gconf removal from upstream branch
    - the .convert migration scripts
  * debian/control:
    - do not build-dep on gconf anymore
    - build-dep on latest compiz for building gsettings keys
      (part 2 of LP: #1035261)
  * debian/unity-common.install, debian/control:
    - don't ship gconf schemas as not built anymore (the gsettings schema ones
      are already shipped)
    - install the gnome-control-center unity keybinding integration
    - install the .convert files handled by the compiz migration script and
      make unity-common depending on the right version of compiz-gnome (with
      the migration script)

  [ Timo Jyrinki ]
  * Add dbus-glib-1 to UNITY_PLUGIN_DEPS to fix FTBFS
  * Remove the remaining gconf files from installation
  * Remove gconf-2.0 dependency from services
  * Make sure USE_GSETTINGS is defined
  * Backports:
    - gnome-control-center integration
 -- Sebastien Bacher <email address hidden> Thu, 23 Aug 2012 17:58:52 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu9

---------------
gnome-settings-daemon (3.4.2-0ubuntu9) quantal-proposed; urgency=low

  [ Sebastien Bacher ]
  * debian/control.in:
    - don't build-depends on gconf
    - updated gnome-control-center breaks version for gsettings
  * debian/patches/revert_git_a11y_gsettings.patch,
    debian/patches/revert_git_stop_using_gconf.patch,
    debian/patches/revert_git_use_gsetting_keybindings.patch:
    - drop the gconf to gsettings migration reverts (LP: #1035261)

  [ Keng-Yu Lin ]
  * debian/patches/git-mask-out-virtual-modifiers.patch
    - patch from upstream git, fix the grabbing issue of the
      keyboard shortcut with virtual (Super, Hyper, Meta) modifier.
      (lp: #950160)

  [ Edward Donovan ]
  * debian/source_gnome-settings-daemon.py: Fix for Python 3. (LP: #1013171)

  [ Hsin-Yi, Chen (hychen) ]
  * debian/patches/git_xrandr_explicitly_set_clone_state.patch:
    - "xrandr; explicitly set clone state variable when generating monitor
      configs" (LP: #1014533)

  [ Michael Terry ]
  * debian/patches/git-smartcard-crash.patch:
    - Don't crash on login with a smartcard (LP: #1031034)
 -- Sebastien Bacher <email address hidden> Thu, 23 Aug 2012 17:04:16 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package metacity - 1:2.34.3-3ubuntu1

---------------
metacity (1:2.34.3-3ubuntu1) quantal-proposed; urgency=low

  * Resync with Debian & refresh patches. (LP: #1032120, LP: #1035261)
    Remaining changes:
  * debian/control:
    - Suggest gnome-themes-standard instead of recommend
    - Add Vcs-Bzr link
  * debian/metacity-common.gsettings-override:
    - Set Ubuntu default button layout order for Classic session
    - Drop previous gconf overrides as obsolete
  * debian/patches/04_support_drag_drop_with_alt_tab.patch:
    - Support alt-tab during drag and drop.
  * debian/patches/05_raise_on_click_for_click_mode.patch:
    - Use raise on click option.
  * debian/patches/06_Add_UXD_shadows_and_borders.patch:
    - patch for a new key in the ubuntu theme for shows and borders
  * debian/patches/10_no-ws-switcher.patch:
    - Don't show the workspace switcher if we only have one.
  * debian/patches/12_dont-show-as-user.patch:
    - Don't show "as user" in title bar.
  * debian/patches/13_better_support_for_button_layout.patch:
    - Corrected support for buttons backgrounds with transparency
  * debian/patches/14_wrong_colormap.patch:
    - Use correct colormap to avoid crash with client side decorations
  * debian/patches/20_do-not-place-windows-over-the-launcher.patch:
    - Try to avoid an already visible launcher in intellihide mode when
      initially positioning new windows.
  * debian/patches/21_fix_compositing_startup.patch:
    Fix some weird rendering effect at startup with compositing activated
  * debian/patches/100_fade_on_long_title.patch:
    - Fade on the end if the title is too long.
  * debian/patches/102_workarea.patch,
    debian/patches/103_struts_in_the_middle.patch,
    debian/patches/104_workarea_union.patch:
    - Add barriers and multimonitor strut support for unity-2d
  * debian/patches/104_workarea_union.patch:
    - Ensure each screen_region generated by
      meta_rectangle_get_minimal_spanning_set_for_region is not outside
      the xinerama screens
  * Dropped patch:
    - 11_hide_tooltip_on_decorator.patch: Obsolete
  * debian/patches/03_strict_focus.patch:
    - Disabled. This needs gsettings-desktop-schemas to be patched if
      we want to bring this back
  * Disabled Unity 2D-related patches that need porting to gsettings:
    - 15_show_maximized_titlebars.patch
    - 16-capture-before-unmap.patch
    - 17-workspace-switcher-cycle.patch
    - 18-auto-maximize-windows.patch
    - 19_add_unity_hud_configuration.patch
    - 101_override_gconf_settings.patch

metacity (1:2.34.3-3) unstable; urgency=low

  [ Josselin Mouette ]
  * 01_focus_new_window.patch: new patch from upstream bugzilla.
    Correctly focus new windows even when they appear behind an ?^?^?always
    on top?^?^? window. Closes: #515577.

  [ Michael Biebl ]
  * Rebuild with xz compression for binary packages.

metacity (1:2.34.3-2) unstable; urgency=low

  * Upload to unstable.
  * Replace Suggests: gnome-themes with Recommends: gnome-themes-standard
    since Adwaita is the preferred window manager theme and we want it to be
    installed by default.
  * Use strict dependency between metacity/libmetacity-private0a...

Read more...

Changed in metacity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.178

---------------
ubuntu-release-upgrader (1:0.178) quantal; urgency=low

  [ Michael Vogt ]
  * add unity_support_test as a upgrader quirk (LP: #1035261)

  [ Jonathan Riddell ]
  * Remove kdm and xsettings-kde
 -- Jonathan Riddell <email address hidden> Fri, 10 Aug 2012 16:54:36 +0200

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Committed → Fix Released
Dylan McCall (dylanmccall) wrote :

I'm using gnome-control-center 3.4.2-0ubuntu13, and the Theme selection in Appearance settings changes the GTK theme and not the WM theme. I'm seeing the same with gnome-tweak-tool 3.5.5-0ubuntu1. From the looks of it, these panels are both changing the dconf key named "theme" in "org.gnome.desktop.wm.preferences", but Compiz is only looking at the obsolete gconf key "/apps/metacity/general/theme." Have I gone and broken something on my end, or is this reproducible? Should I file another bug report?

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
status: Confirmed → Fix Committed
Adolfo Jayme (fitoschido) wrote :

@dylanmccall: See bug 1046895 for that

Changed in compiz:
status: Fix Committed → Fix Released
funicorn (funicorn) wrote :

It's ridiculous the bug affects me today when updating to compiz 0.9.8.4, regression? again ?

Adolfo Jayme (fitoschido) wrote :

@funicorn: I guess you've ridiculously commented on the wrong bug ;-) otherwise I don't understand your comment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints