Trash always full

Bug #269441 reported by mapinas
258
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
caja (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by David Clayton
glib2.0 (Ubuntu)
Low
Unassigned
Nominated for Lucid by David Clayton

Bug Description

I've seen other users having problems with that the trash appears empty even though it isn't. I have the opposite problem: my trash icon on the desktop always appears full, even if empty.

Revision history for this message
Marcus Asshauer (mcas) wrote :

Thank you for reporting this bug. Please add your ubuntu version and tell us which desktop enviroment and theme you are using.

Revision history for this message
mapinas (mapinas) wrote :

Everything is out of the box defaults: Hardy with GNOME and Human theme.

Revision history for this message
Dragomir Minkovski (dejuren) wrote :

I can confirm this - empty trash folder, but the flash icon is showing it's full. It can be related to case when some file is moved to the Desktop via network workstation (MAC or Windows), it is not shown until reboot/logout. Otherwise file is there and is accessible on the terminal.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for the report, May you tell us a few steps in order to recreate the issue? Do you have that partition in removable device or in another hard drive? Which type of partition is that one? Does the trash applet reflect the right status?

Revision history for this message
Dragomir Minkovski (dejuren) wrote :

The file system type is xfs (my home directory is on /dev/sdc4): on an NFS/autofs mounted filesystem.

/dev/sdc4 xfs 372231488 167990656 204240832 46% /export/v4

Revision history for this message
smmalis37 (smmalis37) wrote :

This happens to me all the time, and really is quit annoying.
Intrepid/GNOME/Custom theme
All updates installed.

Revision history for this message
Sebastien Bacher (seb128) wrote :

could somebody having the issue send the bug to bugzilla.gnome.org where the people writting the code will read it?

Revision history for this message
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty?

Revision history for this message
Patrick Goetz (pgoetz) wrote : Re: [Bug 269441] Re: Trash always full

Sebastien Bacher wrote:
> could you try if that's still an issue in jaunty?
>

OK, I was just waiting for Alpha 3 to come out before giving it a try;
so can probably do this in the next few days.

Revision history for this message
Sebastien Bacher (seb128) wrote :

should be fixed in jaunty, closing the bug, you can reopen if you still get the issue though

Changed in gnome-applets:
status: Incomplete → Fix Released
Revision history for this message
Raúl Núñez de Arenas Coronado (dervishd) wrote :

This bug still happens in Jaunty. I suffer it from time to time, and the worst problem is that I don't know how to reproduce.

After the trash applet is "locked" into "full mode" (I can't think of a better way of explaining it) it won't revert to normal behaviour until I log out and on again. Meanwhile I can delete files, empty the trash (and the files will disappear from ~/.local/share/Trash but the trash icon will stay "full") and even open it to see it is empty.

When the trash applet is behaving wrong, it always says "N items in Trash" when I hover the mouse over the applet icon, let's say that "N" is "5": if I delete another file, "N" is "6" (correctly", but if I empty the trash, "N" is "5" again, not "0" as it should.

If I manage to reproduce the bug (now it happens randomly as far as I can tell) I'll update the report.

Raúl

Revision history for this message
Raúl Núñez de Arenas Coronado (dervishd) wrote :

Reopening as it is still happening in Jaunty.

Changed in gnome-applets (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

don't reopen a closed bug because you have a similar issue open a new one rather

Changed in gnome-applets (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
norio@maxiware.co.za (norio) wrote :

I'm having this issue in 9.10. To replicate:

- Insert usb disk
- Delete files
- Unmount
- Empty trash

It will delete local files but seems to keep a record of the files on the usb disk that weren't yet deleted, so never shows an "empty trash" icon.

Hope this helps.

Changed in gnome-applets (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Kip Warner (kip) wrote :

I also confirm this problem and can attest to the observations noted previously. I am running Lucid on amd64. This bug and 390608 appear to be the same.

Revision history for this message
David Clayton (dcstar) wrote :

Yep, it "knows" there are Trash items in the now removed device but should not really remain in that status once the device is removed. Putting the device back in allows you to empty the trash and reset the status of the icon.

Something in the remove script needs to either reset or refresh the Trash status so it is accurate for still mounted/attached devices.

Revision history for this message
Kip Warner (kip) wrote :

Problem still occurs for me under Maverick / amd64.

Revision history for this message
Andrea Lazzarotto (Lazza) (andrea-lazzarotto) wrote :

Any fix for this? Thank you...

Revision history for this message
dniMretsaM (dnimretsam) wrote :

If you recently deleted files from an external HDD, USB drive, etc. and then removed it, you need to plug the device back in and THEN empty the trash. I know this works because I just did.

Revision history for this message
LoneWolf_53 (spezi-machek) wrote :

I'm running Maverick AMD64 and it behaves the same way if I've had a USB drive inserted.

If I put the USB drive back in and empty the trash if behaves normally again.

Obviously some sort of glitch involving trash bin and removable drives.

madbiologist (me-again)
tags: added: lucid
tags: added: maverick
Revision history for this message
lessonae@gmail.com (lessonae) wrote :

First in Ubuntu 12.04LTS 64bit I have had the problem. Had 10.04LTS before

Revision history for this message
David Clayton (dcstar) wrote :

It seems like the Trash icon has some sort of database of mounted drives to keep tabs of items that have been deleted, and then does not refresh this database to only display the status of actually mounted drives.

Since it can never "Empty" the trash of unmounted drives, the display remains showing items to be removed on unmounted or removed drives (and the removable drives could have their Trash actually emptied on other systems anyway).

It seems that the Trash icon needs to hook into the mount/unmount processes to keep itself only displaying the status of drives that are actually mounted on the system at any particular time.

Revision history for this message
Arthur Tan (artgtan) wrote :
Revision history for this message
antonioni (antonioni-rocha) wrote :
Revision history for this message
Jeroen Mathon (deathslycer) wrote :

This problem persists in 15.10.
Someone seriously needs to fix this.

Revision history for this message
Kip Warner (kip) wrote :

Totally. I'm still seeing it in 15.10.

Revision history for this message
antonioni (antonioni-rocha) wrote :

This ridiculous bug looks like ignored (by Gnome, too) since 7.04 (my first distro). Thus it is difficult to spread Linux.

Revision history for this message
Jon Wiedmann (jonwiedmann) wrote :

15.10 still happening

Revision history for this message
George (3grciii) wrote :

Same problem on 14.04.3 with all updates applied. Logging out and back in clears it (although that's not always an option)

Revision history for this message
Bob (elim-css) wrote :

Happens for me in Ubuntu 14.04 and still in 15.10. Actually I tried upgrading just to get rid of this issue but was disappointed.

The trash bin is full in the bottom left corner of the left dock. Click to open and there's nothing inside. I wonder if this is a problem after erasing from removable storage media e.g. USB disk.

At any rate, if the Empty Trash is clicked either from the left dock (right clicking on the bin), or the Empty button from inside the Trash folder it should _always_ reset the state of the icon in the left dock to "empty". This should be a relatively simple fix. Please change the code to do this.

How many more releases until it's fixed?

Revision history for this message
antonioni (antonioni-rocha) wrote :

This bug occurs in the newest version, 16.04! This is ridiculous!

Revision history for this message
antonioni (antonioni-rocha) wrote :

Almost 10 years!

Revision history for this message
Henry J. Douglas (cyberdoug42-deactivatedaccount) wrote :

Add a few more years and we will be facing this bug after deleting files from external flying cars. Ubuntu 16.04. We could make another bug report if this one is dead.

affects: gnome-applets (Ubuntu) → glib2.0 (Ubuntu)
Revision history for this message
TenLeftFingers (tenleftfingers) wrote :

Logging out and back in clears it on 16.04 64-bit. Until next time, of course. I only installed fresh today so I'll try to itemize potential actions to trigger this. I had:

Deleted files from a mounted samba share
Deleted local files with standard permissions (downloaded debs from Telegram.com, skype.com)
Deleted email attachments (.doc and .xls - encrypted, came from a windows user).

I'll monitor this and post back if there's anything useful to add.

Revision history for this message
thom (tsk) wrote :

I can confirm that this bug is still in ubuntu-mate (version 19.10).

when unmounting external drives without emptying trash, the trash icon stays on "full" forever (until the next login)

Expected behaviour would be a re-evaluation of the trash state of the mounted devices after any mount/unmount of any drive

This papercut has reached the respectable age of 11 years which, of course, is getting a bit embarrassing. :-)

I don't know where the trashcan code hides (somewhere in caja ?)
I might try to give it a shot if I knew more. Tips anyone ?

Norbert (nrbrtx)
tags: added: bionic eoan focal xenial
Changed in glib2.0 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Norbert (nrbrtx)
tags: removed: eoan lucid maverick
Sai Vinoba (saivinob)
tags: added: groovy
Changed in ubuntu-mate:
status: New → Confirmed
Revision history for this message
Sai Vinoba (saivinob) wrote :

This issue is a combination of Caja and trash applet from what I see, not necessarily only issue with trash applet. On MATE (Caja) in other distros like Debian, even LinuxMint, we get a dialog to empty trash from external drive to save space on that drive. If we agree trash is emptied and trash icon reflects status correctly. If we eject without emptying trash, the trash-icon stays full. However, on Ubuntu MATE there is no pop-up dialog unlike in other distros when there is deleted content; it just ejects the medium. UM is deviating from default behavior.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in caja (Ubuntu):
status: New → Confirmed
Revision history for this message
Norbert (nrbrtx) wrote :

Can you reproduce this bug with newer version of Ubuntu MATE?

tags: removed: groovy
Revision history for this message
Ark74 (ark74) wrote :

@Norbert what version would you suggest to test with?

Revision history for this message
Norbert (nrbrtx) wrote :

@Ark74 Pleas test both Ubuntu MATE 21.04 and upcoming 21.10; then tag as hirsute and impish if confirmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.