Gdevilspie fails to start with no attribute 'xdg_config_home'

Bug #1161594 reported by Elfy on 2013-03-28
230
This bug affects 51 people
Affects Status Importance Assigned to Milestone
gdevilspie (Debian)
Fix Released
Unknown
gdevilspie (Ubuntu)
High
Unassigned

Bug Description

Fails to start from dash, starting from a terminal gets this

Traceback (most recent call last):
  File "/usr/bin/gdevilspie", line 893, in <module>
    MainWindow = RulesListWindow()
  File "/usr/bin/gdevilspie", line 374, in __init__
    self.UpdateAutostartStatus()
  File "/usr/bin/gdevilspie", line 545, in UpdateAutostartStatus
    if (os.path.exists(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")):
AttributeError: 'module' object has no attribute 'xdg_config_home'

13.04 Ubuntu completely updated.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gdevilspie 1:0.5-3
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
Uname: Linux 3.8.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Thu Mar 28 20:14:03 2013
InstallationDate: Installed on 2013-03-12 (16 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130312)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: gdevilspie
UpgradeStatus: No upgrade log present (probably fresh install)

Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdevilspie (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

Commenting line 374 allows gdevilspie to run

Roland Baudin (roland651651) wrote :

Here is a patch (taken from Arch Linux) that completely solves the issue.
RB

The attachment "xdg_basedirectory.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Elfy (elfy) wrote :

Same issue in 13.10

tags: added: saucy
Pwnicorn (pwnicorndev) wrote :

The patch is working, can someone please merge it?

Ionut C. (icadariu) wrote :

I can confirm that the patched also worked for me

tim nelson (tim-l-nelson) wrote :

apt-get source gdevilspie
cd gdevilspie-0.5
patch -p1 < xdg_basedirectory.patch
dpkg-buildpackage -us -uc -nc
dpkg -i gdevilspie_0.5-3_all.deb

Confirmed as well, this should already be upstream but the above are the needed commands to resolve this if you aren't familiar with fixing a package.

tim nelson (tim-l-nelson) wrote :

Since this bug is:

- Valid.
- Well described.
- Reported in the upstream bug tracker (Launchpad).
- Ready to be worked on by a developer.

it's also triaged.

Changed in gdevilspie (Ubuntu):
status: Confirmed → Triaged

Since this bug prevents the application or any dependencies from functioning correctly at all, it has a priority of 'high'.

Changed in gdevilspie (Ubuntu):
importance: Undecided → High
tobi stadler (stadler-tobias) wrote :

This is still a bug in Lubuntu 13.10.

Roadowl (roadowl) wrote :

Bug confirmed on Jan. 27th 2014, almost a year after initial bug report.

Useless piece of crap.
Please remove from repositories.

Donarsson (benjamin-schwarz) wrote :

@Roadowl, the bug was confirmed on April 4th 2013, seven days after it was reported. Please read the bug and all previous comments carefully before commenting to avoid unnecessary comments and refrain from posting personal opinions. This is a bug tracker, not a forum.

@Chris, I subscribed you because you are listed as the maintainer of this package. It would be highly appreciated if you could help us resolve this issue.

Jake (client-alive) wrote :

Same thing for me on ubuntu 13.10. How dissapointing. I get the same output as the op shows. I tried commenting out line 374 and gdivilspie does launch. However, I notice that ticking the box to autostart the daemon ( bottom of the gdevilspie window ) does nothing. As soon as gdevilspie is closed and reopened the setting is no longer ticked and the daemon is not running. Now, because I'm inexperienced in dealing with matters like this ( manually editing code, applying pathches, compiling stuff, etc, etc, etc... ) I cannot be certain that commenting out line 374 is the cause of the daemon not starting. While the patch mentioned in a reply above may work, I am not comfortable performing the actions required to apply it; and, I assume ( though it was not mentioned ), recompile gdevilspie after the patch were applied? Ultimately, I don't feel as though it's my problem to fix the thing but I do 'NEED' it. It is the only application I have found ( with a gui <-- note it ) that does the things I need to have happen on this system.

Please, I and many others ( I'm sure ), beg the developers of ubuntu from the bottom of our hearts to fix this thing and provide an update that will 'just' work and will just get pulled in with the next update of the system. Pretty please?

Jake (client-alive) wrote :

After downloading and installing the .deb ( attached in post #10 ) - gdevilspie does launch with that .deb installed, and yes the setting to autolaunch the daemon does stay set. However, after closing and restarting the application, it claims the daemon is not running ( even though the option remains ticked ). I don't know if the massage is accurate or not ( that the daemon is not running ) but that's a pretty crucial patrt of gdevilspie.

tags: added: trusty
Andrey (demontager) wrote :

Confirm error on Xubuntu 14.04

$ gdevilspie
Traceback (most recent call last):
  File "/usr/bin/gdevilspie", line 893, in <module>
    MainWindow = RulesListWindow()
  File "/usr/bin/gdevilspie", line 374, in __init__
    self.UpdateAutostartStatus()
  File "/usr/bin/gdevilspie", line 545, in UpdateAutostartStatus
    if (os.path.exists(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")):
AttributeError: 'module' object has no attribute 'xdg_config_home'

Thanks for poster #10, his .deb works, at least allows easly create rules on the fly.

tags: added: utopic
Changed in gdevilspie (Debian):
status: Unknown → New
Changed in gdevilspie (Debian):
status: New → Fix Committed
Changed in gdevilspie (Debian):
status: Fix Committed → Fix Released
Daryl Van Humbeck (dvanhumb) wrote :

Has this fix been released in Trusty yet?
I'm still experiencing this issue with version 1:0.5-3.

Thomas Schüßler (vindolin) wrote :

I get the exact same error in 14.04.

Thomas Schüßler (vindolin) wrote :

^ and the posted patch still works :)

Hans Joachim Desserud (hjd) wrote :

I see that version 1:0.5-3.1 is available in Ubuntu Utopic, which includes a fix for this issue. The normal procedure when a fix for significant bugs exists in a newer release, is to follow the SRU Procedure [1] to bring the need to a developer's attention in order to get the fix into current releases as well.

So before starting that, I thought I'd check with Ubuntu Utopic, but ran into bug 1377662. I'm somewhat hesitant to suggest solving this based on a version which doesn't seem to start either. Has anyone else encountered this, especially those who have applied the patch themselves. It looks possibly unrelated, but hard to say for sure.

 [1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Erdem (mail-erdemakca) wrote :

( 1 ) Open a terminal with ctrl + alt + t
( 2 ) Type sudo gedit /usr/bin/gdevilspie and press enter
( 3 ) Enter your password and press enter
( 4 ) If you do not see line numbers, click the edit menu in gedit, then click preferences ( look for the check box "show line numbers" and check it
( 5 ) Scroll down to line 374 and put a # symbol to the far left of the line ( prefix the line with # )
( 6 ) Press ctrl + s to save the changes and then exit out of gedit ( maybe give it a few seconds to finish saving before exiting though )
( 7 ) You are done with the fix, you can now launch gdevilspie and it ( should ) work.

you want run autostart you write only 'devilspie -a' on command line ;)

anarcha24 (anarcha24) wrote :

thanks Erdem (mail-erdemakca),

i did not need to apply the patch in linux mint 17.2 mate, gdevilspie would not load, i commented out "#" on line 374 in

sudo pluma /usr/bin/gdevilspie

works great, thanks

fermulator (fermulator) wrote :

+1 vote for delivery into ubuntu 14.04 trusty stable LTS

Sadly, this is still broke as of 20160908:

$ apt-cache policy gdevilspie
gdevilspie:
  Installed: 1:0.5-3
  Candidate: 1:0.5-3
  Version table:
 *** 1:0.5-3 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

$ gdevilspie
Traceback (most recent call last):
  File "/usr/bin/gdevilspie", line 893, in <module>
    MainWindow = RulesListWindow()
  File "/usr/bin/gdevilspie", line 374, in __init__
    self.UpdateAutostartStatus()
  File "/usr/bin/gdevilspie", line 545, in UpdateAutostartStatus
    if (os.path.exists(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")):
AttributeError: 'module' object has no attribute 'xdg_config_home'

I used Tim's recommendation in comment #9 above, and although a deb pkg wasn't created I am able to run it from the built source directory.

Commenting line 374, as suggested by Elfry (comment #3), in the original also works:

self.UpdateAutostartStatus() --> #self.UpdateAutostartStatus()

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.