Ubuntu

gdebi-gtk fails with ''dpkg: unable to read filedescriptor flags...."

Reported by Doug McMahon on 2010-08-19
166
This bug affects 36 people
Affects Status Importance Assigned to Milestone
gdebi
Fix Released
Undecided
Unassigned
gdebi (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned
vte (Ubuntu)
Medium
Robert Ancell
Maverick
Medium
Robert Ancell

Bug Description

Binary package hint: gdebi

After recent Maverick updates (thru 08/19) gdebi-gtk fails on any .deb install - full message is
dpkg: unable to read filedescriptor flags fro <package status and progress file descriptor>: Bad file descriptor

dpkg -i <whatever.,deb> works fine

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gdebi 0.6.2
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Aug 19 02:54:14 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100705)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gdebi

Doug McMahon (mc3man) wrote :
David Planella (dpm) wrote :

I too have experienced this problem. It looks like bug 393381 is coming back.

Changed in gdebi (Ubuntu):
status: New → Confirmed

Architecture: i386
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
NonfreeKernelModules: nvidia
Package: gdebi 0.6.2
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-17.23-generic 2.6.35.2
Tags: maverick
Uname: Linux 2.6.35-17-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

apport information

Thomas C. (thomas-creutz) wrote :

have the same bug...

output in german:

dpkg: Kann Dateideskriptorflags für >><Dateideskriptor für Paketstatus und Fortschritt><< nicht lesen: Bad file descriptor

Doug McMahon (mc3man) wrote :

Fixed here with update to 0.6.2ubuntu1

Changed in gdebi (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

Sorry - was testing on some re-installs - it appeared to work.
What was actually happening was the failure wasn't being displayed, gdebi was closing without details being displayed (using the same setting in synaptic
Some it still won't install any packages - the same error is still seen. (have to uncheck the ;automatically close ..." in synaptic to see the error

Changed in gdebi (Ubuntu):
status: Fix Released → Confirmed
Ronan Jouchet (ronj) wrote :

The problem persists for me in GDebi 0.6.2ubuntu1 on Maverick

Joseph Braddock (vw72) wrote :

This problem also still exists for me in gdebi 0.6.2.ubuntu1 on Maverick (xubuntu). In addition, you cannot close the gdebi-gtk window once the error occurs.

Changed in gdebi (Ubuntu Maverick):
importance: Undecided → Low
Michael Vogt (mvo) on 2010-09-02
Changed in vte (Ubuntu Maverick):
status: New → Confirmed
milestone: none → ubuntu-10.10-beta
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

This broke because 91_keep_fds got dropped. While the C interface now exports enough functionatlity now to replace it (vte_terminal_new, vte_terminal_pty_new, vte_pty_child_setup, vte_terminal_set_pty) its not possible yet to do it with python-vte. The whole vte stuff is not yet exported afaiks. Please add 91_keep_fds back.

Michael Vogt (mvo) on 2010-09-03
Changed in vte (Ubuntu Maverick):
milestone: ubuntu-10.10-beta → ubuntu-10.10
Sebastien Bacher (seb128) wrote :

Robert can you add the change back for this cycle?

Changed in vte (Ubuntu Maverick):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.25.91-0ubuntu4

---------------
vte (1:0.25.91-0ubuntu4) maverick; urgency=low

  * debian/patches/91_keep_fds.patch:
    - Update and return patch that hadn't been applied upstream (LP: #620297)
 -- Robert Ancell <email address hidden> Wed, 08 Sep 2010 17:57:18 +1000

Changed in vte (Ubuntu Maverick):
status: Confirmed → Fix Released
Robert Ancell (robert-ancell) wrote :

I've rebuilt the patch and tested using gdebi. It seems to be working, please review the patch if you understand it well because the upstream code changed quite significantly.

Michael Vogt (mvo) on 2010-09-24
Changed in gdebi (Ubuntu Maverick):
importance: Low → Medium
Michael Vogt (mvo) on 2010-09-24
Changed in gdebi (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in gdebi:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers