String needs a translation comment and use of %(var)s python variables

Bug #403632 reported by David Planella on 2009-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
gdebi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdebi

This particular string

https://translations.edge.launchpad.net/ubuntu/jaunty/+source/gdebi/+pots/gdebi/ca/78/+translate

Would need:

a) A comment for translators to indicate what each variable corresponds to

b) The usage of %(var)s python string variables, since otherwise there is no possibility to reorder the variables in the translation, which some languages will need to do.

Related branches

David Planella (dpm) on 2009-07-23
tags: added: i18n
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Is this still a issue? The current code reads:

# TRANSLATORS: the first '%s' is the package that breaks, the second the dependency that makes it break, the third the releation (e.g. >=) and the latest the version for the releation
self._failureString += _("Breaks existing package '%s' dependency %s (%s %s)\n") % (pkg.name, dep.name, dep.relation, dep.version)

Changed in gdebi (Ubuntu):
status: New → Incomplete
David Planella (dpm) wrote :

Hi Michael,

The comment improved the situation, but some languages need to rearrange the order of the strings to make the translation readable, which currently is not possible using %s strings, only %(variable)s variables allow this.

Here's a branch with an attempt to fix this. I haven't tested it yet, since I was not sure how to make gdebi show any of the particular strings affected.

Changed in gdebi (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-translations:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → David Planella (dpm)
Michael Vogt (mvo) on 2010-02-11
Changed in gdebi (Ubuntu):
status: Confirmed → Fix Committed
David Planella (dpm) on 2010-02-11
Changed in ubuntu-translations:
status: In Progress → Fix Committed
assignee: David Planella (dpm) → nobody
David Planella (dpm) wrote :

I'm resubmitting the merge proposal, as in the fix I missed deleting one of the original lines containing the string

Changed in ubuntu-translations:
status: Fix Committed → In Progress
assignee: nobody → David Planella (dpm)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.6.0

---------------
gdebi (0.6.0) unstable; urgency=low

  * data/gdebi.desktop.in, data/gdebi-kde.desktop.in:
    - Remove Encoding field, deprecated.
  * debian/control:
    - Set XS-Python-Version to all (Closes: #570560).
    - Differentiate short descrriptions for gdebi and gdebi-kde.
  * GDebi/DebPackage.py:
    - improve i18n by using %(var)s LP: #403632, thanks to
      David Planella
  * data/gdebi.ui, GDebi/DebPackage.py:
    - alignment fixes in the status label
  * GDebi/SimpleGtkbuilderApp.py:
    - set translation domain here explicitly instead of in gdebi.ui
      (the later is often cleared by glade for some reason)
  * .bzr-builddeb/default.conf:
    - build as native package again
  * unified release for Debian&Ubuntu

gdebi (0.5.9debian3) unstable; urgency=low

  * gdebi, GDebi/GDebiCli.py:
    - Correctly parse translated "y" characters (Closes: #497821).
  * GDebi/GDebiCli.py:
    - Allow install of Debian binary packages with uncommon extensions
      or missing one (Closes: #472693).
  * po/es.po:
    - Update Spanish translation, by Omar Campagne (Closes: #556927).
  * README:
    - No longer mention packages are Ubuntu-specific, they are available
      in Debian too (Closes: #453709).
  * debian/control:
    - Do not build-depend on python-dev, python is enough.
 -- Michael Vogt <email address hidden> Wed, 10 Mar 2010 12:04:46 +0000

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
David Planella (dpm) on 2010-08-19
Changed in ubuntu-translations:
status: In Progress → Fix Released
assignee: David Planella (dpm) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers