Ubuntu

Launching totem when frei0r-plugins is installed shows: Could not load classifier cascade

Reported by papukaija on 2009-10-24
140
This bug affects 33 people
Affects Status Importance Assigned to Milestone
frei0r
Fix Released
Undecided
Unassigned
frei0r (Debian)
New
Unknown
frei0r (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

Starting empathy from the menu does nothing. From the terminal I get the following error message:

ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
Virhe uudelleenskannatessa rekisteriä , child terminated by signal
Run 'empathy --help' to see a full list of available command line options.

(empathy:3052): empathy-WARNING **: Error in empathy init: Virhe uudelleenskannatessa rekisteriä , child terminated by signal

(Virhe uudelleenskannatessa rekisteriä = Error in rescanning the registry)

EDIT: Lucid status is in comment 26.
----
UPDATE: This bug is fixed in upstream v.1.3
---

ProblemType: Bug
Architecture: i386
Date: Sat Oct 24 20:22:39 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: empathy 2.28.1-1ubuntu1
ProcEnviron:
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: empathy
Uname: Linux 2.6.31-14-generic i686

papukaija (papukaija) wrote :
papukaija (papukaija) on 2009-10-25
summary: - Can not start empathy (Could not load classifier cascade)
+ A few Gnome application do not start empathy (Could not load classifier
+ cascade)

Just to add that this happens for brasero and for totem too with the same error message (but without (empathy:3052) -warning).

summary: - A few Gnome application do not start empathy (Could not load classifier
+ A few Gnome applications do not start (Could not load classifier
cascade)
tags: added: karmic

is the file there? /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml ?

Changed in brasero (Ubuntu):
status: New → Incomplete
papukaija (papukaija) wrote :

cat /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
cat: /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml: Tiedostoa tai hakemistoa ei ole

(Tiedostoa tai hakemistoa ei ole = file or directory is missing)

cd /usr/share/opencv/
bash: cd: /usr/share/opencv/: Tiedostoa tai hakemistoa ei ole

-->No, the whole opencv folder is missing. I'm getting this bug after I made a clean install of Karmic RC.

Should I open this bug for ubuntu-desktop (or -meta) or to ubiquity?

Pedro Villavicencio (pedro) wrote :

re assigning to opencv.

Changed in totem (Ubuntu):
status: New → Invalid
Changed in empathy (Ubuntu):
status: New → Invalid
Changed in rhythmbox (Ubuntu):
status: New → Invalid
Changed in brasero (Ubuntu):
importance: Undecided → Low
affects: brasero (Ubuntu) → opencv (Ubuntu)
Changed in opencv (Ubuntu):
status: Incomplete → New
Thomas DEBESSE (illwieckz) wrote :

seems to appear when installing frei0r-plugins (example: for kdenlive). When removing frei0r-plugins from my karmic I've no error messages at all, and totem (and other apps) runs fine.

papukaija (papukaija) wrote :

Why is the missing file only provided in the following packages:

sudo apt-file search haarcascade_frontalface_alt2.xml
gnome-mousetrap: /usr/share/pyshared/mouseTrap/haarcascade/haarcascade_frontalface_alt2.xml
harpia: /usr/share/harpia/images/haarcascade_frontalface_alt2.xml
libcv-dev: /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
sivp: /usr/lib/sivp-0.5.0/etc/haarcascade_frontalface_alt2.xml

I don't want install libcv-dev (100MB with dependencies) to get some Gnome apps working.

papukaija (papukaija) wrote :

Thomas: I can't yet test your suggestion because I need lives for a while.

Developers: Please fix the conflict between frei0r-plugins and opncv packages.

Confirm: removing frei0r-plugins package dress this issue...

Hth

papukaija (papukaija) wrote :

Workaround confirmed here too.

Changed in opencv (Ubuntu):
status: New → Confirmed
Changed in frei0r (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Invalid

Confirming the problem and the solution.
Just installing kdenlive makes that frei0r gets installed and in turn makes that totem can't start.
Uninstalling frei0r fixes the problem.

Thomas DEBESSE (illwieckz) wrote :

installing LiVES install frei0r too, but ca'nt be installed without frei0r (removing frei0r automatically remove LiVES).
We can use totem and kdenlive if we don't install frei0r but we must choose between totem (and so other gnome apps) or LiVES.

Vish (vish) on 2009-11-09
affects: hundredpapercuts → null
praseodym (oliver-ehlert) wrote :

I confirm this bug with the frei0r-plugins package using lives in Ubuntu Karmic

papukaija (papukaija) wrote :

This isn't a bug in openshot, but in opencv and/or in frei0r.

Changed in openshot:
status: New → Invalid
Garibaldi (garibaldi) wrote :

I am running karmic and am also experiencing this bug - uninstalling frei0r-plugins resolves it. I then built frei0r-plugins from git and installed it using checkinstall. Now, after running rhythmbox I receive the following error:
$ rhythmbox
(rhythmbox:18793): GLib-GObject-CRITICAL **: g_param_spec_internal: assertion `(name[0] >= 'A' && name[0] <= 'Z') || (name[0] >= 'a' && name[0] <= 'z')' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstfrei0r.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
Error re-scanning registry , child terminated by signal
Run 'rhythmbox --help' to see a full list of available command line options.

It seems that the offending file is /usr/lib/gstreamer-0.10/libgstfrei0r.so . Is it possible to replace this object file with an older version? Is it necessary for openshot to function?

papukaija (papukaija) wrote :

Garibaldi: Test and report. The file "/usr/lib/gstreamer-0.10/libgstfrei0r.so" might not cause this bug since it´s not shown in the original error message.

Garibaldi (garibaldi) wrote :

I upgraded from the custom built frei0r-plugins to the official one in the repository and rhythmbox still starts okay! I checked the package from the repository and you were right - libgstfrei0r.so does not exist in the official build.

Olivier Girard (eolinwen) wrote :

It seems to be a problem with a librairie of freiOr-plugins (/usr/lib/gstreamer-0.10/libgstfrei0r.so) and Gstreamer. So it's not a problem of Openshot.
Good luck

Changed in openshot:
status: Invalid → Won't Fix
zbi (zbzbzb1) wrote :

Looks like the same issue on Xubuntu 9.10 and OpenShot:
https://bugs.launchpad.net/openshot/+bug/511099

papukaija (papukaija) on 2010-01-22
Changed in openshot:
status: Won't Fix → Invalid
Stinger (e-mindahl) wrote :

Bug#470564 seems to be a duplicate of this one.

papukaija (papukaija) wrote :

Interesting, at https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/470564/comments/3 Stinger says that removing gstreamer0.10-plugins-bad solves this problem.

Changed in gst-plugins-bad:
status: New → Confirmed
picrard (seamusdisguise) wrote :

I had the same problem especially with these apps:

- totem
- gnome-app-install

both of them tried to start, but crashed;
this has solved my problem:

<b><u>sudo apt-get remove frei0r-plugins</u></b>

like in this link:
http://ubuntuforums.org/showthread.php?p=8377817

Both applications work now.

Doug McMahon (mc3man) wrote :

Have had no issues with frei0r-plugins and openshot (latest from experimental) on karmic
Am using gstreamer packages from here instead of the karmic ones

https://launchpad.net/~gstreamer-developers/+archive/ppa

papukaija (papukaija) wrote :

Closing this part of plugin since there's no error message or problems to start a gnome application if this package is installed.

Changed in gst-plugins-bad:
status: Confirmed → Invalid
papukaija (papukaija) wrote :

Lucid update: You *can* use gnome application while frei0r-plugins (which installs some opencv packages) is intalled. I tested this with totem, brasero, rhytmbox and software-center in fully updated Lucid Beta1.

Bad news: If frei0r-plugins is installed, launching totem will show the error message but totem will open normally. Uninstalling frei0r-plugins, but leaving the libcv packages will not the show the error message on totem startup.

description: updated
papukaija (papukaija) wrote :

Reopening as a consequence of comment 26.

summary: - A few Gnome applications do not start (Could not load classifier
- cascade)
+ Launching totem when frei0r-plugins is installed shows: Could not load
+ classifier cascade
Changed in totem (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the issue is not a totem one

Changed in totem (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Stinger (e-mindahl) wrote :

As i wrote in bug#470564

"I got the same bug and can confirm that removing the frei0r-plugins solves this issue.

But removing gstreamer0.10-plugins-bad solves it too, as described in bug#471690 , without having to remove the frei0r-plugins ( Openshot depends on it ).

So it seems that these two plugin packages ( frei0r-plugins and gstreamer0.10-plugins-bad ) can not co-exist without causing trouble."

It must be either frei0r-plugins or gstreamer0.10-plugins-bad who is causing this bug.

Stinger (e-mindahl) on 2010-03-29
Changed in gst-plugins-bad:
status: Invalid → Confirmed
Photodeus (photodeus) wrote :

kdeinit4: preparing to launch /usr/bin/amsn
ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
Could not initialize GStreamer: Error re-scanning registry , child terminated by signal

aMSN would launch, but trying to login to the network made the application crash. No other notification other than that line in .xession-errors (took me a while to figure out to check in there).

sudo apt-get remove frei0r-plugins

resolved the issue

Photodeus (photodeus) wrote :

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

papukaija (papukaija) wrote :

@Photodeus: This bug is worse in Karmic than in Lucid (please read comment 26 for more information).

@subscribers: It might be a good idea to test totem's launching from terminal with up to date Lucid since GNOME was updated between Lucid's dev releases and Lucid final.

Julien (julien-narboux) wrote :

I think the problem is that opencv pacakges do not install the haarcascades, this also impacts Digikam 2.0.0 beta 1 see here:
https://bugs.kde.org/show_bug.cgi?id=262074

jaromil (jaromil) wrote :

i hope this bug can be solved soon, there is a new upstream release of frei0r since October 2010 (version 1.2.1) which solves other issues on other distributions, while the recent commit 55ed8391 in our code might solve this one.

i'm planning to:
 - test this bug and make sure it is solved upstream before our next 1.3 release.
 - once done upload a new version on my ppa.

ciao

--
jaromil, upstream maintainer of frei0r-plugins

jaromil (jaromil) wrote :

upstream frei0r 1.3 release now fixes this bug.

i'm now uploading a new .deb package on ppa:jaromil/frei0r

Changed in frei0r (Ubuntu):
assignee: nobody → jaromil (jaromil)
status: Confirmed → Fix Released
papukaija (papukaija) wrote :

This bug is fixed in upstream, but not yet in Ubuntu as Natty has v.1.1.22git20091109-1.1 of frei0r-plugins.

affects: openshot → frei0r
Changed in frei0r:
status: Invalid → Fix Released
Changed in frei0r (Ubuntu):
status: Fix Released → Confirmed
papukaija (papukaija) wrote :

Closing this part of the bug report as this bug is being fixed in frei0r.

Changed in gst-plugins-bad:
status: Confirmed → Invalid
Changed in opencv (Ubuntu):
status: Confirmed → Invalid
papukaija (papukaija) wrote :

The v.1.3 seems to be a unstable development release -at least it isn't mentioned at http://freshmeat.net/projects/frei0r/releases

Changed in frei0r:
status: Fix Released → Fix Committed
jaromil (jaromil) wrote :

frei0r 1.3 it is a stable development release.

i'm just done compiling and uploading other packages, cross-compiling for different platforms and then also updating the webpage on freshmeat. it all just takes some time.. will be up on freshmeat within 24h.
thanks for reacting so fast!

jaromil (jaromil) wrote :

packages ready on ppa:jaromil/frei0r

Changed in frei0r (Ubuntu):
status: Confirmed → Fix Committed
papukaija (papukaija) wrote :

Is the package in your PPA ready for Ubuntu's official repositories or does it need modifications before it can be copied to there?

papukaija (papukaija) wrote :

The v.1.3 is both in the ftp and Freshmeat site.

Changed in frei0r:
status: Fix Committed → Fix Released
jaromil (jaromil) wrote :

i suggest for the future to take the source repository and the GPG signed message by upstream maintainers as authoritative source for a new release. thanks for your attention to details!

eris23 (jdkatz23) wrote :

jaromil: can you make the packages available for maverick?

jaromil (jaromil) wrote :

it's on ppa:jaromil/frei0r

if problems arise and you can fix them youself i'm happy to incorporate contributed patches upstream (either in master or ubuntu0 branch) just please format them with 'git format-patch'

ciao

jaromil (jaromil) wrote :

i'm sorry but the ppa is not accepting it. i don't know what's wrong: ultimately its just a matter of changing a debian/changelog name, yet it seems there is more to do and i can't do it alone.
i guess there is someone that has more experience with launchpad here? below the error i get:

Rejected:
File frei0r_1.3.orig.tar.gz already exists in frei0r, but uploaded version has different contents. See m
ore information about this error in https://help.launchpad.net/Packaging/UploadErrors.
Files specified in DSC are broken or missing, skipping package unpack verification.

jaromil (jaromil) wrote :

BTW the ubuntu0 branch is in our GIT upstream
 http://code.dyne.org/index.cgi?url=frei0r/tree/&h=ubuntu0
i guess already imported in your bzr, should be easy to add a target for build, no?
how?

Jeremy Bicha (jbicha) wrote :

Thank you for reporting this bug. Please report this to Debian. Once Debian packages the new release which presumably has this issue fixed, then it is very easy to sync Debian's newer package to Ubuntu.

Jeremy Bicha (jbicha) wrote :

Never mind my last message. It looks like this was reported to Debian a year ago.

We really need to fix this in Debian & Ubuntu, not just in a PPA. As of yesterday, gnome-video-effects used by cheese depends on this package.

Jeremy Bicha (jbicha) wrote :

Marking as medium for now since cheese, gnome-video-effects, and frei0r-plugins are not installed by default in Ubuntu 11.10.

Changed in frei0r (Ubuntu):
assignee: jaromil (jaromil) → nobody
importance: Undecided → Medium
status: Fix Committed → Triaged

On Fri, 29 Jul 2011, Jeremy Bicha wrote:

> Marking as medium for now since cheese, gnome-video-effects, and
> frei0r- plugins are not installed by default in Ubuntu 11.10.
>
> ** Changed in: frei0r (Ubuntu)
> Importance: Undecided => Medium

ACK

> ** Changed in: frei0r (Ubuntu)
> Status: Fix Committed => Triaged

what does this means?

> ** Changed in: frei0r (Ubuntu)
> Assignee: jaromil (jaromil) => (unassigned)

why de-assign it?

I've fixed the bug already since long time.

I don't understand what is the workflow, who has the power to upload
and how that can be transferred. providing the fixed package on my PPA
is all what i can do. please if you have time and patience explain me
how this works. i would like to have this fixed, but there seems to be
some beaurocracy i still can't figure out.

thanks

--
jaromil, dyne.org developer, http://jaromil.dyne.org
GPG: B2D9 9376 BFB2 60B7 601F 5B62 F6D3 FBD9 C2B6 8E39

Jeremy Bicha (jbicha) wrote :

The general workflow is documented at https://wiki.ubuntu.com/Bugs/HowToFix

Specifically, to get a brand new version into the current development release (Oneiric) you would do something like:

bzr init-repo frei0r
cd frei0r
bzr branch ubuntu:frei0r oneiric
cd oneiric

Make sure the watch file is up-to-date (in this case, add the appropriate watchfile)
If you had to make changes, then you'll need to bzr commit

bzr merge-upstream
Make any additional changes to the debian/ directory
dch -e to edit the changelog (& update the timestamp automatically)
I then usually do bzr uncommit to undo the commit necessary to run the bzr merge-upstream command

bzr commit

bzr push lp:~jaromil/ubuntu/frei0r/oneiric/frei0r-1.3.1 (the last part can be named whatever)

Then visit https://code.launchpad.net/~jaromil/ in your web browser
Click the propose merge button and submit the merge proposal.

Then find someone with commit access to review your submission.

If you have any questions, feel free to ask in #ubuntu-motu

Changed in frei0r (Debian):
status: Unknown → New
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
papukaija (papukaija) on 2011-12-12
no longer affects: rhythmbox (Ubuntu)
no longer affects: empathy (Ubuntu)
no longer affects: totem (Ubuntu)
no longer affects: opencv (Ubuntu)
tags: added: upgrade-software-version
papukaija (papukaija) on 2011-12-12
description: updated
affects: gst-plugins-bad → null
jaromil (jaromil) wrote :

Hi there. Guys, I'm not sure what is wrong in your process, but this bug was fixed by an upload of release 1.3 already YEARS ago.

Frei0r 1.3 It was never incorporated in Ubuntu despite this bug being open here.

Meanwhile after years we released version 1.4 and it is a rather useful package for your users, see for instance https://www.youtube.com/watch?v=xcFFo_bqg_4

I'm wondering today, how everyone must be struggling with getting it installed and what's wrong between us.

As upstream, I've tried my best, even learning your system and pushing stuff being compiled in your PPA.

Now I'm just sayin', this bug is rather depressing.

ciao

jaromil (jaromil) wrote :

BTW, FWIW this ppa has 1.4 ppa:sunab/kdenlive-release

papukaija (papukaija) wrote :

I opened bug 1186039 to track the progress to update frei0r in Ubuntu's repositories.

tags: removed: karmic upgrade-software-version
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.