Installing from ppa kills video applications (frei0r-plugins)

Reported by zbi on 2010-01-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Undecided
Unassigned

Bug Description

Xubuntu 9.10
Installing OpenShot 1.0.0 from ppa.
After installing OpenShot, Totem and Exaile stop working. The error from terminal: ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml

I also found a solution how to repair Totem and Exaile:
http://www.insidesocal.com/click/2009/11/ubuntu-karmic-fail-pidgin-and.html

It is necessary to use these commands:
# sudo apt-get purge frei0r-plugins libcv1 libhighgui1 libcvaux1
# sudo apt-get install libcv1 libhighgui1 libcvaux1

This unfortunatelly unistalls OpenShot. So I can either have installed OpenShot and killed Totem and Exaile or have functional Totem and Exaile but not OpenShot installed.

This issue seems to be related to frei0r-plugins. When I wanted to unistall frei0r-plugins, it will also require to uninstall OpenShot.

Olivier Girard (eolinwen) wrote :

You have another solution which will confirm (or not) if freiOr-plugins are the case and will give you the possibilities to use Openshot. The freiOr-plugins are not essentiels for working with Openshot. You have an account launchpad so you can have the main branch by this command :
bzr branch lp:openshot/1.0
After go until the folder openshot (the second) and in a console type :
python openshot.py
and enjoy, after you could create a little script and a desktop file.

papukaija (papukaija) wrote :

Thanks for your time to report this bug and to make openshot better. However, this bug is a dupplicate of bug 459940. Feel free to continue submitting bugs that you find.

zbi (zbzbzb1) wrote :

I tried bzr branch lp:openshot/1.0
cd ~/1.0
python openshot/openshot.py

*** ERROR: MLT Python bindings failed to import ***
*** ERROR: MLT Python bindings failed to import ***
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/home/zbi/1.0/openshot/classes/thumbnail.py", line 174, in run
    mlt.Factory().init()
NameError: global name 'mlt' is not defined

I had to install python-mlt_1.0-3~karmic_i386.deb
Then I was able to start OpenShot by python openshot/openshot.py
But Exaile failed on the same error as above.So I had to remove python-mlt that also removed frei0r-plugins.
Than Exaile worked.

Olivier Girard (eolinwen) wrote :

This bug is duplicated here :https://answers.launchpad.net/openshot/+question/95857 and https://bugs.launchpad.net/openshot/+bug/482985.
You can do (if it doesn't work ) too :
sudo ln -s /usr/lib/libmlt++.so.0.4.10 /usr/lib/libmlt++.so.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers