Ubuntu

package flashplugin-installer 10.2.159.1ubuntu1 failed to install/upgrade: nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so

Reported by Ed Whitaker on 2011-04-16
This bug affects 172 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

This occurred after running update manager after logging into Ubunto 11.04 beta2

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: flashplugin-installer 10.2.159.1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 16 13:42:19 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer 10.2.159.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Rohit R (rr0hit) wrote :

Looks like installation/upgrade fails on 64 bit systems with the following error :

nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so

Rohit R (rr0hit) on 2011-04-17
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This should have been fixed with the fix for bug 746758 but it seems that fix didn't do the trick.

Changed in flashplugin-nonfree (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in flashplugin-nonfree (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Rolf Leggewie (r0lf) wrote :

while triaging my bug 766130 (lucid system, 32bit) I found the following in dpkg.log

/var/log/dpkg.log:2011-04-18 08:36:07 update-alternatives: run with --quiet --remove mozilla-flashplugin /usr/lib/flashplugin-installer/libflashplayer.so
/var/log/dpkg.log:2011-04-18 08:36:07 update-alternatives: link group mozilla-flashplugin fully removed

I wonder if the same is happening here?

Rolf Leggewie (r0lf) wrote :

FWIW, I never saw an error during installation of the package

Brian Murray (brian-murray) wrote :

The number of duplicates of this bug has been stuck at 51 for the past day which might mean it isn't happening any more.

Changed in flashplugin-nonfree (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Maarten Kossen (mpkossen) wrote :

Still happening...

Guillaume Hain (zedtux) wrote :

Agree

Sorry, nope.
All works fine! Thank you.

Works fine for me as well.

Am Sat, 20 Aug 2011 08:35:24 -0000
schrieb Christian Kroenert <email address hidden>:

> Sorry, nope.
> All works fine! Thank you.
>

not working at all here. firefox 7 and chromium are both unable to display any flash content. fix soon please.

mlindeblom (lindeblm) wrote :

I switched to the 64 bit beta package -> works well.

Borbinceane Iulian (borby87) wrote :

Still not working for me...

Allison Randal (allison) wrote :

I got it today too. Possibly a multiarch problem? The package has a Depends ia32-libs. From https://lists.ubuntu.com/archives/ubuntu-devel/2011-March/032750.html, I expected to be able to run:

sudo apt-get install flashplugin-installer:i386

But that just reports:

E: Unable to locate package flashplugin-installer:i386

Allison Randal (allison) wrote :

Hmmm... nspluginwrapper isn't getting updated, because of a missing dependency on nspluginviewer:

The following packages have unmet dependencies:
  nspluginwrapper: Depends: nspluginviewer (= 1.4.4-0ubuntu3) which is a virtual package.

But, there doesn't seem to be any package available to satisfy nspluginviewer

allison@otp:~$ sudo aptitude install nspluginviewer
No candidate version found for nspluginviewer
No candidate version found for nspluginviewer

It appears that nspluginwrapper binary package exists in both i386 and amd64 architectures, but nspluginviewer only exists for i386. (http://packages.ubuntu.com/da/oneiric/nspluginviewer)

In Natty, nspluginviewer didn't exist at all, and nspluginwrapper had no dependency on it.

Allison Randal (allison) wrote :

It looks like this may be resolved when the fix for Bug #828162 is released.

Steve Langasek (vorlon) wrote :

Allison,

Please see <https://lists.ubuntu.com/archives/ubuntu-devel-announce/2011-August/000886.html>. You probably have upgraded to oneiric before update-manager was set up to automatically enable multiarch support; if you enable it by hand, aptitude will be able to satisfy nspluginwrapper's dependencies using the i386 packages.

I'm pretty sure this is unrelated to the original issue reported in this bug.

summary: package flashplugin-installer 10.2.159.1ubuntu1 failed to
- install/upgrade: subprocess installed post-installation script returned
- error exit status 1
+ install/upgrade: nspluginwrapper: no appropriate viewer found for
+ /usr/lib/flashplugin-installer/libflashplayer.so
Sam_ (and-sam) wrote :

As commented there the cmd in devel-announce does nothing here. Running Oneiric since alpha1 and upgraded all along.
https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/829182/comments/5

As a workaround there is still version 10.3 d162 in add-ons-manager which could be used by deactivating 10.3 r183.
Since such dependencies are annoying and don't see a good reason to run i386 architecture on 64 bit anyway, in particular when adobe offers native 64bit, removing all flash stuff from Ubuntu.

Sam_ (and-sam) wrote :

Currently installed:
ia32-libs:
  Installed: 20090808ubuntu16
  Candidate: 20090808ubuntu16
  Version table:
 *** 20090808ubuntu16 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

nspluginwrapper:
  Installed: 1.4.4-0ubuntu1
  Candidate: 1.4.4-0ubuntu3
  Version table:
     1.4.4-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/multiverse amd64 Packages
 *** 1.4.4-0ubuntu1 0
        100 /var/lib/dpkg/status

Alex Mayorga (alex-mayorga) wrote :

Same here:

...
2011-08-21 18:17:17 (277 KB/s) - `./adobe-flashplugin_10.3.183.4.orig.tar.gz' saved [5517014/5517014]

Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mario Vukelic (mario-vukelic) wrote :

It works after downgrading ia32-libs to 20090808ubuntu13 from natty.

Alex Mayorga (alex-mayorga) wrote :
Kevin S (ks20xx) wrote :

I've got the same dpkg error.

Fabien Tassin (fta) wrote :

to fix this, in addition to following <https://lists.ubuntu.com/archives/ubuntu-devel-announce/2011-August/000886.html>, you must also install libnss3:i386 (it will drag libnspr4:i386 & libsqlite3-0:i386 with it which as also needed).

that's enough to unbreak the install, but then, you'll notice at runtime that it also need curl:

"Adobe Flash Player error: could not load cURL library"

so you must also install libcurl3:i386.

that fixes it for me.

Note that you should use 'apt-get', as it seems multiarch broke 'aptitude' (which is no longer able to find any solution for the deps resolutions).

Bowmore (bowmore) wrote :

Installing the packages libnss3:i386 and libcurl3:i386 fixes it here too.

However, the final solution should use the Adobe 64-bits libflashplayer.so, still in beta though but works.

Yes. +1 on the vote for amd64 native flash player. Works great and no more 32-bit hackery...

Dejan (dejan-rodiger) wrote :

When I activated i386 as suggested here <https://lists.ubuntu.com/archives/ubuntu-devel-announce/2011-August/000886.html>, then apt-get install flashplugin-installer wants to install about 20+ new packages. I will use 64bit targz for now from the adobe site.

@Dejan: Yes, this is a normal behaviour. It wants to install some required 32-bit libraries (instead of one huge ia32-libs). Everything is okay then, if it wants to install some new packages.

Kevin S (ks20xx) wrote :

Installing the i386 packages didn't resolve this bug for me but the flash 11 x64 beta works resolves this problem.

Steve Langasek (vorlon) wrote :

flashplugin-nonfree in oneiric now pulls in the i386 package, which has complete correct library dependencies. I believe this bug is now fixed.

Changed in flashplugin-nonfree (Ubuntu Oneiric):
status: Triaged → Fix Released
Anders Feder (afeder) wrote :

I still get an error on 'apt-get upgrade':

E: Sub-process /usr/bin/dpkg returned an error code (1)

I did try installing Adobe's x64 beta, though (and failed). Could this be an issue for upgrading this package?

Anders Feder (afeder) wrote :

This solved the issue for me:

$ sudo aptitude install flashplugin-installer

Moisa Doru (moisadoru) wrote :

I installed the native 64bit plugin via the sevenmachines PPA:

~$ sudo apt-cache policy flashplugin64-installer
flashplugin64-installer:
  Installed: 11.0.1.98-0ubuntu0~sevenmachines1
  Candidate: 11.0.1.98-0ubuntu0~sevenmachines1
  Version table:
 *** 11.0.1.98-0ubuntu0~sevenmachines1 0
        500 http://ppa.launchpad.net/sevenmachines/flash/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Works like a charm.

Przemyslaw Golab (n-pigeon) wrote :

I still have problems:

Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-installer

Anders Feder (afeder) wrote :

P. Golab you may want to try:

$ sudo aptitude install flashplugin-installer
$ sudo apt-get install flashplugin-installer

In my case, the first command seemed to clean up some dependencies while the next did the actual pulling of packages.

Przemyslaw Golab (n-pigeon) wrote :

Anders Feder

Thanks for help, I tried you advice but it didn't worked.
Still throws:

Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Same here:
Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of flashplugin-nonfree:
 flashplugin-nonfree depends on flashplugin-installer; however:
  Package flashplugin-installer is not configured yet.
dpkg: error processing flashplugin-nonfree (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 flashplugin-installer
 flashplugin-nonfree

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of P. Golab
Sent: Friday, August 26, 2011 6:18 AM
To: Tim Dunlevy
Subject: [Bug 762968] Re: package flashplugin-installer 10.2.159.1ubuntu1 failed to install/upgrade: nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so

I still have problems:

Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing:
 flashplugin-installer

--
You received this bug notification because you are subscribed to a duplicate bug report (824616).
https://bugs.launchpad.net/bugs/762968

Title:
  package flashplugin-installer 10.2.159.1ubuntu1 failed to
  install/upgrade: nspluginwrapper: no appropriate viewer found for
  /usr/lib/flashplugin-installer/libflashplayer.so

Status in “flashplugin-nonfree” package in Ubuntu:
  Fix Released
Status in “flashplugin-nonfree” source package in Natty:
  Triaged
Status in “flashplugin-nonfree” source package in Oneiric:
  Fix Released

Bug description:
  Binary package hint: flashplugin-nonfree

  This occurred after running update manager after logging into Ubunto
  11.04 beta2

  ProblemType: Package
  DistroRelease: Ubuntu 11.04
  Package: flashplugin-installer 10.2.159.1ubuntu1
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic x86_64
  NonfreeKernelModules: nvidia
  Architecture: amd64
  Date: Sat Apr 16 13:42:19 2011
  ErrorMessage: subprocess installed post-installation script returned error exit status 1
  SourcePackage: flashplugin-nonfree
  Title: package flashplugin-installer 10.2.159.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/762968/+subscriptions

Mario Vukelic (mario-vukelic) wrote :

I think those of you who still have the problem may just have to wait for your local mirrors to sync. I, too, still had the problem after it was marked fixed, but a day and an "apt-get update" later, it worked.

col reilly (lupinehorror) wrote :

aptitude install flashplugin-installer
gives me
The following packages have unmet dependencies:
  flashplugin-installer: Depends: flashplugin-downloader which is a virtual package.
                         Depends: nspluginwrapper but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) flashplugin-installer [Not Installed]

Maarten Kossen (mpkossen) wrote :

I removed my sevenmachines flash (which I used in the mean time) with ppa-purge and then installed ubuntu-restricted-extras. Worked for me.

Note: I do have multiarch enabled.

Przemyslaw Golab (n-pigeon) wrote :

I changed update-manager to mian servers and there were proper upgrades. Everything works.

Sam_ (and-sam) wrote :

Purged the pending nspluginwrapper since it breaks upgrade of ia32-libs, afterwards flawless dist-upgrade.
 ia32-libs : Breaks: nspluginwrapper (< 1.4.4-0ubuntu2) but 1.4.4-0ubuntu1 should be installed.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

dino99 (9d9) on 2013-05-10
Changed in flashplugin-nonfree (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers