Ubuntu

Where's my home button?

Reported by RedHeron on 2008-02-16
4
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.0

When I upgraded, there is no "home" button any more. Is this right???

I use the home button extensively to open new tabs, since my home page is Google and it speeds my research. Even if it's not a default option, removing the option altogether makes me want to switch back to an earlier version. I've even switched themes, and still nothing... is this a bug or a feature? I can't tell.

Thanks, and I hope to hear back on this, at the very least how to restore it (since it's apparently not an option in the "customize" dialog box, either).

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 16 15:55:01 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: firefox 3.0~b3+nobinonly-0ubuntu2
PackageArchitecture: all
SourcePackage: firefox-3.0
Uname: Linux rherp-devel 2.6.24-8-generic #1 SMP Thu Feb 14 20:13:27 UTC 2008 x86_64 GNU/Linux

Dragging it to the navigation toolbar should work fine, and turn it into a button. The change was made in bug 404109.

This bothered me also, and the fix proposed by Jesse worked (so long as I was in the 'Customize Toolbar' mode). Though I do think it is a grave mistake that the home button is by default in the bookmarks toolbar, I for one don't use the bookmarks toolbar and was alarmed to find my home button gone and not in the Customize Toolbar box (obviously now because it was being used already in the bookmarks toolbar without me realizing).

I think the home button should remain on the navigation toolbar by default in order to keep users from becoming confused and disoriented.

Creating a cleaner UI means moving a few things and cutting a few things. For instance: Safari doesn't even have a home button by default. I agree that not all users are going to quickly adapt to this relocation, but if it really bothers them they do have access to a customization palette.

>I for one don't use the
>bookmarks toolbar and was alarmed to find my home button gone and not in the
>Customize Toolbar box (obviously now because it was being used already in the
>bookmarks toolbar without me realizing).

That's certainly a usability problem, I'm confirming and changing the summary to address this issue.

Note: nominating for blocking to get wanted-firefox3+

In , Dao (dao) wrote :

Maybe we should uncollapse all toolbars when customizing?

>Maybe we should uncollapse all toolbars when customizing?

That would work as well, but we obviously don't want to show 27 extension toolbars.

In , Dao (dao) wrote :

Also, I just realized that the toolbars can be collapsed/uncollapsed manually while customizing, so this being confusing in the end.

In , Dao (dao) wrote :

~ so this would be confusing in the end.

I thought about explicitly uncollapsing the personal toolbar in the migration code, but some users might not like this.

I agree that Home icon should remain as default item in navigation toolbar. I never use bookmarks toolbar and was very surprised today to not see the home icon when I first booted-up beta 3.

What was the purpose behind the change?

+1 for comment 9. Have been told in another but that "that's decided already"- and it sucks as it is currently.

Agreed, I like the idea of having it on the bookmark bar but it should be addable in many ways to the toolbar.

I too believe the home icon should remain as a default item on the navigation toolbar if the bookmark toolbar is turned off.

Telling users they have to enable the bookmark bar, drag the icon to the customization palette, and then drag it to the navigation bar seems highly counter-intuitive and may confuse many users who just want the button back.

No casual user is going to be able to understand how to restore their home button, or even how to google to find the fix (which is what I did). They're just... not. First they're going to say, "My home button's gone," or if they have the bookmarks toolbar open, they're going to say, "My home button's moved and I can't get it back."

Either there needs to be a way to simply and intuitively move the button, or it shouldn't be moved at all. This is a drastic and jarring UI change for people who use Firefox every day, and if the blogs are any indication, it's the only feature people absolutely despise about Firefox3.

Personally, I don't use bookmark toolbar. My homepage is google.com. You can imagine just how often I click the home button in the course of a day.

In , Dao (dao) wrote :

I tried to make the migration code move the Home button only if the Personal toolbar isn't collapsed. The problem that I ran into is that the Home still had the "bookmark-item chromeclass-toolbar-additional" class even though it was on the Nav toolbar, due to the way we fixed bug 414945. So I tried to set the class to "toolbarbutton-1 chromeclass-toolbar-additional" by adding it to the localStore, which didn't really work, due to my limited rdf knowledge. I'll attach that patch later, anyway.

(In reply to comment #14)
> I tried to make the migration code move the Home button only if the Personal
> toolbar isn't collapsed. The problem that I ran into is that the Home still had
> the "bookmark-item chromeclass-toolbar-additional" class even though it was on
> the Nav toolbar, due to the way we fixed bug 414945.

In the migration case that wouldn't be true, right? We only migrate once, before the user's profile would have felt the effects of bug 414945...

In , Dao (dao) wrote :

Not sure which case you mean. If the migration code moves Home (which it always does currently), "bookmark-item chromeclass-toolbar-additional" is correct, otherwise it isn't -- as of bug 414945, we don't set the class on startup.

In , Dao (dao) wrote :

Maybe we can persist the class AND call gHomeButton.updatePersonalToolbarStyle on delayedStartup? If it already has the right class (i.e. almost always), that shouldn't be significant extra work.

In , Dao (dao) wrote :

Created attachment 303366
patch

I don't understand the problem with changing the migration code to only move the home button when the personal toolbar is not collapsed. We only migrate once, so changing the migration code only affects people who haven't yet migrated. Those people don't have builds that are affected by the changes in bug 415099. Their home button class will never be "bookmark-item chromeclass-toolbar-additional".

In , Dao (dao) wrote :

"bookmark-item chromeclass-toolbar-additional" is the default class.

In , Dao (dao) wrote :

Created attachment 303381
only flush if needed

In , Dao (dao) wrote :

Created attachment 303382
only flush if really needed

Comment on attachment 303382
only flush if really needed

>Index: browser/components/nsBrowserGlue.js

>+ var personalBarCollapsed = this._getPersist(personalBar, collapsed);

>+ (personalBarCollapsed != "true");

>+ if (personalBarCollapsed == "true")

Move the string compare into the declaration?

In , Dao (dao) wrote :

Created attachment 303388
for checkin

To be honest- regarding comment 19- I don't understand the whole effort of moving the button. It was in the perfect place before it got shuffled around. Just my 2c.

RedHeron (ray-jenson) wrote :

Binary package hint: firefox-3.0

When I upgraded, there is no "home" button any more. Is this right???

I use the home button extensively to open new tabs, since my home page is Google and it speeds my research. Even if it's not a default option, removing the option altogether makes me want to switch back to an earlier version. I've even switched themes, and still nothing... is this a bug or a feature? I can't tell.

Thanks, and I hope to hear back on this, at the very least how to restore it (since it's apparently not an option in the "customize" dialog box, either).

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 16 15:55:01 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: firefox 3.0~b3+nobinonly-0ubuntu2
PackageArchitecture: all
SourcePackage: firefox-3.0
Uname: Linux rherp-devel 2.6.24-8-generic #1 SMP Thu Feb 14 20:13:27 UTC 2008 x86_64 GNU/Linux

RedHeron (ray-jenson) wrote :
Changed in firefox-3.0:
status: New → Confirmed
Michael Bienia (geser) wrote :

I've the "home" button now in the bookmarks toolbar.

Moving the Home button has vastly more negatives than it does positives. Many Firefox's out there, do not have the bookmarks toolbar shown by default, its not necessary, most browsers don't have an entire bookmarks toolbar. Why then is Firefox seemingly pushing it further on people like this?

Many novice users will think the home buttons gone, some will regrettably just turn the bookmarks toolbar on. Another thing to consider as part of this is the bookmarks toolbar folder, and smart bookmarks, not being able to be viewed in the bookmarks dropdown, at least for me. This like the basic function of the Home button on the bookmarks toolbar, will leave some novice users thinking their forced, or easier option, is to keep the bookmarks toolbar shown.

I agree with Kris; some above cite that Safari has no home button on the main toolbar by default, but should another browser's implementation be the reason for a significant change in this software that has clearly confused many users, including myself, most of them highly experienced users? How would this change be seen by the average computer user? It may even bother them so much and themselves be unable to figure out how to restore the home button to it's previous location that they may simply use a different browser, especially if they aren't entirely aware of the differences between Firefox and other browsers other than that they might have been told to use Firefox instead by a more experienced user, sys admin, etc.

I believe that this drastic movement of an essential part of the UI is, and will continue to be, jarring to the majority of users. At the very least, as is mentioned above, if the bookmarks toolbar is not shone than the button should not be moved. As a user of Firefox since it was called Phoenix I find this change unacceptable.

In , Dao (dao) wrote :

(In reply to comment #27)
> At the very least, as is
> mentioned above, if the bookmarks toolbar is not shone than the button should
> not be moved.

You didn't read this bug's summary before commenting, did you? Would have saved you some time.

Alexander Sack (asac) wrote :

upstream has a patch so this will be fixed in beta 4 most likely.

Fully agree. This was a lot of effort to cause a lot of confusion...

Changed in firefox:
status: Unknown → In Progress

Please reinstate the home button on the main toolbar by default. I had to Google to find out how to put it back, and I'm a competent techie. I think you're going to loose a lot of favour with the mom+pop users who loose their comfort button. I teach people to press the "Home" button if they get lost and panicy, and want to go back to somewhere familiar.

(In reply to comment #28)
> You didn't read this bug's summary before commenting, did you? Would have saved
> you some time.

I did read the bug's summary, and in fact have been following this bug since it began. I was simply stating that while I do believe that the home button should not be moved at all, what should be done at the minimum is not to move the button if the bookmarks toolbar is not shown, as this bug proposes. Sorry if you misunderstood.

In , Dao (dao) wrote :

Well, then you know that this bug has a reviewed patch. I don't understand what you (and others) expect from ranting about this.

I hope that it will be known that I, along with many others, are against the movement of the home button entirely not only because of our own experience with the change, but because of how we anticipate less-knowledgeable users may react to the change. Is the bug fix here a crucial step in keeping the confusion of users under control? Yes. But I still firmly believe that the button should not be moved at all and want to ensure that it is known by developers such as yourself.

>But I still firmly believe that the
>button should not be moved at all and want to ensure that it is known by
>developers such as yourself.

We have noted your discontent, however the number of times you restate your concerns will not directly influence our design process.

Two additional notes (beyond the fact that safari doesn't have a home button and IE7 moved it to the far right)

-Novice users are not likely to use anything other than the default chrome, and if the bookmarks toolbar is turned off we won't move the button (purpose of this bug)
-Positioning the button directly under the back button and in the most viewed area of the window (upper left) is actually a more prominent placement than the button's previous position

Checking in browser/components/nsBrowserGlue.js;
/cvsroot/mozilla/browser/components/nsBrowserGlue.js,v <-- nsBrowserGlue.js
new revision: 1.53; previous revision: 1.52
done
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v <-- browser.js
new revision: 1.969; previous revision: 1.968
done

Changed in firefox:
status: In Progress → Fix Released
Alexander Sack (asac) wrote :

beta4 will have the upstream fix.

Changed in firefox-3.0:
importance: Undecided → Low
status: Confirmed → Fix Committed

*** Bug 420167 has been marked as a duplicate of this bug. ***

need to verify this fix during a Major Update test.

Steps to verify:
gavin: to test that, launch firefox 2, hide your bookmark toolbar, then upgrade to firefox 3
[6:02pm] gavin: with that patch, the home button will still be on the navigation toolbar
[6:02pm] gavin: without, we would have moved it to the hidden bookmark toolbar

adding in-litmus? for Major Update Testrun

Tony,
I will test and verify tomorrow...

-Mike

Okay here is what happened:

I had Firefox 2.0.0.12 I set the Bookmarks Toolbar as hidden and proceeded to install Firefox 3. When Firefox 3 opened it toggled the Bookmarks Toolbar to visible and the home button is still on the bookmarks tool bar and not on the navigation bar.

Is this expected?

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030806 Minefield/3.0b5pre

-Mike

In , Dao (dao) wrote :

(In reply to comment #40)
> I had Firefox 2.0.0.12 I set the Bookmarks Toolbar as hidden and proceeded to
> install Firefox 3. When Firefox 3 opened it toggled the Bookmarks Toolbar to
> visible and the home button is still on the bookmarks tool bar and not on the
> navigation bar.
>
> Is this expected?

Yes, if you hadn't customized your toolbar buttons.

"Creating a cleaner UI means moving a few things and cutting a few things. For
instance: Safari doesn't even have a home button by default. I agree that not
all users are going to quickly adapt to this relocation, but if it really
bothers them they do have access to a customization palette."

...the first thing many of us do is remove the bookmarks toolbar. I did just this, 5 minutes later I was wondering what happened to the home button. I did a Google search. ...found out that the button was moved. I went to customize, the button wasn't available, so I had to re-enable the bookmarks toolbar, go back to customize, drag the icon to its proper position, and then once again disable the bookmarks toolbar. This reminds me of something that Microsoft would do. ..and has done with IE7.

A cleaner UI is rubbish if it means a decrease in usability. The home button is very frequently used, and moving it will only piss people off. ...people like us can work around it, but users like my parents are completely thrown off by simple "UI" changes like this. Safari shouldn't be the standard either... There is a reason I use Firefox on my Mac, and the missing home button was an annoyance when I used Safari. ...we definitely shouldn't make changes based on what MS does with IE7. IE7's interface is a disaster.

Many people use the home button much more often than forward button (like those of us who have a Google/iGoogle homepage), does that mean we should remove/move "forward" to clean up the UI? The Firefox UI isn't cluttered. Please don't sacrifice usability. ...and if you guys are going to move buttons around that have been there since the dawn of time, you need better reasons than:

-Safari doesn't have a home button
and IE7 moved it to the far right

-Novice users are not likely to use anything other than the default chrome, and
if the bookmarks toolbar is turned off we won't move the button (purpose of
this bug)

-Positioning the button directly under the back button and in the most viewed
area of the window (upper left) is actually a more prominent placement than the
button's previous position

But don't take my word for it, a recent [p]review by PCWorld:
"One not-so-nice change: Mozilla has moved the Home button off of the Navigation toolbar and onto the Bookmarks toolbar. This may have freed up some real estate on the Navigation toolbar, but it means that if you normally hide the Bookmarks toolbar (which I do), you no longer have access to your Home button. The change does not make much sense."

Sorry for writing a book.

I agree with Laren Dubkowski. I do not use Safari, stuck with the Vista where I tried Firefox 3.0. And first thing I did was to look for the Home button.

I use Firefox as my main browser and have done so for a few years now. I like it for ease of use and the ability to customise the toolbar - IE7 has no customization and fails in many other ways for me.

I did also note Firefox 3.0 had some changes the Bookmark menu structure (I didnt like the Organize Bookmarks disappearing but I finally discovered how to get to it).

After a few days of trying Firefox 3.0 beta I ran into a further glitch with Java causing it to crash (reported it as an issue). Back on v2.0 now and await final release 3.0.

I also agree, Home is the only navigational button to exist on a toolbar it's not meant for, bookmarks. Firefox has had consistency of sectioning items relative to what they are, well over the years. Home isn't a bookmark, so what's it doing on the bookmarks toolbar, a novice or advanced user asks? Why is this an exception?

Clearly with this Mozilla think most people have the bookmark toolbar shown and use it enough to notice items on it. I like many don't use the bookmarks toolbar or believe quite so many as thought, do have it shown, or that those who do use it as regularly as thought. Keep navigation buttons on the navigation toolbar please.

Not sure why people are commenting in this bug about the back button move - this bug was about improving the migration code, not about making the actual change.

In any case, the decision is being revisited in bug 422420. Please don't comment unless you have information to add.

Fabien Tassin (fta) wrote :

beta 4 fixed this. Closing.

Changed in firefox-3.0:
status: Fix Committed → Fix Released
S.Rey (s.rey) wrote :

I have Firefox 3.0b5 in hardy beta with the latest updates, and there is still no home button.

S.Rey (s.rey) wrote :

Firefox 3.0 beta5 in ubuntu hardy beta, doesn't have this bug fixed

Changed in firefox-3.0:
status: Fix Released → Confirmed
S.Rey (s.rey) wrote :

Please, ignore my 2 previous posts. I'm sorry for the inconveniences.

It's true that the home icon is no more in the Navigation Toolbar.
It's however in the bookmarks toolbar.
What confused me is that when you do Right Click/Customize... in the Navigation toolbar, you don't have the home button to choose in the window "Customize Toolbar".
But you can just drag and drop the button in the Bookmarks toolbar to the navigation toolbar, and then you get the home button back.

If the final version doesn't include the home button in the navigation toolbar, I would like this to stay as a wishlist.

Changed in firefox-3.0:
status: Confirmed → Fix Released
Changed in firefox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.