Ubuntu

fglrx driver + compiz's "Sync to Vblank" makes display stutter/slow

Reported by Jiri Grönroos on 2011-04-16
516
This bug affects 118 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Daniel van Vugt
Ubutter
Undecided
Unassigned
compiz (Ubuntu)
High
Daniel van Vugt
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]
The user's display only redraws at 20-30Hz (1/3-1/2 of the correct monitor refresh rate). Making a highly unpleasant graphics experience.

[Development Fix]
Simplified the way the compiz opengl plugin does vsync, using fewer functions and simpler code. This works around the slow functions in the fglrx driver which are the root cause.

[Stable Fix]
As above.

[Test Case]
Make sure "Sync To VBlank" is enabled in the OpenGL section of CompizConfig Settings Manager. In Ubuntu 11.04 it is enabled by default.

Drag some windows around. Also open and close windows. The animations will not be smooth as they appear to stutter. The framerate is only around 20-30Hz.

Now turn "Sync To VBlank" off and repeat the above steps again. If you notice the animations are much smoother than with "Sync To VBlank" on then you are suffering from this bug.

[Regression Potential]
Low.
Worst case: Video tearing occurs. However this is unlikely given the fix has been in everyday use by many users of ppa:vanvugt/compiz for many months already.

[Original Report]
This bug is primarily for users of the fglrx driver, but the proposed fix does improve performance with other drivers. Most NVIDIA users should look at bug 92599 instead.

Package: fglrx
Version: 2:8.840-0ubuntu2

01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]

I have ATI's 5770 with fglrx. Having "Sync to Vblank" on makes Unity and many Compiz features (Enhanced Zoom, Scale etc.) really slow. Turning "Sync to Vblank" off has a huge effect on desktop, responsiveness is much, much better. Turning "tearing" off/on from amdccle doesn't seem to have any effect on responsiveness.

In Maverick "Sync to Vblank" was off by default, in Natty it's on. This will probably have a huge impact on many fglrx users.

Jiri Grönroos (jiri-gronroos) wrote :
Jiri Grönroos (jiri-gronroos) wrote :

"Sync to Vblank" can be found from CompizConfig Settings Manager -> OpenGl -> Sync to Vblank

Stefanauss (stefanauss) wrote :

I can confirm on Ati Mobilty Radeon HD 4570.
More than being slow, the real pain is wepages showing tearing while scrolling. Anybody experiencing this too?

bojanski (bojanski) wrote :

Confirming this on 11.04 on ATI HD 5470 - sync to Vblank off is a major boost in performance.
Also, the website issue manifestation is there also, the entire system is much slower.

Alek Kowalczyk (alek-kowalczyk) wrote :

I confirm that Sync to VBlank improved situation.
But graphics on my desktop is still significantly slower than in 10.10, especially in 3d effects like application switchers, which are now not responsive enough to be pleasant in daily work.

Tested both in Unity and Classic.
ATI Radeon HD 3200 Graphics,
fglrx 2:8.840-0ubuntu4

Relevant xorg.log sections attached.

Nick Mitchell (eb-nickm) wrote :

Same here, even after disabling VSync setting. I see a significant slowdown in simply typing in a text box or using Eclipse vs. 10.10. Even spinners in Firefox are choppy. Oddly enough, the Unity Launcher bar scrolls in and out like butter. Xorg and compiz are also chewing up a lot of CPU cycles, 25% and 16% respectively on a Quad-core processor.

fglrx 2:8.840-0ubuntu4
Radeon HD 4200

Uwe Pfeifer (alphatrax) wrote :

same here. even with v-blank disabled the graphics are slow/laggy.

Felix Kuehling (felix-kuehling) wrote :

The Catalyst Control Center has two vblank settings. One is the global tear-free setting under "Display Option". The other one is "Wait for vertical refresh" under "3D-More Settings".

Does it help if you set the latter to "Off, unless applications specifies" and restart X?

Jiri Grönroos (jiri-gronroos) wrote :

@ Felix, your suggestion didn't help in my case.

Could other people test Felix's suggestion as well?

Nick Mitchell (eb-nickm) wrote :

@Felix Didn't work here either.

Interesting thing I noticed after restarting Xorg was that workspace switching is really smooth with no windows open. Soon as I opened Chrome, performance took a dive and gets progressively worse as windows open...

robinl (robin4home) wrote :

Both tear-free and Wait for vertical refresh are off - still have very poor responsiveness and frame rates while moving windows and switching between applications on my Radeon 5850.

abhijeet (abhijeetnayak) wrote :

I am facing the same issue and I have raised the another bug for it. Application switching the quite sluggish. Is there anyway we can increase the severity of this issue, so that Ubuntu team will start looking into it seriously.

@robinl: What about the sync-to-vsync setting in CompizConfig Settings Manager (AKA ccsm)? As already reported by other users, this seems to be the main problem leading to poor compositor frame rates on Ubuntu 11.04 with fglrx, regardless of raw hardware performance.

Some users with low end or integrated graphics are still experiencing lag even with sync-to-vsync disabled in ccsm. See Nick's report above for example. That's why I was suggesting to try the other vsync and tear-free options in the Catalyst Control Center. You have a fairly powerful discrete graphics card, so I would not expect your system to be affected by long lag as reported by Nick.

robinl (robin4home) wrote :

@Felix That's off too. V-sync is off in both Catalyst centre and ccsm, and tear-free is off too. When I drag windows around my mouse cursor seems to follow my movement without any problems but the window will only redraw at around 1-2fps. Running fgl_glxgears gives me fps in the thousands but the image only updates at less than 5fps.

Here's my Catalyst information page: http://iforce.co.nz/i/u3xkzvl4.ug4.png

Nick Mitchell (eb-nickm) wrote :

Tried fgl_glxgears and got an interesting result, a little different than robinl. It flew along at ~450fps, updating image the entire time, no problem. It would only stop and choke when my XTerm displayed the fps results. I minimized my XTerm, no more choking. I tried something else -- I minimized all windows with text in them, and I can scroll quickly and smoothly between workspaces. If I restore a window with text, goes back to being slow again.

Makes me wonder if this is a font rendering problem....

@robinl: I've seen that problem. The updates very infrequently when there is a high FPS application running, for example glxgears or fgl_glxgears. I believe this is a bug in compiz. Setting "Wait for vertical refresh" under "3D-More Settings" to "Always on" works around the problem for me because it forces the applications to a lower frame rate which doesn't overwhelm compiz.

Do you have any applications running that constantly redraw at a very high frame rate?

Jorge O. Castro (jorge) on 2011-05-03
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Adding a compiz task. Whether or not there's an actual compiz bug under here, it seems like there's a workaround that could be applied in Compiz.

robinl (robin4home) wrote :

@Felix: Thanks for the suggestion. That fixes the the fgl_glxgears update issue but the whole system still feels slower than before. The Compiz window repaint problem is still there - it would redraw fairly often if I move the mouse slowly while moving a window around but if I start moving it quickly it the image would stop to repaint and stay at one place until I slow down my mouse again. All during this time the mouse cursor repaints without any visible slowdown. I tried to record a video of it happening but it didn't work with xvidcap, probably due to compiz.

gunwald (gunwald) wrote :

I can confirm big problems fglrx and new compiz version. I am using a Radeon 4200 onboard device. But I cant confirm that disabling the v-sync option in CCSM and compiz increases the situation. Its rather the opposite. With this option disabled I have to wait some seconds until a window follows my cursor! With vsync enabled it works a bit better, so its usable, but very much slower than with 10.10. I have for example to switch of compiz to play video fluently. Is there some hope that there will be a fix for that soon? If not, I really will have a look for another distribution. Can not understand why Canonical publishes a bad working version of compiz!

bagl0312 (bagl0312) wrote :

Look here:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/768275/comments/5

I found that disabling fglrx and using the open source drivers improves a lot the speed for my card:

01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4200]

Of course also proprietary drivers should work, but the above is a good solution

Unfortunately it's not a solution. Open driver has major power management
issues that prevent many people to use it. See bug 563156.
It's a real shame because it's true, performance-wise (non-gaming) radeon
driver has no issues whatsoever.

Il giorno 04/mag/2011 11:49, "bagl0312" <email address hidden> ha
scritto:
>
> I found that disabling fglrx and using the open source drivers improves
> a lot the speed for my card:
>
> 01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD
> 4200]
>
> Of course also proprietary drivers should work, but the above is a good
> solution
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/763005
>
> Title:
> Fglrx with Compiz's "Sync to Vblank" makes Unity/Compiz plugins to
> crawl
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/763005/+subscribe

@bagl0312 No joy. I can't seem to get X to start without fglrx and video-ati.

Larry (larryfroot) wrote :

Downloaded and installed ati-driver-installer-11-4-x86.x86_64.run for the 48xx series, using debs generated from it. Still getting 59 - 60 fps from glxgears. That's with synch to Vblank and detect refresh rate in compiz manager turned off. With them turned on its still 60 fps. fglrxinfo tells me I have the correct fglrx driver installed.

Daniel Burke (dan-p-burke) wrote :

Even disabling VSync the performance is appalling on my 4870x2, where on 10.10 everything was silky smooth.

Jiri Grönroos (jiri-gronroos) wrote :

Sorry to bother but...

There's also a similar bug report for NVIDIA users, see bug 760814.

Confirmed.
The problem occurs with ATI Radeon HD 4250. Everything is really choppy even with sync-to-vblank off and all those fixes enabled in Catalyst Control Center (described above). Tested both on repository-native drivers and 11.5 from the producer's website.

The open driver works very well with compiz+unity. It doesn't support fast acceleration in games though.

Guys, after installing compiz settings manager and removing vsync checkbox, performance is ok for HD 4770. Ati takes care of vsync with their Tear Free whatever so no vsync issues after removing that checkbox. This is major problem for Ati owners.

I can confirm this on my desktop (Radeon HD 4850) and notebook (Fusion E-350). Disabling Sync to Vblank in CCSM improves desktop performance A LOT.

@Marko Martinović, Dennis-martin-herbers: It's still far from the optimum (and even far from the open-source drivers' performance) after disabling `Sync to Vblank` in CCSM (Radeon 4250). Menus and windows appear with delay. GUI is still choppy.

David Horváth (chronos-hun) wrote :

I confirm the choppiness on HD4200, and upgraded to 8.850 ATI driver to see if it differs, but not.

Any workarounds?

Ricardo Graça (devius) wrote :

@David Horváth Maybe switch to Unity 2D for the time being. It is working very well for me. Only the spread and desktop switcher animations are a bit sluggish and with some visual corruption, but other than that performance is awesome. I'm also using an HD4200 with the latest Catalyst 11.6.

The problem in general seems to be that screen updates are very very slow, as if something is limiting the frame-rate to some 2-4fps (even with no sync to vblank options activated). One good example is inkscape. Try opening it and doing some panning. With Unity it is very very choppy. Same thing with Unity 2D or Ubuntu Classic without effects and it's completely smooth.

Nick Mitchell (eb-nickm) wrote :

@Devius Big ups! Unity-2D makes my workspace bearable again, thanks for that!

Daniel van Vugt (vanvugt) wrote :

This feels like the same issue as bug 145431 where compiz simply had the wrong framerate so was trying to sync to the wrong frequency.

In older versions of CCSM there was an option to fix the framerate manually. I remember it used to incorrectly detect 50Hz where it should have been 60Hz. But I don't see such an option to tweak this in natty.

The turning off Sync to Vblank in CCSM workaround works for me (ATI HD 6350/5450). But it's not ideal enabling tearing. I want smooth graphics back :(

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Tracked down the problem. (Obviously) ATI's implementation of GLX_SGI_video_sync does not behave the way compiz expects it to. And compiz is frequently skipping 1-2 frames, making a 60Hz display actually render compiz at 20-30Hz.

The confusion is that compiz expects glXGetVideoSyncSGI to return immediately but with fglrx it seems to take a whole frame or two before returning. Though I can't find proof that ATI is at fault and have violated the spec at all (http://www.opengl.org/registry/specs/SGI/video_sync.txt).

Shouldn't matter though. The fix for compiz is simple and should work with all drivers. Almost done...

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
summary: - Fglrx with Compiz's "Sync to Vblank" makes Unity/Compiz plugins to crawl
+ Compiz's "Sync to Vblank" makes display stutter/slow with some drivers
+ (like fglrx)

After I had switched from ATI I found that the problem also occurs with some NVidia cards. Initially everything is alright but after couple of hours (NVidia 9600GT) the same strange thing is happening. Perhaps it's some kind of general Compiz issue?

Daniel van Vugt (vanvugt) wrote :

Hmm, since the trigger for this bug is the behaviour of fglrx and it could definitely be improved, best to leave the door open.

Changed in fglrx-installer (Ubuntu):
status: Invalid → Confirmed
Daniel van Vugt (vanvugt) wrote :

@Aleksander: My proposed fix is a general compiz change, so yes it might improve Vsync behaviour for Nvidia too.

Always remember to enable sync to vblank in your driver control panel too. For ATI Catalyst it's called Tear Free Desktop.

Zahan M (zahanm) wrote :

@vanvugt awesome, thanks for looking into this!
Is it safe to come back over to Unity 3d now then? :)

Daniel van Vugt (vanvugt) wrote :

I'm only fixing the exact problem described in the Bug Description. So the fix will only work for you if the workaround described at the top works for you.

Of course, if the workaround works for you then you could always have kept Unity 3D. Just turn off Sync To VBlank in CompizConfig Settings Manager and turn on Tear Free Desktop in ATI Catalyst Control Center.

Actually I found the workaround still has slightly better performance than the fix. This is because even with the fix, compiz has to wait for Vblank. But the workaround uses GPU/driver features to do the same thing more efficiently.

Daniel van Vugt (vanvugt) wrote :

Revisiting this fix today... I discovered a similar (but different) slow down when I switched to Intel graphics this week. So I'm updating the fix for this bug to also address the framerate problem I found on Intel, which really affects all graphics chips.

description: updated
description: updated
Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
affects: compiz-core → compiz
Changed in compiz:
status: In Progress → Fix Committed
description: updated
Changed in compiz:
status: Fix Committed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
status: New → In Progress
milestone: none → 4.22.0
assignee: nobody → Daniel van Vugt (vanvugt)
status: In Progress → Fix Committed
Changed in unity:
milestone: 4.22.0 → 4.24.0
Didier Roche (didrocks) on 2011-10-14
Changed in unity:
milestone: 4.24.0 → 4.26.0
Omer Akram (om26er) on 2011-11-12
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
67 comments hidden view all 147 comments

Newbiest question: I have been using Ubuntu just for two months, and I'm having this issue, so could anyone tell me how can I use the vanvugt's fix? I've already added the repository, but don't know what should I do now.

Bucic (bucic) wrote :

It's not fixed for me. I still get the very same behavior. A question. If I'm suffering from another compiz-related bug can I stick to this ppa and just wait for the compiz 'click' or do I have to dig into the other bugs comments for specific solutions?

Right now I have this version of Compiz installed:
$~ sudo apt-cache showpkg ssh | less
Package: compiz
Versions:
1:0.9.6+bzr20110929-0ubuntu6vv6 (/var/lib/apt/lists/ppa.launchpad.net_vanvugt_compiz_ubuntu_dists_oneiric_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/ppa.launchpad.net_vanvugt_compiz_ubuntu_dists_oneiric_main_binary-amd64_Packages
                  MD5: f8949ff691855a5244d51aa54ee72f8f

1:0.9.6+bzr20110929-0ubuntu6 (/var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric-updates_main_binary-amd64_Packages)
 Description Language: en
                 File: /var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric-updates_main_i18n_Translation-en
                  MD5: f8949ff691855a5244d51aa54ee72f8f
 Description Language:
                 File: /var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric-updates_main_binary-amd64_Packages
                  MD5: f8949ff691855a5244d51aa54ee72f8f

1:0.9.6+bzr20110929-0ubuntu3 (/var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric_main_binary-amd64_Packages)
 Description Language: en
                 File: /var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric_main_i18n_Translation-en
                  MD5: f8949ff691855a5244d51aa54ee72f8f
 Description Language:
                 File: /var/lib/apt/lists/ftp.vectranet.pl_ubuntu_dists_oneiric_main_binary-amd64_Packages
                  MD5: f8949ff691855a5244d51aa54ee72f8f
__
or (from synaptic)
This change is not coming from a source that supports changelogs.
Failed to fetch the changelog for compiz
URI was: http://ppa.launchpad.net/pool/main/c/compiz/compiz_0.9.6+bzr20110929-0ubuntu6vv6_all.changelog

Sorry, I don't know how to get the package version info.

Daniel van Vugt (vanvugt) wrote :

Oscar, after you have added the repository (sudo add-apt-repository ppa:vanvugt/compiz), you just need to open Update Manager (top right power menu, 4th item down), click Check, then click Install Updates.

Bucic, yes you can stick with the PPA and you will still get the next official package update(s) automatically. You will either get the official update, or the official update plus my changes. It depends on whether I have updated the PPA before the official update is released. Your system will just choose the source with the highest compiz version number.

fix works great for me - ATI Radeon HD4800

ok...it worked for like half a minute after i installed the fix and restarted my system...now i am back to stuttering window movement =/

Daniel van Vugt (vanvugt) wrote :

I think you might now be suffering from a different stuttering bug caused by unrelated experimental fixes for other bugs in ppa:vanvugt/compiz. I'm probably going to update the PPA soon to vv7, so stay tuned.

Daniel van Vugt (vanvugt) wrote :

Please also test ppa:vanvugt/unity at the same time as ppa:vanvugt/compiz. The unity PPA contains a fix for a severe performance bug 861061, which slows down all compiz redraws in Ubuntu 11.10.

...thx for your fast response

i had updated unity with ppa:vanvugt/unity when i tesed this but it still stutters like before...
but i will wait for vv7 now and report if it will be fixed...

Bucic (bucic) wrote :

Still no luck. I've updated from both of the PPA's - for Compiz and for Unity. Compiz seems to be vv7 already:
Package: compiz
Versions:
1:0.9.6+bzr20110929-0ubuntu6vv7 (/var/lib/apt/lists/ppa.launchpad.net_vanvugt_compiz_ubuntu_dists_oneiric_main_binary-amd64_Packages) (/var/lib/dpkg/status)

My settings (just in case):
Sync to VBlank - OFF
AMD: Tear-free - ON
AMD: Wait for vertical - Always

Please note that animations like Win+W, minimizing/maximizing and all alike are perfectly smooth. Only dragging windows seems to cause stuttering. And the stuttering occurs after a second or few, not right away.

Bucic (bucic) wrote :

Same with other combinations of these settings for that matter...

same here...vv7 didnt fix my problem...its exactly like Bucic said...animations work smooth...window dragging works fine for like 30 seconds after system reboot...then back to the stuttering...

Daniel van Vugt (vanvugt) wrote :

If some animations are smooth and it's only dragging windows that is a problem then bug 773861 is probably a more appropriate place to look.

This bug is about ALL animations stuttering, which is a bug in the fglrx implementation of "Sync To VBlank". So if you still have issues with "Sync To Vblank" turned off then you're definitely looking at the wrong bug.

summary: - Compiz's "Sync to Vblank" makes display stutter/slow with some drivers
- (like fglrx)
+ Compiz's "Sync to Vblank" makes display stutter/slow with fglrx
description: updated
description: updated
Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid

As mentioned in comment #36, the root cause is fglrx. And fglrx has not been fixed. Even though we worked around it in compiz.

Changed in fglrx-installer (Ubuntu):
status: Invalid → Confirmed
Omer Akram (om26er) wrote :

@Daniel have the fix for this bug reached precise?

Daniel van Vugt (vanvugt) wrote :

The fix is not in precise yet:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/compiz/precise/view/head:/plugins/opengl/src/screen.cpp#L1020

But it is upstream, ready for the next compiz release, which I believe will go into precise when that new compiz release is ready...
http://bazaar.launchpad.net/~compiz-team/compiz-core/0.9.5/view/head:/plugins/opengl/src/screen.cpp#L1102

Pradeepk (raj-pradeep-kumar) wrote :

I can confirm the same problem on Ati Mobilty Radeon HD 5730.

I hope this gets fixed soon. It is almost 10 months since the bug was first fixed and I need good perfomance from the Ati prop for my work.

Daniel van Vugt (vanvugt) wrote :

Sorry, I don't see the fix lined up for any official ubuntu updates yet. But it is definitely in compiz 0.9.7 which should go into Ubuntu 12.04.

You can try the fix out on Ubuntu 11.10 using ppa:vanvugt/compiz:
https://launchpad.net/~vanvugt/+archive/compiz

P.S. It appears I only published the fix in August. So that's 5 months ago. But still far too long, I agree.

affects: compiz → compiz-core
Changed in compiz-core:
importance: Undecided → High
milestone: none → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

FYI, the fix was proposed and accepted for oneiric back in November. But the fix somehow got lost since then and never actually merged into any ubuntu or oneiric branches. Sorry I didn't realize the merge was bungled until now, because I'm using the fix in ppa:vanvugt/compiz.

Changed in compiz (Ubuntu):
status: Fix Committed → Confirmed
Changed in unity:
status: Fix Committed → Confirmed
Lorenzo Villani (lvillani) wrote :

Should we expect 0.9.7 to hit Precise's repository with your fixes anytime soon?

Daniel van Vugt (vanvugt) wrote :

I can't speak for the ubuntu packagers so don't know when they're going to grab 0.9.7. Officially, compiz 0.9.7.0 has not been released upstream yet. I would expect that to happen first...
https://launchpad.net/compiz-core/+milestone/0.9.7.0

I have just re-proposed the fix for oneiric that got lost in November. Hopefully it will get merged this time.

Daniel van Vugt (vanvugt) wrote :

But if you're using Ubuntu 11.10, you will get even better graphics performance using ppa:vanvugt/compiz instead of waiting for the fix in oneiric-proposed.

Lorenzo Villani (lvillani) wrote :

I'm on 10.04 LTS and testing Precise from time to time to get an idea of upcoming changes. Can you push a package built for precise?

Anyway, great work! If you come to FOSDEM this year, remember me that I owe you a beer ;-)

Daniel van Vugt (vanvugt) wrote :

Sorry, but publishing PPA packages for precise would unlikely be worth the effort. I fully expect precise will have compiz 0.9.7 within a month, which would supersede a PPA. But "a month" is just a guess, not an official statement of any sort.

Bryce Harrington (bryce) on 2012-01-27
description: updated
description: updated
Neil Rodgers (neilr1971) wrote :

Daniel,
Thank you for your excellent work! Im using your ppa in Ocelot and I cant believe how buttery smooth my windows are moving now! The last time I remeber seeing them so smooth was on my Maverick install. Using fglrx with HD4200.
 This is kind of a noobish question but the fixes are improving the performance of compiz in general right? Not just when moving windows? Because after upgrading with your ppa it seems some of my games are running better and I didn't know if its just a placebo affect or they really are. Thanks.

Daniel van Vugt (vanvugt) wrote :

Correct; the fixes improve the performance of compiz in general. Not just moving windows. It's not a noobish question but actually quite perceptive.

The main improvement in game performance is best described by bug 861061. The fix for that is in ppa:vanvugt/unity.

Neil Rodgers (neilr1971) wrote :

Thanks, I knew it wasn't just me:) I am using your unity ppa as well. I hate to ask because Im sure you have more important stuff to work on, but maybe one rainy day you could look at bug 770283? It involves compiz and fglrx and the title bars not updating on unmaximized windows.

Sebastien Bacher (seb128) wrote :

I've sponsored the stable update with the fix for that bug on https://code.launchpad.net/~om26er/ubuntu/oneiric/compiz/perf-sru/+merge/92444

The update should be reviewed and accepted earlier next week, the bug will be updated when that happens

Changed in compiz (Ubuntu Oneiric):
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu Oneiric):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu1

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream snapshot:
    - Fix slow/stuttering display with fglrx (LP: #763005)
    - Don't dynamically link to compiz_core
    - Fix build failures with glib 2.30 (oneiric) (LP: #921406)
    - Fix uninitialized variable warnings in valgrind (LP: #921451)
    - Fixes up a bunch of boost::variant edge cases
    - Fixes a race condition where the xig restart test would fail spuriously
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - Benchmark window slows the system and degrades graphics resources
      (LP: #254561)
    - Windows that hide themselves when closed don't appear in any
      "this workspace" switcher (LP: #684731)
    - hang in g_spawn_sync and select() (LP: #690239)
    - word misspelled - bunding (LP: #694169)
    - sometimes, restored window placed too high. (LP: #716521)
    - Compiz clears the root window in the installer session (LP: #720679)
    - unity-window-decorator: When switching between windows, Orca does
      not speak the title of the focused window. (LP: #724093)
    - Cannot open a window that starts iconified (LP: #732997)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - Pixmap memory leak in gtk-window-decorator (LP: #740258)
    - Windows should not automatically be focused when opened if the
      focus is on another application (LP: #748840)
    - [sandybridge] Graphics tearing when playing video (LP: #755841)
    - Compiz's "Sync to Vblank" makes display stutter/slow with fglrx
      (LP: #763005)
    - [regression] Moving windows lags behind the mouse by 1-2 seconds;
      appear to freeze when dragging. (LP: #764330)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - scrolling on top of a close animation switches viewports (LP: #795065)
    - unity video tearing when moving windows in oneiric with
      nvidia-current (LP: #798868)
    - dialogs really slow to be displayed since the compiz update (LP: #812711)
    - It is possible to stack windows relative to windows that are
      destroyed (LP: #837252
    - Should keep list of windows last sent to server and last recv
      from server (LP: #841727)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/
      show_minimized_windows is set to true (LP: #847967)
    - maximized windows fail to update their input extents when
      undecorated (LP: #853734)
    - resizing bugs with xterm (LP: #854725)
    - crash on closing a window (LP: #856015)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in CompScreen::insertServerWindow()
      (LP: #857487)
    - compiz crashed with SIGABRT in raise() (LP: #857738)
    - Applications which create multiple windows that are transients of
      each other...

Read more...

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2012-02-13
no longer affects: unity

Hello Jiri, or anyone else affected,

Accepted compiz into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Strange, Sync To VBlank still slows down 3D accelleration here with fglrx. When unchecked, it's much better.

compiz-1:0.9.7.0~bzr2995-0ubuntu4
Precise 12.04

Lorenzo Villani (lvillani) wrote :

I have no problems with fglrx + compiz-1:0.9.7.0~bzr2995-0ubuntu4 + Sync to VBlank.

Make sure to have the amdcccle's "Tear-free" option turned off.

Daniel van Vugt (vanvugt) wrote :

It is true there is some slowdown caused by the new compiz 0.9.7, in order to eliminate tearing. But not everyone will notice it.

The slowdown is discussed in bug 930192. I hope we'll have it fixed before 12.04.

adrenochrome (adrenochrome) wrote :

with the last fix,
 compiz vsync on + catalyst tear free off
 overall smoothness is still worst than with
compiz vsync off + catalyst tear free on
(lastest catalyst on mobility hd5870)

Changed in compiz-core:
status: Fix Committed → Fix Released
Varun Priolkar (varunpr97) wrote :

I too have the problem.

Varun Priolkar (varunpr97) wrote :

Using Radeon 4650

bugbot (bugbot) on 2012-05-31
tags: added: natty
Changed in ubutter:
status: New → Fix Released
Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Confirmed for fglrx as per comment #34.

Changed in fglrx-installer (Ubuntu):
status: Invalid → Confirmed
summary: - Compiz's "Sync to Vblank" makes display stutter/slow with fglrx
+ fglrx driver + compiz's "Sync to Vblank" makes display stutter/slow
SolidSteel144 (milesrdz) wrote :

I too have this issue.
Radeon HD 7970 and Ubuntu 12.10 with the latest fglrx at the time of this post.
Only way to minimize the lag is to disable sync to v-blank and screen tearing in CCC.

It's a very serious performance issue.

Daniel van Vugt (vanvugt) wrote :

SolidSteel144:

This bug is Fix Released. Please log your problem as a new bug using this command:
    ubuntu-bug fglrx-installer

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
Changed in fglrx-installer (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in fglrx-installer (Ubuntu):
status: Invalid → Confirmed
Changed in fglrx-installer (Ubuntu Oneiric):
status: Invalid → Confirmed
Adolfo Jayme (fitoschido) wrote :

(Untargetting obsolete release)

no longer affects: compiz (Ubuntu Oneiric)
no longer affects: fglrx-installer (Ubuntu Oneiric)
Displaying first 40 and last 40 comments. View all 147 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers