Compiz effects slow and laggy on Natty with ATI card

Bug #768275 reported by Exquisite Dead Guy on 2011-04-21
112
This bug affects 24 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Sorry if this is filed under the wrong package.

Under exactly the same hardware configuration, Maverick always ran very swiftly and smoothly. Since switching to Natty, graphics are now very slow and lagged. This is most noticeable when using compiz zoom, before it was very smooth, now it's very choppy and difficult to use. It's also noticeable on ALT-Tabbing, sometimes it takes 3 seconds for the dialog to popup. Scrolling in applications is much more choppy than before. Makes the system feel slow and lagged despite having a very low system load and plenty of memory.

The same problems occur in Classic Desktop as well as Unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110415-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,move,grid,water,place,gnomecompat,compiztoolbox,imgpng,mousepoll,unitymtgrabhandles,resize,session,neg,vpswitch,regex,wall,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Apr 21 07:39:11 2011
DistUpgraded: Log time: 2011-04-20 10:06:36.779189
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc RS880 [Radeon HD 4250] [1002:9715] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:843e]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
InstallationMedia_: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
JockeyStatus: xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=98197701-1f0a-4e8e-a5b0-65d2965baec3 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2011-04-20 (0 days ago)
dmi.bios.date: 08/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0603
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A88T-M/USB3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0603:bd08/23/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A88T-M/USB3:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
nvidia-installer.log: Error: [Errno 2] No such file or directory: '/var/log/nvidia-installer.log'
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Valentin (valentin-stn) wrote :

+1

Worked very well with Maverick but now in Natty the hole desktop is very slow. The new 11.4 proprietary driver maybe could solve the problem?

Changed in compiz (Ubuntu):
status: New → Confirmed
bagl0312 (bagl0312) wrote :

I see the same problem.
My card is also:

01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4200]

David Rando (david-rando) wrote :

Did you try disabling v-sync? also, disabling the "detect refresh rate" (or update rate, i have it in spanish) and then move the refresh rate bar to the right (will mark 200).

It resolved (almost) all my problems with compiz in my system (but i'm using intel). I use to do the same changes for nvidia. (not tested with natty yet)

bagl0312 (bagl0312) wrote :
Ari Torhamo (ari-torhamo) wrote :

I tried the instructions linked by "bagl0312" (comment #5), and things got quite a lot faster for me too. I didn't remove the xorg.conf file though. I wonder if it's safe to remove it, and does removing affect anything else than (possibly) performance?

bagl0312 (bagl0312) wrote :

HI Ari,
xorg.conf is not anymore needed since karmic (ubuntu 9.10).
You can just rename it to xorg.conf.back

Indeed xorg.conf may be needed to use proprietary ATI drivers (fglrx).

Please note that following the recipe of my previous post you are using the open source ATI driver (xserver-xorg-video-ati)
instead of the proprietary one (fglrx), which apparently has problems with unity.

Tamás Nepusz (ntamas) wrote :

Reverting to the open-source driver from the proprietary one solved the problem for me.

In my case, I solved by disbling the "blur" effect in Compiz, nothing else.
Driver flgrx, video board Radeon HD 5450, motherboard MSI G31TM-P21, 3Gb RAM.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers