Does not support current Lucid kernel (2.6.32) or xserver (1.7)

Bug #494699 reported by Dave Morley on 2009-12-09
570
This bug affects 131 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Critical
Alberto Milone
Lucid
Critical
Alberto Milone
fglrx-installer (zUbuntu)
Fix Released
Undecided
Unassigned

Bug Description

Jockey failed to install ati fglrx binary driver.

This is because a version of -fglrx which supports the .32 kernel and 1.7 xserver has not yet been released by ATI. Various crashes and other assorted problems can be expected from fglrx until we receive an updated driver.

Technically, jockey should not be offering -fglrx even on hardware which would otherwise be supported; this is deliberate. From https://launchpad.net/ubuntu/+source/fglrx-installer

fglrx-installer (2:8.660-0ubuntu6) lucid; urgency=low

  * debian/control:
    - Provide xserver-xorg-video-5 so as to make the package
      uninstallable until AMD restores compatibility with X.
 -- Alberto Milone <email address hidden> Wed, 10 Feb 2010 10:14:14 -0500

The ATI Catalyst (fglrx) driver does not currently support Xserver 1.7. If support does not arrive this month Ubuntu 10.04 "Lucid Lynx" may be released with a special unreleased Catalyst driver to support Xserver 1.7, similar to what occurred in 9.10 "Karmic Koala" and 9.04 "Jaunty Jackalope".

Workaround in the mean-time is to uninstall -fglrx and use the open source -ati driver instead.

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 9 19:55:37 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
Package: jockey-gtk 0.5.5-0ubuntu4
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-7-generic root=UUID=81cd3311-853b-405c-a8cb-a139abc7e813 ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
SourcePackage: jockey
Tags: lucid
Uname: Linux 2.6.32-7-generic x86_64
dmi.bios.date: 01/23/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS K8N4-E SE ACPI BIOS Revision 0106
dmi.board.name: K8N4-E SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSK8N4-ESEACPIBIOSRevision0106:bd01/23/2006:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnK8N4-ESE:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Dave Morley (davmor2) wrote :
tags: added: iso-testing
Martin Pitt (pitti) wrote :

Apparently the module does not build:

Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.660/build/ for more information.

Error! Could not locate fglrx.ko for module fglrx in the DKMS tree.
You must run a dkms build for kernel 2.6.32-7-generic (x86_64) first.

Can you replicate this by apt-get install xorg-driver-fglrx and then look at the make log?

affects: jockey (Ubuntu) → fglrx-installer (Ubuntu)
Martin Pitt (pitti) wrote :

superm1 | i dont think the driver in the archive yet

Changed in fglrx-installer (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) wrote :

... supports 2.6.32

summary: - Ati binary driver failed to install using jockey
+ Does not support current Lucid kernel (2.6.32)

There has been a trivial patch in Debian unstable for a while to make recent fglrx build with linux 2.6.32.
The real show stopper though, is that Catalyst at least up to 10.1 won't work with Xorg 7.5 found in lucid.

tags: added: patch
Martin Pitt (pitti) on 2010-02-17
Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
Bryce Harrington (bryce) on 2010-03-09
summary: - Does not support current Lucid kernel (2.6.32)
+ Does not support current Lucid kernel (2.6.32) or xserver (1.7)
description: updated
Changed in fglrx-installer (Ubuntu Lucid):
importance: High → Critical
milestone: none → ubuntu-10.04-beta-2
Bryce Harrington (bryce) on 2010-03-09
description: updated

Hell,So that's why I get the dreaded :
xorg-driver-fglrx:
 Depends: xserver-xorg-core but it is not going to be installed
 Recommends: fglrx-amdcccle but it is not going to be installed
?
Damn,Running 10.04 A3 (daily build)

Changed in fglrx-installer (Ubuntu Lucid):
status: Triaged → In Progress
Alberto Milone (albertomilone) wrote :

I have uploaded a new driver but it will be available only after the beta freeze (i.e. after beta 1 is released). In other words, you'll get it soon.

Changed in fglrx-installer (Ubuntu Lucid):
status: In Progress → Fix Committed
mattrenfer (mr-renfer) wrote :

"Workaround in the mean-time is to uninstall -fglrx and use the open source -ati driver instead"

Is the open-source driver used by default? I've never installed fglrx.

I have an ATI Mobility Radeon 9600. It's my understanding that ATI has stopped support for the Control Catalyst for my card. What exactly do I do then?

I've not installed a driver since installing Lucid, but I know my graphics are not working properly (3d games/youtube videos run choppy and medium desktop effects run slow).

How do I use the open-source ATI driver if I'm not already using it?

Andrzej Kłapeć (solidslash) wrote :

The open-source ATI driver is installed by default, you don't have to do anything in order to get it.

mattrenfer (mr-renfer) wrote :

Thank you for clarifying SolidSlash. So now my question is: Why isn't my card working the way it's supposed to?

node42 (node42) on 2010-03-19
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: patch-accepted
removed: patch
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
mattrenfer (mr-renfer) wrote :

I am still having problems installing the proprietary driver, whether it's the fglrx driver in terminal, ati-driver-installer-9-3-x86.x86_64.run, or ati-driver-installer-9-12-x86.x86_64.run.

This is the error I get for trying to install the fglrx driver:
"The following packages have unmet dependencies: xorg-driver-fglrx: Depends: xserver-xorg-core but it is not going to be installed E: Broken packages."

I attached all the errors I receive in the terminal for each attempt.

I have an ATI Mobility Radeon 9600.

mattrenfer (mr-renfer) wrote :

Here are the logs for the other attempts.

Sandro Mani (sandromani) wrote :

The drivers available from the official AMD/ATI website do not yet support the lucid kernel / xserver - use the packages that just got pushed to the lucid repositories (which basically is a unreleased catalyst) - you may have to wait a few hours until all mirrors are up-to-date, or you can take a look over at https://launchpad.net/ubuntu/lucid/+source/fglrx-installer/2:8.721-0ubuntu1 .

Markus Birth (mbirth) wrote :

The 2:8.721-0ubuntu2 package for amd64 is missing the /usr/lib/fglrx/ld.so.conf and thus it doesn't configure correctly. You can fix this for now by creating that file with the contents "/usr/lib/fglrx" (without quotes) and then doing a "dpkg --configure -a". Worked fine for me.

dmatt (martind) wrote :

xorg-driver-fglrx is still not installable, it conflicts with xserver-xorg-core

istalled versions:

ii xorg 1:7.5+3ubuntu1 X.Org X Window System
ii xserver-xorg 1:7.5+3ubuntu1 the X.Org X server
ii xserver-xorg-core 2:1.7.5-1ubuntu3 Xorg X server - core server

aptitude install error is in attachment

Alberto Milone (albertomilone) wrote :

@Markus:
The file is already in the package:
$ dpkg-deb --contents ../fglrx_8.721-0ubuntu2_amd64.deb | grep ld
-rw-r--r-- root/root 6327376 2010-03-20 12:10 ./usr/lib32/fglrx/libaticaldd.so
-rw-r--r-- root/root 32 2010-03-20 12:10 ./usr/lib/fglrx/ld.so.conf
-rw-r--r-- root/root 6521616 2010-03-20 12:10 ./usr/lib/fglrx/libaticaldd.so

and the package can be installed correctly.

@martind:
the fglrx driver is no longer called xorg-driver-fglrx

Download full text (4.8 KiB)

Alberto,

2010/3/20 Alberto Milone <email address hidden>:
> @Markus:
> The file is already in the package:
> $ dpkg-deb --contents ../fglrx_8.721-0ubuntu2_amd64.deb | grep ld
> -rw-r--r-- root/root   6327376 2010-03-20 12:10 ./usr/lib32/fglrx/libaticaldd.so
> -rw-r--r-- root/root        32 2010-03-20 12:10 ./usr/lib/fglrx/ld.so.conf
> -rw-r--r-- root/root   6521616 2010-03-20 12:10 ./usr/lib/fglrx/libaticaldd.so

Despite this, I still receive the same error as Markus. Your binary
and mine seem to differ:

toby@leopard:~/Downloads/Packages$ dpkg-deb --contents
fglrx_8.721-0ubuntu2_amd64.deb | grep usr/lib/fglrx
drwxr-xr-x root/root 0 2010-03-20 07:02 ./usr/lib/fglrx/
-rw-r--r-- root/root 471136 2010-03-11 21:08 ./usr/lib/fglrx/libAMDXvBA.cap
-rw-r--r-- root/root 2171672 2010-03-20 07:02
./usr/lib/fglrx/libAMDXvBA.so.1.0
drwxr-xr-x root/root 0 2010-03-20 07:02 ./usr/lib/fglrx/bin/
-rwxr-xr-x root/root 57592 2010-03-20 07:02 ./usr/lib/fglrx/bin/amdnotifyui
-rwxr-xr-x root/root 264848 2010-03-20 07:02 ./usr/lib/fglrx/bin/atieventsd
-rwxr-xr-x root/root 293192 2010-03-20 07:02 ./usr/lib/fglrx/bin/aticonfig
-rwxr-xr-x root/root 37552 2010-03-20 07:02 ./usr/lib/fglrx/bin/atiodcli
-rwxr-xr-x root/root 689752 2010-03-20 07:02 ./usr/lib/fglrx/bin/atiode
-rwxr-xr-x root/root 25136 2010-03-20 07:02 ./usr/lib/fglrx/bin/fgl_glxgears
-rwxr-xr-x root/root 8736 2010-03-20 07:02 ./usr/lib/fglrx/bin/fglrx_xgamma
-rwxr-xr-x root/root 13296 2010-03-20 07:02 ./usr/lib/fglrx/bin/fglrxinfo
-rw-r--r-- root/root 212064 2010-03-20 07:02 ./usr/lib/fglrx/libatiadlxx.so
-rw-r--r-- root/root 11168 2010-03-20 07:02
./usr/lib/fglrx/libfglrx_dm.so.1.0
-rw-r--r-- root/root 9064 2010-03-20 07:02
./usr/lib/fglrx/libfglrx_gamma.so.1.0
-rw-r--r-- root/root 12120 2010-03-20 07:02 ./usr/lib/fglrx/libXvBAW.so.1.0
-rw-r--r-- root/root 798440 2010-03-20 07:02 ./usr/lib/fglrx/libGL.so.1.2
drwxr-xr-x root/root 0 2010-03-20 07:02 ./usr/lib/fglrx/dri/
-rw-r--r-- root/root 26859936 2010-03-20 07:02 ./usr/lib/fglrx/dri/fglrx_dri.so
drwxr-xr-x root/root 0 2010-03-20 07:02 ./usr/lib/fglrx/xorg/
drwxr-xr-x root/root 0 2010-03-20 07:02 ./usr/lib/fglrx/xorg/modules/
-rw-r--r-- root/root 202848 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/amdxmm.so
-rw-r--r-- root/root 6681216 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/glesx.so
drwxr-xr-x root/root 0 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/drivers/
-rw-r--r-- root/root 9337664 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
drwxr-xr-x root/root 0 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/linux/
-rw-r--r-- root/root 53528 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/linux/libfglrxdrm.so
drwxr-xr-x root/root 0 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/extensions/
-rw-r--r-- root/root 594528 2010-03-20 07:02
./usr/lib/fglrx/xorg/modules/extensions/libglx.so
-rw-r--r-- root/root 56456 2010-03-20 07:02 ./usr/lib/fglrx/libaticalcl.so
-rw-r--r-- root/root 6521720 2010-03-20 07:02 ./usr/lib/fglrx/libaticaldd.so
-rw-r--r-- root/root 64584 2010-03-20 07:02 ./usr/lib/fgl...

Read more...

Alberto Milone (albertomilone) wrote :

The problem is that something went wrong when the packages were built.

It looks like the builder ignored "echo" and "printf" commands in debian/rules.

if you grab the source and try to build it locally it will work.

See the attached output of my pbuilder chroot and compare it with the build log from launchpad:
http://launchpadlibrarian.net/41378586/buildlog_ubuntu-lucid-amd64.fglrx-installer_2:8.721-0ubuntu2_FULLYBUILT.txt.gz

I'll investigate the issue.

Alberto Milone (albertomilone) wrote :

The problem should be solved in fglrx_8.721-0ubuntu3.

Andrzej Kłapeć (solidslash) wrote :

I have installed this driver on a clean, freshly installed ubuntu 10.04 beta. As a result, the system is unbootable - it doesn't go any further than a purple screen - the GDM doesn't start and the system freezes. Also, the recovery mode stops at a black screen and is also unusable. Changing VTs with ctrl alt fX doesn't work, all I can do is to power down my laptop ( dell 1555 with ati 4570 ). Any ideas how to un-brick my system? I guess chrooting from a live-cd is the only way to go, but I'm listening for your ideas.

Sandeep (sandeepsb) wrote :

Can I add something,
I have an ATI 5850 GPU and can't run the installation or boot into Ubuntu 10.04 Beta 1 with a HDMI output, only DVI + VGA can do all the screen display.

After installing the Drivers above as I thought this would fix the HDMI issue I get no HDMI output and when booting in with DVI I get a bunch of lines going down the screen and everything going fuzzy.

Andrew Gorcester (andrewsg) wrote :

I installed the fglrx_8.721-0ubuntu3 packages on my beta 1 install (up to date as of late March 20). X started properly but all gl-related applications segfaulted. These included the fglrx-specific programs like fglrxinfo and also glxgears, glxinfo, etc. I then removed the packages and gl-related applications like glxinfo, glxgears and glxdemo started functioning again.

Markus Birth (mbirth) wrote :

@SolidSlash #21: I guess you have the same problem as I had: fglrx conflicts with the "radeon" kernel module. You have to add "nomodeset" or "radeon.setmode=0" to your kernel options, i.e. get into GRUB, edit the parameters for recovery mode and add it manually to the kernel line. After getting into a root console, add the parameters to the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub . After that, run "update-grub" and reboot.

Thomas Astleitner (danube) wrote :

I'm using a HP nc8430 Laptop running a ATI Radeon Mobility X1600, I'm not able to use 10.04 beta 1 because the screen flickers and nothing can be identified or read on the screen. Waiting for the next release.
danube

David Clayton (dcstar) wrote :

Same as post #23 for me, Also fglrx-amdcccle_8.721-0ubuntu3_amd64 installed but amdcccle won't run:

There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

No ATI graphics driver is installed, or the ATI driver is not functioning properly.
Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig.

David Clayton (dcstar) wrote :

Ok, running sudo aticonfig --initial (which creates an xorg.conf file) and rebooting allows sudo /usr/lib/fglrx/bin/amdcccle to then run as anticipated, but just "sudo amdcccle" results in command not found.

It looks like the fglrx-amdcccle_8.721-0ubuntu3_amd64 package does not put the binary in a path or create a menu entry (at least I can't find it).

David Clayton (dcstar) wrote :

As well, after changes in post #26 glxgears now works (old driver 3866 frames/5 secs, new driver 16188) and glxinfo runs with no caveats on my hardware.

Andrew Gorcester (andrewsg) wrote :

Got it to run on my system by running sudo aticonfig --initial, and then sudo service gdm restart.

Brandon Elliott (brelliott) wrote :

After following the steps above and re-installing a few times the ATI driver is working for 2D/3D; however the function keys for brightness on my notebook (Sony) are no longer working. (They worked with Karmic + ATI drivers)

From dmesg:
[ 8.403523] sony-laptop: brightness ignored, must be controlled by ACPI video driver

I forget the command but the notebook is seeing the fn+F5 and fn+F6 commands.

Also, issuing this works to dim the screen: echo 5 > /sys/class/backlight/acpi_video0/brightness

Cuppa-Chino (hamcatcher) wrote :

I have tried installing a couple of times on sony e-series laptop with radeon mobility hd5650 and am getting segfaults in the driver and defaulting to "low graphics"/vesa

$ lspci -nn | grep Radeon
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Redwood [Radeon HD 5600 Series] [1002:68c1]
01:00.1 Audio device [0403]: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series] [1002:aa60]

complete xorg.0.log file posted here:
http://pastebin.com/vkGTJpr8

key error (I think)
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4a25e8]
1: /usr/bin/X (0x400000+0x6538d) [0x46538d]
2: /lib/libpthread.so.0 (0x7f20ee50a000+0xf920) [0x7f20ee519920]
3: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN24DisplayCapabilityService19QuerySinkCapabilityEP21DisplaySinkCapability+0x2c6) [0x7f20eb4005a6]
4: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN15TopologyManager20detectSinkCapabilityEP22TmDisplayPathInterfaceP17TMDetectionStatus+0xc5) [0x7f20eb3d2e45]
5: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN15TopologyManager12detectTargetEP22TmDisplayPathInterfacebP17TMDetectionStatus+0x30) [0x7f20eb3d2af0]
6: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN15TopologyManager17doTargetDetectionEP22TmDisplayPathInterface15DetectionMethodP17TMDetectionStatus+0x108) [0x7f20eb3d2ab8]
7: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN15TopologyManager28detectTargetWithReportOptionEP22TmDisplayPathInterface15DetectionMethodP20TMConnectivityReport+0x42) [0x7f20eb3d27a2]
8: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN15TopologyManager18DoInitialDetectionEv+0x59) [0x7f20eb3cee29]
9: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (_ZN4Dal214EnableInstanceEP14_DAL_INIT_INFO+0x29) [0x7f20eb3a2409]
10: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (DALEnableInstance+0x8d) [0x7f20eb2122ad]
11: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (swlDalDisplayEnableDAL+0x1bb) [0x7f20eb188b3b]
12: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xilDisplayAdaptorCreate+0x5b) [0x7f20eb18640b]
13: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (atiddxDisplayPreInit+0x561) [0x7f20eb176c31]
14: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (atiddxPreInit+0x7e4) [0x7f20eb154064]
15: /usr/bin/X (InitOutput+0x552) [0x473682]
16: /usr/bin/X (0x400000+0x25f95) [0x425f95]
17: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f20ed203c4d]
18: /usr/bin/X (0x400000+0x25ce9) [0x425ce9]
Segmentation fault at address (nil)

Caught signal 11 (Segmentation fault). Server aborting

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log

Andrzej Kłapeć (solidslash) wrote :

The brightness keys on my Dell 1555 also don't work at their best - I mean, they do change the brightness indeed but notify-osd doesn't show the 'progress' bar.

SolidSlash: On my Dell 17' notify-osd has never shown this bar. I know it should appear when I change brightness, but on Jaunty+fglrx, Karmic+radeon, Karmic+fglrx, Lucid+radeon and now on Lucid+fglrx I have never seen the progress bar, although the brightness changes. This is why I think this is not a fglrx-related bug.

Andrzej Kłapeć (solidslash) wrote :

And I think it is somehow related to fglrx. On Karmic+fglrx I had to add "noapic" option to grub and as a result notify-osd worked great. On Lucid+open-source ati I didn't have to do nothing - it worked out-of-the-box. However on Lucid+fglrx, adding "noapic" hasn't changed anything. It's broken on my lucid machine SINCE I installed the fglrx driver.

mattrenfer (mr-renfer) wrote :

I downloaded and installed all 4 of these packages:
https://launchpad.net/ubuntu/+source/fglrx-installer/2:8.721-0ubuntu1/+build/1568895

It may well have made problems worse for me.

I'm running Lucid and have a ATI Mobility Radeon 9600.

Before the download, my graphics during games and videos were very choppy and my medium visual effect desktop settings were very slow.

Now I cannot even run games (Glest, TeeWorlds won't start...they don't do anything when I click on them) and I cannot even attempt to switch to medium or high visual effects.

I notice my screen is brighter, but other than that it still does not fix my problems: that I'm essential running without a graphics driver.

Oh, and the Catalyst Control Center is nowhere to be found even though I installed it.

Aurélien COUDERC (coucouf) wrote :

@danube Your graphic chip is not supported by the binary fglrx driver, you should probably file a new bug against the xserver-xorg-video-radeon free software package.

@mattrenfer Your graphic chip isn't supported by fglrx either, you should stick to the radeon driver.

Please note that fglrx only supports most recent AMD products :
Desktop : Radeon HD 24xx to 59xx.
Laptop : Mobility Radeon HD 24xx to 48xx.
Integrated : Radeon HD 30xx, 31xx, 32xx, 33xx and 42xx.

The fglrx driver won't work with older graphic chip, whether HD pre 24xx Radeons, or all former non HD Radeons. Users of these types of hardware should stay with the (default) radeon driver.

mattrenfer (mr-renfer) wrote :

@Aurélien Couderc

I have stuck with the default radeon driver when installing Lucid, and guess what? That's not working either. My 3d graphics are choppy. How do I solve this problem!?

Sandro Mani (sandromani) wrote :

@mattrenfer
The open-source driver has yet to mature especially in the 3D area, currently you won't get full performance. Since AMD decided to ditch support for older graphic-cards in their binary driver, you'll have to wait a while until the open driver gets optimized.

Thomas Astleitner (danube) wrote :

@Aurélien Couderc: Thanks for the info, unfortunately I have no permission to access bug tracking of package xserver-xorg-video-ati under https://launchpad.net/ubuntu/+source/xserver-xorg-video-ati

madbiologist (me-again) wrote :

@danube - I couldn't load that page either. Got a message stating "Not allowed here Sorry, you don't have permission to access this page. You are logged in as madbiologist.", which I though was a bit odd, given I can access the pages about other packages. I might file a bug about that later.

Anyway, the solution is to log out first and then go to that page.

Dmitry Tantsur (divius) wrote :
cosmos (alantonop) wrote :

Comment #29 helped.My ATI 2600pro AGP worked after doing that which is described at #29.
sudo aticonfig --initial and then sudo service gdm restart.

quantux (quantux) wrote :

Steps listed in post 29 worked after installing fglrx package via synaptic. Watching it install, the module build/load looked like it worked fine, maybe the package is just missing the aticonfig part thats neccessary even with the installer from ati.

Nguyen Anh Minh (minhna) on 2010-03-27
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Segitz (flacht82) wrote :

I have the same laptop as #31, and I have the same problem too... going to reinstall the system now, just to try it out.

Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

I still have segmentation fault with newest 2:8.721-0ubuntu7.

ATI Mobility Radeon HD 4330
x86_64

Aurélien COUDERC (coucouf) wrote :

@Andrzej Kąkolewski
I think your problem doesn't belong this bug report.
You should open a new one and describe your problem more precisely because « hav[ing] a segmentation fault » is quite vague… :-)

I have similar output in logfile like #31.
I think it is related with this bug.

Simon Schmid (schmsimo) wrote :

If you got problems removing xorg-driver-fglrx-dev or xorg-driver-fglrx-dev then open /var/lib/dpkg/status and search for those packages. Remove the paragraphs and save the file (don't forget to back it up). Now you can install the patched driver.

Brendan_P (brendan-p) wrote :

After running updates from yesterday I get the following error on start-up this morning

(EE) Unable to initialise PCS database
(EE) Missing PCS defaults file /etc/ati/amdpcsdb.default
(EE) No devices attached

Running "sudo aticonfig --initial" gives "Unable to open /etc/ati/control, please reinstall the driver.
aticonfig: No supported adapters detected"

All was 100% before the update

Brendan_P (brendan-p) wrote :

Removing driver, restart and re-installing driver via Admin > hardware drivers interface resulted in same issue.

Using Synaptic, I completely removed fglrx packages, restarted, reinstalled them. This solved the issue for me. Rough ride to have before the first cup of coffee for the day ;)

David Clark (pcman-master) wrote :

I am running beta 10.04 on ati hd 4870 card video is fine but now sound

I have 1GB 4870 card and this driver worked well for me.. I don't use it for HDMI sound so I don't know about that, though I see the ATI card in my sound output list.. I'll attach my working xorg.conf, hope it helps..

spbike (bill-broadley) wrote :

I have a 64-bit lucid install fully patches as of 2010-04-01 or so. I patched and saw 300 MB of patches including fglrx and kernel patches. I had exactly what #49 Brendan P had happen. Perfectly working system with a radeon 5770. Apt-get update, apt-get upgrade, something indicated I should reboot so I did. When it booted it complained about Missing PCS defaults file /etc/ati/amdpcsdb.default.

Here's a bigger piece of the log file:
(II) Module dri2: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.1.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.7.1, module version = 8.72.10
        Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.7.1, module version = 8.72.10
(II) ATI Proprietary Linux Driver Version Identifier:8.72.10
(II) ATI Proprietary Linux Driver Release Identifier: 8.72.1
(II) ATI Proprietary Linux Driver Build Date: Mar 10 2010 23:41:33
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(EE) Unable to initialize PCS database
(EE) Missing PCS defaults file /etc/ati/amdpcsdb.default
(EE) No devices detected.

I tinkered quite a bit, I reverted the fglrx driver to the previous version, booted the previous kernel, tried the driver from ati.com, all without luck. At some point I had run apt-get update and another batch of patches came down, then I just said "aticonfig --initial" and it worked.

So now as far as I can tell I'm 100%, running 2 20" monitors, radeon 5770, and the current kernel and fglrx driver as supplied by ubuntu. Maybe there's some bug where upgrading fglrx while the fglrx module is in use somehow corrupts /etc/ati/amdpcsdb.default?

spbike (bill-broadley) wrote :

Ah, better bug for exactly this problem, and the work around at bug number 552548:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/552548

Alberto Milone (albertomilone) wrote :

Ok, let's discuss the problem is bug #552548

Workaround in the mean-time is to uninstall -fglrx and use the open source -ati driver instead.
How do I install the OS driver from command line?

Ron Adams (tohuw) wrote :

fglrx seems to build correctly in 2.6.32-19-generic.

HX_unbanned (linards-liepins) wrote :
Download full text (5.3 KiB)

NO! It does not / still is bugged!

Here is terminal log:

linards@linards-desktop:~$ sudo apt-get install -f
[sudo] password for linards:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  pwgen libfreebob0 plasma-dataengines-workspace python-pygoocanvas
  kdelibs4c2a libprocessui4 docvert libtaskmanager4 libqimageblitz4
  libboost-regex1.38.0 libpackagekit-glib2-12 libkscreensaver5
  libsolidcontrolifaces4 python-beaker kdebase-runtime-data-common twolame
  kdelibs-data libgoocanvas-common python-sqlalchemy libxmu-headers
  libknotificationitem1 openoffice.org-hyphenation-en-us liblualib50 libass3
  libservlet2.4-java gnumeric-common libplasma-geolocation-interface4
  libexiv2-5 python-nose gnumeric-doc nautilus-sendto-empathy
  libswt-gtk-3.4-java libsqlite0-dev libphp-pclzip python-gtkspell
  alsaplayer-alsa libpackagekit-qt-12 sdparm libx264-67 mysql-server-core-5.1
  install-package jpegoptim python-celementtree libksgrd4 fuseiso9660
  kdebase-runtime-bin-kde4 fckeditor libkworkspace4 libcelt0 libfltk1.1
  libavahi-qt3-1 python-sip4 libplasmagenericshell4 libkfontinst4 libxmu-dev
  openbsd-inetd libjline-java openoffice.org-thesaurus-en-au libwmf-bin
  openoffice.org-hyphenation libffado1 libntlm0 openoffice.org-thesaurus-en-us
  libgoffice-0-8 python-packagekit libiso9660-5 libiso9660-7 packagekit
  libkephal4 kdebase-workspace-data software-properties-kde ksysguardd
  libplasmaclock4 liblcms1-dev libxml++2.6-2 proftpd-basic libweather-ion4
  kdebase-workspace-kgreet-plugins rhino libsolidcontrol4 khelpcenter4
  libumlib0 librsvg2-bin mjpegtools akonadi-server update-manager-kde
  packagekit-backend-apt python-wnck python-elementtree liblua50 libmng-dev
  libplasma-applet-system-monitor4 libswt-cairo-gtk-3.4-jni libprocesscore4
  gstreamer0.10-gnonlin libsensors-dev libgoocanvas3 optipng empathy-common
  libgnomecups1.0-1 libswt-gtk-3.4-jni libgoffice-0-8-common
  libswt-mozilla-gtk-3.4-jni
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
linards@linards-desktop:~$ sudo apt-get install fglrx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  pwgen libfreebob0 plasma-dataengines-workspace python-pygoocanvas
  kdelibs4c2a libprocessui4 docvert libtaskmanager4 libqimageblitz4
  libboost-regex1.38.0 libpackagekit-glib2-12 libkscreensaver5
  libsolidcontrolifaces4 python-beaker kdebase-runtime-data-common twolame
  kdelibs-data libgoocanvas-common python-sqlalchemy libxmu-headers
  libknotificationitem1 openoffice.org-hyphenation-en-us liblualib50 libass3
  libservlet2.4-java gnumeric-common libplasma-geolocation-interface4
  libexiv2-5 python-nose gnumeric-doc nautilus-sendto-empathy
  libswt-gtk-3.4-java libsqlite0-dev libphp-pclzip python-gtkspell
  alsaplayer-alsa libpackagekit-qt-12 sdparm libx264-67 mysql-server-core-5.1
  install-package jpegoptim python-celementtree libksgrd4 fuseiso9660
  kdebase-runtime-bin-kde4 fckeditor libk...

Read more...

Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Fix Committed
Download full text (6.2 KiB)

First of all do a sudo apt-get autoremove to remove all those packages.
A side of that, you appear to have some residuals from the
xorg-driver-fglrx package which no longer exists. Try to sudo apt-get
purge xorg-driver-fglrx. If that does not work, your package database
may be messed up from some previous attempts. You can either manually
remove the files / edit the package database at your own risk or simply
install a clean beta 2. Anyhow this issue is specific to your
installation and not a general issue.

On 04/09/2010 08:54 PM, HX_unbanned wrote:
> NO! It does not / still is bugged!
>
> Here is terminal log:
>
> linards@linards-desktop:~$ sudo apt-get install -f
> [sudo] password for linards:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer required:
> pwgen libfreebob0 plasma-dataengines-workspace python-pygoocanvas
> kdelibs4c2a libprocessui4 docvert libtaskmanager4 libqimageblitz4
> libboost-regex1.38.0 libpackagekit-glib2-12 libkscreensaver5
> libsolidcontrolifaces4 python-beaker kdebase-runtime-data-common twolame
> kdelibs-data libgoocanvas-common python-sqlalchemy libxmu-headers
> libknotificationitem1 openoffice.org-hyphenation-en-us liblualib50 libass3
> libservlet2.4-java gnumeric-common libplasma-geolocation-interface4
> libexiv2-5 python-nose gnumeric-doc nautilus-sendto-empathy
> libswt-gtk-3.4-java libsqlite0-dev libphp-pclzip python-gtkspell
> alsaplayer-alsa libpackagekit-qt-12 sdparm libx264-67 mysql-server-core-5.1
> install-package jpegoptim python-celementtree libksgrd4 fuseiso9660
> kdebase-runtime-bin-kde4 fckeditor libkworkspace4 libcelt0 libfltk1.1
> libavahi-qt3-1 python-sip4 libplasmagenericshell4 libkfontinst4 libxmu-dev
> openbsd-inetd libjline-java openoffice.org-thesaurus-en-au libwmf-bin
> openoffice.org-hyphenation libffado1 libntlm0 openoffice.org-thesaurus-en-us
> libgoffice-0-8 python-packagekit libiso9660-5 libiso9660-7 packagekit
> libkephal4 kdebase-workspace-data software-properties-kde ksysguardd
> libplasmaclock4 liblcms1-dev libxml++2.6-2 proftpd-basic libweather-ion4
> kdebase-workspace-kgreet-plugins rhino libsolidcontrol4 khelpcenter4
> libumlib0 librsvg2-bin mjpegtools akonadi-server update-manager-kde
> packagekit-backend-apt python-wnck python-elementtree liblua50 libmng-dev
> libplasma-applet-system-monitor4 libswt-cairo-gtk-3.4-jni libprocesscore4
> gstreamer0.10-gnonlin libsensors-dev libgoocanvas3 optipng empathy-common
> libgnomecups1.0-1 libswt-gtk-3.4-jni libgoffice-0-8-common
> libswt-mozilla-gtk-3.4-jni
> Use 'apt-get autoremove' to remove them.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> linards@linards-desktop:~$ sudo apt-get install fglrx
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer required:
> pwgen libfreebob0 plasma-dataengines-workspace python-pygoocanvas
> kdelibs4c2a libprocessui4 docvert libtaskmanager4 libqimageblitz4
> libb...

Read more...

Rich Hart (sirwizkid) on 2010-04-09
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
Rich Hart (sirwizkid) wrote :

sorry, new to launchpad. Didn't realize I changed the status. Changing it back.

Changed in fglrx-installer (Ubuntu Lucid):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

This bug *is* fixed. HX_unbanned, the issue you're seeing is bug #552782. Please don't reopen this bug, file new bug reports for new issues.

Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
theLawman (billieboy) on 2010-04-10
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Butt Munch (littermail) wrote :

Hey there.
For all Linux users with older Ati graphic cards. Give up struggling with drivers for 9,04, 9,10 and the upcoming 10,04, it's not gonna work. That goes for the open source drivers as well. The proprietary driver in 8,04 still works for older Ati cards, like 9200 for instance. You can get 8,04 at this page:
http://releases.ubuntu.com/hardy/ (PC (Intel x86) desktop CD).
Use that instead. Install it, let it update, and after updating it will automatically notify you about the proprietary driver. It can't get any easier. I just checked before writing this. The driver is there, and it works. So don't let anyone tell you that the driver has been removed by Ati, like a lot of people claim.
8,04 is a LTS version (long time support) and is supported till 24-4-2011, and will of course still be working after that time.
For users with newer Ati cards: You have my deepest sympathies. You're properly gonna have a lot of trouble, and you might realize that you made a bad investment (but don't let it scare you from using Linux). There's a very good reason for the existence of open source drivers for Ati cards, all though they are not very good either. As far as I know there's no open source drivers for Nvidia cards. There's also a good reason for that. Keep that in mind the next time you invest in new gear. It will make your life so much easier.
I have Nvidia on all my machines, except on an old Acer laptop with Radeon Mobility 9200. I use 8,04 on that one, and it works great. With only a very few exceptions all the software you find for the newer versions is available in 8,04. You should not be missing anything by using it.
I really love Ubuntu and it just gets better for every version, when using Nvidia. Intel graphics is'nt bad either. But I think it might would be a good idea for Ubuntu developers to slow down just a little bit, and make sure the existing Ati drivers that worked in earlier versions, still works in the new ones (and is easy to install for new users). Linux has always had a reputation of being great to install on older machines because it kinda bring new life to them. A lot of new users is being introduced to Linux that way. If their first experience is massive problems, they might never wanna use it again. If you surf the net, you will properly find hundreds (if not thousands) of pages with people complaining about Ati drivers for Linux. Of course Ati/Amd is to blame for that. On the other hand Ubuntu have their part of the blame as well, constantly changing the operating system without making sure of compatibility with existing drivers and other software. Fast development has its upsides, but also its downsides. If you should rewrite the drivers you provide, perhaps every six month, wouldnt you get a little tired of it?
(Lets not forget that Ati is the most selling card. At least at the moment. A little something to keep in mind).
In my opinion Ubuntu is already great as it is. Instead of changing color, layout and other rather pointless changes and call it a new version, I think they should make sure that it works for everyone, and keeps working.
With all that said, Linux IS the best.

Butt Munch (littermail) wrote :

By the way, if you are a new user, you might not know this site: http://www.playdeb.net/updates/Ubuntu/all/
If you like gaming you will find some great stuff in there. Check it out.

On this site you can find programs not listed in the Ubuntu software center: http://www.getdeb.net/updates/ubuntu/9.10/

There's instructions how to install on both pages. Its really easy. Tell it to everyone.

For those who might think this info dos not belong here, trust me it does. A lot of people read this page.

Really? I have been using Ati cards since I remember and I have never had any serious trouble with it.
Yes, AMD is to be blamed for the damned fglrx, but, seriously, I, personally, do not complain. For some time I used fglrx, then I moved to open-source drivers (due to this bug) and I found out they are working perfectly... I used to have some trouble with them, because of some tiny bugs, but I can get great performance and everything I could wish...
I do agree some people may be disappointed by poor support for their cards in Ubuntu, but you can't say everyone with Ati card will have lots of trouble... If you are conscious enough, you can avoid any trouble and gain full support. Maybe not for the lastest and hottest cards, but as in my case, it IS possible even to play the newest games.
In my opinion the open-source drivers are not as bad as many people claim, and also fglrx is not as trouble-causing as it looks like. I think people are over-complaining about Ati cards, as from my experience, and from what I know from the Internet, they just have a terrible stereotype, while the truth is that they are usable (but getting them to work sometimes requires some work).

Butt Munch (littermail) wrote :

Hey Rafal.
It's great to hear that you don't have problems with Ati graphics. But a lot of users really do. Especially new Linux users. Other more advanced users have struggled like hell, tried everything, and they still ended up blank. Thats a fact, and there's no stereotyping in that.
Surfing the net, you will find hundreds of pages describing those problems. Some of them new, and others as old as Ubuntu it selves. A lot of users with those problems turn to pages like this to find solutions, but the way things in here is described will only make them more confused (No disrespect to anyone).
Its sad to see new users (not using Nvidia) drop Ubuntu like a pair of soiled trousers, because they can't find solutions anywhere. Especially if other people have the answers. The hole idea in Ubuntu is sharing, and its actually really disappointing when users with Ati problems look for solutions, all they find is page after page with the exact same problems they have themselves, but no answers on how to fix it. If they are lucky to come across a page with solutions, it still does not help them, because its so badly described that only a total hardcore Linux wizard maybe is able to get something out of it. Considering that you got yours working, maybe you could be the one to change all that?
If you could write a detailed step by step instruction on how to make it work, that new users could easily follow, and put it on this page (and perhaps on some other pages too), a lot of people could really benefit from it.
As I told in my first commend I have been using Nvidia all the time, except on the old Acer Laptop which is running fine with 8,04. I have never had to struggle with drivers, and therefore I have no solutions to pass on to others, except if they have an old Ati card to try out 8,04 or switch to Nvidia. But there is one thing I can do: Speak up, and write about the problem (like in my first commend) on all the pages like this that I come across. I could of course say: I got my a.. covered by using Nvidia, so I don't care. But the thing is that I do care. I really like Ubuntu, and I want to see it grow. So I'm gonna continue writing till someone like you for instance who has the knowledge, write one or more really great instructions, and make them as visible on the net as possible.
Kinda hope for Jackpot this time.

By the way, I'm not saying that Ati is junk. I actually think Ati kicks butt. Especially in Windows (pardon the nasty word). Its just a shame that so many Linux users have such a struggle with them.

Kind regards.

Butt Munch (littermail) wrote :

Ps. You are the first I have ever heard saying that the open source drivers work as they should, and support all fuctions. The net is filled with people saying quite the opposite. If they really work, why don't the Ubuntu developers put them in the operating system and solve the problem once and for all?

Tim Wells (timnwells) wrote :

If nvidia are so much better than ATI then where is the kernel-mode-setting support in their driver. Its a small thing but on my laptop using the nvidia driver the bootup (however brief) looks the crap compared to the open source ATI driver on my desktop machine.

ATI seem interested in making the open source driver work. They are providing hardware specs and the development of the open-source ATI driver has been improving in leaps and bounds IMHO.

I have desktop effects working beautifully, the plymouth startup on lucid looks so much better using the open source ATI drivers than it does using the closed nvidia ones. I think the open source drivers are definitely a much better solution and for now the quickest way to absolutely kick-ass drivers designed properly by the open-source community who know the Linux kernel and drivers a lot better than a hardware manufacturer.

The fact that the closed ATI drivers are sub-standard makes me believe even more in the open-source drivers. Let the hardware people make the hardware and the software people make the software. ATI obviously aren't that good at making Linux drivers so it makes a lot of sense for ATI to open the hardware specs and let Linux drivers experts create the drivers.

So for that reason I'm sticking with ATI for the time being and waiting to see what the near future holds, but my experience with open source and Linux thus far tells me that I would rather use open-source that put up with buggy closed software/drivers.

Dmitry Tantsur (divius) wrote :

Tim Wells, who needs KMS when you just cannot start X? And with my NVidia card it just works, though without this KMS.

Tim Wells (timnwells) wrote :

I guess I might be looking at things a little to simple, just because I know the landscape of graphics card driver issues on Linux and can make an informed choice doesn't mean that someone new to Linux does.

However, someone new to Linux shouldn't be installing an alpha or beta release of a Linux OS.

If they were to use a current stable release of the OS they would find the fglrx driver works on the stable version.

Dmitry Tantsur (divius) wrote :

> If they were to use a current stable release of the OS they would find the fglrx driver works on the stable version.

For me it doesn't and I'm afraid it won't.

Tim Wells (timnwells) wrote :

> If they were to use a current stable release of the OS they would find the fglrx driver works on the stable version.
>
> For me it doesn't and I'm afraid it won't.

Interesting. Well then I retract my previous statement. I haven't come across an ATI card that hasn't worked for me, but I haven't done much with the older cards or the really new cards and I guess its the really new and the older cards that might be where the issues are.

Butt, thanks for sharing your opinion. Well, I've thought of preparing a guide on how to deal with Ati card on Linux. However, I found out that the only step I can recommend is just to use Ubuntu 10.04 (or at least when it will become stable).
When I was saying about open-source drivers, I meant 'radeon' and 'radeonhd', which, as far as I know (and that's somehow not surprising at all) are on Ubuntu CD, and in fact everything works out of the box. If someone isn't satisfied with those drivers, he can get the proprietary drivers easily, by the time of release of Ubuntu 10.04 they will be working very well, as it was with almost every previous Ubuntu release.

I do share Tim's hope, that open-source drivers will get as good as it is possible. I am also avoiding any form of closed software, and I really like the fact ATI shares with hardware specs.
I must agree part of users DO have trouble with those cards, but in my opinion there is nobody to blame - Ati supports open-source drivers, and they do try making their drivers as good as they can, open-source drivers' developers are doing their best; I think everything is on a very good way to improve this - not really satisfying - situation.

By the way, I am really surprised I am one among the very few who do not complain about open-source drivers, I think you may just have a fake impression of everyone complaining, for only the ones who have some trouble with them write about it in the net. In fact I know a lot of users who doesn't have any problems with open-source drivers.
And, in fact, as they are working well, Ubuntu developers DID put them in the operating system (which DID solve the problem, at least in my case) (if you don't mean some other open-source drivers, I have X's 'radeon' on my mind :) [they are open-source, aren't they?] ).

Untitled No. 4 (untitled-no4) wrote :

+3 on being happy with open source drivers. This is for three machines with three with different ATI cards all running with open source drivers. Two which are no longer supported by fglrx and one which is. One (older) card is running Karmic and the other two are running Lucid. It's not that everything's perfect, but it's very good.
And it's possible that if it wasn't for ATI opening the specs to their cards it the open source drivers wouldn't be that good, so I'm going to stick to ATI in the future as well.

Rajeev Nair (rajeev) wrote :

Butt munch and cieslak,

Please use the forums for discussing this, this is only for tracking bugs ,lengthy posts like yours make it difficult for bug fixers and triagers to monitor the report

thanks

rajeev

Rajeev Nair (rajeev) wrote :

Or keep such posts to 1 line. :)

thanks again.

Butt Munch (littermail) wrote :

Well I suppose there must have been a lot of this kinda writing, considering all the bugs there has been in all versions giving Ati users problems for years. Short enough?

step #29 worked for me too.

Kiren Pillay (kirenpillay1) wrote :

I installed the proprietary drivers, and used step #29 and it seems to work. Only problem is that the secondary screen is being used as my main screen,and my main screen is blank. Using an ATI Radeon 5850. This happens with the free and the proprietary driver.

encoded (encoded) wrote :

@Kiren I have a 5850 as well. I had to use aticonfig a few times, but eventually something "clicked" and I have both screens running just fine now. I know that isn't terribly helpful, I wish I could point out exactly what I did to get things to fall into place, but they eventually did.

Untitled No. 4 (untitled-no4) wrote :

If you are trying to set up the second screen using catalyst then you probably need to disable xrandr. Have a look here: http://ubuntuforums.org/showpost.php?p=7170485&postcount=2

Kiren Pillay (kirenpillay1) wrote :

@encoded, you're right. I think the initial setup steps the Ubuntu installer tried to do to detect the primary monitor caused it to a locked up state(the monitor).

I switched the monitor off and then on, and the monitor started working (Samsung Syncmaster 226BW).

icosena (gonzasiman) wrote :

Hello, I install the fglrx drivers according to the instructions:

sudo apt-get update

sudo apt-get install fglrx-amdcccle fglrx fglrx-dev fglrx-modalias

But I have the following problem:

$ Glxinfo | grep vendor

X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 157 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 14
  Current serial number in output stream: 14

@icosena: make sure you don't have an old version of libGL laying around in /usr/lib. In Ubuntu Lucid there should be no /usr/lib/libGL.so*. If you have any version of libGL left there, try removing it (keep a backup just in case) and see if the problem goes away.

DjznBR (djzn-br) wrote :

I have installed fglrx successfully,
HOWEVER, its performance is around 4300 FPS.
WAS 18200 in Karmic Koala.

SunnyDrake (beebop) wrote :

10.4 official ati drivers(ati-driver-installer-10-4-x86.x86_64.run) do not support default 10.4 ubuntu release.
you may see in /var/log/Xorg.0.log
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
symptoms
fglrxinfo will output
X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 136 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 20
  Current serial number in output stream: 20
trying to use opensource drivers for now.

@SunnyDrake: When you install the Catalyst driver from amd.com, make sure you uninstall the fglrx packages included in Ubuntu first.

SunnyDrake (beebop) wrote :

solved! by deleting via synaptic all fglrx packages and installing fglrx_8.723.1-0ubuntu4_i386.deb
(also modded /usr/share/ati/fglrx-uninstall.sh to run(dirty fix by -n to !) because $FORCE_ATI_UNINSTALL not recognized inside script )

SunnyDrake (beebop) wrote :

this also fixed fullscreen flash issue present in stock 10.4 ubuntu ati driver( and which exist in ATI_Catalyst_10.3_OGL4_Preview_Linux also).. Glad it worked out .. one issue left with 10.4 is sound..

SunnyDrake (beebop) wrote :

maybe its wrong way.. as Felix Kuehling noted this also be problem with old ati kernel module installed and removed by fglrx-uninstall.sh.. but it's just work for me.

Heimen Stoffels (vistaus) wrote :

On Kubuntu 10.04 the driver doesn't work 100%
I can't choose what desktop effects I want because it says that my video card is not capable. However, in 9.10 it worked and my video card is more than capable.

ATI Mobility Radeon 4550HD with 512 MB in a seperate GDDR3 cache.

radit hermawan (om-shoes) wrote :

On Ubuntu Lucid the driver doesn't work correctly (ati-driver-installer-11-5-x86.x86_64.run).
after finished install and write command "sudo aticonfig --initial -f" in terminal and i have the output command is :

"coenkcore@coenkcore-pc:~/catalyst11.5$ sudo aticonfig --initial -f
aticonfig: No supported adapters detected"

Ati radeon Xpress Series

can you give a troubleshooting about this?

Aurélien COUDERC (coucouf) wrote :

The bug was still marked opened for zUbuntu (zSeries port of Ubuntu) which makes no sense, closed.

Changed in fglrx-installer (zUbuntu):
status: New → Fix Released
To post a comment you must log in.