Error while Storing folder 'INBOX'

Bug #183136 reported by Norbert Hartl on 2008-01-15
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evolution
Expired
Medium
evolution (Ubuntu)
Low
Unassigned
Nominated for Karmic by Paolo Benvenuto

Bug Description

Binary package hint: evolution

I upgraded to Hardy Heron two days ago. Since then I have problems working with evolution. The symptoms are that I can get mail via imap but filtering, moving etc. is not possible.

I get an error 'Error while Storing folder 'INBOX''

I removed the complete ~/.evolution/mail/imap/ directory. After that it fetched all emails again and filtering succeeded. Shortly after it doesn't. Next try was to remove cmeta and every index file from the INBOX. This let me filter my inbox for most of the emails in INBOX. But only once.

What I can see is that after removing the index the bottom shows

Storing folder 'Inbox'

and shortly after that

Error while Storing folder 'INBOX'

Is it that the folder name gets corrupted or is this just an error displaying the error message

Pedro Villavicencio (pedro) wrote :

Thanks for your report, is that reproducible with another new user created on your system? It seems something there's something corrupted on your account, thanks.

Changed in evolution:
assignee: nobody → desktop-bugs
status: New → Incomplete
Norbert Hartl (norbert-hartl) wrote :

Did a quick check with another account. I discovered no problem. Then I removed my complete .evolution dir but this didn't help. Now I have removed the account and the evolution directory and recreated the account. Looks better now. But it is just 10 Minutes ago. I'll drop a notice if I get the problem again.

Thanks for your help.

Norbert Hartl (norbert-hartl) wrote :

Hi,

everything went fine until now. Now I get the error again. What would be the best way to generate debugging info? Or is there any hint what gets corrupted.

Thanks, Norbert

Changed in evolution:
status: Incomplete → New
Norbert Hartl (norbert-hartl) wrote :

Hmmm, I removed .ev-summary, jounal and cmeta, summary* in folders/INBOX and then it recovers

Sebastien Bacher (seb128) wrote :

Do you still get the issue?

Changed in evolution:
importance: Undecided → Low
status: New → Incomplete
Norbert Hartl (norbert-hartl) wrote :

Yes, I get them on a regular base. Removing the summary* files in the INBOX folder (or another corrupted folder) heals it for some time. But it comes back after one or two days.

Could it be that this is kind of a language/locale problem?

JP Foster (jeepster) wrote :

I get this too. It only appears with imap exchange for me. Gmail is OK. Removing the summary files work.
I never had any problem in gutsy.

Sebastien Bacher (seb128) wrote :

Do you use a read only directory? The bug is similar to http://bugzilla.gnome.org/show_bug.cgi?id=512738

Norbert Hartl (norbert-hartl) wrote :

No, I don't. The imap folders are fully accessable. But in the meantime I don't have the error anymore. I bought a new laptop one week ago and installed a fresh OS. I also did not copy any of my settings from the old laptop. I'm using the new computer now for 4 days and didn't experience the problem until now.

Sebastien Bacher (seb128) wrote :

closing since that works correctly now, feel free to reopen if you get the issue again though

Changed in evolution:
status: Incomplete → Invalid
Vytas (vytas) wrote :

I got this problem today, mails got duplicated and still don't know how to resolve it so far

Changed in evolution:
status: Invalid → New
Vytas (vytas) wrote :

After deleting some summary files etc I finally fixed it, but it is kind of annoying.
Unfortunately, there is no way to reproduce this bug.

My evolution setup was quite an ordinary one, 2 pop accounts, 12k messages in inbox, 3k in another folder, 500 sent, 10k junk

Pedro Villavicencio (pedro) wrote :

Closing this report, please only re open it if you have some steps in order to reproduce it with latest evolution package on Hardy, thanks in advance.

Changed in evolution:
status: New → Invalid
Boris B. (borisbergman) wrote :

I get the same error everytime since upgrated from GG to HH. I use a pop server over ssl. Really annoying because of every email I leave a copy on the server. The next time retrieving my email, the old copy is also downloaded again.

Only error I got: (evolution:7672): e-data-server-WARNING **: Could not open converter for 'unicode-1-1-utf-7' to 'UTF-8' charset

Arthur Sa (artie) wrote :

Pretty much the same as Boris problem, but all corrupted my inbox.
Help!!!

Åskar (olskar) wrote :

I got the "Error while Storing folder 'INBOX'"

I am using gmail over pop3 with SSL on Hardy Heron. I am using Swedish language if that matters.

What I did was:

mv .evolution .evolution-backup

And then the error disappeared. I will report back if I get the bug again, but I do think it should be open since the bug "Error while Storing folder 'INBOX'" apparently still present.

Askar,

Thanks for the info. When/if the error reappears please tell us. And when that happens, please list everything that you did with Evolution between now and then (what settings you changed, what mail servers you connected to, how much mail you had downloaded, etc).

Thanks!

Arthur Sa (artie) wrote :

I also cannot expunge the trash folder. How can I remove the summary files?

Arthur Sa (artie) wrote :

Removing the summary files does not help. This is listed above "importance- low", well like many others, email is the main reason I use Ubuntu.

rendier (the-wandering-god) wrote :

i'm on hardy...with evolution 2.22

i had the same problem...evolution was storing folders so much it was causing bad lag...and i had to close it.

ran across a suggestion for the command line...i ran it as root...it seems to have fixed things for the moment...though it's only been a few hours.

root@thewanderinggod:/home/rendier# evolution --force-shutdown

I hope it may help some of you.

Pablo Quirós (polmac1985) wrote :

I've got the same problem.

This are the things I did that caused it:

-On mistake, I moved the Inbox folder to some other folder.
-I didn't realize it, and when I saw it had dissapeared, I closed evolution and opened it again. I had my Inbox as a child of other folder, and another (empty) inbox had been created.
-Then I moved all the mails from my old inbox to the new one that had been created, and I deleted the old one.
-When I started evolution again, I seemed had lost lots of mails (maybe they were just not in order and it seemed that to me). It started to sync with my mail accounts, while trying to store the inbox folder. It showed an error storing inbox folder, and synced again with my mail accounts. Everytime this happened, I got a new copy of all my mails from the server.
-This happens again and again until I kill evolution. The next time I start it, same thing happens.

I think this is not a low priority issue as Evolution is unusable and I may have lost info, and Evolution is a key application in Ubuntu.

dave945 (dave-dtabor) wrote :

I ran into this problem and I think I can tell you one way to re-produce it.

I logged in to my regular Ubuntu 8.10 box from another linux box (SuSE 10.3) using ssh -X. I ran evolution in remote XTerm mode for a couple of days (I was having issues with the video on the main box).

On the remote box, the shell I used to start the remote XWindow session reported some errors (maybe about a hundred) of two kinds:

(evolution:5533): camel-local-provider-WARNING **: Expected a From line here, didn't get it. SO recovering....

I got about 30 of those, and

(evolution:5533): camel-CRITICAL **: get_message_info: assertion `folder->summary != NULL' failed

I got about 90 of those in the screen rollback summary from the remote shell history.

Now, when I switched back to my Ubuntu HH box, evolution is extremely slow and cpu-intensive, showing the error message described in this thread: Error while Storing folder 'INBOX'

I also see a modal dialog box with the error "Detected a corrupt mbox file or an invalid 'From' header." I'll attach that screen shot.

I also observed the duplicate messages mentioned earlier in this thread.

Are there any evolution utils to fix a corrupted mbox file? Losing a few messages would be ok but losing them all would be like having a lobotomy, and I'd like to avoid that.

Many thanks to all who contribute in big and little ways

Dave

dave945 (dave-dtabor) on 2009-01-08
Changed in evolution:
status: Invalid → New
dave945 (dave-dtabor) wrote :

I figured out how to solve my problem of a corrupted evolution mailbox mbox! Maybe this will help others:
1. I backed up my mail using File > Backup Settings... to create evolution-backup.tar.gz
It asked me to shut down evolution which I did.
The next time I started evolution it said the last shutdown was not clean and would I like to recover? I said yes.
2. I used synaptic package manager to reinstall evolution. I did not have to restore from backup.
After that, no problems! pretty painless!
Dave

Pedro Villavicencio (pedro) wrote :

could someone having this issue forward it to bugzilla.gnome.org? thanks in advance.

I'll do so now. Were you able to note my description of (a) how to
produce the error and (b) how to fix it:

http://<email address hidden>/msg251446.html

Pedro Villavicencio wrote:

>could someone having this issue forward it to bugzilla.gnome.org? thanks
>in advance.
>
>
>

Sebastien Bacher (seb128) wrote :
Changed in evolution (Ubuntu):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

Does anybody still get the issue in intrepid or jaunty and could comment on the GNOME bug?

Changed in evolution:
status: Unknown → New
dave945 (dave-dtabor) wrote :

Did you see the steps to reproduce? Posted by Dave945 (me) on 2009-01-08
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/183136
- Dave

Sebastien Bacher wrote:
> Does anybody still get the issue in intrepid or jaunty and could comment
> on the GNOME bug?
>
> ** Also affects: evolution via
> http://bugzilla.gnome.org/show_bug.cgi?id=571577
> Importance: Unknown
> Status: Unknown
>
>

Sebastien Bacher (seb128) wrote :

yes but the comment is not really clear I've no OpenSuse 10.3 box to ssh from and "wait some days" doesn't seem clear instructions on how to trigger the bug

dave945 (dave-dtabor) wrote :

I think the key is to run evolution via remote ssh with -X xterm. I
don't know how long it takes to corrupt the inbox -- I guess it depends
on the level of mail traffic. I get around 10-20 messages a day at this
account, so three days at 10-20 messages a day would be running it until
you get about 30-60 messages. I don't think it matters what platform
you ssh from -- another ubuntu box would work just fine.
I have a junk account that I never check -- <email address hidden> -- it
probably gets 300-400 spams a day. Would you like me to set it up and
test? I'm on HH now. 8.10. I don't mind testing with that account or
I can create one specifically, perhaps <email address hidden> and we can all
just bombard it while I run evolution in remote X window mode. Would
that help?
Dave

Sebastien Bacher wrote:

>yes but the comment is not really clear I've no OpenSuse 10.3 box to ssh
>from and "wait some days" doesn't seem clear instructions on how to
>trigger the bug
>
>
>

Sebastien Bacher (seb128) wrote :

you could perhaps comment on bugzilla directly? that would be easier than having a bug triager trying to get the issue only to do the gateway then there

silvagroup (casaba7339-ubuntu) wrote :

This just happened to a few days ago, when it does my cpu usage goes to 100% or both core start going nuts at over 50 to 60% of usage.
Doesn't affect memory usage it stays low.
Just did:

sudo evolution --force-shutdown
find ~/.evolution/mail/local -name "*ev-summary" -exec rm -f {} \;

and seems to be working for now.
I did a complete re-installation of my system because of the cpu usage thing not realising it was Evil ution. Should have Googled earlier, my bad.

silvagroup (casaba7339-ubuntu) wrote :

Fix doesn't "fix" the problem, just came back when I refreshed my email, seems to be a particular imap account that it happens with.
By the way I am using Jaunty with all the all the latest updates.
And now my wife is now complaining of a similar problem but with Thunderbird, so is this really an Evo problem? and she doesn't she doesn't use imap but she too is using same version of Jaunty.
Is this the tip of the iceberg.

Trond Husoe (tr-huso) wrote :

Totally agree that fix does not fix the problem. I believe that the problem must be related to one or more corrupted messages. I had this message a few times. Removed the files, but the message comes back.

Today it got worse. I had a message saying that the Inbox was corrupted. So I "lost" some 800 e-mails. I love to use Evolution, but when something like this happens I get seriously worried. I took backup of the folders just prior to the corruption so I have the e-mails. This is worrying though.

It is one of those things that I would say shall not happen, and is another reason for me not to suggest going from Windows to Ubuntu Linux in the Enterprise.

Trond

Paolo Benvenuto (donpaolo) wrote :

Experimenting the same bug since some 6 month, I must close and restart evolution, and many times restarting doesn't solve the problem.

I backup up my data with the menu backupa and restore, without luck: everything is the same.

I'm using italian locale. Once it happened that it gave the error, and shutting it down and restarting it with LC_ALL=C gave no error. When running it from the gnome menu again (italian!) , the error appeared again. Next time I launched with LC_ALL=C the error was there.

Did anyone evaluate whether the bug is a non-C locale only? Subscribers, please report what locale you are getting the bug with.

Besides that, it has been a month that, after 2-3 days of continuous runnign, evolution hangs and I must kill the process.

I have been using evolution since 2002, and perhapes some change in directory structure have happened, and perhaps I have some wrong dir... anyone could post here the correct directory structure in ~/.evolution ? thank you!

This bug is very annoying, and makes me very nervious with evolution....

Paolo Benvenuto (donpaolo) wrote :

I moved all the messages I had in inbox to another folder and expunged inbox.

Result: error while storing inbox

shutdown evolution and restart it

result: all inbox messages are there

expunged inbox

resulte: expunge ok

shutdown evolution and restarted it

now I have no message in inbox, but I keep getting the error "error while storing the folder inbox". In the terminal:
$ LC_ALL=C evolution &
** (evolution:13297): DEBUG: mailto URL command: evolution %s
** (evolution:13297): DEBUG: mailto URL program: evolution
** (evolution:13297): DEBUG: EI: SHELL STARTUP

(evolution:13297): camel-local-provider-WARNING **: Expected a From line here, didn't get it 2893726

(evolution:13297): camel-local-provider-WARNING **: Expected a From line here, didn't get it 2893726
evolution-mail-Message: Error occurred while existing dialogue active:
Summary and folder mismatch, even after a sync

I fetch mail from google, and if I disable the automatic fetching I get no error. I get the error only after evolution check the mail on google, and I get:

(evolution:13643): camel-local-provider-WARNING **: Expected a From line here, didn't get it 2893726

note that inbox is void!!!

perhaps a bug with google pop server or in the pop routine?

Paolo Benvenuto (donpaolo) wrote :

I'm running evolution and getting no error

If I fetch mail from google and there is mail -> no error
if there isn't any mail -> error

it appears reproducible here

Paolo Benvenuto (donpaolo) wrote :

How to reproduce it:

- go to a fresh guest session
- run evolution and in configure it with your google account; set it to fetch mail every x minutes
- every time you run evolution it will fetch your gmail mail, and when it doesn't find any mail it gives the "error while storing folder 'INBOX'".

I had the same problem - the bug 183136: "Error while Storing folder Sent".
In the same time I had problem with the bug 27014: "Summary and folder mismatch, even after a sync".
It was very annoying.
I have solved both problems in a very simple way.

Just delete file "folders.db" from ~/.evolution/mail/local and start "evolution". In the first time the evolution needs more time to rebuild folders.db. After that, everything works fine.

CasinoJobs (amari-casinojobs) wrote :

Zoran Mijanovic

You are the best after three hours your fix fixed me LOL
Thank You and great job.

nicolas_dh (nicolas-dh) wrote :

Great, removing

    folders.db

from

   ~/.evolution/mail/local

worked for me too. :)

Still not fixed for me; have tried all index and folder removes as suggested starting with bug331381. Has happened twice, situation is: I have a POP server (cloud) and IMAP server (local). I use IMAP on storage machine to off load old mail from local computer. I only use it 2x / year, File/preferences/enable Imap server. This issue happens while moving blocks of files to the IMAP server *and* if evo decides to automatically get mail from POP. POP may finish, but IMAP stalls at some percentage of moving files, and the error messages are forever with me. First time, I did fix it by removing folders.db in local. Should I be removing folders|Inbox|Sent .ibex, libx.data or others, all at the same time? What about the .cmeta files? What about folder.db in the POP and IMAP folders?

Changed in evolution:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Is this still an issue with Lucid?

Changed in evolution (Ubuntu):
status: Triaged → Incomplete
Paolo Benvenuto (donpaolo) wrote :

Let me wait lucid !

Changed in evolution:
status: Incomplete → Invalid
Omer Akram (om26er) wrote :

@are there any news about this bug. is any one still affected?

AlphaZeta (kerryw) wrote :

Yes I have run into the exact problem "error while storing inbox" with a newly setup 10.04 box. I just did the remove folders.db thing suggested and seemed to have worked so far.

I am using evolution both locally and remotely via an NX session.

John Rose (johnaaronrose) wrote :

I have same/similar problem. After deleting folders.db and restarting Evolution I now get 'Column folder_name is not unique' presumably referring to Inbox. Should this be a new bug? Screenshot is attached.

John Rose (johnaaronrose) wrote :

I forgot to mention that this is a clean Lucid installation working OK for first 2 weeks: when I dId the install, I did a Restore immediately of Evolution's Settings. Also, after deleting folders.db, it is created again.

John Rose (johnaaronrose) wrote :

Created ev log using CAMEL.

PS Due to problem I'm having with Launchpad in that it doesn't show bugs that I have reported as part of My Bugs nor does it send me email about them, there may be duplicates of this.

Changed in evolution:
importance: Unknown → Medium
status: Invalid → Expired
develCuy (develcuy) wrote :

Deleting folders.db did the job, Evolution rebuild it, taken some time when started and also when closing, but now works pretty well. Guess that folders.db got corrupted at some point when I turned off my computer suddenly.

Léa GRIS (lea-gris) wrote :

Getting this bug after fresh install and up to date Natty with newly configured first IMAP account.

Changed in evolution (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Please test with Oneiric or Natty this is a really old report and it was closed as incomplete upstream.

Changed in evolution (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.