Stuttering audio playback when empathy is used with pulseaudio

Bug #302038 reported by Gioele Barabucci on 2008-11-25
50
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Medium
empathy (Ubuntu)
Medium
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

I cannot use empathy to voice chat (GTalk) because the audio playback is intermittent: it seems like the audio stops playing for a split second three or four times a second, making the voice incomprehensible.

I tested this with two different other computers, whose mic is working perfectly fine.

My setup:
  ubuntu intrepid x86_64
  empathy: 2.24.1
  pulseaudio: 0.9.10
  pulseaudio playback sink: ALSA PCM on front:0 (STAC92xx Analog) via DMA

It seems I have this issue too on three different machines: https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/316529

Gioele Barabucci (gioele) wrote :

Joe Bishop confirmed this problem on an x86 installation of Ubuntu 8.10.

This problem was also confirmed at empathy bug tracker:
http://bugzilla.gnome.org/show_bug.cgi?id=567784

2009/1/13 Gioele Barabucci <email address hidden>

> Joe Bishop confirmed this problem on an x86 installation of Ubuntu 8.10.
>
> --
> Stuttering audio playback when empathy is used with pulseaudio
> https://bugs.launchpad.net/bugs/302038
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Changed in empathy:
status: Unknown → New
Gioele Barabucci (gioele) wrote :

Confirmed by other users on gnome bug tracker

Changed in empathy:
status: New → Confirmed
Gioele Barabucci (gioele) wrote :

Happens with Ubuntu Jaunty as well:

Comment #3 from denis.cheremisov@.....com
> The same behaviour in Ubuntu 9.04 (2.6.28, ALSA 1.0.18, Pulse).

Changed in empathy:
status: New → Confirmed
Changed in empathy (Ubuntu):
importance: Undecided → Medium
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Guillaume Desmottes (cassidy) wrote :

This issue SEEMS to be fixed with the latest Debian experimental package (0.9.16~test2~20090726git59659e1db-1). The ubuntu package should be fixed as well.

Anakin Starkiller (sunrider) wrote :

So, is there any chance to see it in Karmic ?

2009/8/3 Guillaume Desmottes <email address hidden>

>
> This issue SEEMS to be fixed with the latest Debian experimental package
> (0.9.16~test2~20090726git59659e1db-1). The ubuntu package should be
> fixed as well.
>
> ** Also affects: pulseaudio (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> Stuttering audio playback when empathy is used with pulseaudio
> https://bugs.launchpad.net/bugs/302038
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

There are plans to get pulseaudio v0.9.16 into karmic.

So no working audio in karmic empathy?

2009/8/3 Luke Yelavich <email address hidden>

> There are plans to get pulseaudio v0.9.16 into karmic.
>
> --
> Stuttering audio playback when empathy is used with pulseaudio
> https://bugs.launchpad.net/bugs/302038
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Guillaume Desmottes (cassidy) wrote :

That SHOULD work with pulse audio 0.9.16. Would be good to retest once this version of pulse audio reaches Karmic.

Daniel T Chen (crimsun) wrote :

Karmic now has 0.9.16~test4.

On Aug 5, 2009 7:25 AM, "Guillaume Desmottes" <email address hidden> wrote:

That SHOULD work with pulse audio 0.9.16. Would be good to retest once
this version of pulse audio reaches Karmic.

-- Stuttering audio playback when empathy is used with pulseaudio
https://bugs.launchpad.net/bugs/...

Steffen Sindzinski (stesind) wrote :

I can affirm latest version of Empathy 2.7.5 from telepathy PPA works with PA 0.9.16 from themuso PPA in Karmic. Audio chat is works very well although there is some additional noice.

Steffen Sindzinski (stesind) wrote :

Maybe Luke can make 0.9.16 available in Jaunty?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) wrote :

Closing this bug now. as there seem to be no more related bug reports and If you still face please try empathy 2.30 from this ppa https://launchpad.net/~telepathy/+archive/ppa and if the problem is still there please open a new bug report.

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
Changed in empathy:
status: Confirmed → Invalid
Changed in empathy:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.