Ubuntu

eclipse unable to 'install new software'

Reported by Robert Hall on 2010-03-18
126
This bug affects 25 people
Affects Status Importance Assigned to Milestone
commons-httpclient (Debian)
Fix Released
Unknown
eclipse (Ubuntu)
Undecided
Unassigned
openjdk-6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

Install eclipse via aptitude, run eclipse.

===========================================
eclipse -> Help -> Install New Software...

Error Popup: Problem Occurred
Content: Some sites could not be found. See the error log for more detail.

Details:
Some sites could not be found. See the error log for more detail.
  No repository found at http://download.eclipse.org/technology/epp/packages/galileo.
  No repository found at http://download.eclipse.org/eclipse/updates/3.5.
  No repository found at http://download.eclipse.org/releases/galileo.

Error Log:
java.net.ConnectException: Invalid argument
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:310)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:176)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:163)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:384)
at java.net.Socket.connect(Socket.java:542)
at org.eclipse.ecf.provider.filetransfer.events.socket.SocketEventCreateUtil.createSocket(SocketEventCreateUtil.java:43)
at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:81)
at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:73)
at org.eclipse.ecf.internal.provider.filetransfer.httpclient.ECFHttpClientProtocolSocketFactory.createSocket(ECFHttpClientProtocolSocketFactory.java:65)
at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientRetrieveFileTransfer.performConnect(HttpClientRetrieveFileTransfer.java:1017)
at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientRetrieveFileTransfer.openStreams(HttpClientRetrieveFileTransfer.java:610)
at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:808)
at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:506)
at org.eclipse.ecf.provider.filetransfer.retrieve.MultiProtocolRetrieveAdapter.sendRetrieveRequest(MultiProtocolRetrieveAdapter.java:98)
at org.eclipse.equinox.internal.p2.repository.FileReader.sendRetrieveRequest(FileReader.java:317)
at org.eclipse.equinox.internal.p2.repository.FileReader.readInto(FileReader.java:263)
at org.eclipse.equinox.internal.p2.repository.RepositoryTransport.download(RepositoryTransport.java:71)
at org.eclipse.equinox.internal.p2.repository.RepositoryTransport.download(RepositoryTransport.java:127)
at org.eclipse.equinox.internal.provisional.spi.p2.artifact.repository.SimpleArtifactRepositoryFactory.load(SimpleArtifactRepositoryFactory.java:72)
at org.eclipse.equinox.internal.p2.artifact.repository.ArtifactRepositoryManager.factoryLoad(ArtifactRepositoryManager.java:62)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:669)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:617)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.basicRefreshRepository(AbstractRepositoryManager.java:186)
at org.eclipse.equinox.internal.p2.artifact.repository.ArtifactRepositoryManager.refreshRepository(ArtifactRepositoryManager.java:97)
at org.eclipse.equinox.internal.provisional.p2.ui.operations.ProvisioningUtil.refreshArtifactRepositories(ProvisioningUtil.java:266)
at org.eclipse.equinox.internal.provisional.p2.ui.dialogs.RepositoryManipulationPage$20.run(RepositoryManipulationPage.java:555)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

===========================================
eclipse -> Window -> Preferences -> Install/Update -> Available Software Sites

Listed entries:
http://download.eclipse.org/technology/epp/packages/galileo
http://download.eclipse.org/eclipse/updates/3.5
http://download.eclipse.org/releases/galileo

Select any entry -> Test connection

Error Popup: Problem Occurred
Unable to connect to repository http://download.eclipse.org/releases/galileo/site.xml

org.eclipse.equinox.internal.provisional.p2.core.ProvisionException
===========================================

Just started using eclipse, so pretty much vanilla settings.
Internet connection is functional for everything else; not behind a proxy.
On:
ubuntu lucid 10.04
eclipse 3.5.1+repack~3-0ubuntu2

ProblemType: Bug
Architecture: i386
Date: Thu Mar 18 16:10:00 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: eclipse 3.5.1+repack~3-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: eclipse
Uname: Linux 2.6.32-16-generic i686

Robert Hall (reh07) wrote :
Thanos Lefteris (alefteris) wrote :

I'm also affected by this bug, using the latest eclipse package from the lucid repo. I get exactly the same errors with above. Also just to clarify that my net connection is working fine. I also had the same problem with Aptana Studio (which is based on eclipse) on lucid, if that helps with anything.

Very well made and detailed bug report Robert :) Someone please set bug as confirmed.

Changed in eclipse (Ubuntu):
status: New → Confirmed
Niels Thykier (niels-thykier) wrote :

Hi

I think this might be a bug in openjdk6 [1]. Do you both have openjdk installed and is it used to run eclipse (check your alternative settings for /usr/bin/java)? Also, can you reproduce this issue with another java e.g. gcj[2] or sun-java6? Remember to update your alternatives or start eclipse using the specific JVM - see "man eclipse" for more info on how to start eclipse with a specific JVM.

~Niels

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573742

[2] Please note gcj is probably not a good long term choice as JVM for eclipse. There has been a lot of issues running eclipse with gcj in the past.

Matthias Klose (doko) wrote :

please recheck after install the openjdk-6 test version from https://launchpad.net/~openjdk/+archive/ppa

Robert Hall (reh07) wrote :

java version "1.6.0_18"
Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
Java HotSpot(TM) Server VM (build 16.0-b13, mixed mode)

I was able to access the updates with sun-java6.

=======================================

However, using
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1~ppa1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

still produces the same errors.

Javier Jardón (jjardon) wrote :

@Matthias:

I've updated the openjdk-6 packages with your repository version and now the problem is solved

Ubuntu Lucid here.

Robert Hall (reh07) on 2010-03-19
Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Changed in eclipse (Ubuntu):
status: Confirmed → Invalid
Robert Hall (reh07) wrote :

java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1~ppa1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

Workaround: using these arguments allows eclipse to find the updates using openjdk-6
# eclipse -vmargs -Djava.net.preferIPv4Stack=true

Running just 'eclipse' however still produces the same described errors; on ppa version.

Matthias Klose (doko) wrote :

so for one person solved, not for another. that's not confirmed

Changed in openjdk-6 (Ubuntu):
status: Confirmed → New
Alex Vaystikh (bornio) wrote :

Robert Hall's flags for running eclipse solve the problem for me as well.
Thank you Robert!

Russel Winder (russel) wrote :

I am running Lucid and have the OpenJDK installed but not the Sun JDK. I was getting the problem of not being able to update Eclipse. I now use a launch script of:

    #! /bin/sh

    export GDK_NATIVE_WINDOWS=1
    $HOME/eclipse-x86_64/eclipse -vmargs -Djava.net.preferIPv4Stack=true

and updates work fine. so this would seem to confirm that the issue is as hypothesized.

Robert Hall (reh07) wrote :

Could someone affected by this bug please,

1) Install the openjdk-6 version from the PPA: https://launchpad.net/~openjdk/+archive/ppa

2) Verify that openjdk-6 is set as the java alternative; # java -version outputs:
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1~ppa1)

3) Launch 'eclipse' without using the '-Djava.net.preferIPv4Stack=true' workaround.

4a) If, still unable to update or 'install new software' within Eclipse, change this bug status to Confirmed.
4b) Else, report that the issue has been fixed.

Thanks. :)

wantedcanine (wantedcanine) wrote :

I was affected by this bug running 64 bit Lucid and confirm that this solution works.

Alex Eftimie (alexeftimie) wrote :

Same bug, lucid 32bit, after adding the ppa and updating, it works.

gugli (gugli100) wrote :

same bug lucid 32bit, after adding the ppa and updating, it doesn't work

Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Benjamin Wohlwend (piquadrat) wrote :

Adding the ppa fixed the problem for me, on amd64

tested with ppa- works.

SOLVED in my case

with version from ppa problem with eclipse fixed

Changed in openjdk-6 (Ubuntu):
status: Confirmed → Fix Committed
Bryan Hermsen (b-hermse) wrote :

Adding the ppa did not fix the problem for me. But launching Eclipse with the flags listed above still works.

gugli (gugli100) wrote :

Not fixed my problem, I installed Eclipse Ganymede

computorist (travis-hume) wrote :

Updated ppa without -Djava.net.preferIPv4Stack=true allowed updates to proceed but I started receiving frequent core dumps from eclipse.

Rolled back to official openjdk with -Djava.net.preferIPv4Stack=true and everything is working well.

Lucid i386
eclipse 3.6m6 JavaEE build from (http://eclipse.org/downloads/packages/release/helios/m6)

freezeloud (freezeloud) wrote :

Using lucid lynx with only openjdk installed and for me didn't work any of these solutions. Using eclipse from repos.

Robert Hall (reh07) wrote :

I reverted status back to Confirmed since there are many people who are using the PPA version and the problem is still not solved.

Changed in openjdk-6 (Ubuntu):
status: Fix Committed → Confirmed
Jamal Fanaian (jamalta) wrote :

Using the OpenJDK PPA solved the problem for me. Thanks!

Matthias Klose (doko) wrote :

works for me with 6b18~pre3-0ubuntu1 without any extra parameter.

Changed in openjdk-6 (Ubuntu):
status: Confirmed → Incomplete

yesterdays 6b18~pre3-0ubuntu1 update has fixed this here too.

Matthias Klose (doko) wrote :

> yesterdays 6b18~pre3-0ubuntu1 update has fixed this here too

thanks for checking. closing the report. Robert, if this problem persists for you, please could you recheck with a recent liveCD with eclipse installed on top of it, or with an virtualbox/kvm installation?

Changed in openjdk-6 (Ubuntu):
status: Incomplete → Fix Released
Robert Hall (reh07) wrote :

java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1)
OpenJDK Server VM (build 16.0-b13, mixed mode)

The bug still persists with me.

Loaded virtualbox and installed ubuntu-10.04-beta1-desktop-i386.iso.
Grabbed eclipse from the repositories, it also pulled openjdk-6
test@test-laptop:~$ java -version
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1)
OpenJDK Client VM (build 16.0-b13, mixed mode, sharing)

Run eclipse, still get the same error when trying to 'install new software'

Jamie Jones (jbjonesjr) wrote :

I can mirror Robert's comments on this bug. It seems like the openjdk upstream bug that I think corresponds to this issue [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573742] was just closed last night at targetted at 6b18~pre3.1, so I doubt that this issue has been truly fixed until that update makes it downstream.

developer@developer-laptop:~$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1)
------------
developer@developer-laptop:~$ eclipse
Mar 23, 2010 3:55:18 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request: Invalid argument
.......

I'm also running in a virtual box environment. The fact that Javier's repo update in Message #6 solved it for so many people makes me wonder if there is another transient package or dependency that is causing the root problem with this bug.

Torsten Werner (twerner) wrote :

I have tested Eclipse in Debian with openjdk 6b18~pre3-1:

I works with net.ipv6.bindv6only=0 but it does not work with net.ipv6.bindv6only=1. I am quite sure that this is a bug in eclipse or one of the libraries it is using and it can't be fixed in OpenJDK. Every non broken test works with net.ipv6.bindv6only=1 but I am unable to debug eclipse. I cannot even find the source code that fails with java.net.ConnectException.

Does Ubuntu set net.ipv6.bindv6only=1 by default?

just to clarify. i certainly had this problem up until yesterday (on amd64) when the openjdk update came through. The only other update that might be relevant is bind9 over the last 24 hours as far as i can see, though i've tested the backdated version of this and can't replicate the problem so i assume its not that. i havent used the ppa at all and i have no problem with -Djava.net.preferIPv4Stack=true or false now. i'll try using the previous openjdk tomorrow

hav0cer (dvanoverbeke) wrote :

After updating to:

java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1)
OpenJDK Server VM (build 16.0-b13, mixed mode)

Problem still exist..

Applied workaround:

-Djava.net.preferIPv4Stack=true'

This fixes the issues for the moment.

Dan Andreșan (danyer) wrote :

hav0cer, please cut and paste correctly (you forgot -vmargs)

The correct workaround is:
-vmargs -Djava.net.preferIPv4Stack=true

I was affected too and now I'm ok if I launch eclipse this way.

freezeloud (freezeloud) wrote :

Problem fixed after java update.
Using
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1)
OpenJDK Server VM (build 16.0-b13, mixed mode)
and Eclipse downloaded from eclipse org site...

i tried downgrading openjdk to 6b16-1.6.1-3ubuntu1 but still can't recreate the problem, eclipse update sites still work fine. so its fixed here but i have no idea how!

Everybody, please, upgrade to eclipse 3.5.2 (which is synchronized from debian I suppose).
Debian guys did some work with the issue.

Report afterwards.

JanHolbo (janholbo) wrote :

using the latest packages (lucid lynx) and the openjdk ppa, without the

-vmargs -Djava.net.preferIPv4Stack=true

workaround I still have a problem.

with it, no problems

João Pinto (joaopinto) wrote :

I had the same problem with the latest version (3.5.2-2) .

I am able to install updates using:
eclipse -Djava.net.preferIPv4Stack=true

João Pinto (joaopinto) wrote :

openjdk-6-jre-headless 6b18~pre3-0ubuntu1

I'ce checked with the ver. 2.5.2-2ubuntu1.

Installation functionality works as it should.

lucid amd64 and openjdk 6b18~pre3-0ubuntu1

hav0cer (dvanoverbeke) wrote :

After update to 3.5.2 Eclipse Build id: M20100211-1343
and with OpenJDK Runtime Environment (IcedTea6 1.8pre) (6b18~pre3-0ubuntu1).

The problem is still persistent.

without -vmargs -Djava.net.preferIPv4Stack=true I cannot access the eclipse software repos...

Borden Rhodes (dominussuus) wrote :

Same problem and workaround on Debian Squeeze with M20100211-1343

Frederik Hahne (atomfrede) wrote :

Starting Eclipse with -vmargs -Djava.net.preferIPv4Stack=true works for me.

Using newest OpenJDK and Lucid version.

Changed in commons-httpclient (Debian):
status: Unknown → Fix Committed
Robert Hall (reh07) wrote :

java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18~pre4-1ubuntu1)
OpenJDK Server VM (build 16.0-b13, mixed mode)

Fixed.

Changed in commons-httpclient (Debian):
status: Fix Committed → Fix Released
suguru (oouc) wrote :

Partial help wrote,
  ¨Everybody, please, upgrade to eclipse 3.5.2 (which is synchronized from debian I suppose).
    Debian guys did some work with the issue.¨

Please say how to do this by giving the commands necessary to to this instead of just saying do it.

Ernst Sjöstrand (ernstp) wrote :
Download full text (3.8 KiB)

I always get the following error when trying the default update site.
It seems like a very similar error but not the same, the IPv4/6 flags doesn't help.

!MESSAGE Unable to access "http://download.eclipse.org/eclipse/updates/3.5".
!STACK 1
org.eclipse.core.runtime.CoreException: Error parsing site stream. [The XML stream is not a valid default "site.xml" file. The root tag is not site.]
        at org.eclipse.update.core.Utilities.newCoreException(Utilities.java:225)
        at org.eclipse.update.core.Utilities.newCoreException(Utilities.java:256)
        at org.eclipse.update.core.model.SiteModelFactory.parseSite(SiteModelFactory.java:95)
        at org.eclipse.update.internal.core.SiteURLFactory.createSite(SiteURLFactory.java:80)
        at org.eclipse.update.internal.core.InternalSiteManager.createSite(InternalSiteManager.java:334)
        at org.eclipse.update.internal.core.InternalSiteManager.createSite(InternalSiteManager.java:326)
        at org.eclipse.update.internal.core.InternalSiteManager.createSite(InternalSiteManager.java:298)
        at org.eclipse.update.internal.core.InternalSiteManager.attemptCreateSite(InternalSiteManager.java:222)
        at org.eclipse.update.internal.core.InternalSiteManager.getSite(InternalSiteManager.java:162)
        at org.eclipse.update.core.SiteManager.getSite(SiteManager.java:82)
        at org.eclipse.update.search.UpdateSearchRequest.searchOneSite(UpdateSearchRequest.java:454)
        at org.eclipse.update.search.UpdateSearchRequest.performSearch(UpdateSearchRequest.java:325)
        at org.eclipse.update.ui.UpdateJob.runSearchForNew(UpdateJob.java:183)
        at org.eclipse.update.ui.UpdateJob.run(UpdateJob.java:171)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.xml.sax.SAXException: The XML stream is not a valid default "site.xml" file. The root tag is not site.
        at org.eclipse.update.core.model.DefaultSiteParser.handleInitialState(DefaultSiteParser.java:393)
        at org.eclipse.update.core.model.DefaultSiteParser.startElement(DefaultSiteParser.java:198)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:504)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook(XMLNSDocumentScannerImpl.java:602)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:3080)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:899)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML1...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.