Eclipse crashes due to jvm crash

Bug #174759 reported by thomas coopman on 2007-12-07
284
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Eclipse
Invalid
Unknown
eclipse (Gentoo Linux)
Fix Released
Medium
eclipse (Ubuntu)
Undecided
Unassigned
openjdk-6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

eclipse crashes on kubuntu hardy.
with both eclipse from apt and eclipse from website.
I'm using java-sun6

I checked on #kubuntu-devel but didn't find anyone with the problem

error log from command:

#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x06219a26, pid=25424, tid=3075606192
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_03-b05 mixed mode, sharing)
# Problematic frame:
# V [libjvm.so+0x219a26]
#
# An error report file with more information is saved as hs_err_pid25424.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

thomas coopman (tmske) wrote :

error log

Daniele Dellafiore (ildella) wrote :

I have exactly the same problem, on gutsy gibbon.
Also happens with 1.5.0_13

I have the same problem on Hardy as of today, as a matter of fact. Used to work, but it doesn't anymore, and I don't know why, thanks to the large glut of updates we get on a daily basis.

Changed in eclipse:
status: New → Confirmed

I believe I solved my problem.

I reinstalled eclipse, and it turned out that the workspace was problematic.

For what it is worth, I have started to have the same issue. And it might well be a corrupt workspace, but the JVM should probably still not crash...

WIll try a new workspace as a workaround though.

Daniele Dellafiore (ildella) wrote :

Using a clean eclipse installation sometimes fix the problem, but just temporary.
Today I am having a lot of crashes, here is another log:

# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb56cbe93, pid=5802, tid=3029511056
#
# Java VM: Java HotSpot(TM) Client VM (10.0-b19 mixed mode, sharing linux-x86)
# Problematic frame:
# J org.eclipse.jdt.internal.compiler.lookup.MethodBinding.<init>(I[CLorg/eclipse/jdt/internal/compiler/lookup/TypeBinding;[Lorg/eclipse/jdt/internal/compiler/lookup/TypeBinding;[Lorg/eclipse/jdt/internal/compiler/lookup/ReferenceBinding;Lorg/eclipse/jdt/internal/compiler/lookup/ReferenceBinding;)V

 This is *really* annoying, I simply cannot work in this condition, eclipse crashes continuously.

Daniele Dellafiore (ildella) wrote :

I think that bug 77393 is a duplicated of this one.

Daniele Dellafiore (ildella) wrote :

I know you cannot believe this but during last eclipse session, eclipse crashes with this error on the console:

della@della-desktop:~/programs/eclipse-3.3$ The program 'gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 347140 error_code 182 request_code 157 minor_code 23)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Firefox was open and did not crash at all, still running.

Michael (michael-bischoff) wrote :

same here

traced to native code in libjvm.so

It consistently crashes. a second or so after the workspace is started.
tried icedtea, sun java 6 and 5 and gcj

My version is the normal ubuntu(64) though. not kubuntu, everything worked perfectly before I updated to hardy.

Doesn't look at all like the sloppy lock thing ppl are raving about in the alpha releases. (also the proposed fixes don't work)

Dorgendubal (svenwerlen) wrote :

Same problem (apt-get Eclipse and sun-jvm 6).
Perfectly worked until I tried to open a file that was modified outside Eclipse. IDE crashed.
Since then... Eclipse crashes 1-2 seconds after the workspace is started.

Dorgendubal (svenwerlen) wrote :

Some investigation... could maybe help others.
Just after the workspace is started, I immediately stopped the "building workspace..." background action.
Eclipse didn't crash then. I disabled "build automatically" and switch to PHP perspective (PHPEclipse).
This helped in my case. I'm developping with PHP (not Java) and don't need "automatic compilation" which seems to be the problem.

Applying "sed -i 's/XINERAMA/FAKEEXTN/g' /opt/jdk1.5.0_15/jre/lib/amd64/xawt/libmawt.so fixes this issue. After I applied this, my eclipse doesn't crash anymore.

Nicolas Albert (nicoa380) wrote :

The problem during when Eclipse compile java code.

The first build is ok, but if I edit a java source, the "automatic building" crash.
If I disable "automatic building" and I run the java application, the compiler run and crash.
If I make "project > clean" (delete .class) and rebuild, it's ok.

I have Ubuntu Hardy (2.6.24-16-generic) 64 bit, Eclipse 3.3.2 (from eclipse.org) 32 & 64 bit, all this JVM :
64 openjdk-6> OpenJDK 64-Bit Server VM (build 1.6.0-b08, mixed mode)
32 openjdk-6 (with getlibs) > OpenJDK Server VM (build 1.6.0-b08, mixed mode)
32 ia32-sun-java6 > Java HotSpot(TM) Server VM (build 10.0-b19, mixed mode)

No problem on Windows with the same java application and Eclipse version.

Kai Krueger (kakrueger) wrote :

Thanks, disabling "automatic building" seems to have fixed it for me.

Previously I had tried it with a variety of Java versions (sun java 1.6, sun java 1.7beta, iced tea) and several eclipse versions (3.2, 3.4M6a) and all showed the same problem. It does also seem to have something to do with the workspace metadata, as not all workspaces showed the same crashing immediately after startup.

This is all on Hardy 64bit.

Nicolas Albert (nicoa380) wrote :

Eclipse doesn't crash anymore but it is slower.
I add -Xint in my eclipse.ini, the jvm don't try to optimize by compiling native code (mixed mode).
I havn't test all jvm/eclipse with this option, but you can try.
(Eclipse really eat more CPU with -Xint ! :( so it isn't a good solution)

I can confirm that the -Xint option in eclipse.ini solves the problem, I didn't see the cpu hit though. I will be attent for it. I have a vanilla eclipse 3.2.2 and jdk 1.6.0_04 from sun

Thanks.

The IBM Java6 SDK doesn't trigger this bug, so if you can live with that in the time being, it seems a good substitute until this gets fixed.

Eclipse 3.3.2 64-bit, sun-java6 6-06-0ubuntu1, Hardy beta 5 AMD 64:

Confirming crash on java build (both automatic and non-automatic).
Also confirming the -Xint option workaround.
Also confirming slowdown with -Xint option (but this is no surprise, as it disables JIT compilation).

everflux (tklaunchpad) wrote :

Same hier - downgrade or -Xint fixes the problem. AMD64 dual core machine.
-Xint is really a serious performance hit.
I have crashes with other java applications (RSSowl), too - seems not to be eclipse compiler related. And this is not the xinerama / x bug.

Eclipse 3.3.2 64-bit, sun-java6 6-06-0ubuntu1, Hardy beta 5 AMD 64:

Confirming that downgrade to sun-java6 6-03-0ubuntu2 (gutsy version) fixes the problem.

everflux (tklaunchpad) wrote :

Upgrading to the Jdk 6 u10 beta version fixes the problem, too. afaik there is no package of it yet, so the jdk must be replaced manually.

Matthias Hilbig (hilbig) wrote :

jdk 6 u10 beta crashes for me too.

Tony McCrary (tmccrary) wrote :

I've tried both jdk 6 u10, Sun Java 6 and the most recent version of OpenJDK in the repos.

They all cause Eclipse to crash. Nothing like this happened with Gutsy.

Tony McCrary (tmccrary) wrote :

The issue occurs with Java JDK 6 Update 6 as well.

Tony McCrary (tmccrary) wrote :

It looks like this issue is caused by a bug introduced with JDK 6u5.

Here is an eclipse bug report:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214092

Here is the bug on Sun's bug tracker:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6614100

A workaround for this is to exclude the method from being optimized by hotspot or to downgrade the JDK before 6u5, namely JDK 6u3.

Tony McCrary (tmccrary) wrote :

Okay, I take that back. 6u3 crashes as well.

Tony McCrary (tmccrary) wrote :

I'm switching to fedora.

> I'm switching to fedora.

I can appreciate the frustration, but let's not get nuts.

:)

Tony McCrary (tmccrary) wrote :

You're right, I may have jumped the gun a little. It's just a major problem when you can't do any work because your tools crash at random intervals.

So far excluding this from the hotspot JIT:

echo "exclude org/eclipse/core/internal/dtree/DataTreeNode forwardDeltaWith" > ~/.hotspot_compiler

...and modifying eclipse's VM args (edit /usr/bin/eclipse).....

VMARGS="-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -Xms512m -Xmx1024m"

...seems to help reduce the amount of crashes.

However, it still has crashed, just not everytime eclipse tries to compile something.

everflux (tklaunchpad) wrote :

Starting with "-Xint" (vmargs) should fix the problem - which switching to Fedora wouldn't, since the bug is from upstream Java/JVM.

Tony McCrary (tmccrary) wrote :

That switches the ENTIRE JVM into interpreted mode. Not really a smart idea. It's better to just disable the function causing the crash.

Also, Fedora and Red Hat maintain their own JVM port, IcedTea. There's a good chance they don't have the same problems (or that it's already fixed). They seem to move faster than Sun when it comes to stuff like this.

I realize IcedTea is also in Ubuntu, but it originally comes from the Red Hat folks, so they probably have a more up to date version. They generally do a much better job maintain eclipse and eclipse related software.

Matti Tiainen (mvtiaine) wrote :

At work I've been using the IBM JDK as a workaround, Eclipse seems to work perfectly with that. You can then even speedup Eclipse startup a bit by using class data sharing (-Xshareclasses) option, which is similar to the -Xshare option in Sun JRE, but vastly better :)

http://www-128.ibm.com/developerworks/java/jdk/linux/download.html
http://www.ibm.com/developerworks/java/jdk/linux/6/sdkandruntimeguide.lnx.html#classdatasharing

Xtien (xtien) wrote :

-Xint doesn't work for me on AMD64 dual core. I have downgraded to Sun jdk 1.5.

Pasi (pasi-lehtimaki) wrote :

Eclipse 3.2.2 crashes on startup every time using Java VM: OpenJDK Server VM (1.6.0-b09 mixed mode linux-x86). Using sun jdk it works fine.

Attached log file.

Mirko Nasato (mirko-nasato) wrote :

Same problem here - frequent crashes with Eclipse 3.3.2 and Sun JDK 1.6.0_06. No crashes with JDK 1.5.0_15.

Adding

  -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith

to eclipse.ini as suggested by Tony McCrary seems to fix the problem with JDK 1.6. (Thanks Tony!)

Changed in eclipse:
status: Unknown → Confirmed
terigox (terigox) wrote :

I don't know if you need anymore confirmations on this Bug, but I have it as well. I'm running an up to date Hardy Ubuntu (amd64), Eclipse 3.3.2 from their website, sun-java-6 packages from Ubuntu. It crashes very often when I try to manipulate files it seems. Although that could not be related. I haven't found anything that will force it to crash yet. I always seem to notice it when I'm using the project explorer.

I tried downgrading to sun-java-5 (and uninstalling 1.6), but that didn't change anything for me. Also tried adding several things to my eclipse.ini:

-Xms128m
-Xmx512m
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith

None really seemed to help. I haven't tried downgrading to a previous version of sun-java-6 yet, as I haven't found the packages.

terigox (terigox) wrote :

I meant "Package Explorer" not "Project Explorer".

terigox (terigox) wrote :

And I feel silly now, of course right after I write that, it just crashed while trying to Auto-Complete something.

Markus Majer (mpathy) wrote :

Why not starting Eclipse with sun-java-5 and doing your projects in a newer java version?
Sun Java 5 is additionally the version who is recommended for Eclipse 3.2.* and 3.3.* !!

Just curious? :/

Markus Majer (mpathy) wrote :

I want to provide a link how to change the VM with which Eclipse is started, you can do that in your eclipse.ini:
http://wiki.eclipse.org/Eclipse.ini
("-vm" !)

Before you have to install sun-java-5.

Dmitriy Geels (dmig) on 2008-05-27
Changed in sun-java6:
status: New → Confirmed
Changed in openjdk-6:
status: New → Confirmed
Changed in eclipse:
status: Unknown → Invalid
Matthias Klose (doko) on 2008-08-05
Changed in openjdk-6:
status: Confirmed → Incomplete
Matthias Klose (doko) on 2008-08-14
Changed in openjdk-6:
status: Incomplete → Fix Released
Changed in sun-java6:
status: Confirmed → Incomplete
Matti Lindell (mlind) on 2008-09-05
Changed in sun-java6:
status: Incomplete → Confirmed
35 comments hidden view all 115 comments
Franck (alci) wrote :

Thanks Claudio.

On my side, eclipse runs perfectly here on a freshly installed 8.10 AMD64 Ubuntu. I use default-jdk package, that is openjdk-1.6.

Maybe the bug is gone ?

Hi,

I realized that this occurred with many people ...
I do not use Gnome, the official distribution of SuSE is KDE 3.5 ...
Thank God the Eclipse worked.
These post here of the forum were very helpful.
I do not need the JVM from Sun for the development of my applications. My clients use Windows, then do the tests for the application I need to use VirtualBox for example.

!!!! Long live the Linux community !!!!!

Thank you very much.

Hugs,
Claudio

Ops....

Sorry, I meant Slackware up.

Hugs,
Cláudio

Changed in eclipse:
status: Confirmed → Fix Released
Andrew Lenards (lenards) wrote :

proving my laziness (and partly dreading issues like this), I just upgrade my work machine from gutsy to hardy and I can confirm the java-6-sun and I can confirm this issue w/ the following:

OS Linux xxxx.xxx.xxxxxxx.edu 2.6.24-23-generic #1 SMP Mon Jan 26 01:04:16 UTC 2009 x86_64 GNU/Linux

Eclipse 3.3.2 (manual download) (developing java)

java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)

I had no issues in Gutsy until the upgrade today.

I work on the Tree of Life Web project and we're using 1.5 so the downgrade to java-1.5.0-sun appears to be working. I will see if openjdk6 works.

James Stansell (jamesstansell) wrote :

I was reading eclipse release notes recently (probably the 3.5M5 release) and saw a warning about using a whole range of JVM versions. I think something like 6u3 through 6u7 had problems.

It's possible to grab 6u11 or 6u12 from intrepid and/or jaunty and install it on hardy (and even earlier than hardy) if you care to try that.

Having the same problem with both Eclipse 3.4 and 3.5RC4 and both latest sun jvm and latest openjdk on Jaunty:

# Java VM: OpenJDK 64-Bit Server VM (14.0-b08 mixed mode linux-amd64 )
# Distribution: Ubuntu 9.04, package 6b14-1.4.1-0ubuntu7
# Problematic frame:
# C [libxul.so+0x6416fe]

# Java VM: Java HotSpot(TM) 64-Bit Server VM (11.3-b02 mixed mode linux-amd64)
# Problematic frame:
# C [libxul.so+0x6416fe]

A downgrade to libxul-common 1.8.1.16 fixed the problem for me.

its happend to me in karmic ,

searching for compatible vm...
  testing /usr/lib/jvm/java-6-sun/jre...found
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x703e5187, pid=7110, tid=3073883024
#
# JRE version: 6.0_14-b08
# Java VM: Java HotSpot(TM) Server VM (14.0-b16 mixed mode linux-x86 )
# Problematic frame:
# C [libxul.so+0x440187]
#
# An error report file with more information is saved as:
# /home/fenris/hs_err_pid7110.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

after upgrading eclipse to 3.4.1 , attach with error report

using libxul-common 1.8.1.16+nobinonly-0ubuntu1

searching for compatible vm...
  testing /usr/lib/jvm/java-6-openjdk/jre...found
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x08c74187, pid=7190, tid=5708688
#
# JRE version: 6.0-b16
# Java VM: OpenJDK Server VM (14.0-b15 mixed mode linux-x86 )
# Distribution: Ubuntu karmic (development branch), package 6b16~pre3-0ubuntu1
# Problematic frame:
# C [libxul.so+0x440187]
#
# An error report file with more information is saved as:
# /home/fenris/hs_err_pid7190.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

if using openjdk

Marcos Petry (marcosrpetry) wrote :

I had the same problem...
It could sound strange but as workaround I removed the ../workspace/.metadata folder and restarted the IDE.

Regards,

Ichthyostega (ichthyo) wrote :

> Marcos Petry wrote on 2009-07-24:
> ... as workaround I removed the ../workspace/.metadata

outch, I whouldn't recommend that to anyone!

- you throw away maybe lots of local workspace data and configuration
- this isn't a workaround, it just hides the problem until your workspace
  configuration/data is again in shape to trigger the problem

In the current situation, there are two known resolutions or workarounds:
- use a Java-5 JRE to run ECLIPSE (note: you can still use a JDK-6 inside for your programs)
- use the newest updates for sun java-6 (> update 11)

Ichthyostega (ichthyo) wrote :

...just to add some clarifications:

I don't know how the situation is with OpenJDK? Did they already pick up the upstream fix?

As I understand it, this bug is about a crash caused in the JDK java compiler.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214092
Of course, there might be other unrelated bugs in other third party libraries which also cause
a hard crash of the JVM (personally, I saw libxul, the GTK and occasionally the xserver-xorg,
but nither of these was reproducable for me).

For a Java user, all of these crashes might seem like "the same bug", but they aren't.
You can see the source of the problem in the stacktrace: look at the "Problematic frame".

PolitikerNEU (bobbug) wrote :

I have got a similar error in my downloaded eclipse, it crashes all the time, e.g. after clicking "finish" of the configure-server-dialogue:

[Fatal Error] :37899:55: Premature end of file.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f7b4475ccfa, pid=8234, tid=140168307648848
#
# JRE version: 6.0_14-b08
# Java VM: Java HotSpot(TM) 64-Bit Server VM (14.0-b16 interpreted mode linux-amd64 )
# Problematic frame:
# C [libpango-1.0.so.0+0x24cfa] pango_layout_new+0x2a
#
# An error report file with more information is saved as:
# /home/robert/eclipse/hs_err_pid8234.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

PolitikerNEU (bobbug) wrote :

Forgot to mention: I use karmic, amd64, adding the -Xint-Option doesn't help.

Rarian Rakista (rakista) wrote :

searching for compatible vm...
  testing /usr/lib/jvm/java-6-sun...found
!SESSION 2009-09-06 11:45:00.863 -----------------------------------------------
eclipse.buildId=M20080911-1700
java.version=1.6.0_15
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_CA
Framework arguments:
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2009-09-06 11:45:01.121
!MESSAGE Error reading configuration: No such file or directory
!STACK 0
java.io.IOException: No such file or directory
        at java.io.UnixFileSystem.createFileExclusively(Native Method)
        at java.io.File.checkAndCreate(File.java:1704)
        at java.io.File.createTempFile(File.java:1792)
        at org.eclipse.osgi.storagemanager.StorageManager.initializeInstanceFile(StorageManager.java:189)
        at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:693)
        at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:208)
        at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:142)
        at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:124)
        at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:180)
        at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:152)
        at org.eclipse.osgi.framework.internal.core.OSGi.createFramework(OSGi.java:90)
        at org.eclipse.osgi.framework.internal.core.OSGi.<init>(OSGi.java:31)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:286)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

Crashes with no error message

Matthias Klose (doko) on 2009-10-08
tags: added: local-binary swt-gtk
Niels Thykier (niels-thykier) wrote :

Hi

Please retest this in eclipse 3.5.1. You probably have to remove your "~/.eclipse" for it though and may also have to use an empty workspace.

Thank you in advance,
~Niels

Changed in eclipse (Ubuntu):
status: Confirmed → Incomplete
Volodymyr Buell (vbuell) wrote :

eclipse 3.5.1 have the same problems i had with 3.5 (as well as eclipse 3.6m2). And in my case it crashes at pango_layout_new+0x2a

Niels Thykier (niels-thykier) wrote :

Hi

I think this might be cause the swt cairo lib is very old. In the next upload of eclipse we should have this fixed.

~Niels

Changed in eclipse (Ubuntu):
assignee: nobody → Niels Thykier (niels-thykier)
status: Incomplete → Fix Committed
Vanda Ribeiro (vanda-ribeiro) wrote :

I had a problem with Eclipse crashing when I debugged/ran a program.
Using Java-5 JRE to run Eclipse worked for me (at least, so far so good).
Thanks :)

Niels Thykier (niels-thykier) wrote :

Hi

This should be fixed in 3.5.1-0ubuntu3, which was uploaded some 8 hours ago. You may have to remove your ~/.eclipse and start in a empty workspace for it to work.

If you still experience this, please write back and we will reopen it.

~Niels

Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released
Allan Bogh (ajbogh) wrote :

I received this same problem on Ubuntu 9.10 64bit. Eclipse version: 3.5.1 build id: M20090917-0800. It happens when I try to install phpEclipse from the software installation window. It will let me get through everything but when I hit Finish it immediately crashes with the same error as the originator. I will try to install Java 5 (not preferable).

BeowulfOF (beowulfof) wrote :

On Ubuntu 9.10 it is stilll an actual problem, I can't work with eclipse, since all thre steps it crashes, even in the tutorials.

Niels Thykier (niels-thykier) wrote :

@BeowulfOF:

Hi

Checking your log it looks like you are suffering from #445009 and not this one. Said bug will be closed on next upload to Ubuntu.

~Niels

rbt (rula6) wrote :

It still seems to be a problem with Ubuntu 9.10 for sun-java5 and sun-java6. Therefore I think the status of this bug should be changed.

Best.

rbt

Dmitriy Geels (dmig) wrote :

I haven't seen this problem for a long time, since I use Eclipse 3.5 (manually installed) and sun-java6 (from repo).
I recommend installing latest Eclipse from official site.

rbt (rula6) wrote :

Even with Eclipse 3.5.2 and sun-java6 I do have this problem. See attached log

Andries (andries-spies) wrote :

My fix for this was to remove firefox + xulrunner completely, re-installing older version of xulrunner (1.9.2) and gnome-integration. This fix the problem for me. Probably not the best solution (i'm without firefox), but google's chrome browser is replaces firefox nicely.

Which version of Ubuntu are you on? Xulrunner 1.9.2 is the current
version in Lucid. Also, Firefox in Lucid doesn't need xulrunner as it
ships its own copy.

On 04/28/2010 09:25 AM, Andries wrote:
> My fix for this was to remove firefox + xulrunner completely, re-
> installing older version of xulrunner (1.9.2) and gnome-integration.
> This fix the problem for me. Probably not the best solution (i'm without
> firefox), but google's chrome browser is replaces firefox nicely.
>

I see this also in 10.04, In fact eclipse is pretty un-useable with an apparently random crash every other minute. Doesn't seem to matter if I use sun-java or openjdk its just really unstable. Attached openjdk error

Niels Thykier (niels-thykier) wrote :

Will wrote:
> I see this also in 10.04, In fact eclipse is pretty un-useable with an
> apparently random crash every other minute. Doesn't seem to matter if I
> use sun-java or openjdk its just really unstable. Attached openjdk error
>
> ** Attachment added: "hs_err_pid18828.log"
> http://launchpadlibrarian.net/48675372/hs_err_pid18828.log
>

Hi

The crash is due to xulrunner; could you try to ensure you only got one
xulrunner installed.

~Niels

Niels, Thanks had some 1.9.1 components still installed. Removed and now working for 20mins crash free.

fingerskier (fingerskier) wrote :

Haven't had any issues until this. Eclipse crashed while switching workspaces as an update was downloading in yet another workspace. Thanks in advance for attention given to this matter.

Raymond Hill (rhill) wrote :

I also have regular crashes, all occurring in libjvm.so. Address at or around 0x4fdf52 seems to be involved, is it shows up in 3 out of 4 crashes I had today, while the other I had 0x4fdf48.

Laszlo Suto (laszlo-suto) wrote :

I have regular jvm crashes also these days. It happens starting jboss 5.1.0 or eclipse 3.5 or 3.6, but it is not reproducible. I've attached one of my crash report. The crash occurs every time in the libjvm.so but the address is not constant. I've tried already with openjdk-6 but it is the same, tried also with the fresh sun java 1.6.0_21 but nothing has been changed. I've got updated lucid lynx with sun-java6 default java.

Niels Thykier (niels-thykier) wrote :

@Raymond Hill:

If you still have this issue, please file a new bug against eclipse. We need additional info than the one provided by your crash log (though please do attach it to your new bug). Depending on how you file the bug, you may have to run apport-bug $new_bug_id after wards.

@fingerskier and @Laszlo Suto:

You both use an eclipse that has not been installed via Ubuntu's repositories; we cannot do much about your issue. If you can reproduce the issue with the eclipse from Ubuntu's APT repositories then please follow the same instructions as I gave Raymond Hill (please use the crash log produced by the Ubuntu eclipse). Otherwise, you will have to file a bug against eclipse upstream asking them to fix the issue. You should probably file a new bug (at least do not use the one linked from here - it seems to be a different issue/cause).

Thank you in advance,
~Niels

Changed in eclipse (Ubuntu):
assignee: Niels Thykier (niels-thykier) → nobody
Changed in eclipse (Gentoo Linux):
importance: Unknown → Medium
Nem Nesic (nemnesic) wrote :

I have the same problem running Ubuntu 10.04 on my lap top only. JVM crashes all the time. It is not only related to Eclipse. It crashes when I run grails app, or tomcat , or anything that runs in JVM. Now, the weird thing is that I have the same java, eclipse, grails, ubuntu, tomcat on my desktop. So the software part is identical and everything works fine. No JVM crashes at all!
I read someowere that bad hardware can cause JVM to crash. Is this true?

Oh and I tried open jdk and sun jdk 6. but no luck.

nn

Laszlo Suto (laszlo-suto) wrote :

Yes, it could be the hardware. For me it turned out that the memory module was faulty, after it was replaced everything works fine.

1 comments hidden view all 115 comments
linux4guru (linux4guru) wrote :

I do think this is hardware related too - we have desktop system on ASUS i5 and some i7 which worked fine with FC12 but the newer ASUS with i7 2600k CPU - those system crashed every time.

no longer affects: sun-java6 (Ubuntu)
Displaying first 40 and last 40 comments. View all 115 comments or add a comment.