Ubuntu

Upgrade to Eclipse 3.5.0

Reported by Andreas Schildbach on 2007-06-29
764
This bug affects 81 people
Affects Status Importance Assigned to Milestone
eclipse (Baltix)
Undecided
Unassigned
eclipse (Debian)
Fix Released
Undecided
Unassigned
eclipse (Ubuntu)
Wishlist
Unassigned
Nominated for Dapper by slemos
Declined for Feisty by Colin Watson
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by StefanPotyra
Declined for Intrepid by Steve Langasek
Declined for Jaunty by Steve Langasek
Nominated for Karmic by Micah Gersten

Bug Description

Binary package hint: eclipse

Eclipse 3.5.0 "Galileo" is out in time for an LTS preview in Karmic.

Matti Lindell (mlind) on 2007-06-29
Changed in eclipse:
importance: Undecided → Wishlist
status: New → Confirmed
Dan Allen (dan.j.allen) wrote :

Why can't we get it into Fiesty? The way I see it, Eclipse is a completely "external" package, not affecting the distro in any way. People want to get the latest version of Eclipse without having to upgrade to a new distribution. It is very important for developers. Eclipse releases are backwards compatible, so it isn't like you have to go get all new plugins.

Matti Lindell (mlind) wrote :

Hi Dan, new package needs to be included in current Ubuntu development version first before it can be considered for a stable release.
Then then the package go though SRU or backport process.

I hope this helps.

https://wiki.ubuntu.com/MOTU/Packages/New
https://wiki.ubuntu.com/UbuntuDevelopment
https://wiki.ubuntu.com/BackportRequestProcess
https://wiki.ubuntu.com/MOTU/SRU

Changed in eclipse:
status: Unknown → New
Colin Watson (cjwatson) wrote :

What mlind said. A backport would probably be entirely reasonable once it's in gutsy.

Changed in eclipse:
assignee: nobody → xxxxx1
status: Confirmed → In Progress
Zach Tibbitts (zachtib) wrote :

I'd just like to voice my support for Eclipse 3.3 as well. I've been trying to find a source package for Europa so that I can build proper packages on Feisty, but so far I haven't been able to. I don't like to install software manually that isn't in a deb package, but so far I have to for this.

Trond Husoe (tr-huso) wrote :

I will also voice my support fro Eclipse 3.3. I am trying to add the PHP addin for Eclipse, but it does not support the 3.2 version that comes with Feisty. So I really hope that the Ubuntu community makes an upgrade available. Europa is now in stable distribution as far as I can understand on their website.

best regards

GSMD (gsmdib) wrote :

Definitely it would be great to have Eclipse 3.3 "apt'able" in Gutsy, yet nothing prevents you from running a generic package from eclipse.org.

Thanks for all commentaries. I am working on it right now.

William, thanks for the good job. I really think that Eclipse must have to be updated to 3.3.

Scott Kitterman (kitterman) wrote :

We are now almost a month past the Upstream Version Freeze for Gutsy. Eclipse is a very complex package and so a UVF exception is very unlikely.

J. Pablo Fernández (pupeno) wrote :

Will Eclipse be upgraded to 3.3 in time for Gutsy?

slamdunk (antongiulio05) wrote :

yet another same question:

will be eclipse upgrade to 3.3 in stable-gutsy or not? real problem is many plugins doesn't run with eclipse < 3.3

Progress Nerd (progressnerd) wrote :

Yeah, I hope eclipse 3.3 is added to gutsy soon.

dbmuse (lhcj666) wrote :

Adobe's new flex for linux requires Eclipse 3.3 and sun jdk 1.5.
Please provide such packages for Ubuntu so its easy for us Linux Newbies.
thanks

Shane O'Connell (shaneoc) wrote :

I want 3.3 in gutsy as much as the rest of you.. but it really looks like it's pretty much impossible at this point, it's way too late. Sort of annoying considering that 3.3 came out long before the deadline for merging new versions.

But all is not lost, luckily eclipse happens to be extremely easy to install without an ubuntu package. If you download the precompiled version from eclipse.org, you only have to extract it into a directory and run it. I've been using it for a long time now this way.

What chance of it appearing in gutsy-backports after (or even at) release?

On 12/10/2007, Shane O'Connell <email address hidden> wrote:
> I want 3.3 in gutsy as much as the rest of you.. but it really looks
> like it's pretty much impossible at this point, it's way too late. Sort
> of annoying considering that 3.3 came out long before the deadline for
> merging new versions.
>
> But all is not lost, luckily eclipse happens to be extremely easy to
> install without an ubuntu package. If you download the precompiled
> version from eclipse.org, you only have to extract it into a directory
> and run it. I've been using it for a long time now this way.
>
> --
> Upgrade to Eclipse 3.3
> https://bugs.launchpad.net/bugs/123064
> You received this bug notification because you are a direct subscriber
> of the bug.
>

This is pretty trivial, but in my pursuit of desktop perfection, I'm a bit annoyed by the eclipse icon (icon.xpm file) that comes bundled in the precompiled version of Eclipse from Eclipse.org. Namely, it has a purple background around the Eclipse sphere instead of transparency. I recall getting an icon with a transparent background when I installed Eclipse 3.2 from the repository, and that's definitely the icon you get if you download the 3.3 Windows or Mac versions. What's extra strange is that I had Eclipse 3.3 running when I tried out the AWN dock recently, and the nicer icon magically appeared in the dock! Where did it come from, and why doesn't it look that way when I create a custom launcher for Eclipse with icon.xpm as the icon?

On Fri, 2007-10-12 at 05:59 +0000, Ashton Batty wrote:
> What chance of it appearing in gutsy-backports after (or even at)
> release?
>

I would say that it is odd that development-packages is
distribution-dependent. Any version of Eclipse should be updated /
installed on any distro-version you are using.
In other words: Distribution independent.

And it should be easy to install so you don't have to spend hours and
hours and ... to get your development-tool up and running.

Trond

Matti Lindell (mlind) on 2007-10-14
Changed in eclipse:
status: In Progress → New

Sorry about delay, since I'm too busy. Two weeks and all OK.

Changed in eclipse:
assignee: nobody → deadwill
Changed in eclipse:
status: New → In Progress
billih (billi-home) wrote :

any idea when it will be available? thanks.

John Dong (jdong) wrote :

Ok, first let's get it packaged and built in Hardy, then I'd be more than happy to look at backporting it.

Someone nominated it to Gutsy.. John, are you able to decline that? I'm pretty close to finish it.

Oh, and yes, i'm packaging to Hardy :)

thanks! when will it be ready for gutsy and will it include php & svn plugins?

Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Huy Phan (huyphan) wrote :

I am also looking forward to Eclipse 3.3 in Ubuntu.

So, is it confirmed that it will be in Hardy as default, with all the CDT, PHP plugins, etc?

Matti Lindell (mlind) wrote :

No, it's currently not confirmed. If anyone is contributing to this task, they should join forces with Debian Java maintainers.

John Dong (jdong) wrote :

> What chance of it appearing in gutsy-backports after (or even at) release?

Probably slim. Eclipse churns out SWT and other development packages, libraries, etc that other software in the repositories depend on and it all depends on whether or not introducing these newer versions are going to be backwards-compatible.

Eclipse isn't just an IDE, it's also a platform and library.

I'm also looking forward to Eclipse 3.3 in Hardy so that Azureus 3.x can go in, and thank in advance the volunteers that will take this job forward :)

Rob Loach (robloach) wrote :

Yet a note showing my interest in getting Eclipse 3.3 in Gutsy and/or Hardy.

+1
simple downloading and unpacking don't work for me :(
There is exception:

JVM terminated. Exit code=13
/usr/bin/java
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-jar /home/seth/Програмування/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/seth/Програмування/eclipse/eclipse
-name Eclipse
--launcher.library /home/seth/Програмування/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.2.R331_v20071019/eclipse_1021.so
-startup /home/seth/Програмування/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
-exitdata 1e10018
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-jar /home/seth/Програмування/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar

Martin (martin615) wrote :

"If anyone is contributing to this task, they should join forces with Debian Java maintainers."

So, since the Debian import freeze came and went a long time ago and feature freeze is just two weeks away... no 3.3 in Hardy then... most likely. :(

And downloading and running from the website doesn't work (I've forgotten what the error was for me in Hardy and I'm back in Gutsy now). Oh well.

(Just felt like complaining a little. ;)

Marcus Sundman (sundman) wrote :

So, since we're complaining... ;-)
Do the ubuntu devs want developers to use another distro, or why is only a 1+ year old version of eclipse available? 3.4 will go final shortly after hardy is released and yet not even 3.3 is in hardy. This is so absurd I find it difficult to believe.

I dont think it will be so bad if 3.3 is not included in Hardy because if u are a java developer, it would be able to intall Eclipse it own on Ubuntu there would be no prolbem, of course it would be nicer if we could say apt-get install eclipse but if not, no problem to i think..

The more we can apt-get the better. Then we know that the software is
being installed the correct way. We also know that it is being removed
from the system when we uninstall it as well.

-t-

On Thu, 2008-02-21 at 06:32 +0000, farkarich wrote:
> I dont think it will be so bad if 3.3 is not included in Hardy because
> if u are a java developer, it would be able to intall Eclipse it own on
> Ubuntu there would be no prolbem, of course it would be nicer if we
> could say apt-get install eclipse but if not, no problem to i think..
>

Ashton Batty (ashton) wrote :

I think it is probably a bit late to get a release out and tested
enough before Hardy. I am a bit surprised nothing at all has been
released yet... there have been a handful of people who have claimed
to be working on it since before Gutsy.

On Thu, Feb 21, 2008 at 6:46 PM, Trond Husoe <email address hidden> wrote:
> The more we can apt-get the better. Then we know that the software is
> being installed the correct way. We also know that it is being removed
> from the system when we uninstall it as well.
>
> -t-
>
>
>
> On Thu, 2008-02-21 at 06:32 +0000, farkarich wrote:
> > I dont think it will be so bad if 3.3 is not included in Hardy because
> > if u are a java developer, it would be able to intall Eclipse it own on
> > Ubuntu there would be no prolbem, of course it would be nicer if we
> > could say apt-get install eclipse but if not, no problem to i think..
> >
>
> --
> Upgrade to Eclipse 3.3
> https://bugs.launchpad.net/bugs/123064
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Cmon, they don't give a $heet bout java developers which is inherited from the fact that Debian guys have exactly the same attitude. Extremely dumb in the first case (given the fact that Ubuntu is desktop-oriented) and just fine in the second (as Debian is more server-side).
Besides Eclipse, how long would it take for Tomcat 6 to get into repos? It went stable almost a year ago.

 HI!

Don't take tomcat as example, because @ tomcat you dont have troubles with the SWT Libs! It would be even easier to take the Jboss Application Server in the repos than it is with eclipse!

GSMD wrote:
> Cmon, they don't give a $heet bout java developers which is inherited from the fact that Debian guys have exactly the same attitude.
Hold on a sec, this is a bug report, not a forum for your rants about
Ubuntu developer priorities. The beauty of an open community effort is
that it inherits the priorities of everyone who participates. You are
welcome to step up and help to get the work done that you think is most
important, subject to the overall guidance of the technical board.

In the case of Java:

 - our primary constraint has been that upstream Java could not go into
main because of licensing concerns
 - we aim to get java into main as soon as it is possible to do so
 - we are currently post feature freeze, and so it will be difficult to
change Hardy

We are working with Sun on OpenJDK, but it's not yet clear what can be
achieved by Hardy without putting other pieces of the distribution, like
OpenOffice, at risk. One of our requirements in working with Sun is that
Eclipse work well. I fully support the idea of being able to apt-get the
latest stable Eclipse, and am pretty offended by your sweeping statement
to the contrary.

Mark

Eclipse 3.3.1 (From Eclipse site) works quite well using the beta version of icedtea and jdk7 (from the repositories)
I've used it to create some c++ code using cdt, seems to work with problems.
(the memory usage is also a lot better)
it needed some manual editing of the java virtual machine configuration.

Matti Lindell (mlind) on 2008-03-10
Changed in eclipse:
status: In Progress → New
description: updated
Changed in eclipse:
assignee: nobody → festor90
status: New → In Progress
Changed in eclipse:
assignee: festor90 → nobody
status: In Progress → Confirmed
description: updated
description: updated
Wes Garner (wesgarner) on 2009-02-26
Changed in eclipse:
assignee: nobody → mcasadevall
assignee: mcasadevall → medibuntu
assignee: medibuntu → medibuntu-maintainers
Hew McLachlan (hew) on 2009-02-27
Changed in eclipse:
assignee: medibuntu-maintainers → nobody
description: updated
description: updated
Hew McLachlan (hew) on 2009-04-28
description: updated
Rockwalrus (rockwalrus) on 2009-06-16
description: updated
summary: - Upgrade to Eclipse 3.4.2
+ Upgrade to Eclipse 3.5.0
143 comments hidden view all 223 comments
Chris Aniszczyk (caniszczyk) wrote :

There's a Linux Distros project at Eclipse that aims to make Eclipse easier to use on Linux.

Maybe some people from the Ubuntu team should consider joining?

Red Hat is an active participant and they have done some recent work to help things.

http://dev.eclipse.org/mhonarc/lists/linuxtools-dev/msg00130.html

Or maybe talking to the Eclipse team would help?

The problem is that, for the most part, there is no debian/ubuntu eclipse team.

There is mostly just individuals right now, many with almost no free time
(e.g., I don't even use eclipse nowadays).

Removing the ancient 3.2 version might help bring a few more interested
developers to assist towards packaging 3.5.

Btw, some things the eclipse team could do to make packagers' lives easier
and increase the chances for an eclipse version that meets debian's high
freedom/quality standards:

* Test your code with openjdk.
* Assist with building eclipse in a headless manner from the command-line.
(this practically means test your code with eclipse-build and help fix the bugs)
2-3 redhat people trying to fix bugs in the ant scripts of more than 50 people
doesn't really scale, especially if said 50 people continuously add new bugs :)

There are other issues like proper policy for eclipse and plugins (placement
within FHS) etc but debian people can deal with those and the build issue
is currently the thorniest

Justin Dugger (jldugger) wrote :

It appears that Doko (Matthias Klose) has uploaded a 3.4 package to Karmic.

karl michael (karlzt) wrote :

why not 3.5?

Victor Bielawski (bielawski1) wrote :

Why not be thankful?

On 6/29/09, karl michael <email address hidden> wrote:
> why not 3.5?
>
> --
> Upgrade to Eclipse 3.5.0
> https://bugs.launchpad.net/bugs/123064
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “eclipse” package in Ubuntu: Confirmed
> Status in “eclipse” package in Baltix: New
> Status in “eclipse” package in Debian: New
>
> Bug description:
> Binary package hint: eclipse
>
> Eclipse 3.5.0 will soon be out.
>

--
Victor Bielawski

v4sw5CJUhw4ln4pr7OPck2/3ma4u7Lw3+2TVXm5l6DFRUi2Ce2t2b7AHIMTen5a16s4r2p-1/-1g1

Mr. Anderson (walch-martin) wrote :

If it is any help: I think on Gentoo it is possible to compile eclipse with openjdk (at least 3.4, did not test with 3.5, yet).

Where is the packege? I mean it's not here:

http://packages.ubuntu.com/search?keywords=eclipse&searchon=names&suite=karmic&section=all

I think that if 3.4 was uploaded then the path is clean to have eclipse 3.5 or 3.5+1 in karmic+1 isn't it?

BTW I am thankful :)

Julian Alarcon (alarconj) wrote :

On Tue, Jun 30, 2009 at 2:11 PM, Vincenzo Ciancia<email address hidden> wrote:
> Where is the packege? I mean it's not here:
>
> http://packages.ubuntu.com/search?keywords=eclipse&searchon=names&suite=karmic&section=all
>
> I think that if 3.4 was uploaded then the path is clean to have eclipse
> 3.5 or 3.5+1 in karmic+1 isn't it?
>
> BTW I am thankful :)
>
> --
> Upgrade to Eclipse 3.5.0
> https://bugs.launchpad.net/bugs/123064
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hey, it is here:
https://launchpad.net/ubuntu/karmic/+source/eclipse

dominikg (dominik-goepel) wrote :

That package contains eclipse 3.4.1

Matthias Klose was active here on 2009-05-26: https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/123064/comments/169

At that date the description here was already asking for 3.4.2 and got changed to 3.5.0 on 2009-06-16.

Eclipse releases at a very accurate schedule (a major release at the last week of june for 6 years in a row with service releases in fall and winter), so i wonder why 3.4.1 was used instead of 3.5 (or at least 3.4.2).
And while 3.4.1 is better than 3.2, it's still outdated (major and minor). So including this would be an improvement but no solution. In my opinion removing the eclipse package altogether would be better than including 3.4.1.

description: updated
tags: added: java

Remove eclipse totally is better than have a completely and totally obsolete version. It's better both for Ubuntu project, at least they can pretend it's a choice, and more important here for eclipse. Eclipse 3.2 is soooooo old that it's completely ridiculous. Eclipse project SHOULD forbid any distribution as old as this one. It changed so much since that it's just a bad publicity for them.

At least the binary installation provide by eclipse project is working fine and it's easy to install. Naturally for any large deployement in a compagny that can be a problem but they will other distributions that's it and naturally canonical will lost contract because of this...

Chris Aniszczyk (caniszczyk) wrote :

In a previous comment (https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/123064/comments/184), I mentioned the Ubuntu team talking to the Eclipse linux community for help.

I've seen nothing yet.

If RedHat can do it... so can Ubuntu
     http://fedoraproject.org/wiki/Eclipse

How about getting some collaboration going? We don't bite.

Yeah, Eclipse 3.4.1 finally arrived in Karmic! Thanks to anyone who made this possible!

aporter (aporter) wrote :

Yes thanks very much for eclipse 3.4 in karmic.

I have to ask, why does the "eclipse-platform" package depend on the "firefox" package?

Shouldn't it just depend on the "www-browser" virtual package or is there something in firefox that it needs? If it's the latter, then the firefox-3.5 package should probably have "Provides: firefox" or eclipse-platform should depend on "firefox | firefox-3.5" or something.

For a few people at my work, the "firefox-3.5" package is already installed in karmic and apt is trying to install firefox 3.0 too when we run "apt-get install eclipse"

thanks again,

On Fri, Jul 17, 2009 at 9:57 PM, aporter<email address hidden> wrote:
> Yes thanks very much for eclipse 3.4 in karmic.
>
> I have to ask, why does the "eclipse-platform" package depend on the
> "firefox" package?

Eclipse uses a particular version of xulrunner for various functions
e.g., to display the welcome page.

Brian Rogers (brian-rogers) wrote :

Shouldn't it depend directly on xulrunner, then? Or does it require something from the firefox package?

Justin Dugger (jldugger) wrote :

A quick comment from doko after he uploaded:
<doko> I'm filing a bug report to remove this package again, because it does include a handful or more third party libs inside the eclipse package. if you want to keep eclipse, please fix these bugs, hint, hint ;)

Basically, where possible, it's preferred to tear out libraries Ubuntu already ships.

Matthias Niess (mniess) wrote :

As the description states 3.5.0 is out and SHOULD be tested in karmic to make it run great in the next LTS release. Ubuntu already is the distro of choice for most developers. It is sad that they have to get Eclipse from somewhere else than the Ubuntu repos. So I vote for exchanging 3.4 with 3.5 in karmic.

James Tait (jamestait) wrote :

The Eclipse linuxtools project has just released version 0.3.0, which includes an eclipse-builder component that standardises Eclipse builds across Linux distros. This currently works with 3.5.x, I don't know about 3.4.x, but it might be a way to get to 3.5.x quickly. From the announcement:

The Eclipse Linux Tools team is pleased to announce our 0.3.0 release! This
release is compatible with the Galileo releases of the Eclipse SDK (version
3.5) and CDT (version 6.0). It is available now from our update site:

http://download.eclipse.org/technology/linuxtools/update
(yes, that will give a 404 in the browser; just use it in the update manager)

Should you prefer a zip of the release, it is available at our downloads page:

http://www.eclipse.org/linuxtools/downloads.php

Installation instructions are available:

http://wiki.eclipse.org/Linux_Tools_Project/PluginInstallHelp

113 bugs [1] were closed as part of this release including bug fixes and new
features. Highlights include:

* integration of the SystemTapGUI project including editing and graphing capabilities
* a Valgrind suppressions editor
* importing/exporting of SRPMs/RPMs
* Eclipse Help documentation for some of our plugins
* manual control of the OProfile daemon
* the first coordinated release of eclipse-build, our scripts to ease the
  building of the Eclipse SDK for Linux distributions (tested so far on Fedora
  and Debian). See: http://wiki.eclipse.org/Linux_Tools_Project/Eclipse_Build
* C++ hover help for the libstdc++ library

The full list of highlights can be see on our new and noteworthy page:

http://eclipse.org/linuxtools/new

Benjamin Drung (bdrung) wrote :

Since some days we (Niels Thykier, Adrian Perez, and I) work on getting an eclipse 3.5 build for Debian/Ubuntu based on the Linux Tools. You can grab the current status from the git repository [1]. Helping hands are welcome (especially ant hackers and FHS experts). You can find us in the #eclipse-linux channel on Freenode and in #debian-java on OFTC.

[1] http://git.debian.org/?p=pkg-java/eclipse.git;a=summary

Derek (bugs-m8y) wrote :

So, I had been using the 3.4 ppa build mentioned in this bug in Jaunty with some success.

I decided to give Karmic a shot, and after some entertainment with the Karmic eclipse not picking up all its dependancies (had to manually add them a few at a time, working my way down), eclipse was installed and running.

However, on starting eclipse I get:
"This Eclipse build doesn't have support for the integrated browser"

None of my oh-so-crucial plugins like subclipse appear to be there, and if I go to software updates I get:
"Cannot launch the Update UI. This installation has not been configured properly for Software Updates."

I suppose I can go back to the ppa build which did indeed work quite nicely and also uninstalled quite nicely too, but I'm wondering if anyone here has had better luck.

Derek (bugs-m8y) wrote :

Enabling classic update seems to work.
Not sure exactly what happened to my existing plugins, but, hey. looks hopeful.

Derek (bugs-m8y) wrote :

Fail. Seems to want to install in /usr/lib, and running as root (hey, whatever, I'll install the packages globally if it wants - I'd rather it was ubuntu packaged subclipse anyway) simply aborts with various errors like:
!MESSAGE Missing required bundle org.eclipse.wst.common.environment_[1.0.100,1.1.0).

Guess I'm going back to:
https://launchpad.net/~yogarine/+archive/eclipse

Which I think was what I was using before.
Oh well. I'll stop spamming the bug now and go back to lurking.

Derek (bugs-m8y) wrote :

Oh. One more bit of bugspam. I'm not sure exactly what is going on w/ Yogarine's - it is definitely not the one I was using before.

eclipse depends on eclipse-platform and eclipse-jdt, but eclipse-jdt depends on eclipse-platform-sdk which conflicts with eclipse-platform.

plus circular deps between various other packages.
after 30m of mucking about in dpkg -i I think I'm going to look for some alternative packaging.

Derek (bugs-m8y) wrote :

... one more. Sorry. Just didn't want to muck people up with prior comments.
 I shouldn't have tried installing the .deb files myself it seems.
Appears that adding yogarine as a repo works just fine. However, the subclipse package only has SVNkit which doesn't play so well with svn 1.6 (errors on lack of format file). On the other hand, software update appears to work normally, so I guess I'll just install that by hand and not use the package.

Alwin Garside (yogarine) wrote :

Well, my packages are only tested on Jaunty. And it makes sense Subclipse breaks on Karmik since Jaunty still uses Subversion 1.5. ;-)

Also you shouldn't mix the different eclipse repo's out there. (Like eclipse-teams repo.) Eclipse's dependencies are pretty complicated, so it can easily go wrong. ;-) Anyway, eclipse-jdt depends on eclipse-platform OR eclipse-platform-sdk, so if it gives a conflict saying eclipse-platform-sdk can't be installed, it's probably because you have an old version of eclipse-platform installed. (I'll try to improve the dependencies in future packages...)

And when Karmik beta comes out I'll package Eclipse for Karmik as well...

Either way, thanks for trying out my packages. :-)

Changed in eclipse (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.1-0~ubuntu1

---------------
eclipse (3.5.1-0~ubuntu1) karmic; urgency=low

  * Fix build failure on lpia.
  * For anything else kudos to the eclipse-team.

eclipse (3.5.1-0~ppa1) karmic; urgency=low

  * New upstream release. (LP: #123064)
    - Supports xulrunner-1.9.1 (Closes: #538871, #507536)
  * Converted build system to use eclipse-build. (Closes: #501533)
  * Removed obsolete linda overrides.
  * New maintainers. (Closes: #526489)
  * Added kdebase-bin as alternative to zenity (Closes: #537605)
  * Added missing "apt" plug-in for eclipse-jdt.
    (Closes: #403655, LP: #120610)
  * Added conflicts on the old eclipse-*-nls packages.
    (Closes: #538869)
  * Removed "builtin browser not supported"-warning; it did not
    work. (Closes: #403675, #402340)
  * Removed dependency on libtomcat5.5-java and liblucene-javadoc.
    (Closes: #530722, #537605)

 -- Matthias Klose <email address hidden> Tue, 06 Oct 2009 14:22:24 +0200

Changed in eclipse (Ubuntu):
status: In Progress → Fix Released
gerstrong (gerstrong) wrote :

Sorry, but Eclipse CDT is at version 3.1

That's very old. It also should be upgraded, because it doesn't work with the newest platform.

Changed in eclipse (Ubuntu):
status: Fix Released → Incomplete
Ilya Barygin (randomaction) wrote :

gerstrong, eclipse-cdt is a separate package, there's bug 163739 for tracking its upgrade.

Changed in eclipse (Ubuntu):
status: Incomplete → Fix Released
weliad (weliad) wrote :

This will probably cause me to be scorned by the developers, though I honestly think they're doing really great job, well, for the most part, but my humble opinion is that being unable to provide an upgraded version of Eclipse with each new Eclipse release (and with that for each flavor - plug-in if you may), is at the very least sad.

Sure, a user can simply download the Eclipse environment from the website and use it as is (no installation needed), but it would be much more convenient and aligned with Ubuntu's motto of "it just works" (or is that no longer true?) if the user would have been able to install the package system wide using the package manager.

-- Liad W.

Benjamin Drung (bdrung) wrote :

@Liad:
Packaging eclipse (or a plugin like eclipse-cdt) is not easy and consumes much time. We lack of time / manpower / skills / motivation to update eclipse-cdt, but we do not scorn our users. Updating the eclipse-cdt package is on our todo list, but we cannot promise, that it will be in karmic.

I am willing to review and upload a eclipse-cdt package if someone provides one.

Justin Dugger (jldugger) wrote :

I agree that it's a disappointing, but rather than play a blame game between volunteers within Ubuntu, Debian and Eclipse upstream, I'd rather see how we can address the problem of keeping eclipse closer in sync with upstream.

For starters, can anyone locate an eclipse roadmap for 3.6?

Chris Aniszczyk (caniszczyk) wrote :

The project plan for Eclipse 3.6 is here:

http://www.eclipse.org/projects/project-plan.php?projectid=eclipse

This is for the Eclipse platform though. Eclipse is a large place and there are many projects within Eclipse that have their own respective plans.

On Sat, Oct 10, 2009 at 7:58 PM, Chris Aniszczyk <email address hidden> wrote:
> The project plan for Eclipse 3.6 is here:
>
> http://www.eclipse.org/projects/project-plan.php?projectid=eclipse
>
> This is for the Eclipse platform though. Eclipse is a large place and
> there are many projects within Eclipse that have their own respective
> plans.
>

WRT inclusion of eclipse in debian / ubuntu a promising direction is
to utilize the eclipse-build system developed as part of the linux tools
project upstream @ eclipse.org

I think this project already has its first (alpha sort of) release.

Otherwise there are a few existing packages but currently there seems
to be a lack of volunteers. E.g., I have no time to continue my effort
until next May due to serving in the greek army.

To everyone complaining: feel free to look at the problem. If you
have a use for eclipse there is a good chance you are a Java/Ant
developer so why not contribute?

James Tait (jamestait) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

pkt wrote:
> WRT inclusion of eclipse in debian / ubuntu a promising direction is
> to utilize the eclipse-build system developed as part of the linux tools
> project upstream @ eclipse.org
>
> I think this project already has its first (alpha sort of) release.

Judging by the changelog for Eclipse in Ubuntu Karmic, it's about to go
into production:

eclipse (3.5.1-0~ubuntu1) karmic; urgency=low

  * Fix build failure on lpia.

  * For anything else kudos to the eclipse-team.

 -- Matthias Klose <email address hidden> Tue, 06 Oct 2009 14:22:24 +0200

eclipse (3.5.1-0~ppa1) karmic; urgency=low

  * New upstream release. (LP: #123064)

    - Supports xulrunner-1.9.1 (Closes: #538871, #507536)

  * Converted build system to use eclipse-build. (Closes: #501533)

> Otherwise there are a few existing packages but currently there seems
> to be a lack of volunteers. E.g., I have no time to continue my effort
> until next May due to serving in the greek army.
>
> To everyone complaining: feel free to look at the problem. If you
> have a use for eclipse there is a good chance you are a Java/Ant
> developer so why not contribute?

Yes, I would love to, and was going to compose a mail to this effect
anyway, so your mail links nicely to what I was going to say. I wanted
to use the Mylyn, pydev and svn plugins the other day and discovered
that they are not yet packaged. CDT is another I may be interested in
down the line.

I'd love to contribute a package, but frankly I wouldn't know where to
start. Is there any possibility that someone with the requisite
knowledge could talk some potential contributors through the process on
IRC? A bit like the OpenWeek sessions, but targeted directly at
building Eclipse plugin packages? If that knowledge can be passed on to
a few people, we can each then help other people who show an interest
and hopefully each contribute a package or two, to spread the load.

Cheers,

JT
- --
- ---------------------------------------+--------------------------------
James Tait, BSc | xmpp:<email address hidden>
Programmer and Free Software advocate | VoIP: +44 (0)870 490 2407
- ---------------------------------------+--------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrRDWYACgkQyDo4xMNTLiYjDQCgiAjCo40C3RWxrfuQlkuOmQiz
6gYAoIDqRZ9eiH9Oo3NIa3mQPR4QhgLU
=uywS
-----END PGP SIGNATURE-----

Benjamin Drung (bdrung) wrote :

Am Samstag, den 10.10.2009, 22:40 +0000 schrieb James Tait:
> Judging by the changelog for Eclipse in Ubuntu Karmic, it's about to go
> into production:

Yes, you are right. We use a current eclipse-build svn checkout to build
eclipse 3.5.1.

> I'd love to contribute a package, but frankly I wouldn't know where to
> start. Is there any possibility that someone with the requisite
> knowledge could talk some potential contributors through the process on
> IRC? A bit like the OpenWeek sessions, but targeted directly at
> building Eclipse plugin packages? If that knowledge can be passed on to
> a few people, we can each then help other people who show an interest
> and hopefully each contribute a package or two, to spread the load.

Join #eclipse-linux on Freenode and #debian-java on OFTC to get in
contact with us. Currently we are three people working on the
Debian/Ubuntu eclipse package: nthykier, blackxored, and bdrung (me). In
#eclipse-linux there are the great guys from Fedora: overholt and
akurtakov.

We maintain eclipse in git:
http://git.debian.org/?p=pkg-java/eclipse.git;a=summary

There are mailing lists, too (but IRC is more frequently used):
<email address hidden>
<email address hidden>
<email address hidden>

Instead of abuse this bug report, please use these IRC channel / mailing
lists to continue.

--
Benjamin Drung
Ubuntu Developer (www.ubuntu.com) | Debian Maintainer (www.debian.org)

Artur Rona (ari-tczew) on 2009-11-07
Changed in eclipse (Debian):
importance: Unknown → Undecided
Changed in eclipse (Debian):
status: New → Fix Released
Michael Jones (jonesmz) wrote :

Are there any plans to upgrade to Eclipse 3.6? Should that be a new bug?

Victor Costan (costan) wrote :

I added a bug for updating to Eclipse 3.6. You can vote on it to show you care:
https://bugs.launchpad.net/bugs/604390

Micah Gersten (micahg) wrote :

That's bug #604390.

On 07/11/2010 05:09 PM, Michael Jones wrote:
> Are there any plans to upgrade to Eclipse 3.6? Should that be a new bug?
>

SoloTurn (soloturn) on 2011-04-22
Changed in eclipse (Baltix):
status: New → Invalid
Displaying first 40 and last 40 comments. View all 223 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.