[nvidia-glx] Switch user/switch VT causes lockup with compiz/beryl/desktop-effects

Bug #88152 reported by C Pirnat on 2007-02-26
192
Affects Status Importance Assigned to Milestone
desktop-effects (Baltix)
Undecided
Unassigned
desktop-effects (Ubuntu)
Medium
Unassigned
linux-restricted-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

Using Nvidia Geforce 7600 with nvidia-glx drivers and desktop effects package. When I switch users the other user is able to login and Gnome works properly. When that user logs out the screen goes black with just a cursor and the system hangs. There is no way to recover from this other than a hard reset.

Changed in compiz:
status: Unconfirmed → Confirmed
description: updated

Please do not confirm your own bugs.

Changed in desktop-effects:
status: Confirmed → Unconfirmed
Emilio Pozuelo Monfort (pochu) wrote :

I would bet that's a compiz issue, and not a desktop-effects one.

Could you run compiz from the terminal, instead of from desktop-effects, and see what happens?

Can anybody else tell wether this is a desktop-effects or a compiz one?

Changed in compiz:
importance: Undecided → Medium
Changed in desktop-effects:
importance: Undecided → Medium

Yes its a compiz issue however I could not select compiz as a package when I
reported the bug.

On 2/26/07, Emilio Pozuelo Monfort <email address hidden> wrote:
>
> I would bet that's a compiz issue, and not a desktop-effects one.
>
> Could you run compiz from the terminal, instead of from desktop-effects,
> and see what happens?
>
> Can anybody else tell wether this is a desktop-effects or a compiz one?
>
> ** Changed in: compiz (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: desktop-effects (Ubuntu)
> Importance: Undecided => Medium
>
> --
> Switch user causes lockup
> https://launchpad.net/bugs/88152
>

C Pirnat (histoplasmosis) wrote :

Problem ca also be recreated just by switching to a virtual terminal and
back to X.

i.e. CTRL+ALT+F1 then CTRL+ALT+F7 will also lock the system.

On 2/26/07, Charles Pirnat <email address hidden> wrote:
>
> Yes its a compiz issue however I could not select compiz as a package when
> I reported the bug.
>
> On 2/26/07, Emilio Pozuelo Monfort < <email address hidden>> wrote:
> >
> > I would bet that's a compiz issue, and not a desktop-effects one.
> >
> > Could you run compiz from the terminal, instead of from desktop-effects,
> > and see what happens?
> >
> > Can anybody else tell wether this is a desktop-effects or a compiz one?
> >
> > ** Changed in: compiz (Ubuntu)
> > Importance: Undecided => Medium
> >
> > ** Changed in: desktop-effects (Ubuntu)
> > Importance: Undecided => Medium
> >
> > --
> > Switch user causes lockup
> > https://launchpad.net/bugs/88152
> >
>
>

Closed the desktop-effects bug then :)

Changed in desktop-effects:
status: Unconfirmed → Rejected
Travis Watkins (amaranth) wrote :

This is a bug in the nvidia driver. I've told one of their developers about the bug, will have to hope it gets fixed.

Changed in compiz:
status: Unconfirmed → Confirmed

Perhaps this needs to be switched to the nvidia-glx package? I am unable to
change the package for the bug for some reason.

On 3/3/07, Travis Watkins <email address hidden> wrote:
>
> This is a bug in the nvidia driver. I've told one of their developers
> about the bug, will have to hope it gets fixed.
>
> ** Changed in: compiz (Ubuntu)
> Sourcepackagename: compiz => linux-restricted-modules-2.6.20
> Status: Unconfirmed => Confirmed
>
> --
> Switch user causes lockup
> https://launchpad.net/bugs/88152
>

This sounds a lot like Bug #32389 .

C Pirnat:
Do you have the same problem when you use the nvida-glx-new drivers?

Settings to needsinfo pending reply from C Pirnat.

Changed in linux-restricted-modules-2.6.20:
status: Confirmed → Needs Info
kseise (kevin-seise) wrote :

I have a similar problem, but only on Feisty with out compiz. My wife tried to log in (switch user) and the screen went black. Nothing came back up. Alt + CTL + F1 didn't take me to the rescue command line. I had to actually use the reset button on the box to reboot the machine.

I don't know what logs to quote. I am too much of a noob. Ask and you will receive.

chehov (at-the-moment) wrote :

Have: Ubuntu Festy + Beryl with nVidia.
Problem: Black screen on second log in after switch users.

Fix (for me?..):
1. run beryl-settings -> General Options -> General Options -> Main -> uncheck 'Sync To VBlank'
2. use option --force-nvidia for starting beryl (this can setup in beryl-manager)

P.S. I use package 'nvidia-glx-new' from official repository but not 'nvidia-glx'

chehov (at-the-moment) wrote :

I want say that this help me to fix problem! :)

chehov (at-the-moment) wrote :

But after this fix (see above), i have another: background users's beryl process have very high cpu usage!

kmax (kmaxima) wrote :

I was having this problem as well with Feisty and nvidia geforce 6200. Tried both compiz and beryl and with nvidia-glx and nvidia-glx-new drivers and was always getting the black screen when changing back to an already logged in user. I also got this behavior whenever I ran a game that went to full screen and then exited that game. I tried chehov's fix above in beryl to no luck, then I also tried the following in the beryl-settings -> General Options -> General Options -> Main:

1. Uncheck 'Detect Refresh Rate'. The beryl wiki says that this does not always work and is not recommended, so not sure why it is selected by default.
2. Set 'Refresh Rate' slider to refresh rate being used by X.

After this I logged out restarted X and logged back in (simple beryl restart may be enough) and have had no black screens since then. I did a bunch of switching between three sepearte users and never had a problem. I didn't check to see if background users were using cpu up as chehov notes however, I will check into that.

kseise (kevin-seise) wrote :

I changed video cards after posting. I guess when I reconfigured the xserver it fixed the problem. Everything is running fine now.

Cardy (andrei-bogomolov) wrote :

The above solution by kmax really works for me. User switch and text console dont freeze my system now with black screen. But now after switch back to user with beryl, after gdm login WHITE screen appears without any windows :) I guess this is unlock screen. I blindly type my password again and it works!

kmax (kmaxima) wrote :

I do also get the white screen with this fix, however being that mine is a personal home desktop I don't have screensaver passwords turned on so I hadn't really noticed it that much. I just move the mouse and the white screen goes away and is replaced by the new user's desktop. The one time that it didn't, ctrl-alt-bksp restarted X for me without a problem so at least for me this workaround makes everything quite usable compared to the previous behavior. Also, I haven't noticed any excessive CPU usage as pointed out by chehov.

wilk (j-cubizolles) wrote :

kmax solution fixed for me too for compiz on a nvidia GeForce FX 5200 (driver nvidia-glx-new). If you only have compiz, you don't even need to use beryl-settings. Just uncheck the /apps/compiz/general/screen0/options/detect_refresh_rate key in gconf-editor, or use
gconftool -s /apps/compiz/general/screen0/options/detect_refresh_rate -t boolean false

Sitsofe Wheeler (sitsofe) wrote :

C Pirnat:
Does disabling the refresh rate detection resolve the problem for you too?

wilk (j-cubizolles) wrote :

I disabled it and also disabled the sync_to_vblank. with only the detect_refresh_rate trick I could switch and back to the console but not to another X display. Now everything is mostly okay. Last bug I noticed : my gnome-panel with a transparent background was completely transparent (but still there with all its applets) after coming back from another X display. Just changing its background restored it.

Travis Watkins (amaranth) wrote :

This is a real bug (even if people have discovered workarounds for it). It was fixed in the 100 series drivers. Also, moving to linux-restricted-modules-2.6.22 since that's the current one.

Changed in linux-restricted-modules-2.6.20:
status: Incomplete → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

(Request for 2.6.22 NVIDIA 100 series drivers is Bug #120943 )

Sitsofe Wheeler (sitsofe) wrote :

Travis:
Note that many bugs were not duplicated on this because C Pirnat never replied and it was not clear whether the issue was exactly the one described in the title.

This is happening between different versions of ubuntu.
There are bug reports about this for both NVidia and ATI cards. So it's not specific to a graphics driver.
The only common factor is compiz.

So i've marked all the duplicates and changed the description.

description: updated
Changed in desktop-effects:
status: Invalid → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

Ralf:
No! This bug was about the system being locked up when AIGLX was being used on NVIDIA drivers. The applet crashing is nowhere near as severe as this and is a separate issue (as the fact it happens on hardware different to that in this bug will attest). Please change this bug back and unset the duplicates.

Sitsofe Wheeler (sitsofe) wrote :

(Further it should be "impossible" for userspace only programs like compiz to make a system lockup in this fashion. If starting a normal program can cause such a crash then it is usually indicative of either kernel side issues or an issue in a privileged app like X that is directly programming the hardware or faulty hardware or etc)

Changed in desktop-effects:
status: Confirmed → Invalid
description: updated

Thanks for changing this back Ralf. I know the problems look similar but my guess is that this is either a Xorg, kernel, kernel graphics driver issue.

@Sitsofe

Since you feel so strongly, i have reverted it back.

But although you are right, it should not be possible to lock the system up for a userspace app, thats far from the current situation with graphics. Several xserver extensions and usage make it crash (look at all the bugs).

The bug is obviously not in the user-space app. But we can't fix the nvidia or ati driver..
Where can a workaround be placed? Well, compiz-fusion is the common factor. A workaround was already in place in Beryl (using nvidia- and ati-extensions instead of generic xserver-extensions).

So the bug is in the userspace app, but the workaround might be placed there.

Ralf:
The bugs will still be there and I think if it isn't compiz-fusion triggering it then it will be something else (perhaps the KDE4 compositor). The quickest workaround is not to use AIGLX but I don't think that's what you're looking for. I do see what you're saying though (as I believe compiz-fusion has had a beryl workaround for some of the NVIDIA black screen issues added) but in that case I think you are better off filing a new bug report on compiz-fusion asking for only that (and then posting a link to the new bug here) rather than changing bugs talking about the underlying issue. What's your take on this?

I'm acutely aware of the bugs (maybe it will help if you take a look at the bugs I've commented on via my person page) but I guess my thinking is that it just means the NVIDIA and ATI need to be contacted to see if they can work out where the bug lies and if they can generate a fix (or at least talk to those who can).

The intent of my comments was to inform and have the issue resolved as quickly as possible (hence the followup userspace/system lockups explanation) but I see from your reaction that this was not the case. What should I have done (I'll keep this in mind for future comments)?

jaimesilva (jaimealbsilva) wrote :

I'm also having this problem in a Compaq Presario F572US with Ubuntu 7.04 (Feisty). I removed the usplash package, the splash kernel boot option and added the vga=normal boot option and now I can swith to virtual console (Ctrl-Alt-F1) and back to X (Alt-F7) only if I am using the metacity (normal) window manager but if I enable compiz (composite manager) the problem comes back (blank screen with mouse pointer and must reset the machine).

Here is the hardware info:

$ uname -a
Linux f572us 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
$lspci
...
00:05.0 VGA compatible controller: nVidia Corporation C51 PCI Express Bridge (rev a2)
...

I can't make suspend work with any window manager :'(

On 2007-02-28, I filed Bug #135412 (KDE with Compiz and nVidia crashes hard on session log-out on an up-to-date Gutsy Gibbon) which, it has been suggested, is probably related to this bug.

The most recent dist-upgrade, which included new compiz packages and new kernel packages has brought on the frozen white screen as soon as KDE loads. I am not able to do anything at that screen except Ctl-Alt-F1 to a terminal console from which I restart the X server. I am able to work normally in XFCE.

The current basic specs for kernel and video are:

bruce@Herodotus:~$ uname -a
Linux Herodotus 2.6.22-10-386 #1 Wed Aug 22 07:43:24 GMT 2007 i686 GNU/Linux
bruce@Herodotus:~$ lspci
...
01:00.0 VGA compatible controller: nVidia Corporation NV36.2 [GeForce FX 5700] (rev a1)
...

Installed nvidia packages are:
ii nvidia-glx-new 100.14.11+2.6.22.3-10.1 NVIDIA binary XFree86 4.x/X.Org 'new' driver
ii nvidia-glx-new-dev 100.14.11+2.6.22.3-10.1 NVIDIA binary XFree86 4.x/X.Org 'legacy' driver development files
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files
ii nvidia-new-kernel-source 100.14.11+2.6.22.3-10.1 NVIDIA binary 'new' kernel module source

Note that these include new nVidia "100-series" drivers

Same problem here on an ASUS A6K-Q014H:

hibernate work only when compiz is unactivated (it work but fail on resume when compiz is activated)

The graphic driver is nvidia-glx ... and the graphic card is an Geforce 6200 Tc

This is probably a nvidia-glx issue or a compiz one. (I am not sure but I remember it worked with beryl on edgy ...)

Nico (nico-rdo) wrote :

Same problem here.

Login user 1,VT 1, with full desktop effects.

Fast user switch to user 2, VT 2, who has no effect.

Fast user switch to user 1, on VT 1 -> black screen with responding mouse cursor only.

CTRL+ALT+FKEY for VT switch not operational

The only solution I have at the moment to come out of this is a system reset. I hate doing those...

No password set for any user.

Up-to-date Gutsy from new install, nvidia-glx-new.

This used to work well on the same machine, with Feisty, manual nvidia driver (9755 I believe) and git packages of compiz/fusion (Trevino).

This is a rather annoying bug that I consider a blocker either for the Fast-User switching by default, or for the Desktop effect by default. I do not understand its medium importance.

I saw the concept work, so there is a way to fix this (wishful thinking?), now is the time before the beta cycle!

I am clearly willing to help with testing and any additional info needed.

Nico

Nico (nico-rdo) wrote :

just subscribing

Richard Ayotte (rich-ayotte) wrote :

Same problem here. nVidia states "You can only run one X server per GPU." http://www.nvnews.net/vbulletin/showpost.php?p=1379365&postcount=14

I think this bug should have a high priority since Desktop Effects will be enabled by default and will affect a large number of users.

In this case, we might be better off just disabling this behaviour by default for nvidia-users and displaying a message about why. Which a message about explaining why, and which products from which vendors do support this feature.

Sitsofe Wheeler (sitsofe) wrote :

Regarding the "One X per GPU" comment: It is not 100% clear whether that comment only covers running two X servers simultaneously off the same GPU (e.g. one card running two different X servers on two different monitors simultaneously) or whether that covers the user switching scenario too (two X servers on the same GPU but not not necessarily changing the screen the same time but rather co-operatively). Someone will have to explicitly ask NVIDIA what that statement does and doesn't cover (ideally with examples).

If NVIDIA indicate that the later case is not supported (and can say why) and they do not wish to hear about issues arising from it, then I would recommend a new bug report be created separately from this. That way VT switching issues are kept separate and people having user switching issues on the NVIDIA binary only drivers are at least informed about its situation.

Jan de Mooij (jandemooij) wrote :

From the release notes of the new nVidia driver (http://www.nvnews.net/vbulletin/showthread.php?t=98635):

* Fixed a problem causing X to render incorrectly after VT switches with composited desktops.

Is this the same bug?

Thanks

Vivian Stewart (vivichrist) wrote :

that particular bug seems to have been quashed for me I can switch between VT's and X. where as before I could switch to any VT and get a blank screen from which I could not return from and either had to push power button or CTRL+ALT+DEL or hard reset.
I have amd64 gutsy though and used envy to to compile drivers for generic and rt kernels.

Nico (nico-rdo) wrote :

the new nvidia drive seems to have fixed it for me.

Nico

Philip Kovac (pkovac) wrote :

Same problem, amd64 gutsy, nvidia GeForce 8500GT, using the gutsy nvidia-glx-new package. With compiz enabled via the Appearance dialog, on hopping to a vterm and back to the X session, I get a black screen, with only the mouse responsive. I believe with this issue I've been able to use alt+sysrq+k to get the machine back, though I may be confusing that with another issue I had (which I will file a separate bug for.) If there is any information I can provide to help resolve this, I would be glad to help.

Olivier Cortès (olive) wrote :

Here on Gutsy x86_64 (nVIDIA Quadro FX360M), the latest nvidia-glx-new (the latest dist-upgrade indeed) fixes the bug. When I switch to VT then back to X, I get the black screen with responsive mouse (like the bug), but one second or two after, the screen gets repaint and everything is back fine.

Didn't test on Gusty i386 if the bug is corrected or not (i definitely switched to x86_64 today), but it was triggered while the machine was running Gutsy i386.

Matt Price (matt-price) wrote :

This bug was fixed for me (gutsy/generic i386) for a couple of days, is now broken again, presumably after recent updates. let me know if more info will help.

I'm having the exact problem described by Nico in comment #32 if I try to switch users with compiz enabled in gutsy.
If I disable Sync to VBlank - i get the white screen issue described above (about 90% opaque) and typing my password gets rid of it.
If i disable compiz altogether - no problems.

This is all in the latest gutsy, with all updates.

Btw, is this the same bug as #135809 ?

Also, shouldn't this bug be of very high importance - since the Fast User Switch applet is enabled by default in gutsy, many people will be exposed to user switching who were maybe not aware of that before - only to have it crash, especially as compiz is enabled by default as well.

On Tue, 2007-10-02 at 02:41 +0000, Matthew Vermeulen wrote:
> Also, shouldn't this bug be of very high importance - since the Fast
> User Switch applet is enabled by default in gutsy, many people will be
> exposed to user switching who were maybe not aware of that before - only
> to have it crash, especially as compiz is enabled by default as well.
>
except that compiz won't be enabled by default on nvidia, will it? i
thought that would only happen on systems where compositing is
suppported by free drivers.

--
Matt Price
History Dept
University of Toronto
<email address hidden>

Compiz will not be enabled 'out of the box'. However, every user will be practically walked through the process of installing the appropriate proprietary drivers by the Restricted Drivers Manager, so it would be safe to assume (imho) that the average user with an nvidia card will have compositing enabled...

Jeremy Visser (jeremy-visser) wrote :

I can still reproduce this bug while running Compiz on Gutsy x86_64 with the nvidia-glx-new package. Switch to VT1, back to VT7, and I get a black screen with only a mouse pointer.

I think this is a _very_ big problem, because as Matthew Vermeulen stated, the FUSA applet is enabled by default, and have experienced this bug with all the computers in my house. I think this is a very embarrassing issue for Ubuntu, even if it is technically an NVIDIA bug.

Is it possible/feasible to disable Compiz before switching?

Jeremy Visser (jeremy-visser) wrote :

So yeah, 100 series driver still has the problem for me on a 7600GT.

@Matt Price

Compositing _will_ be enabled by default.
But Nvidia 3d driver will NOT be enabled by default.

So, at the first login, the restricted drivers manager pops up.
It ask, "do you want to install NVidia driver?"
User clicks yes. It installs, it asks for a reboot. User reboots.

User will now login the 2nd time. Compositing is now already enabled.

==========================================

Possible fix (but MAJOR HACK)
Only on NVidia hardware: Make switching users go back to the login screen.
This for some weird reason does works. (same as System -> Shutdown .. -> Switch User)

Another thing: why enable the fast-user-switch thingie by default?
Or better put: why show it when only one user is configured?
Can't the user-switch-applet to patched to just hide itself unless there is more than one desktop user?

Jeremy Visser (jeremy-visser) wrote :

Ralf, no point in hiding the applet, seeing as though it doesn't let you switch users with yourself. Go and have a look — with only one user on the system, you click it, and the only dropdown menu item that pops up is your own name, which is disabled.

I'm talking about a multi-user system with all the users running Compiz. When trying to switch users, the system appears to lock up. (I know it's not _really_ a lockup, and a kill -9 on compiz will fix it, but it's undesirable nonetheless.)

Matt Price (matt-price) wrote :

On Tue, 2007-10-02 at 12:33 +0000, Jeremy Visser wrote:
> Ralf, no point in hiding the applet, seeing as though it doesn't let you
> switch users with yourself. Go and have a look — with only one user on
> the system, you click it, and the only dropdown menu item that pops up
> is your own name, which is disabled.
>
> I'm talking about a multi-user system with all the users running Compiz.
> When trying to switch users, the system appears to lock up. (I know it's
> not _really_ a lockup, and a kill -9 on compiz will fix it, but it's
> undesirable nonetheless.)
>

my experience is that often, it's impossible to enter kill -9 even on a
console, so unless you have another machine and ssh, you're out of luck.

matt

--
Matt Price
History Dept
University of Toronto
<email address hidden>

I second the "impossible to kill -9" experience. It is quite a humbling
experience to login to the kids' Windows XP, putty and sudo reboot.

Rich

On 10/2/07, Matt Price <email address hidden> wrote:

> my experience is that often, it's impossible to enter kill -9 even on a
> console, so unless you have another machine and ssh, you're out of luck.
>
> matt
>
> --
> Matt Price
> History Dept
> University of Toronto
> <email address hidden>
>
> --
> [nvidia-glx] Switch user/switch VT causes lockup with
> compiz/beryl/desktop-effects
> https://bugs.launchpad.net/bugs/88152
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On 10/2/07, Richard Ayotte <email address hidden> wrote:
>
> I second the "impossible to kill -9" experience. It is quite a humbling
> experience to login to the kids' Windows XP, putty and sudo reboot.
>
> Rich

And to look at it another way, your average user will not have any idea how
to do that, or even think of trying to ssh into their pc.

--
Matthew Vermeulen
http://www.matthewv.id.au/
MatthewV @ irc.freenode.net

Progdis (progdis) wrote :

After todays update it works.
compiz 1:0.6.0+git20071002-0ubuntu1

On 10/3/07, Progdis <email address hidden> wrote:
>
> After todays update it works.
> compiz 1:0.6.0+git20071002-0ubuntu1
>
> --
> [nvidia-glx] Switch user/switch VT causes lockup with
> compiz/beryl/desktop-effects
> https://bugs.launchpad.net/bugs/88152
> You received this bug notification because you are a direct subscriber
> of the bug.
>
Yep seems to be working :) after a fashion anyway - I still see the white
screen thingy, but at least this is an improvement :)

On 10/4/07, Matthew Vermeulen <email address hidden> wrote:
>
> Yep seems to be working :) after a fashion anyway - I still see the white
> screen thingy, but at least this is an improvement :)

Looking closer, it appears that what's actually been done is to disable
syncing to vblank by default, or at least for nvidia cards. Not ideal, but i
suppose it will fix it for the use cases discussed above...

Still, it would be nice to see this working with sync to vblank, which looks
much nicer..

Jon Ramvi (ramvi) wrote :

Using fglrx, my computer is brought to a full stop if I log into an account, switch to an other and log out.
Is this a duplicate of this or should I make a new bug report?
Can I create some kind of logs to help out?

almost certainly a new problem, as our issue appears to relate directly
to a nvidia bug.

m

On Mon, 2007-11-05 at 12:29 +0000, Jon Ramvi wrote:
> Using fglrx, my computer is brought to a full stop if I log into an account, switch to an other and log out.
> Is this a duplicate of this or should I make a new bug report?
> Can I create some kind of logs to help out?
>
--
Matt Price
<email address hidden>

unggnu (unggnu) wrote :

Suspend, resume and console switching works fine for me with current Ubuntu Hardy but I still got the white screen problem. Entering password works but this is still an annoying bug.
VGA compatible controller: nVidia Corporation GeForce 8800 GTS 512 (rev a2)

Maybe we should create a different bug report for the white screen issue since this bug seems to be fixed.

Timo Aaltonen (tjaalton) wrote :

Ok, closing this one.

The white screen bug is bug 160264.

Changed in linux-restricted-modules-2.6.22:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers