Ubuntu

Canon inkjets (and some other printers) print only half of the last page after 20120801 upgrade to v1.5.3-0ubuntu2

Reported by Paul R. on 2012-08-03
116
This bug affects 20 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Critical
Unassigned
Precise
Critical
Till Kamppeter

Bug Description

My Canon i560 was working fine until the update two days ago. Now it fails every single job, printing half a page and then ejecting the page when a USB reset is issued. Same printer works fine when printing through Windows in Virtualbox with USB passthrough.
Summary: the USB backend "improvements" have rendered my printer useless with CUPS. Unloading the usblp module makes no difference - the USB reset is what aborts the print job.

[ 224.008042] usb 3-1: reset full-speed USB device number 3 using uhci_hcd
[ 224.161701] usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04A9 pid 0x108

Kubuntu 12.04

[IMPACT]

Everyone with a Canon inkjet connected to USB and also users of some other printer models on USB get printouts with the last page being incomplete. This happens for every job.

For everyone with a Samsung printer the problem of bug 995111 shows up again.

[TESTCASE]

Unfortunately, for reproducing this bug one needs the actual hardware.

Connect a Canon inkjet (or other models mentioned in this bug report) to the USB and print from a completely updated Precise system. The last page of each job will come out incomplete.

Connect a Samsung printer to the USB and print from a completely updated Precise system. You will get printouts with weird characters (at least from the second job on) as described in bug 995111.

After installing the proposed package all these problems should disappear.

[Regression Potential]

Regression risk is very low. The fix is not doing the USB device reset on the printer after the job for most printers. The fix contains an exception rule for Samsung printers and Prolific Technology USB->Parallel adapters, to avoid reoccurring of bug 987485 and bug 997040. It is still possible that some printers are treated incorrectly in terms of whether they need a reset after the job or not. As most printers work both with and without reset this risk is very low. All reported problems are solved with the proposed fix.

*******
dpkg -l "*cups*"|grep ii
ii bluez-cups 4.98-2ubuntu7 Bluetooth printer driver for CUPS
ii cups 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - server
ii cups-bsd 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - BSD commands
ii cups-client 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - client programs (SysV)
ii cups-common 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - common files
ii cups-filters 1.0.18-0ubuntu0.1 OpenPrinting CUPS Filters
ii cups-ppdc 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - PPD manipulation utilities
ii ghostscript-cups 9.05~dfsg-0ubuntu4.1 interpreter for the PostScript language and for PDF - CUPS filters
ii libcups2 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - Core library
ii libcupscgi1 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - CGI library
ii libcupsdriver1 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - Driver library
ii libcupsfilters1 1.0.18-0ubuntu0.1 OpenPrinting CUPS Filters - Shared library
ii libcupsimage2 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - Raster image library
ii libcupsmime1 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - MIME library
ii libcupsppdc1 1.5.3-0ubuntu2 Common UNIX Printing System(tm) - PPD manipulation library
ii printer-driver-hpcups 3.12.2-1ubuntu3.1 HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii python-cups 1.9.61-0ubuntu2 Python bindings for CUPS
ii python-cupshelpers 1.3.8+20120201-0ubuntu8.1 Python modules for printer configuration with CUPS
**********

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Changed in cups (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Changed in cups (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Critical
tags: added: regression-update
Till Kamppeter (till-kamppeter) wrote :

It seems that with the newest version of the USB CUPS backend as it is currently used in the Precise CUPS SRU (1.5.3-0ubuntu2) and in CUPS 1.5.4 and 1.6.x upstream (1.6.0 currently in Quantal) Canon printers do not work any more, having the last portion of the last page cut off.

One of the changes in the new USB backend is that a port reset is done in the end of the job to clean up. This reset fixes other bugs and does not cause any problem for non-Canon printers. I will add a quirk handler to the USB backend which suppresses the reset for Canon printers.

See also the upstream bug report http://www.cups.org/str.php?L4155

Smee (jusmee) wrote :

Actually, it got me too, but my printer is an Epson NX130 - i.e. NOT a Canon. I've pulling my hair out all day, then I found this. I have been trying single page printouts, and been getting half a page only. I presume the reset in the log below (captured while printing a document) is what this bug is about?

Aug 6 09:29:57 Ubuntu-desktop kernel: [ 776.596628] usblp0: removed
Aug 6 09:30:18 Ubuntu-desktop kernel: [ 797.865308] usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0883
Aug 6 09:30:18 Ubuntu-desktop kernel: [ 797.865386] usblp0: removed
Aug 6 09:30:18 Ubuntu-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2:1.1/usb/lp0
Aug 6 09:30:18 Ubuntu-desktop udev-configure-printer: unable to access /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2:1.1/usb/lp0
Aug 6 09:30:18 Ubuntu-desktop kernel: [ 797.976027] usb 3-2: reset full-speed USB device number 2 using uhci_hcd
Aug 6 09:30:18 Ubuntu-desktop kernel: [ 798.127176] usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0883
Aug 6 09:30:18 Ubuntu-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2:1.1/usb/lp0
Aug 6 09:30:18 Ubuntu-desktop udev-configure-printer: device devpath is /devices/pci0000:00/0000:00:1a.0/usb3/3-2
Aug 6 09:30:18 Ubuntu-desktop udev-configure-printer: Device already handled

Till Kamppeter (till-kamppeter) wrote :

As the problem was also observed on an Epson I will let the backend only do the reset after a job where the reset fixes a reported bug, currently bug 987485 and bug 997040. For all other printers no reset will be sent.

Changed in cups (Ubuntu):
status: Triaged → In Progress
Changed in cups (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.6.1-0ubuntu1

---------------
cups (1.6.1-0ubuntu1) quantal; urgency=low

  * New upstream release
     - The Japanese and English web interface headers were swapped (CUPS STR
       #4148)
     - Documentation fix (CUPS STR #4149)
  * debian/patches/add-ipp-backend-of-cups-1.4.patch: Refreshed with quilt.
  * debian/patches/usb-backend-reset-after-job-only-for-specific-devices.patch:
    Let the USB backend only send a clean-up reset after the job if it is
    really needed (LP: #1032456).
 -- Till Kamppeter <email address hidden> Mon, 06 Aug 2012 12:52:30 +0200

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
Ishaan Dalal (izx) wrote :

So, any idea when can we expect a fix for this in Precise? Thanks!

Till Kamppeter (till-kamppeter) wrote :

Currently we are in an SRU (Stable Release Update) freeze for Precise 12.04.1. To give you all the possibility to get your problem fixed as soon as possible and also to already test my fix now I have made available fixed CUPS packages on my PPA (Personal Package Archive). The package version is 1.5.3-0ubuntu3~ppa1. To install packages from my PPA go to

https://launchpad.net/~till-kamppeter/+archive/ppa

and follow the instructions of the section "Adding this PPA to your system", then do a system update, either with update-manager or via the following commands in a terminal window:

sudo apt-get update
sudo apt-get upgrade

Please tell here whether your problem got solved or not and stay tuned for further instructions, also if the test was successful, as you will have to test the official update later.

Changed in cups (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Till Kamppeter (till-kamppeter)
summary: - Canon i560 prints half a page after 20120801 upgrade to v1.5.3-0ubuntu2
+ Canon inkjets (and some other printers) print only half of the last page
+ after 20120801 upgrade to v1.5.3-0ubuntu2
Chris Spencer (headscratcher) wrote :

Just tried it and it works on my Canon iP5200!

Will update if there are any issues as soon as I have given it a good testing!

Till - thank you very much - I can turn off Virtualbox now!!!

That's great speedy work! You hero!

Changed in cups (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Till Kamppeter (till-kamppeter) wrote :

Uploaded proposed fix for Precise to -proposed. As soon as the fix gets approved, we will post instructions for installing it here. Please test it then (independent whether you have tested my PPA from comment #7 already) as only with your feedback the package will make it into the official updates for Precise.

To the SRU team: debdiff attached.

description: updated
JVecht (justvecht) wrote :

Tried the fix from the PPA as in comment #7.

Problem solved on Canon MP160. Thanks! I will follow posts and test again when this fix is approved.

Hello Paul, or anyone else affected,

Accepted cups into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups/1.5.3-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Scott Kitterman (kitterman) wrote :

Note to those who tested the PPA package - We still need verification that the package in precise-proposed fixes your problem so we can release it to all users.

kopiwe (kopiwe) wrote :

Also happens to me with a canon printer/scanner.

I found a quick and dirty solution - Let the printer print the document with 2 copies. The first will be a blank page, but the second one will be complete. Only tested with pdf.

kopiwe, please try the proposed package of comment #11, thanks.

Nils Durner (ndurner) wrote :

1.5.3-0ubuntu3~ppa1 does not fix https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1032385 (which may be related). Printing two copies also does not work for me (it continued to print about one and a half lines of text from the first page onto the second page and ejected it).

@Nils: Are you experiencing a regression from what was in 12.04 before or has
it always been broken on 12.04 and continues to be broken?

Nils Durner (ndurner) wrote :

I can't really tell because I don't print that often. It may well be that
it never worked in 12.04.

tags: added: verification-done
removed: regression-update verification-needed
Scott Kitterman (kitterman) wrote :

@Chris: Does that mean the precise-proposed package works for you?

tags: added: regression-update
Chris Spencer (headscratcher) wrote :

Hi Scott -

Yes the Precise proposed package installed and working OK and as expected on a Canon iP5200.

Previously it was exhibiting the bug behaviour as described.

ian brodie (frenchian) wrote :

Till, just to say the revised package fixes the problem on my Canon MP270. Thanks

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.3-0ubuntu3

---------------
cups (1.5.3-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/usb-backend-reset-after-job-only-for-specific-devices.patch:
    Let the USB backend only send a clean-up reset after the job if it is
    really needed (LP: #1032456).
 -- Till Kamppeter <email address hidden> Mon, 6 Aug 2012 18:49:01 +0200

Changed in cups (Ubuntu Precise):
status: Fix Committed → Fix Released

Scott, Nils Durner has problems with both cups 1.5.3-0ubuntu2 and 1.5.3-0ubuntu3, so there is no regression caused for him by this SRU. It is not yet clear whether Precise's original package, cups 1.5.3-0ubuntu1 worked for him, so we do not know whether he is suffering another regression in cups 1.5.3-0ubuntu2 which is not fixed by this SRU.

Nils Durner (ndurner) wrote :

Update: it got much better with the precise-proposed package. I was able to print 8 print jobs before the printer hung again, and another four jobs after resetting the printer (by pulling the plug), with the "connecting-to-device" message only appearing once (without any problems on the printer's side).

Smee (jusmee) wrote :

1.5.3-0ubuntu3 has fixed this problem on my Epson NX130 too. Many thanks to all!!

Paul R. (paul-nz) wrote :

Just another confirmation: my i560 is working perfectly again. Thank you for your work, we appreciate it.

Nokir (nokir) wrote :

Canon IP4200 works. Thanks

Renato Rolandi (rewasp1973) wrote :

Canon PIXMA MP 210 works well

Thank you

Ridgeland (rambutan1) wrote :

Just used synaptic package manager to download and install
cups (1.5.3-0ubuntu3)
in Ubuntu 12.04
Now my Canon i560 prints full page again.
Thank You!

JVecht (justvecht) wrote :

Canon PIXMA MP 160 works OK now als after update through synaptic.

Thank you!

csola48 (mail-csordaslaszlo) wrote :

Healed likewise at me the Canon i550, but invariably it i850 is going out with driving one...

Kees van den Broek (kvdb-kvdb) wrote :

My Canon still prints the first half of the page, then 'hangs' until I power off and on again:

lsusb:
Bus 002 Device 014: ID 04a9:10b6 Canon, Inc. PIXMA iP4300 Printer

dpkg -p cups
...
Version: 1.5.3-0ubuntu3

Kees van den Broek, your problem is bug 1035130, please follow the instructions of comment #6 there and report there whether and how you got it working. Thanks.

I have a Canon MP180 (Ubuntu 12.04 64 bits) which used to work just fine before this "prints only hlaf page" bug crept in through a recent cups update. I print quite regularly, so I am sure that this update about usb-reset was what caused the printer to malfunction (half pages). I updated again to 1.5.3-0ubuntu3 a couple of days ago and that fixed the "half page" problem but introduced a new bug. My printer completes printing a page, ejects it out but the job stays in the print queue saying "Rendered" and the printer will not shut down when I power it off. The printer hangs while showing "SHUTTING DOWN..." indefinitely in its LCD display. I need to pull the power cord on the printer and power it back on again to clear this stuck state. I cannot issue another print job either without doing this power-reset on the printer. I would be glad to help diagnose this problem, please let me know what I need to provide.

Attaching my CUPS error log.

Kaushik Kannan, Can you cancel all jobs via the command

cancel -a

turn off and turn on the printer (or disconnect and reconnect the power cord), and then run

lsusb

and post the output here and after that run

lpadmin -p <printer> -o usb-unidir-default=true

After that try to print again. Does it work now?

Thank you for the reply Till Kamppeter. However, after a couple of reboots of the desktop and pulling the power cord on the printer, I don't have the hanging problem any more. I did a linux kernel update (to 3.2.0-29-generic) inbetween the reboots but I don't think that could have fixed it. Though it works now, I removed the printer and re-added it to my Printers list and it still works fine.

I have not set usb-unidir-default=true; I checked this under Properties->Job Options->Other Options (Advanced). I did issue a couple of cancel -a. lsusb says "Bus 001 Device 009: ID 04a9:1715 Canon, Inc. MP180 Storage"

Changed in cups (Ubuntu Precise):
status: Fix Released → In Progress
Changed in cups (Ubuntu):
status: Fix Released → Triaged
description: updated
tags: removed: verification-done

André, I have uploaded the fix (identical to the package on my PPA) to the precise-proposed repository now, as soon as it gets approved, please test it and tell here whether it works for you. These feedback is essential for us to make the fix an official update.

SRU/Release team: debdiff attached and description updated.

Applied the fix for the Samsung problem to the Debian BZR repository of CUPS, so that it goes into the next Quantal package of CUPS.

Changed in cups (Ubuntu):
status: Triaged → Fix Released

Updated also the upstream bug report http://www.cups.org/str.php?L4155

Till Kamppeter,

I am out of town right now (on vacation). I will be back in September, when
I will be glad to test the fix.
Just a note: the bug I have seems to be somewhat different from this
because when the printer prints, everything is ok. The problem is: only
some pages are printed, but those pages (which got printed) are printed
fully. When I send some pages to print, sometimes it gets printed,
sometimes it does not. It is like I have never sent the page to print.

Best regards.

Hello Paul, or anyone else affected,

Accepted cups into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups/1.5.3-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Everyone reading this,

please test the new CUPS update as described in comment #42 and check whether you are able to print. Does your Canon print the last page completely? Does your Samsung print more than one job in a row without printing pages with weird characters or error messages? Are you able to print through a Prolific Technology USB->Parallel adapter?

Please give all your feedback here in this bug report as soon as possible, best in a few minutes but at least today, as it is about fixing your problem in Ubuntu Precise 12.04.1 due on Thursday.

Dimitri John Ledkov (xnox) wrote :

Samsung CPL-325 attached via USB to the CUPS server. Printing from the laptop over the network fails with ubuntu3, passes with ubuntu4.

Nokir (nokir) wrote :

I did a quick test on Canon IP 4200. Last page is complete. So far I don't see a difference between ubuntu3 and ubuntu4.

Nokir, thank you very much for testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.3-0ubuntu4

---------------
cups (1.5.3-0ubuntu4) precise-proposed; urgency=low

  * debian/patches/usb-backend-reset-after-job-only-for-specific-devices.patch:
    The clean-up reset after the job was not actually sent for Samsung printers
    (LP: #1032456).
 -- Till Kamppeter <email address hidden> Mon, 20 Aug 2012 10:17:01 +0200

Changed in cups (Ubuntu Precise):
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed
Paul R. (paul-nz) wrote :

Another test: Canon i560 still working good.

Ridgeland (rambutan1) wrote :

Another test: Canon i560 still working for me with ...4

Arie Maaskant (arimaask) wrote :

It does not work for a Brother HL-1430. See bug #1038695

Till Kamppeter,

I am sorry I could not test it before (because I was on vacation). I've tested today, but the problem persists (some times the job are printed and some times not). I've added your ppa and updated no success. Then I've deleted the print and added again. Still no success.

Best regards.

Andre, you probably have a completely new bug. Please report a new bug and follow the instructions of the sections "USB printer", "CUPS error_log", and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems and also attach your /var/log/syslog file. Thanks.

Ralph Myers (ralph-john-myers) wrote :

I have 12.04 (Xubuntu) and have cups (1.5.3-0ubuntu4).
Rebooted a few times as well.
My Canon MP500 and 98% of the time it hangs halfway through the last page.
Printer becomes unresponsive and needs to be power cycled.

Looks like this bug is still there.

Let me know if there is anything I can do to assist with troubleshooting this problem.

Ralph Myers. can you run the command

lsusb

in a terminal window and post the output here.

Can you then do the following:

In a terminal window, run the command

lpadmin -p <printer> -o usb-unidir-default=true

with <printer> being the name of your printer as displayed by the "lpstat -p" command.

Now turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

If not,

run

lpadmin -p <printer> -R usb-unidir-default

and then

lpadmin -p <printer> -o usb-no-reattach-default=true

Again, turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

If not, try

lpadmin -p <printer> -o usb-no-reattach-default=true
lpadmin -p <printer> -o usb-unidir-default=true

and turn off and turn on your printer, then try to print several jobs. Does this solve the problem?

Please tell what works for you.

If nothing works, reset all to defaults via

lpadmin -p <printer> -R usb-no-reattach-default
lpadmin -p <printer> -R usb-unidir-default

Ralph Myers (ralph-john-myers) wrote :

Hi Till,
Quick summary and then the data dumps:
1) Applied lpadmin -p <printer> -o usb-unidir-default=true and power cycled
2) It printed successfully about 6 times. No errors. YAY!
3) I then reset all defaults and power cycled printer again
4) It then failed half way through last page of a six page document.
Please note that I have a very long USB cable maybe 15m.

Dumps as requested. There seems to be a keyring problem but only a warning.

panamagold@panamagold:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 004: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 007 Device 002: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 006: ID 04a9:170c Canon, Inc. PIXMA MP500 Scanner

lpstat -p
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-Wk26KK/pkcs11: No such file or directory
printer Canon-MP500 is idle. enabled since Sun 23 Sep 2012 17:41:01 EST

Thanks for your help!
Let me know if there is anything else I can do.

Thanks, the behavior is like with many other Canon printers and I have added an appropriate exception rule to the CUPS USB backend in Quntal. I t is not decided yet whether we issue another Precise SRU with all collected new exception rules. For the time being stay with

lpadmin -p <printer> -o usb-unidir-default=true

You only need to do the setting once, it survives reboots.

Erik Ackermann (domohawk) wrote :

I think this bug may have reappeared. This bug starting hitting my Canon PIXMA MP450 today with the exact same symptoms (partial page printing then completely hanging, USB transaction timeouts, etc..) however I am running latest Quantal with cups version 1..1-0ubuntu11 which should include the fix.

Finally found this thread and the "lpadmin -p Printer -o usb-unidir-default=true" workaround finally got my simple page to print. I tested setting the unidir-default false/true a couple times and same result every time.

Is there any further debug I can provide?

Erik Ackermann (domohawk) wrote :

Aha, it appears my version number is missing from the quirk rules fix, filing a new bug to have it added.

Erik, can you run the command

lsusb

with your Canon PIXMA MP450 connnected and turned on? Thanks.

KennoVO (kenno-xs4all) wrote :

Confirmed with Canon MP520 on Precise . Tested very thoroughly with all different combinations of flags.
Didn't work: lpadmin -p Canon-PIXMA-MP520 -o usb-unidir-default=true
Didn't work: lpadmin -p Canon-PIXMA-MP520 -o usb-no-reattach-default=true
Did work: both of the above flags set at the same time.

Details:
$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 014: ID 04a9:1724 Canon, Inc.
Bus 003 Device 003: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 13d3:5719 IMC Networks
Bus 003 Device 004: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 003 Device 005: ID 046d:c042 Logitech, Inc. G3 Laser Mouse
Bus 003 Device 006: ID 046d:c313 Logitech, Inc. Internet 350 Keyboard
Bus 003 Device 007: ID 0b95:7720 ASIX Electronics Corp. AX88772
Bus 003 Device 008: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port
Bus 003 Device 009: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 003 Device 010: ID 0d8c:0006 C-Media Electronics, Inc. Storm HP-USB500 5.1 Headset

My 2c: it very much sounds like the remedy to bug 987485 and bug 997040 is worse than the disease, and that the above 2 flags should be made the default rather than the exception.

Paul BROWN (frozenzia) wrote :

I believe I may have this bug as well, but not sure. At least the workaround

(sudo lpadmin -p <printer queue> -o usb-unidir-default=true)

seems to work beautifully.

I had created a separate bug for this (https://bugs.launchpad.net/bugs/1202631), and have included lots of logs, etc. there. Please let me know if I can provide more info. I'll add a note to that bug that it may be a repeat of this one.

Richard Vagg (richardjv) wrote :

Also affects canon pixma mx300

Using "sudo lpadmin -p <printer queue> -o usb-unidir-default=true" fixes the issue.

cups package version:
ii cups 1.5.3-0ubuntu8 Common UNIX Printing System(tm) - server

~$ lsusb
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 007: ID 04a9:1727 Canon, Inc. MX300 ser
Bus 003 Device 003: ID 04f2:b374 Chicony Electronics Co., Ltd
Bus 003 Device 004: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
Bus 003 Device 009: ID 0489:e04e Foxconn / Hon Hai
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Let me know if you need anything else to add the exception for this printer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments