Ubuntu

Keyboard shortcuts - Unity window placement shortcuts require a numpad

Reported by Jacob Johan Edwards on 2011-04-05
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Marco Trevisan (Treviño)
compiz (Ubuntu)
High
Didier Roche
compiz-plugins-main (Ubuntu)
Undecided
Didier Roche
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The current key binding for window placement in Unity is`Ctl-Alt-[Numpad 0-9]` (see bug https://bugs.launchpad.net/ayatana-design/+bug/878820 ). This is great with a full keyboard, but on notebooks and netbooks the numpad is absent, so there is no keyboard support for tiling.

Ideally, additional bindings should be added for the most common window placements.

-----------------------------------------------------

Desired Solution:

Implement the following additional keybindings for window management

If a window is in the restored state:
- `Super-up` = Maximize the active window
- `Super-down` = Minimize the active window
- `Super-left = Semi-maximise the active window to the left
- `Super-right = Semi-maximise the active window to the right

If a window is in the maximised or semi-maximised state:
- `Super-up` = Maximize the active window (if currently maximised do nothing)
- `Super-down` = Restore the active window
- `Super-left = Semi-maximise the active window to the left (if currently semi-maximised to the left do nothing)
- `Super-right = Semi-maximise the active window to the right (if currently semi-maximised to the right do nothing)

Note the full set of Unity keybindings are defined in the following document https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit?hl=en_GB

Here's a separate comment for my opinion on a solution. I think the following additional bindings would be reasonable:

  `Super-up` -- Maximize the active window
  `Super-down` -- Minimize the active window
  `Super-left -- Tile the active window to the left
  `Super-right -- Tile the active window to the right

These shortcuts fit Unity's use of the super key for window management, and roughly copy the mouse gestures used for tiling. Also, Unity could later overlay arrow keys on the active window while the super key is held, making tiling bindings more discoverable than the more feature-rich numpad solution.

Henry G (henry1337) wrote :

In addition to laptops and netbooks, a good share of keyboard enthusiasts use tenkeyless layouts or even smaller ones (such as the famous Happy Hacking Keyboard).

Alex Launi (alexlauni) on 2011-04-13
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
stianst (stianst) wrote :

I just found out about the window placement yesterday when I was using my workstation at home. It's the greatest thing ever! Imagine my disappointment when I got home on my laptop and this feature is completely non-existent!

I've got a proposal for a modification to the original shortcuts that I believe would work on both desktops and laptops.

Super-left-top - Place window in top left corner of screen.
Super-top - Place window in top half of screen.
Super-right-top - Place window in top right corner of screen.
Super-left - Place window on the left side of the screen.
Super-left-right - Center/Maximize the window in the middle of the screen.
Super-right - Place window on the right side of the screen.
Super-left-down - Place window in the bottom left corner of the screen.
Super-down - Place window in the bottom half of the screen.
Super-right-down - Place window in the bottom right corner of the screen.
Super-top-down - Maximize window.

stianst (stianst) wrote :

Is there any way to override the window placement keyboard shortcuts? I can't find them in keyboard shortcuts under settings.

Josh Benner (sjbenner) wrote :

If you download compiz settings manager (sudo apt-get install compizconfig-settings-manager), you can update the bindings in the grid plugin. The grid plugin can be found in the "Window Management" section.

Tv (tv42) wrote :

Changing the compizconfig grid plugin bindings doesn't seem to affect anything. I changed them to various different combinations, but none of the windows seem to react to the keypresses at all. Running 11.10 beta2, unity 4.20.0-0ubuntu2, compiz 1:0.9.6+bzr20110929-0ubuntu1.

John Lea (johnlea) on 2011-10-11
description: updated
tags: added: onew udo
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
John Lea (johnlea) on 2011-11-03
Changed in unity:
importance: Undecided → High
assignee: Sam Spilsbury (smspillaz) → Jason Smith (jassmith)
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2011-11-25
description: updated
Omer Akram (om26er) wrote :

I guess this is something for didrocks to change in compiz default settings or is something new being cooked for window management in the pipes? ;-)

Changed in unity (Ubuntu):
importance: Undecided → High
John Lea (johnlea) on 2011-12-12
description: updated
John Lea (johnlea) on 2011-12-12
summary: - Unity window placement shortcuts require a numpad
+ Keyboard shotcut - Unity window placement shortcuts require a numpad
John Lea (johnlea) on 2011-12-12
tags: added: keybinding
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - Unity window placement shortcuts require a numpad
+ Keyboard shortcut - Unity window placement shortcuts require a numpad

Tangentially on topic, I feel these keybindings could do with discoverability overlays. As in, when the user holds meta for longer than the launcher shortcuts display delay, the active window is overlayed with a visual indiation of available (not-in-use) window placement shortcuts.

 - In a non-tiled state, show four arrows (up, left, right, down). Minimize arrow shaded differntly perhaps?.
 - When maximized, show three arrow (left, right, down). All colored similarly, since the down arrow will not minimize.
 - In left tiled state, show three arrows (up, right, down)
 - In right tiled state, show three arrows (up, left, down)

This would require a toy-size compiz plugin (1000 lines~, I would guess) which I'm fairly confident I could write on my own, and will start working on soon unless someone thinks this is a terrible idea.

Rough target visual attached.

John Lea (johnlea) wrote :

@j-johan-edwards; already done ;-) see bug https://bugs.launchpad.net/ayatana-design/+bug/855532

Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: backlog → 5.4.0
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Didier Roche (didrocks) on 2012-02-14
Changed in unity:
milestone: 5.4.0 → 5.6.0
Didier Roche (didrocks) on 2012-02-22
no longer affects: unity
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Didier Roche (didrocks)
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu5

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu5) precise; urgency=low

  * Change some keybindings as per design (LP: #878820, #891757, #751050)
    debian/patches/ubuntu-config.patch:
    - Show desktop is now Super + d
    - Super + Up maximize the window
    - Super + Down restore the window
    - Super + W initiate scale for all windows on current ws
    - Control + Alt + NumPad 5 is used to switch/restore maximize state
    - Control + Alt + NumPad 0 is used to minimize current window
    - Ensure we don't have any conficting keys anymore (LP: #922354)
  * 01_ctrl_alt_*tea*.patch:
    - Merged into ubuntu-config.patch, no reason to keep it separated
  * debian/compiz-gnome.gconf-defaults, debian/rules, debian/unity.ini:
    - Set the new plugin order with the incoming unity change as the default
 -- Didier Roche <email address hidden> Wed, 22 Feb 2012 13:44:25 +0100

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu3

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu3) precise; urgency=low

  * apply design changes for the keybindings (LP: #878820, #891757, #751050),
    debian/patches/ubuntu_config.patch:
    - Control + Alt + KP_5: don't center, used for toggling maximize state
      by core
    - Remove Control + Alt + KP_0 to not maximize, (used to minimize in core)
    - Super + Left, Right key to semi maximize and stack on left or right
    - Remove zoom in/out/box (like in oneiric and before). Those should be
      enabled in g-c-c with the a11y tools.
 -- Didier Roche <email address hidden> Wed, 22 Feb 2012 15:04:30 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) wrote :

good thing it was changed in compiz and not hacked into unity. Doing that cause bugs like bug 933776 for example.

Greg A (etulfetulf) wrote :

I think fixing this bug may have caused Bug 954797 (Unity shortcuts ctrl-alt-numpad4 and 6 do not work in Precise)

John Lea (johnlea) on 2012-03-30
summary: - Keyboard shortcut - Unity window placement shortcuts require a numpad
+ Keyboard shortcuts - Unity window placement shortcuts require a numpad
John Lea (johnlea) wrote :

Marking as fix released, but part of this bug still needs to be implemented. See bug #988997 for full details

Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: onew udo udp
no longer affects: compiz
Changed in unity:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.1.1
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers