Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed when a user presses and holds the Super key

Reported by John Lea on 2011-09-21
120
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Andrea Azzarone
unity-2d
High
Unassigned
unity-2d (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

Add keyboard shortcut hint overlay that is displayed when a user presses and holds the Super key.

See the attached design "Super_key_shutcuts_overlay.png". The overlay should use exact same border and transparent material as Alt-Tab. The keyboard shortcuts themselves are defined in the following google doc https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit?authkey=CLGG9NkJ&hl=en_GB

This should be displayed every time the user presses and holds the Super key, at the same time the Launcher keyboard shortcut hints are displayed. Releasing the Super key should hide this overlay, again at the same time the Launcher keyboard shortcust hints are hidden. If screen size is smaller than 1024*768, the shortcut window should not be displayed.

Also not that the design of the Launcher keyboard shortcust hints has been updated.

The design is attached to this bug, see "keyboard_shortcuts_overlay.png". Dimensions are detailed in attached image "keyboard_shortcuts_sizes.png"

---------------------------------

Accessibility notes:
- For users of screen readers, as soon as the Alt key is held down, a reading of the text should be piped directly through to the speech dispatcher. The reading should stop as soon as the Alt key is released.
- This overlay should be automatically disabled if sticky keys are turned on

Related branches

lp:~andyrock/unity/shortcut-hint
Merged into lp:unity at revision 1833
Marco Trevisan (Treviño): Approve on 2012-01-13
John Lea: Approve (design) on 2011-12-20
Tim Penhey (community): Approve on 2011-12-20
lp:~unity-2d-team/unity-2d/shortcut-hint-overlay
Rejected for merging into lp:unity-2d
Albert Astals Cid: Needs Fixing on 2012-03-30
Michał Sawicz: Needs Information on 2012-02-14
Florian Boucault: Needs Fixing on 2012-02-13
Gerry Boland: Pending requested 2012-02-13
Florian Boucault: Needs Fixing on 2012-02-10
Gerry Boland: Needs Fixing on 2012-02-03
Michał Sawicz: Needs Fixing on 2012-02-02
Albert Astals Cid: Needs Fixing on 2012-02-01
John Lea (johnlea) on 2011-09-21
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: onew udo
Omer Akram (om26er) wrote :

Confirmed as I am not sure whose plate this will fall into.

Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: Triaged → Confirmed
Changed in unity (Ubuntu):
status: Triaged → Confirmed
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-20
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Changed in ayatana-design:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-11-03
Changed in unity:
assignee: Didier Roche (didrocks) → Jason Smith (jassmith)
John Lea (johnlea) on 2011-11-17
description: updated
Dustin Kirkland  (kirkland) wrote :

It would be *awesome* if I could press Super+F1 and get this "help" on demand. Currently I have it set as my desktop background, but would much rather have some lovely art as my background, than a permanent unity cheat sheet :-)

Thanks!

Gerry Boland (gerboland) on 2011-11-18
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Changed in unity-2d (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (andyrock) wrote :

@John
Should the window be shown on each monitor?

Are we showing the Launcher in every monitor? Do we have a clear idea of
a primary monitor, or a monitor-with-focus?

Jason Smith (jassmith) wrote :

On 11/23/2011 02:23 PM, Mark Shuttleworth wrote:
> Are we showing the Launcher in every monitor? Do we have a clear idea of
> a primary monitor, or a monitor-with-focus?
>

Primary monitor is an interesting problem. We inside unity have an idea
of a primary monitor which is not directly tied to whatever X considers
the primary monitor. This allows us to easily move it to, for example,
follow the mouse, or window focus.

As we will be showing a launcher on every monitor, primary monitor needs
to be more cleanly defined. Currently I have been working off the idea
that primary monitor will more or less follow the mouse. This matches
the behavior that was shown in the multi-monitor demo (dash open on the
monitor the BFB was clicked on, or the monitor the mouse was on when you
press the super key). Alt-tab also observes this same primary follows
mouse behavior.

Jason

Also i just realized this was filed inside ayatana-design so I may have gotten way ahead of things here... sorry :)

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
John Lea (johnlea) wrote :
description: updated
John Lea (johnlea) on 2011-12-08
description: updated
Xi Zhu (xi.zhu) on 2011-12-08
description: updated
Omer Akram (om26er) on 2011-12-11
Changed in unity:
milestone: backlog → 5.2.0
quent57 (quent57) wrote :

Very good idea
But I don't see the middle clic on the top bar for switching between current window and last selected window.
Add it could be a great idea I think.

Satchit Bhogle (satchitb) wrote :

How long does Super need to be held? As it is, there is a fine balance required to use Super+# shortcuts: if you press it too quickly, the Dash is called up and the number or letter is entered into the search field. If the period required for the shortcut guide is too short, it may interfere with the use of Super shortcuts.

Alan Bell (alanbell) wrote :

Keyboard shortcuts are more useful to screen reader users than people who can use a mouse. This feature would be really useful to an orca user, however sadly this use-case does not appear to have been considered in the design, as this shortcut screen is only visible whilst pressing the super key there does not appear to be an opportunity to put focus on the panel and read it. Please can we stop breaking accessibility by not even thinking about it in the design phase, it is massively harder to fix it afterwards than it is to design it in from the start.

sticks (orawas) wrote :

quick question: frm what I understand, this overlay brings up static text. Wouldn't it be prudent to have it read the current shortcuts from the current cofiguration? IMO It would be better for those using gconf to tweak or future customization additions to unity. Just my 2 cents.

Andrea Azzarone (andyrock) wrote :

@sticks
It's not static text, it already read the configuration dynamically.

Alan Bell (alanbell) wrote :

Having built the overlay and tested with orca I can confirm that this is broken by design for non-visual users of Ubuntu. You can't navigate to the overlay because it won't accept focus and only displays when the super key is held down, so using the orca modifier keys to attempt to navigate won't work. Is there a way the design can be modified such that screen reader users can access this information that is particularly valuable to these users?

Alan Bell (alanbell) on 2011-12-11
tags: added: a11y
John Lea (johnlea) wrote :

Note: document defining the keyboard shortcuts has just been slightly updated, see https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit?hl=en_GB

John Lea (johnlea) on 2011-12-12
summary: - Add keyboard shortcut hint overlay that is displayed when a user presses
- and holds the Super key
+ Keyboard shotcut - Add keyboard shortcut hint overlay that is displayed
+ when a user presses and holds the Super key
John Lea (johnlea) on 2011-12-12
description: updated
John Lea (johnlea) on 2011-12-12
tags: added: keybinding

Hi everyone,

Will this be possible to add another level of shortcuts (e.g. numbers ) to miniature windows displayed when Win-W shortcut is pressed. This will allow users to jump from an application to an application ( e.g. terminals ) very quicly and without touching mouse. This little change will make my life ( I am busy-bee system administrator ) much easier.

I am a big fan of Ubuntu and I am seriously concerned that luck of consideration for power users in the current state of Unity implementation will force me to abandon Linux distribution I love and care about. I understand that this may not be a right place to make my suggestions, if not, I will greatly appreciate if you can point me to the right direction.

Kind regards, and thank very much for doing this important work!

Michael Hall (mhall119) wrote :

There is an additional Compiz plugin for Scale that let's you filter the Win-W windows by title as you type. But your request is really separate from this bug, and you should create a new one if you want to pursue it.

Alan Bell (alanbell) wrote :

the overlay is also broken for sticky keys, in the universal access settings turn on sticky keys which allows people to use modifiers and shortcut keys whilst pressing one key at a time, hit super and hold to bring up the overlay, then try and get rid of it. The thing just stays there, just as unreadable as before to orca, but now obscuring and blurring applications for sighted users.

John Lea (johnlea) on 2011-12-14
description: updated
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - Add keyboard shortcut hint overlay that is displayed
+ Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
when a user presses and holds the Super key
Alan Bell (alanbell) wrote :

this overlay is also a very annoying thing if you use super+mouse wheel to zoom in and out with compiz enhanced zoom!

Otto Kekäläinen (otto) wrote :

My suggestion is that Super+H (as in Help) would bring up the keyboard shortcuts help. The screen would keep focus even when Super+H is lifted (I think this satisfies the accessibility requirements). Then the screen would automatically disappear as any key is pressed.

This is implemented in the Scribes text editor (with Alt+H as key) and it is great to use. http://scribes.sourceforge.net/functions.html

PS. I also liked the idea in comment #20 that when Super+W is pressed the windows would have number shortcuts. At the moment Gnome 3 shell is superior to Unity only in the window switching usability.

Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :

visual design updated to fix a couple of bugs.

description: updated
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
milestone: none → 5.4
Changed in unity-2d:
status: Confirmed → In Progress
Gerry Boland (gerboland) on 2012-02-14
Changed in unity-2d:
milestone: 5.4 → 5.6
Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8

I really like the idea of how the shortcut hint works now in ubuntu 12.04 beta, but I think that when one uses a shortcut with the super key and holds that shortcut, the hint behaviour should not continue.
Example:
If I try to maximize a window with super + up arrow, and I don't release the super key soon enough, the hint window will be displayed.
In other words: if a shortcut with the super key is used, the timer for the hint window should stop.

Luis Mondesi (lemsx1) wrote :

this possibly broke keyboard shortcut launchers for gnome-shell users? Now I can't assign any keys to do things like "Open terminal" etc... (though it could be another bug). Using 12.04 beta.

Changed in unity-2d:
assignee: Lohith D Shivamurthy (dyams) → Tiago Salem Herrmann (tiagosh)
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
JP Vossen (jp-jpsdomain) wrote :

I disagree with "If screen size is smaller than 1024*768, the shortcut window should not be displayed" because I just spent about half an hour tring to figure out why I don't get the overlay on my Mini9 1024x600 screen.

Also, I have a VM that comes up as 800x600 or something silly because of a hardware KVM that reports wonky values, but auto-resizes (using VMware tools) to a useful size when I fiddle with it, and I don't get the overlay there either. I assume that's because it probably checks the screen size once and sets a flag, but that fails in this case, and may fail on a tablet or phone that changes "sizes" when rotated. OTOH, checking he scrren size every time SUPER is pressed is probably bad too. There must be a way to have a screen_resize event trigger, and change that flag...

If the screen really is too small at the moment:
Worst case, users should get an alternate overlay that says "Your screen must be at least 1024x768 for this feature to work."
Best case, users should get an alternate overlay that fits their screen.

Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Changed in unity-2d:
assignee: Tiago Salem Herrmann (tiagosh) → nobody
Changed in unity-2d:
status: In Progress → Triaged
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
milestone: 5.12 → 5.14
John Lea (johnlea) on 2012-10-01
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: onew udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers