Ubuntu

compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()

Reported by Christophe on 2011-02-02
824
This bug affects 180 people
Affects Status Importance Assigned to Milestone
Nux
Undecided
Unassigned
Unity
Critical
Unassigned
compiz (Ubuntu)
High
Unassigned
Natty
High
Unassigned
nux (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: compiz

Hi,

compiz crashed just a few minutes after logging in, I just had opened the "Disk Utility", but it doesn't crash every time I open it. I updated all packages about 10 minutes ago.

Christophe

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop4-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
CrashCounter: 1
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1400x1050 1400x1050 1280x1024 1280x1024 1280x960 1280x854 1280x800 1280x720 1152x768 1024x768 1024x768 800x600 800x600 848x480 720x480 640x480 640x480
 edid-base64: AP///////wAwrkJAAAAAAAAPAQOAHhd46jyAl1dRiiciUFQhCACBgAEBAQEBAQEBAQEBAQEBMCp4IFEaEEAwcBMAMOQQAAAYJSN4IFEaEEAwcBMAMOQQAAAYAAAADwCQQzKQQygUAQAyDFMhAAAA/gBMUDE1MEUwNy1UTDAzAMo=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Wed Feb 2 16:05:12 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
GraphicsCard: Subsystem: Lenovo Thinkpad T60 model 2007 [17aa:2006]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110130)
MachineType: LENOVO 9461DXG
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: compiz
ProcCwd: /home/christophe
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=13307cc6-7895-4fee-86a9-e71c1412fa5c ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f2bf00d5173 <_ZNSt15_List_node_base7_M_hookEPS_+19>: mov %rdi,(%rax)
 PC (0x7f2bf00d5173) ok
 source "%rdi" ok
 destination "(%rax)" (0x00000050) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 std::_List_node_base::_M_hook(std::_List_node_base*) () from /usr/lib/libstdc++.so.6
 nux::InputArea::OnEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::BaseWindow::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::WindowCompositor::ProcessEvent(nux::Event&) () from /usr/lib/libnux-0.9.so.0
 nux::WindowThread::ExecutionLoop(unsigned int) () from /usr/lib/libnux-0.9.so.0
Title: compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:2191): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nautilus:2191): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
 (nm-applet:2200): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
dmi.bios.date: 08/28/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7CETD3WW (2.23 )
dmi.board.name: 9461DXG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7CETD3WW(2.23):bd08/28/2009:svnLENOVO:pn9461DXG:pvrThinkPadR60:rvnLENOVO:rn9461DXG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 9461DXG
dmi.product.version: ThinkPad R60
dmi.sys.vendor: LENOVO
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu5
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Christophe (christophe-wk3) wrote :
visibility: private → public

StacktraceTop:
 std::_List_node_base::_M_hook ()
 nux::InputArea::OnEvent (this=0x1843790,
 ?? ()

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
Timothy Kross (timkross) on 2011-02-04
Changed in compiz (Ubuntu):
status: New → Confirmed
Gvozdik Artem (gvozdik) wrote :

also crushed on athlon x64, radeon X1300 video

magowiz (magowiz) wrote :

also crashed on oracle virtualbox PUEL on a ubuntu 10.10 amd64 host

David Tomaschik (matir) wrote :

Also on Intel Core 2 Duo with GM965 graphics.

Changed in compiz (Ubuntu):
importance: Medium → High
wayman (kotpes) wrote :

Also netbook Acer Aspire One 532H

Alex Launi (alexlauni) on 2011-02-18
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu Natty):
status: New → Confirmed
Changed in unity (Ubuntu Natty):
importance: Undecided → High
Neil J. Patel (njpatel) on 2011-02-25
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Critical
milestone: none → 3.6
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Gvozdik Artem (gvozdik) wrote :

For today Unity denied loading. Writing from classic mode. Also no compiz acivity. There are some artifacts sometimes, like black "whirls", or lines, I don`t know how to explain.
Alpha 3 updated up to 5 march, Radeon X1300 video.

Neil J. Patel (njpatel) on 2011-03-07
tags: added: unity-priority
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-08
tags: added: dids-top-ten
Loïc Molinari (loic.molinari) wrote :

It looks like the same issue than all these crashes in nux::GpuRenderStates::SubmitChangeStates() ¹. It happens at initialization and the bottom of the stack ² at frame 14 looks smashed right after a call to SubmitChangeStates() with "this" set to NULL.

¹ https://bugs.launchpad.net/nux/+bugs?field.searchtext=SubmitChangeStates
² http://launchpadlibrarian.net/62758765/Stacktrace.txt

Jay Taoko (jaytaoko) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
David Barth (dbarth) on 2011-03-11
tags: added: unity
Changed in unity (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in compiz (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
netfreedom59 (netfreedom59) wrote :

crashed on intel Q9550 and ATI RADEON HD6870

Neil J. Patel (njpatel) on 2011-03-21
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Loïc Molinari (loic.molinari)
David Barth (dbarth) on 2011-03-23
Changed in unity (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Loïc Molinari (loic.molinari)
Changed in compiz (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Loïc Molinari (loic.molinari)
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
David Barth (dbarth) on 2011-03-28
tags: removed: unity-priority
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Changed in compiz (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Changed in nux (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
importance: Undecided → High
Neil J. Patel (njpatel) wrote :

I believe that this bug and it's dupes (which hide two different bugs) are all fixed now. If you do get this again, please open a _new_ bug with the stack, as this one is holding a bunch of info that isn't useful in the dupes).

Changed in unity:
assignee: Loïc Molinari (loic.molinari) → nobody
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Natty):
assignee: Loïc Molinari (loic.molinari) → nobody
status: Confirmed → Fix Committed
Changed in nux (Ubuntu Natty):
status: New → Fix Committed
Changed in nux:
status: New → Fix Committed
Changed in compiz (Ubuntu Natty):
status: Confirmed → Fix Committed
assignee: Loïc Molinari (loic.molinari) → nobody
Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-07
Changed in compiz (Ubuntu Natty):
status: Fix Committed → Fix Released
Fayer Michael (fayer012) wrote :

This may be the 10th bug I have reported after upgrading to Ubuntu 11.10 beta. Some of them have been fixed, some not (eg, at least this one). I didn't do anything special when this error occurred, or just I don't know.

System:
$ lsb_release -rd
Description: Ubuntu oneiric (development branch)
Release: 11.10

$ apt-cache policy compiz
compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu1
  Candidate: 1:0.9.6+bzr20110929-0ubuntu1
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers