compiz crashed with SIGSEGV in nux::InputArea::OnEvent()

Bug #712810 reported by bingo1912 on 2011-02-03
136
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Nux
Confirmed
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
nux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

compiz crashed with SIGSEGV in nux::InputArea::OnEvent()

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop4-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1400x1050 1280x1024 1440x900 1440x900 1280x960 1360x768 1280x800 1280x800 1152x864 1280x768 1280x768 1024x768 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 848x480 640x480 640x480 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBOFJEZCgMAABoQAQN6Jh54L+xZpVhKmiYhUla/74BxT4FAgYABAQEBAQEBAQEBvDQAmFEAKkAQkBMAbSQRAAAeAAAA/QAoTB5RDgAKICAgICAgAAAA/ABTY2VwdHJlICAKICAgAAAA/ABYOUctTmFnYVYKICAgAGk=
Date: Thu Feb 3 23:04:42 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GdmLog1: Not present
GdmLog2: Not present
GraphicsCard: Subsystem: Giga-byte Technology GA-MA78GM-S2H Motherboard [1458:d000]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: Gigabyte Technology Co., Ltd. GA-MA78G-DS3H
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SegvAnalysis:
 Segfault happened at: 0x512caa7 <_ZN3nux9InputArea7OnEventERNS_5EventEll+2535>: cmp %edx,0x8(%ecx)
 PC (0x0512caa7) ok
 source "%edx" ok
 destination "0x8(%ecx)" (0x00000108) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 nux::InputArea::OnEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::View::PostProcessEvent2(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::TextureArea::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 PanelIndicatorObjectView::ProcessEvent(nux::Event&, long, long) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in nux::InputArea::OnEvent()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/12/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F8
dmi.board.name: GA-MA78G-DS3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF8:bd08/12/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA78G-DS3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA78G-DS3H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA78G-DS3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu5
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

bingo1912 (travis-wenks) wrote :
visibility: private → public
tags: added: compiz-0.9
Tormod Volden (tormodvolden) wrote :

Are all of you other affected on radeon? I have an X700 Mobility (RV410), while the original reporter has an HD3200 (RS780).

Jarrett Chisholm (chisser98) wrote :

Hi! No Radeon here, just an integrated Intel on a Dell Latitude D520 laptop.

I've tried two computers. One with Radeon, another with integrated Intel. Both give same failure in compiz after only short amount of usage.

Junaiyo85 (bendisoftware) wrote :

Same with me just an integrated intel on acer aspire 4315

StacktraceTop:
 nux::InputArea::OnEvent (this=0x8f436c8,
 ?? ()

Changed in compiz (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

compiz-core: installed version 1:0.9.2.1+glibmainloop4-0ubuntu8, latest version: 1:0.9.2.1+glibmainloop4-0ubuntu9
libglibmm-2.4-1c2a: installed version 2.27.91.1-0ubuntu1, latest version: 2.27.93-0ubuntu1
x11-common: installed version 1:7.6~3ubuntu1, latest version: 1:7.6~3ubuntu3

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
John S. Gruber (jsjgruber) wrote :

I marked this as confirmed since duplicate LP #714837 has up to date software but the same (basically) trace.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
John S. Gruber (jsjgruber) wrote :

I've added the ubuntu nux project since it is also implicated in the traceback.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 711916, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers