Ubuntu

GUI elements stop updating

Reported by Steve Dee on 2009-03-14
90
This bug affects 12 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by Steve Dee
Nominated for Karmic by Սահակ
Nominated for Lucid by Paul Broadhead

Bug Description

Under some conditions, certain windows and panels will stop being redrawn while using compiz. This persists until they are moved around or minimized/restored. This is particularly bad with panels---while it rapidly becomes apparent that an application has stopped visually responding, there is usually no obvious sign at all that the panel has stopped updating, resulting in reading the wrong time or in thinking that panel applets are in a different state from reality.

One way to reliably reproduce this bug (as shown in the attached video) is to, while connected to a wireless network, with applets in a non–full-width panel, use nm-applet to initiate a connection to another network. This causes the panel to stop responding, as well as certain windows (observed with a full-screen Firefox window.)

Josh Lee (jleedev) wrote :

I have two somewhat reliable ways of triggering this behavior.

The first is to use CompizConfig and enable a random plugin, such as Blur.

The second is to put the notification area on an unexpanded panel and then disconnect so nm-applet will change its icon and thus its size.

Steve Dee (mrdomino) wrote :

This also seems to be triggered fairly reliably on resume from suspend.

Steve Dee (mrdomino) wrote :

Here's an example of the behavior, with a panel in the top-right corner of the screen.

Steve Dee (mrdomino) wrote :

Er, in the video, watch the seconds ticker on the clock to see when the panel stops redrawing. The NetworkManager icon changing size on connecting to a network (as Josh says) causes the panel to stop redrawing; moving the panel around causes it to start redrawing again.

If a Firefox window happens to be open at this time, it will also stop responding until it is moved, exhibiting similar behavior to the panel in this respect.

N.B., this isn't triggered with a full-width panel.

description: updated
Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - windows and panels stop redrawing
+ GUI elements stop updating
Travis Watkins (amaranth) wrote :

I have seen similar problems in the past but only with nvidia? Do you guys all have nvidia cards?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Steve Dee (mrdomino) wrote :

I have an ATI card -- specifically, Radeon Mobility X1400.

Charlie Powell (powellc) wrote :

I do, and I believe I was running nvidia driver version 180.something... I've since updated the kernel and video drivers several times and have not received this problem.

In addition, for the short time I've been on Karmic, I haven't seen this bug yet either, again running a newer nVidia driver.

Ralf (ralf-kaestner) wrote :

I have an intel 965 and the same issue after resume from suspend (2ram).
I can fix it by ctrl-alt+f1, kill compiz, get back to ctrl-alt-f7, compiz --replace -> everything fine

if I switch from tty7 (with "stuck" compiz) to tty1 and immediately back to tty7 without killing compiz via tty1, then I can not even go back to tty1 anymore (where the first time was ok). At this time only "SYSQR REISUB" can help me to get out and reboot. This happens almost any time when I get back from suspend, but not all time.

Travis Watkins wrote:
> I have seen similar problems in the past but only with nvidia? Do you
> guys all have nvidia cards?

No, Intel

Travis Watkins (amaranth) wrote :

Alright, I cannot reproduce using the steps listed in the description using intel gm965 hardware. Does anyone else have any steps they can use to reliably reproduce this?

Ralf (ralf-kaestner) wrote :

looks like the latest mesa fix (bug #429241) has fixed this on my side.
I need to do dome more testing to confirm 100%

Travis Watkins (amaranth) wrote :

Zash: Can you confirm that?

ahmedre (ahmedre) wrote :

i still have this problem (with the latest updates and such). it seems to happen when the screensaver runs (although not necessarily every time, and not necessarily in a given amount of time -- sometimes, it happens within a few minutes, and other times, i can leave the screensaver for hours to have found that it died only a few minutes before i came back).

i have an nvidia card and am using compiz as well. killall gnome-panel fixes the problem temporarily until it decides to repeat itself again.

Henrik Nyberg (henrik-mysko) wrote :

I am experiencing what seems to be the same problem, with gnome-panel freezing and again working after being dragged. I have a nvidia graphics card and the issue happens at least with the 185.xx and 190.xx drivers. A similar problem has sometimes happened with the Firefox window after it is started, requiring the window to be moved for it to start drawing properly.

I have no reliable way of reproducing the problem, but if there are any tests I could do to aid in gathering debug info, I would gladly help. Maybe somebody has an idea of what I could try to do to reproduce it.

Henrik Nyberg (henrik-mysko) wrote :

After performing an upgrade on 2009-09-28, with the previous upgrade done on the 27th, this bug appears to have been solved for me. Since then my panel has not frozen at any time. Can anybody else who has been afflicted confirm?

Henrik Nyberg (henrik-mysko) wrote :

Ack. I take back the previous statement as my gnome-panel just froze again.

Սահակ (petrosyan) wrote :

I can reproduce this bug 100% of the time with Ubuntu 9.10 beta.

here is a screenshot illustrating this bug http://launchpadlibrarian.net/32759925/Screenshot.png

Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
hkais (r-2) wrote :

Hello all,

i have this problem at least since 9.04!

Also a big pain is, that if you try to work with terminal servers (Terminal Server client) many UI controls inside VNC or the terminal server client are missing. Often the text-fields...
So it is again unusable for me.

Here my screenshot of a Browser, there I only scrolled up and down.

I have asked in previous reports how I can help, so now I hope the repsonsible persons will get in contact to get more input. I hope not the bug is too "unimportant" to get fixed. Compiz is the default, so it should also work as default. For now I have to switch off compiz, since it is unusable for me... :(

I am willing to help, but I need instructions how to help..

bye
PS: I will add later all previously found bugs to reference this bug.

hkais (r-2) wrote :

seems to be the identical Bug #269904

Travis Watkins (amaranth) wrote :

Your problem doesn't seem to be the same as the original report. In either case, this bug is not getting any attention because I have no idea what is going on.

If someone can consistently reproduce this problem (note, that means it happens every single time you do something, not randomly) and give instructions that also consistently reproduce it for me or one of the other compiz developers upstream we might be able to figure it out. Otherwise I wouldn't be too hopeful, this bug has existed as long as compiz has.

Sukry Baharuddin (papanselaju) wrote :

okay..i got the same problems..
when animations add-on enabled in compiz, my windows just freeze when trying to minimize..
if the add-on is not enabled it is OK.
really dont want to downgrade to 9.04 because of the EXT4. i got no problem on 9.04.

system:
IBM T40 laptop
ATI Mobility Radeon 9000 AGP

tags: added: iso-testing
nick parlante (nick-parlante) wrote :

I'm seeing this bug about once a day on a 9.10 laptop with intel graphics. Gnome Panel 2.28.0.

The appearance of the applets at the top of the screen gets rearranged and freezes, and the clock stops advancing, so that's maybe the most obvious symptom to a regular user. For me, the list of windows at the bottom of the screen is blanked, leaving just the desktop button at the far left and the trash and workspaces at the far right.

I propose that the definitive test is that you can go to System > Preferences > Appearance > Visual Effects and change it from Normal to None, and that fixes it to show the right current state instantly. That's also, obviously a good workaround for people having problems with this bug.

Doing some experiments, I was able to trigger the bug once this way: Visual Effects set to Normal. Shut the laptop, triggering whatever the default suspend is. Wake the laptop (entering password), and the applets are in the messed-up and frozen state. This happened once, but 5 subsequent suspend/resume cycles didn't show the bug. The bug showed only the *first* time I did a suspend/resume, so I wonder if something about switching the visuals from Normal to None once clears something about the underlying bug.

I don't see any logging that jumps out as the problem.

Սահակ (petrosyan) wrote :

this bug has been fixed in Ubuntu 10.10

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
fsando (fsando) wrote :

Is there a way to get this fix in 10.04?

mthome (mthome) wrote :

My machine still exhibits this issue with all panel widgets (including clock, weather, cpu monitors, etc) ceasing to update. Usually, but not always, stops sometime while the screensaver (simple blanking) is active.

Ubuntu 10.10, x86_64 w/ 2.6.37-020637-generic
"Force synchronization between X and GLX" is on but doesn't seem to have any effect.

The only thing I see in the logs that is obviously suspicious is that there is some NTP state changing a bit before the time the panel clock freezes at. Kicking NTP actually seems to restart the panel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers