chromium-browser, gvfsd-http and others using eglibc crash with SIGSEGV in __nscd_get_mapping() or gethostbyname2_r()

Bug #929219 reported by omarly666 on 2012-02-08
This bug affects 571 people
Affects Status Importance Assigned to Milestone
GLibC
Fix Released
Medium
eglibc
Fix Released
Medium
chromium-browser (Ubuntu)
High
Lucas Santos Silas
Precise
High
Lucas Santos Silas
Quantal
High
Lucas Santos Silas
eglibc (Ubuntu)
High
Adam Conrad
Precise
High
Lucas Santos Silas
Quantal
High
Adam Conrad
gwibber (Ubuntu)
Undecided
Lucas Santos Silas
Precise
Undecided
Lucas Santos Silas
Quantal
Undecided
Lucas Santos Silas

Bug Description

updated latest - rebooted and tried to open chromium, no such luck

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: chromium-browser 16.0.912.77~r118311-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic 3.2.3
Uname: Linux 3.2.0-14-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CheckboxSubmission: 8617bffd198177508bf030f94c880aca
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
CrashCounter: 1
CrashDB: ubuntu
Date: Thu Feb 9 00:48:53 2012
Desktop-Session:
 DESKTOP_SESSION = ubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-ubuntu:/etc/xdg
 XDG_DATA_DIRS = /usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/chromium-browser/chromium-browser
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0xb7db005: lock xadd %ecx,0xc(%eax)
 PC (0x0b7db005) ok
 source "%ecx" ok
 destination "0xc(%eax)" (0x0000000b) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: chromium-browser
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 gethostbyname2_r () from /lib/i386-linux-gnu/libc.so.6
ThirdParty: True
Title: chromium-browser crashed with SIGSEGV in gethostbyname2_r()
UpgradeStatus: Upgraded to precise on 2012-02-05 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
chromium-default: CHROMIUM_FLAGS=""

Related branches

I have seen some reports where glibc crashes if nscd is not running, especially with chromium but also with ktorrent. This is not always reproduceable, so there's some kind of race or random memory corruption.

valgrind reports:
==16750== Process terminating with default action of signal 11 (SIGSEGV)
==16750== Access not within mapped region at address 0x17
==16750== at 0xC63DC1E: __nscd_get_mapping (in /lib64/libc-2.15.so)
==16750== by 0xC63DDE3: __nscd_get_map_ref (in /lib64/libc-2.15.so)
==16750== by 0xC63B2E1: nscd_gethst_r (in /lib64/libc-2.15.so)
==16750== by 0xC63BB96: __nscd_gethostbyname2_r (in /lib64/libc-2.15.so)
==16750== by 0xC6213F0: gethostbyname2_r@@GLIBC_2.2.5 (in /lib64/libc-2.15.so)
==16750== by 0xC5F5D8F: gaih_inet (in /lib64/libc-2.15.so)
==16750== by 0xC5F6ED2: getaddrinfo (in /lib64/libc-2.15.so)
==16750== by 0x140E7BD: net::SystemHostResolverProc(std::string const&, net::AddressFamily, int, net::AddressList*, int*) (in /usr/lib64/chromium/chromium)
==16750== by 0x1407C57: net::HostResolverImpl::Job::DoLookup(base::TimeTicks const&, unsigned int) (in /usr/lib64/chromium/chromium)
==16750== by 0x2B5B2FA: base::(anonymous namespace)::WorkerThread::ThreadMain() (in /usr/lib64/chromium/chromium)
==16750== by 0x11753C1: base::(anonymous namespace)::ThreadFunc(void*) (in /usr/lib64/chromium/chromium)
==16750== by 0x919FF65: start_thread (in /lib64/libpthread-2.15.so)

gdb gives a similar backtrace.

After reverting commit 3a2c02424d9824f5cdea4ebd32ff929b2b1f49c6, the problem does not appear anymore.

I can't reproduce it yet on my system - so no further information.

Reports:
https://bugzilla.novell.com/show_bug.cgi?id=741021
https://bbs.archlinux.org/viewtopic.php?id=133021

I confirm this for Chromium on archlinux.

Specs (just in case):
- kernel 3.3-rc2 (vanilla)
- glibc 2.15

I can only add 2 things:
- this happens only once in a session, i.e. when Chromium is launched for the first time after boot; after that Chromium starts normally.
- I couldn't yet reproduce this bug *within* gdb - it always starts without a problem. I will continue trying though.

omarly666 (omarly666) wrote :

StacktraceTop:
 __nscd_get_mapping (type=GETFDHST, key=0xb8191b5 "hosts", mappedp=0xb85fac4) at nscd_helper.c:417
 __nscd_get_map_ref (type=GETFDHST, name=0xb8191b5 "hosts", mapptr=0xb85fac0, gc_cyclep=0xaf3a8a0c) at nscd_helper.c:452
 nscd_gethst_r (key=0xb831d84c "api.facebook.com", keylen=17, type=GETHOSTBYNAME, resultbuf=0xaf3a8de4, buffer=0xaf3a8b00 "", buflen=512, result=0xaf3a8e08, h_errnop=0xaf3a8e0c) at nscd_gethst_r.c:147
 __nscd_gethostbyname2_r (name=0xb831d84c "api.facebook.com", af=2, resultbuf=0xaf3a8de4, buffer=0xaf3a8b00 "", buflen=512, result=0xaf3a8e08, h_errnop=0xaf3a8e0c) at nscd_gethst_r.c:62
 __gethostbyname2_r (name=0xb831d84c "api.facebook.com", af=2, resbuf=0xaf3a8de4, buffer=0xaf3a8b00 "", buflen=512, result=0xaf3a8e08, h_errnop=0xaf3a8e0c) at ../nss/getXXbyYY_r.c:194

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
summary: - chromium-browser crashed with SIGSEGV in gethostbyname2_r()
+ chromium-browser crashed with SIGSEGV in __nscd_get_mapping()
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed

I am just starting testing an update from "2.14.90" to "2.15" for
mandriva, and I get this randomly, varying from 1 to 4 times every
restart of chromium-browser.

$ rpm -qf /usr/bin/chromium-browser
chromium-browser-unstable-17.0.963.26-1-mdv2012.0.x86_64

$ LD_LIBRARY_PATH=/usr/lib64/chromium-browser gdb /usr/lib64/chromium-browser/chrome
...
0x00007ffff18f5e7e in __nscd_get_mapping (type=<optimized out>, key=
    0x7ffff19436b4 "hosts", mappedp=0x7ffff1b82548) at nscd_helper.c:417
417 if (oldval != NULL && atomic_decrement_val (&oldval->counter) == 0)
(gdb) p oldval
$1 = (struct mapped_database *) 0xffffffffffffffff
(gdb) bt
#0 0x00007ffff18f5e7e in __nscd_get_mapping (type=<optimized out>, key=
    0x7ffff19436b4 "hosts", mappedp=0x7ffff1b82548) at nscd_helper.c:417
#1 0x00007ffff18f4098 in __nscd_get_nl_timestamp () at nscd_gethst_r.c:113
#2 0x00007ffff18e2be8 in __check_pf (seen_ipv4=0x7ffff7ed071e, seen_ipv6=
    0x7ffff7ed071f, in6ai=0x7ffff7ed06e0, in6ailen=0x7ffff7ed06f0)
    at ../sysdeps/unix/sysv/linux/check_pf.c:324
#3 0x00007ffff18aa015 in __GI_getaddrinfo (name=
    0x555559ba3a68 "www.statcounter.com", service=<optimized out>, hints=
    0x7ffff7ed0a60, pai=0x7ffff7ed0a98) at ../sysdeps/posix/getaddrinfo.c:2305
#4 0x00005555566a0c9c in ?? ()
#5 0x000055555669b3e8 in ?? ()
#6 0x0000555557d85b95 in ?? ()
#7 0x0000555556437fb2 in ?? ()
#8 0x00007ffff4239bd0 in start_thread (arg=0x7ffff7ed1700)
    at pthread_create.c:309
#9 0x00007ffff18bd93d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

I believe this should correct it, but not the proper solution:

--- glibc-2.15-a316c1f/nscd/nscd_helper.c.orig 2012-02-11 20:25:37.804514879 -0200
+++ glibc-2.15-a316c1f/nscd/nscd_helper.c 2012-02-11 20:26:07.428588082 -0200
@@ -414,7 +414,8 @@ __nscd_get_mapping (request_type type, c
   struct mapped_database *oldval = *mappedp;
   *mappedp = result;

- if (oldval != NULL && atomic_decrement_val (&oldval->counter) == 0)
+ if (oldval != NULL && oldval != NO_MAPPING
+ && atomic_decrement_val (&oldval->counter) == 0)
     __nscd_unmap (oldval);

   return result;

hopefully also useful:

(gdb) frame 0#0 0x00007ffff18f5e7e in __nscd_get_mapping (type=<optimized out>, key=
    0x7ffff19436b4 "hosts", mappedp=0x7ffff1b82548) at nscd_helper.c:417
417 if (oldval != NULL && atomic_decrement_val (&oldval->counter) == 0)
(gdb) p keylen
$12 = 6
(gdb) p mapsize
$13 = 0
(gdb) p iov
$14 = {{iov_base = 0x7ffff7ed0330, iov_len = 6}, {iov_base = 0x7ffff7ed04a0,
    iov_len = 8}}
(gdb) p cmsg
$15 = <optimized out>
(gdb) p (cmsg)->__cmsg_data
value has been optimized out
(gdb) p ip
$16 = <optimized out>
(gdb) p mapfd
$17 = <optimized out>
(gdb) p st
No symbol "st" in current context.
(gdb) p mapping
$18 = <optimized out>
(gdb) p size
No symbol "size" in current context.
(gdb) p oldval
$19 = (struct mapped_database *) 0xffffffffffffffff
(gdb) p result
$20 = (struct mapped_database *) 0xffffffffffffffff

Forgot to add some extra information:

$ ls /usr/lib64/chromium-browser
chrome* libppGoogleNaClPluginChrome.so* resources.pak
chrome.pak locales/ themes/
chrome-sandbox* nacl_helper* xdg-mime*
chromium-wrapper* nacl_helper_bootstrap* xdg-settings*
default_apps/ nacl_irt_x86_64.nexe
libffmpegsumo.so* resources/

If removing libppGoogleNaClPluginChrome.so from that directory,
or overriding the wrapper and starting chrome without setting
LD_LIBRARY_PATH I could not get it to crash, neither did notice
any problems.

It's already fixed in archlinux, though it was one helluva big commit:
http://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/glibc&id=8e950112da65c96ad17cbd650ac9db3050343a3f
I'm not even sure where to look...

That is called reverting the commit that caused the issue... Not fixing it.

(In reply to comment #5)
> That is called reverting the commit that caused the issue... Not fixing it.

Okay.
It's already reverted in archlinux. Hope this stays reverted for good and finds it's way into the upstream (if this wasn't archlinux-only problem since it was *package* version that changed...)

visibility: private → public
tags: added: bugpattern-needed
Jean-Baptiste Lallement (jibel) wrote :

Confirmed on amd64 with
chromium-browser:
  Installed: 16.0.912.77~r118311-0ubuntu1

Changed in chromium-browser (Ubuntu):
importance: Medium → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

Unassigning canonical desktop team. Chromium in universe, not officially supported, and does not have a current maintainer.

Changed in chromium-browser (Ubuntu):
status: Triaged → Confirmed
tags: added: qa-manual-testing rls-mgr-p-tracking
Changed in chromium-browser (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in chromium-browser (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Victor Vargas (kamus) wrote :

same here with the latest release 17.0.963.56~r121963-0ubuntu1, however when I tried to report this issue apport opened chromium without problems so it seems that happens the first try.

omarly666 (omarly666) wrote :

same as #8 here - first time for me and second run fine

17.0.963.56 (Developer Build 121963 Linux) Ubuntu 12.04

Diego Schulz (dschulzg) wrote :

17.0.963.56 (Developer Build 121963 Linux) Ubuntu 12.04

chromium-browser crashed with SIGSEGV in getaddrinfo()

I'm nearly 99% sure this problem started after the last libc6 update some days ago (maybe a week).

Micah Gersten (micahg) wrote :

Marking triaged as this seems to be a libc bug.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
jesusiniesta (jesus-iniesta) wrote :

Same thing here, but on a x86_64 architecture (12.04 up to date).

James Hunt (jamesodhunt) wrote :

As shown on bug 941812, a work-around to the issue is to start chromium with stdin redirected to /dev/null, like this:

    chromium-browser < /dev/null

Daniel Hahler (blueyed) wrote :
Changed in eglibc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in eglibc:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in glibc:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: rls-p-tracking
tags: removed: rls-p-tracking
Steve Langasek (vorlon) on 2012-03-22
Changed in eglibc (Ubuntu):
assignee: nobody → Matthias Klose (doko)
Changed in chromium-browser (Ubuntu):
status: Triaged → Invalid
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Adam Conrad (adconrad) on 2012-03-24
Changed in eglibc (Ubuntu Precise):
assignee: Matthias Klose (doko) → Adam Conrad (adconrad)

here it happened with Chromium 17.0.963.83 (Build 127885 Linux) over Ubuntu 12.04 Precise, dev branch.

regards

I got this bug on booting the 12.04 Beta 2 image and running the Ubuntu One client. To my knowledge I did not launch Chromium so it seems strange to get a crash in it.

I got this after upgrade and reboot in 12.04. I do not use usually Chromium.

Based on just reading the code, I wonder if a one thread is mucking up hst_map_handle.mapped behind the back of nscd_get_mapping.

nscd_get_nl_timestamp doesn't bother to grab the hst_map_handle lock and calls into nscd_get_mapping which could potentially change hst_map_handle.mapped to NO_MAPPING.

If this occurs after another thread had passed the NO_MAPPING check in nscd_get_map_ref, but hasn't yet hit the atomic_decrement_val in nscd_get_mapping then it could cause the failure mode reported in this report (and several others across various distros, upstream kde and possibly elsewhere).

That would also explain why the patch in c#2 works as well as the lack of reproducability.

Vladimir/Paulo: I don't have a way to reproduce the problem here, but I could pass along a patch to y'all if you're interested in testing my theory.

(In reply to comment #7)
[...]
> Vladimir/Paulo: I don't have a way to reproduce the problem here, but I could
> pass along a patch to y'all if you're interested in testing my theory.

  I can test it tonight at home, that is the only place I managed to
reproduce the problem. I almost sure it should be some race condition
as when running chromium under gdb it would always have a lot of
threads running, and when playing with the libraries and LD_LIBRARY_PATH
I should have just changed some timing.

Jeff, please add the patch here and we all can test it. Thanks for looking into this!

Created attachment 6307
Potential fix

Kazi Shahnoor Ashraf (kaziweb) wrote :

I was browsing internet. Suddenly, this happened. But My Chromium was working fine!!!!!!!!!!!!! I was noticing a slow behavior for two days by Chromium.

Just a note from a tester within Red Hat. He was reporting a ktorrent crashes when starting up which appeared to be related to, or possibly this same problem.
After installing the patch already attached to this BZ, the ktorrent crashes have ceased.

Micah Gersten (micahg) on 2012-03-30
no longer affects: chromium-browser

I have not been running into this issue lately. I wonder if any of the latest distro updates have kicked in some fix or change some of the defective conditions.

micahg, it still is a problem It effects me when ever I open it.

John Ginis (jhnginis) wrote :

The bug affect me immediately after I started the app

Shane (shane-blether) wrote :

I rebooted after applying all latest Precise (beta) updates.
Chromium as a Startup Application suffered this fault.

Benjamin (nailartcenter) wrote :

my indicator-weather is crashed. Apport popped up and I sent it but it indicated that this problem was already reported this bug and opened in the browser even though this is part of a chromium crash. Is that OK?

Benjamin (nailartcenter) wrote :

chromium was not in use.

karl anliot (kanliot) wrote :

seems to only crash when something is launching chromium, or when chromium is launching something I downloaded

Evan Huus (eapache) wrote :

@nailartcenter Yes, that's fine. The original report was against chromium, but as you can see from the list of affected projects the actual bug is in glibc. Since both chromium and indicator-weather use libc, both programs can see this bug.

Vince (thehappytrucker) wrote :

This bug shown either at sartup or seemingly random,However I do not use chromium.I use Firefox.

I had a spontaneous crash when I just booted up my Ubuntu 12.04. My version gets all available updates.

It seems the crash happens each time Evolution has a mail with a link it has to open, as well as a few spontaneous crashes after just booting the computer.

Sorry folks, but ... in my case it was a weird Rhythmbox behaviour. And I fail to parse the full activity log manually (as human) to make sure this has not already been reported. But I do hope we can find out soon what the actual PROBLEM with all this massive code is. I am so excited with the look & feel so far. Lets keep going :o)

Hanine HAMZIOUI (hanynowsky) wrote :

I get the crash immediately after clicking on Chromium launcher. Right after the login.
Using Precise Beta 2 updated and Unity shell. AMD64 laptop.

Sometimes Chromium won't just run using Unity Dashboard or launcher.
As far as I can tell the crash happens the first time the user tries to launch Chromium right after login.
And if it does not launch, running it from a terminal shell does not fail.

richud (richud.com) wrote :

Chromium just doesnt launch most of the time , have to keep retrying from terminal...

rfm6@UbuntuX64:~$ chromium-browser &
[1] 3126
rfm6@UbuntuX64:~$ chromium-browser &
[2] 3153
[1] Segmentation fault (core dumped) chromium-browser
rfm6@UbuntuX64:~$
(exe:3293): Gdk-WARNING **: XID collision, trouble ahead
[3288:3288:97377413:ERROR:gl_surface.cc(87)] Not implemented reached in virtual bool gfx::GLSurface::Resize(const gfx::Size&)

(exe:3293): Gdk-WARNING **: XID collision, trouble ahead

(exe:3293): Gdk-WARNING **: XID collision, trouble ahead

(exe:3293): Gdk-WARNING **: XID collision, trouble ahead

(exe:3293): Gdk-WARNING **: XID collision, trouble ahead

(exe:3293): Gdk-WARNING **: XID collision, trouble ahead

John DeLuca (johnnyde94) on 2012-04-03
Changed in chromium-browser (Ubuntu Precise):
status: Invalid → Confirmed
Micah Gersten (micahg) wrote :

It was marked invalid since the bug isn't in Chromium, but in eglibc. It has not been fixed yet.

Changed in chromium-browser (Ubuntu Precise):
status: Confirmed → Invalid
Neal Gamradt (ngamradt-d) wrote :

I received this error when first trying to start Chromium.

Sancho (steven-sanchez) wrote :

I have this almost (but not all) times i first start up chromium after booting the machine. Second I try to open it it works fine.

iGadget (igadget) wrote :

I got this bug after booting the 12.04 Beta 2 image, browsing through the available apps and clicking on a suggested app for download (Calligra Flow in this case), which opened up the Ubuntu Software Center. So Chromium is not even present.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/929219

tags: added: iso-testing
wesley tamagi (tama-wes) wrote :

This bug occurs after a chromium-broswer after upgrade to 18.0.1025.142

I've been rolling updates since 12.04 Alpha (x86-64), chromium-browser 17 and 18 and it occurs every time I launch a new chromium-browser service. It doesn't occur when I've already got a window open.

Changed in chromium-browser (Ubuntu Precise):
status: Invalid → Incomplete
Evan Huus (eapache) wrote :

@xatt11 Please don't change the bug status if you don't understand what it means. As per the numerous comments, this is not actually a bug in chromium, but in eglibc, which is why the correct status for the chromium package for this bug is "Invalid".

Changed in chromium-browser (Ubuntu Precise):
status: Incomplete → Invalid

This bug seemed to happen after I unintentionally opened 2 chromium instances (or sessions?) at the same time.
-Denny

dino99 (9d9) wrote :

Get this error on Precise i386 b2 with;

midori 0.4.4 (midori-dev ppa)

crashed with SIGSEGV in __nscd_get_mapping()

Nothing else was running, fresh start-up of system. Clicking on relaunch in the crash window however did open Chromium.

Alexander (alexander-) wrote :

Would be nice to get this fixed already, annoying. And the release is only few days off...

Daniel (toasty27) wrote :

Chromium crashed with this error litterally every time I try to log into Chromium with my Google account. I have the same exact problem on Ubuntu 12.04 Beta 2 and on 11.10, both 64-bit. This has been going on for a few months now.

Wow, Apport led me here and I don't even have chromium installed! I opened Rythymbox and got a crash, Apport said it was already reported, and linked me here....

Michel Filipe (mfilipe) wrote :

I opened GoldenDict and Apport sends me to here.

Steve Langasek (vorlon) on 2012-04-09
tags: added: rls-p-tracking
summary: - chromium-browser crashed with SIGSEGV in __nscd_get_mapping()
+ chromium-browser, gvfsd-http and others using eglibc crash with SIGSEGV
+ in __nscd_get_mapping() or gethostbyname2_r()
Martin Olsson (mnemo) wrote :

We're getting _very_ close to final freeze now, can't someone just package the fix Red Hat has been working on? i.e:
http://sourceware.org/bugzilla/attachment.cgi?id=6307&action=diff

tags: added: patch
laura garcía (lauritta18) wrote :

Some moments ago, after an update ubuntu 12.04 (23 bist) crashed. That problem brought me here. I dont think it is related to the browser.

Brad Kell (syko4mt) wrote :

My crash was generated when I started Last.fm.
It had worked flawlessly for several days prior.

Kazi Shahnoor Ashraf (kaziweb) wrote :

This happened while I was typing Bangali language for launchpad translation.

Atul Sharma (mantissaman) wrote :

Happened when I tried to open Chromium Web browser.

dombai (avv-baiani) wrote :

When I tried to open Chromiun browser it crashed. Happened on Ubuntu 12.04 beta 2

MarkieB (ubunt-u-markbenjamin) wrote :

I should add — I'm another indicator-weather rather than chromium person — that it was during resume after suspend that apport notified me; of course quite a bunch happens during resume, including notably restarting wifi, although some kind of timing may assist to track the glibc call from indicator-weather that is causing it

precise similarly

Giannis (karzisss) wrote :

"segmentation fault-core dumped" message on terminal. it happens after upgrade to 12.04 from 11.10.

Peter Henriksen (repete) wrote :

Launched chromium from unity panel, while waiting I started rearranging another icon in the panel, then got this error .. 12.04 beta and chromium 18.0.1025.151

This bug happened during my attempt to post from a aol video to my facebook account. In attempting to share this data with Facebook, it crashed.

This is probably not at all useful, but too much is better than too little info, aye?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.15-0ubuntu7

---------------
eglibc (2.15-0ubuntu7) precise; urgency=low

  [ James Hunt ]
  * debian/debhelper.in/libc.preinst: Moved logic from postinst to
    prompt user for services to restart. We ask here to allow the
    problematic cron to be stopped in the preinst, but defer the restart of
    remaining services until postinst time (LP: #508083).

  [ Steve Langasek ]
  * debian/debhelper.in/libc.{pre,post}inst: drop special casing of upstart
    jobs when restarting, since the check was completely wrong anyway,
    depending on the no-longer-existent /lib/init/readlink.
  * Drop obsolete gdm upgrade handling code that only applies for upgrades
    from hardy to lucid.
  * Remove the /etc/ld.so.conf.d/i486-linux-gnu.conf conffile on upgrade on
    i386, since it's no longer shipped and we should give consistent results
    on upgrade and install; and add a Breaks on the three library packages
    in lucid that used this path.

  [ Adam Conrad ]
  * debian/patches/any/local-nscd-NO_MAPPING.diff: Apply patch from Jeff Law
    to clean up thread handling in __nscd_get_nl_timestamp and resolve a few
    random crashing issues with chromium-browser and ktorrent (LP: #929219)
  * debian/rules.d/debhelper.mk: Fix RTLD_SO replacement regex for sanity.
 -- Adam Conrad <email address hidden> Thu, 12 Apr 2012 00:18:08 -0600

Changed in eglibc (Ubuntu Precise):
status: Triaged → Fix Released
Adam Conrad (adconrad) wrote :

Can any of the people who could previously reproduce this bug let me know if the above eglibc upload fixed things for them? It's dreadfully difficult for me to actually trigger in the first place.

dino99 (9d9) wrote :

@Adam

fixed for me (post #55 ) on Precise i386, logged as gnome-classic

I've gotten confirmation from a few Ubuntu users that Jeff's fix is working for them, FWIW.

Kazi Shahnoor Ashraf (kaziweb) wrote :

Don't know what happened! I was browsing Launchpad through Chromium browser.

Dave Vree (hdave) wrote :

Running 12.04 beta and ended up here from apport due to indicator-weather crash.

idsfa (idsfa) wrote :

Running 12.04 with eglibc (2.15-0ubuntu10) and had indicator-weather crash.

So no, that didn't fix it.

I don't think this is fixed. Was getting it with indicator-weather in 11.10 and still getting it in 12.04.

We want this fix in 2.16, setting milestone.

Piet Zeeman (peteliz) on 2012-05-09
Changed in chromium-browser (Ubuntu Precise):
assignee: nobody → Piet Zeeman (peteliz)
status: Invalid → Incomplete
Adam Conrad (adconrad) on 2012-05-14
Changed in chromium-browser (Ubuntu Precise):
assignee: Piet Zeeman (peteliz) → nobody
status: Incomplete → Invalid

this is fixed now with:

commit 509072a0f7f8a37bedf61a78c0cdd7783368c65a
Author: Andreas Jaeger <email address hidden>
Date: Tue May 15 20:35:53 2012 +0200

    Avoid race in nscd

    2012-05-15 Jeff Law <email address hidden>
                Andreas Jaeger <email address hidden>

            [BZ #13594]
            * nscd/nscd-client.h (__nscd_acquire_maplock): New function, split
            out from...
            * nscd/nscd_helper.c (__nscd_get_map_ref): ... here.
            * nscd/nscd-client.h: Add __nscd_acquire_maplock.
            * nscd/nscd_gethst_r.c (__nscd_get_nl_timestamp): Add locking to
            code changing __hst_map_handle.map.

Thanks for taking care of this Andreas. I've just updated Fedora Rawhide to use your version of this fix.

Changed in eglibc:
status: Confirmed → Fix Released
Changed in glibc:
status: Confirmed → Fix Released
Cesar Silva (cmsv20) on 2012-05-25
Changed in chromium-browser (Ubuntu):
status: Invalid → Confirmed
Changed in chromium-browser (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Changed in chromium-browser (Ubuntu Precise):
status: Invalid → Confirmed
dino99 (9d9) on 2012-07-12
Changed in chromium-browser (Ubuntu):
status: Confirmed → Invalid
Changed in chromium-browser (Ubuntu Precise):
status: Confirmed → Invalid
Carey Underwood (cwillu) wrote :

Adam, I still run into this on a fully updated precise; the crash reported doesn't permit me to file a new bug, instead directing me to this page.

As with Carey, I'm still seeing this crash as of today (fully patched Quantal and just rebooted). I can't file a bug because I am also directed to this page.

Janne Snabb (snabb) wrote :

I encountered this issue today the first time when adding a torrent to transmission's download queue. According to apport it is the same bug.

I have the following libc6 package version, my system is fully up to date:

2.15-0ubuntu10

Ted Gould (ted) wrote :

When I look at the crash before uploading it says that this is coming from gwibber-service. Up-to-date Quantal.

Chris Halse Rogers (raof) wrote :

Also, before uploading, the top 5 frames of this crash appeared to be in libdbus, rather than libc. I suspect the duplicate detector has gone a bit mental.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu Precise):
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: New → Confirmed

Какой хромиум клоуны тупоголовые разве в ubuntu 12.10 он стоит? Почему на экране пропадает изображение и от панели юнити тянутся полосы?

I'm not getting this bug with Chromium; I'm getting redirected to this bug when indicator-weather (in fully patched Quantal) crashes. It won't let me open another bug report because of the redirect here.

Changed in chromium-browser (Ubuntu):
status: Invalid → New
status: New → Fix Released
Changed in chromium-browser (Ubuntu Precise):
status: Invalid → Fix Released
Changed in chromium-browser (Ubuntu):
assignee: nobody → Lucas Santos Silas (lucas-19161)
Changed in chromium-browser (Ubuntu Precise):
assignee: nobody → Lucas Santos Silas (lucas-19161)
Changed in gwibber (Ubuntu):
assignee: nobody → Lucas Santos Silas (lucas-19161)
Changed in gwibber (Ubuntu Precise):
assignee: nobody → Lucas Santos Silas (lucas-19161)
Changed in eglibc (Ubuntu Precise):
assignee: Adam Conrad (adconrad) → Lucas Santos Silas (lucas-19161)
David Callé (davidc3) wrote :

Happen at times when the Dash is loading results thumbnails from the web in the Photos lens.

Ken VanDine (ken-vandine) wrote :

davidc3: is the photos lens using urllib2 to fetch the photos?

Ken VanDine (ken-vandine) wrote :

If this is affecting gwibber-service, it would be something coming from urllib2, which is likely being bitten by the bug in libc. It would not be anything that needs fixing in gwibber. Perhaps the bug in libc has resurfaced?

Changed in gwibber (Ubuntu Precise):
status: Confirmed → Invalid
Changed in gwibber (Ubuntu Quantal):
status: Confirmed → Invalid

*** Bug 260998 has been marked as a duplicate of this bug. ***
Seen from the domain http://volichat.com
Page where seen: http://volichat.com/adult-chat-rooms
Marked for reference. Resolved as fixed @bugzilla.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.