multiple problems with new chromium-browser

Bug #1307717 reported by Søren Holm on 2014-04-14
This bug affects 20 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)

Bug Description


Chromium-browser was just updated and there are multiple problems with it.

* icedtea-plugin not detected.
* pepper seems to be the only API supported now.
* Maximizing/normalizing the window the top right part of the window is not redrawn.
* The font size in the address line is too huge.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: chromium-browser 34.0.1847.116-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-lowlatency 3.13.9
Uname: Linux 3.13.0-24-lowlatency i686
ApportVersion: 2.14.1-0ubuntu2
Architecture: i386
CurrentDesktop: KDE
Date: Mon Apr 14 22:59:57 2014
 DESKTOP_SESSION = kde-plasma
 XDG_CONFIG_DIRS = /etc/xdg/xdg-kde-plasma:/usr/share/upstart/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share:/usr/share/kde-plasma:/usr/local/share/:/usr/share/
InstallationDate: Installed on 2013-12-24 (111 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20131224)
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
 . /usr/lib/pepflashplugin-installer/
gconf-keys: /desktop/gnome/applications/browser/exec = b'firefox\n'/desktop/gnome/url-handlers/https/command = b'firefox %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'firefox %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.chromium.browser.default: [modified]
modified.conffile..etc.default.chromium.browser: [deleted]
mtime.conffile..etc.chromium.browser.default: 2013-12-24T14:26:50.548847

Søren Holm (sgh) wrote :
Søren Holm (sgh) on 2014-04-14
description: updated
Chad Miller (cmiller) wrote :

Let's split this into distinct bugs. This should be the first.

What does dconf say about your display scale?

$ dconf dump /com/ubuntu/user-interface/

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Søren Holm (sgh) wrote :

Yeah - might be an idea to not include multiple things, but release is in 48 hours and I would not like to see this bug in trusty. Actually I thing the best way ot go is to roll back to the previous version.

Anywya dconf says nothing. The response in the command line is empty.

Søren Holm (sgh) wrote :

Please roll back to the previous version before the release tomorrow.

Søren Holm (sgh) wrote :

Theres another thing. It fails to detect the installed icedtea-plugin package. So Java is broken in it too.

Søren Holm (sgh) on 2014-04-16
description: updated
Søren Holm (sgh) wrote :

Come on. Release is in a few hours. Roll back to 33.0.1750.152-0ubuntu1~pkg995.1

kaefert (kaefert) wrote :

I've uploaded a screenshot of how chromium with aura looks on my kubuntu 14.04 desktop in the kubuntu forum here:

Miek Gieben (miek) wrote :

Updating to google-chrome-beta (Setting up google-chrome-beta (35.0.1916.47-1)) does not fix the problem. Also wiping ~/.config/chromium and restarting chrome (stable or the -beta) does not fix it.

Note: I'm my case I'm not running Unity, nor Gnome. I do have gnome-settings-daemon running.

Miek Gieben (miek) wrote :

Doing a 'apt-get install ubuntu-desktop' and then logging in into your own desktop (in my case i3) fixes the problem.

The font-size of the url bar is still too large though.

Søren Holm (sgh) wrote :

Upgrading does not help. The problem is that 14.04 is shipped with a version that has been en the repositories for 3-4 days. M34 landed there this monday and the release was thursday. NPAPI has apparently been scrapped in M34. As I wrote before in this bug chromium should be rolled back to M33 which works in all respects. If there are security issues with this version appropriate patches should be applied on top of M33. Thats just for fixing this bug without talking about breaking/removing APIs after FeatureFreeze February 20th.

Miek Gieben (miek) wrote :

Yes, also the upgrading worked temporary (WTF?). Back to firefox for the time being.

Miek Gieben (miek) wrote :

Downgrading chrome to the version from saucy makes it behave OK. I also tried the -beta and the -unstable version of Chromium, they all don't work in the same way.

Mark Lila (mark-lilas) wrote :

My icedtea-7-plugin doesn't work in Chromium 34. is related.

Søren Holm (sgh) wrote :

icedtea does not work because NPAPI was dropped in 34. It will happen no matter what we do, but pulling it into 14.04 3 days before release is not the way to do it.

Miek Gieben (miek) wrote :

For the redraw issue 'chromium-browser --disable-gpu' might work.

Vincent (vdavy-mobile) wrote :


I confirm since upgrading from 13.10 to 14.04 chromium is fully buggy.
I got the rendrering problem mentionned above, systray icons (for running apps such as hangouts) disappeared, the menus were awful (parameters menu, search bar suggestions, bookmarks, right click in page etc...) : not using kde design but a flat white strange menu.

By downgrading to previous version from saucy, I got rid of these problems. So it is clearly they come from the new version.

For them who want to downgrade, here is a quick howto :
-open package manager, and search for installed packages maching *chromium* pattern (for me it was chromium-browser, chromium-browser-l10n and chromium-codecs-ffmpeg-extra)
-go to this page, search for them and download from saucy repository and select the proper version against your system (x64 or i686)
-close all chromium processes (this can be done using the "killall chromium-browser" command)
-put all the downloaded packages in the same directory on your hdd and run the following command in a terminal : sudo dpkg -i chromium*

This will downgrade chromium to previsous version, so we can wait for the fix.

Søren Holm (sgh) wrote :

Any news on this. It should be faily easy to downgrade to 33 or something.

many of the issues and some others also have affected me in version 34.
 - Address bar font is HUGE, cant be changed with Xfce DPI settings anymore
 - Horizontal scroll does not work
 - Every other file download randomly crashes chromium

As this is really a meta-bugreport - If You know, please point me to specific bug reports, so I can track there.

I found this page with all the builds

and from that list here is last (AFAICT) amd64 build with version 33 for trusty/14.04

Søren Holm (sgh) wrote :

I've reported no other bugs. Basically this report was done in a rush because shipping 35 in 14.04 was wrong in the first place IMHO.

Louis Zuckerman (semiosis) wrote :

I'm having these same problems with chromium-broswer since upgrading to trusty from saucy (kubuntu amd64).

One other thing I didnt see mentioned is that menus are all messed up. They render weird and only a couple items are displayed, with scroll arrows at the top & bottom. This affects context menus (right click) as well as drop-down lists on web pages, and makes web forms practically unusable.

I've switched to the Google Chrome Dev Channel browser (google-chrome-unstable package from google) and it works great on my kubuntu trusty. It's a decent workaround until the chromium-browser package is working again.


kaefert (kaefert) wrote :

this problem also shows itself with a Cinnamon desktop

This new chromium release that includes aura does seem to only work with the Unity desktop.

Saikrishna Arcot (saiarcot895) wrote :

Chromium M36 (currently in beta) works fine for me, and the rendering issues should be fixed in M35.

Diaa Sami (diaa.sami) wrote :

I was able to fix the large sized UI/fonts using the following command-line:
chromium-browser --force-device-scale-factor

Paul White (paulw2u) wrote :

This multiple issue bug report was marked incomplete over 5 years ago but did not expire due to the bug watches, three of which were added after comment #25 without explanation.

Upstream bugs:

#363053 was closed "WontFix" on 2014-04-14 as NPAPI plugins no longer supported.
#363921 is a duplicate of #363088
#363088 was closed "Fixed" on 2014-05-01 (keyboard input ignored)
#99369 was closed "WontFix" on 2011-10-11 as side tabs were experimental so removed
#188 and its many duplicates refer to the usability of Chromium when a very large number of tabs are opened but this issue was not referred to when this bug report was opened.

There have been no comments here for over 5 years and further to comments #24 and #25 I'm closing this as being fixed as recent releases of Chromium don't seem to be affected by the reported problems.

Anyone still experiencing any of the issues noted above should open a new bug report for each issue.

Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.