Brasero creating incomplete image (.ISO) files

Bug #648283 reported by Noel J. Bergman on 2010-09-26
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Fedora)
Won't Fix
Medium
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

I was testing to see if Brasero 2.31.92 fixed Bug 541019, but when I made the test burn, Basero only claimed to burn 750MB (see screen capture) of the ~5GB that should have been burnt, and the actual image size is shown below (smaller than even just the md5sum file should be), along with a good burn made using Fedora 11.

  $ ls -l *.iso
  -rw-r--r-- 1 noel noel 2097152 2010-09-26 12:30 brasero.iso
  -rw-rw-r-- 1 noel noel 5090373632 2010-03-18 12:17 piccolo.iso

This problem is reproducible. I have not tried burning this project to a disc, but it totally fails to create the ISO image.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: brasero 2.31.92-0ubuntu2
Uname: Linux 2.6.36-020636rc5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Sep 26 13:40:55 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100601)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: brasero

Noel J. Bergman (noeljb) wrote :
Noel J. Bergman (noeljb) on 2010-09-26
description: updated
Noel J. Bergman (noeljb) on 2010-09-27
summary: - Basero creating incomplete image (.ISO) files
+ Brasero creating incomplete image (.ISO) files
Changed in brasero:
importance: Unknown → Critical
status: Unknown → New
Changed in brasero:
status: New → Incomplete
Changed in brasero (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Noel J. Bergman (noeljb) wrote :

Still broken in 2.32.

Noel J. Bergman (noeljb) wrote :

I have tested the upstream fix at https://bugzilla.gnome.org/show_bug.cgi?id=630651#c12, and it does work.

Noel J. Bergman (noeljb) wrote :

Please note: this bug is marked CRITICAL upstream, and the patch should be applied ASAP for Maverick! The current code distributed with Maverick corrupts/loses data. The fix is a patch to a single file (plugins/burn-libisofs.c).

Changed in brasero:
status: Incomplete → Fix Released
madbiologist (me-again) wrote :

This fix has been included in GNOME 2.32.1 - see http://ftp.gnome.org/pub/GNOME/desktop/2.32/2.32.1/NEWS

BlackSir (blacksir) wrote :

I confirm it's fixed in brasero 2.32.1.

Temporary workaround (until brasero 2.32.1 will be released in maverick-updates):
wget http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/brasero_2.32.1-0ubuntu1_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/libbrasero-media1_2.32.1-0ubuntu1_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/brasero-cdrkit_2.32.1-0ubuntu1_i386.deb
sudo dpkg -i brasero_2.32.1-0ubuntu1_i386.deb libbrasero-media1_2.32.1-0ubuntu1_i386.deb brasero-cdrkit_2.32.1-0ubuntu1_i386.deb

P.S. This bug have two effects:
1. When you trying to create an iso image brasero creates an image with length of exactly 2097152 bytes (2Mb)
2. When you trying to burn the same project to dvd (without creating an image) brasero burns dvd with error 27 "Some files may be corrupted on the disc". The resulting disk is actually have files, but most of them just filled with zeroes (0x00)

2011/1/16 BlackSir <email address hidden>

> I confirm it's fixed in brasero 2.32.1.
>
> Temporary workaround (until brasero 2.32.1 will be released in
> maverick-updates):
> wget
> http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/brasero_2.32.1-0ubuntu1_i386.deb
> wget
> http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/libbrasero-media1_2.32.1-0ubuntu1_i386.deb
> wget
> http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/brasero-cdrkit_2.32.1-0ubuntu1_i386.deb
> sudo dpkg -i brasero_2.32.1-0ubuntu1_i386.deb
> libbrasero-media1_2.32.1-0ubuntu1_i386.deb
> brasero-cdrkit_2.32.1-0ubuntu1_i386.deb
>
> P.S. This bug have two effects:
> 1. When you trying to create an iso image brasero creates an image with
> length of exactly 2097152 bytes (2Mb)
> 2. When you trying to burn the same project to dvd (without creating an
> image) brasero burns dvd with error 27 "Some files may be corrupted on the
> disc". The resulting disk is actually have files, but most of them just
> filled with zeroes (0x00)
>
> --
> You received this bug notification because you are subscribed to
> Brasero.
> https://bugs.launchpad.net/bugs/648283
>
> Title:
> Brasero creating incomplete image (.ISO) files
>
> Status in A disc burning application for gnome 2:
> Fix Released
> Status in “brasero” package in Ubuntu:
> Triaged
> Status in “brasero” package in Fedora:
> Unknown
>
> Bug description:
> Binary package hint: brasero
>
> I was testing to see if Brasero 2.31.92 fixed Bug 541019, but when I
> made the test burn, Basero only claimed to burn 750MB (see screen
> capture) of the ~5GB that should have been burnt, and the actual image
> size is shown below (smaller than even just the md5sum file should
> be), along with a good burn made using Fedora 11.
>
> $ ls -l *.iso
> -rw-r--r-- 1 noel noel 2097152 2010-09-26 12:30 brasero.iso
> -rw-rw-r-- 1 noel noel 5090373632 2010-03-18 12:17 piccolo.iso
>
> This problem is reproducible. I have not tried burning this project
> to a disc, but it totally fails to create the ISO image.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: brasero 2.31.92-0ubuntu2
> Uname: Linux 2.6.36-020636rc5-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sun Sep 26 13:40:55 2010
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64
> (20100601)
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: brasero
>
>
>

thx bro..
--
agus purnomo
memberi dan membagi, balaslah yang memberi kamu dengan memberi ke orang yang
membutuhkan
<http://majapahit.linux.or.id>
http://ladang.web.id
http://blog.tajdidlinux.org <http://tajdidlinux.org>
http://blankonlinux.or.id
http://kiosfoss.com
http://investigasiindonesia.com
<http://webhemat.com>http://sabily.org

Franko Burolo (fburolo) wrote :

Recently, there was an upgrade of Brasero in Maverick, but version is still 2.32.0, and the problem persits...
What's the point in upgrading a package without such a critical bug fixed, when a fix seems exist?

I guess I will just install v. 2.32.1...

The link to the 2.32.1 deb is not working. What happened?

BlackSir (blacksir) wrote :

2JeanAustinR
Brasero Natty packages have been updated recently. Check new *.deb names here - http://archive.ubuntu.com/ubuntu/pool/main/b/brasero/

Marco Sulla (xdq4gh24rq) wrote :

Thank you BlackSir.

If I can say, the lack of support for this bug from Ubuntu is astonishing. The fix was released in 2010-10-17, and this bug is already in Status = Triaged and Importance = Low for Ubuntu???

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- agus

agus purnomo
Employed at Phasedev.com
Indonesia

Confirm that you know agus purnomo
https://www.linkedin.com/e/-qythzn-govbqf58-63/isd/3193618981/aGEgj7CC/

--
(c) 2011, LinkedIn Corporation

Changed in brasero (Fedora):
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.