Brasero burns corrupted disks and 2MB images

Bug #657684 reported by Claudio Moretti on 2010-10-10
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: brasero

Yesterday, I tried to burn a data disk containing a bunch of MP3 files.
Burning completed, but checksum verification failed with similar errors as in bug #405165;
In my case, though, the disk itself is corrupted.
I first thought about a "normal" failed writing.
Re-burning the disk resulted in the same problem (and got me a little bit angry).
Today, I tried several times burning the same project on a disk image: brasero burned it at a strangely high speed, but said the image was 570+ MB; yet, checking the real size of the image showed me it was 2 MB.
Mounting the ISO, showed the correct filesystem structure, but playing a random track resulted in errors.

Note: I added files to the project by dragging and dropping them from Rhythmbox
I _THINK_ I added one of the files by drag and drop from nautilus and it was the only file that correctly played in my car cd reader.

Attaching brasero-session.log from the second disk burn and hexdump -C brasero.iso

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: brasero 2.32.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Oct 10 15:00:43 2010
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: brasero

Claudio Moretti (flyingstar16) wrote :
Claudio Moretti (flyingstar16) wrote :
Daniel Lee (longinus00) wrote :

This is apparently triggered by adding files from different directories. Attempting to make an iso where all the files come from the same directory works but otherwise it cancels with "brasero (libisofs)MISHAP : Image write cancelled".

Changed in brasero (Ubuntu):
status: New → Confirmed
Franko Burolo (fburolo) wrote :

I am experiencing the same (or a very similar) bug on Maverick 64 bit. I noticed this just today, but have obviously experienced it a few days ago, too, when I got a corrupted data DVD after it burned, seemingly, without errors. But then I had no time to investigate so I left it for later till today.
A few days ago I had the checksum plugin disabled, and Brasero showed no errors, but the disk itself was corrupted -- it wasn't possible to open the audio files I burnt on it. I was burning today a similar CD, a bunch of mp3 files, got the same behaviour. So I went to check the plugins, and enabled the checksums control. Then I re-tried to burn the same project, it gave out an error, and indeed, the disk was corrupted the same way as before. I re-tried again, now it showed no errors, but the disk was still corrupted. I even tried to simulate the burning before the real burning itself. The simulation seemed to be way to fast, but it reported as it was done correctly so Brasero proceded forward to the real burn proces. In the end... the same corrupted disk.
I thought it might be that my burner device was gone, so to opt-out this possibility, I thought of trying to burn with other software. So I installed Xfburn, which woked fairly well and the resulted disk was normally functional, the mp3's played normal. So it is obviously something about Brasero going on here...
After I read this bug report, I tried to make an image, too. Got the same result as reported above by Claudio Moretti.

I must say that I usually don't drag and drop files to Brasero, not from Rhythmbox nor from Nautilus, I use the Brasero's own interface to add files, and still got this bug. Also, until not so long ago everything worked fine... I don't remember if there were any Brasero-related upgrades recently... But all of a sudden it stopped to work correctly, which bothers me, as otherwise it is my favourite burning application... :-/

Gál Zsolt (galzsolt-freemail) wrote :

I am using Debian 6.0 "Squeeze" with the similar result, when I try to make isoimage. Here are debug message after adding files:
brasero (libisofs)DEBUG : Creating low level ECMA-119 tree...
brasero (libisofs)DEBUG : Matching hardlinks...
brasero (libisofs)DEBUG : Sorting the low level tree...
brasero (libisofs)DEBUG : Mangling names...
brasero (libisofs)DEBUG : Creating low level Joliet tree...
brasero (libisofs)DEBUG : Sorting the Joliet tree...
brasero (libisofs)DEBUG : Mangling Joliet names...
brasero (libisofs)DEBUG : Computing position of dir structure
brasero (libisofs)DEBUG : Computing length of pathlist
brasero (libisofs)DEBUG : Computing position of Joliet dir structure
brasero (libisofs)DEBUG : Computing length of Joliet pathlist
brasero (libisofs)DEBUG : Starting image writing...
brasero (libisofs)DEBUG : Write volume descriptors
brasero (libisofs)DEBUG : Write Primary Volume Descriptor
brasero (libisofs)DEBUG : Write SVD for Joliet
brasero (libisofs)DEBUG : Writing ISO Path tables
brasero (libisofs)DEBUG : Writing Joliet Path tables
brasero (libisofs)DEBUG : Writing Files...
brasero (libisofs)DEBUG : Reader thread being cancelled
brasero (libisofs)MISHAP : Image write cancelled
brasero (libisofs)DEBUG : Writer thread joined
brasero (libisofs)DEBUG : Reader thread being cancelled
brasero (libisofs)DEBUG : Writer thread joined
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave

BlackSir (blacksir) wrote :

This bug is fixed in brasero 2.32.1
For workaround see bug #648283

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers