nautilus crashed with SIGSEGV in start_thread()

Bug #335942 reported by Nio on 2009-02-28
216
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Undecided
Pedro Fragoso
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: nautilus

.Nautilus didn´t even start in the current relase of Ubuntu 9.04 (Daily) (28. Feb. 09)

ProblemType: Crash
Architecture: i386
DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module is deprecated import sets Ubuntu 9.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.25.91-0ubuntu1
ProcCmdline: nautilus
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
 start_thread () from /lib/tls/i686/cmov/libpthread.so.0
Title: nautilus crashed with SIGSEGV in start_thread()
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nio (vs-nicolas-ubuntu) wrote :

StacktraceTop:brasero_medium_init_real (object=0x8c9d418,
brasero_medium_probe_thread (self=0x8c9d418)
g_thread_create_proxy (data=0x8bcca70)
start_thread () from /lib/tls/i686/cmov/libpthread.so.0
clone () from /lib/tls/i686/cmov/libc.so.6

Changed in nautilus:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=573929

Changed in brasero:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in brasero:
status: Unknown → Incomplete
Yann Simon (yann-simon-fr) wrote :

This bug is maybe related to the bug #339993.

Ian! D. Allen (idallen) wrote :

This is still a problem in 9.04 Jaunty Beta.

This failure of Nautilus to start makes it difficult to configure 9.04
to run well in a VMware virtual machine, since the VMware Tools CDROM ISO
image can't be attached without causing a Nautilus crash loop that fills
the task bar. You have to SIGSTOP Nautilus, mount the CDROM ISO file
manually, install VMware tools, unmount the ISO, then SIGCONT Nautilus.

See https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/344371

Nio (vs-nicolas-ubuntu) wrote :

I would change the importance of this Bug to high, because how likes to install an OS which doesn't´t even start well in VMware??? Souch a problem in a Live-Mode, which shoud show the users a good Ubuntu isn´t realy.... useful;-)
In my way of thinking that´s an absolut no-go!

Sebastien Bacher (seb128) wrote :

that's not a nautilus bug

Changed in nautilus (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

May the reporters/subscribers update to brasero 2.26.0-0ubuntu2 and see if that's still an issue? please comment back, thanks.

joneskoo (joneskoo) wrote :

I believe I have the version 2.26.0-0ubuntu2 installed, submitted Bug #353150 that was marked as duplicate. Does that count?

Ian! D. Allen (idallen) wrote :

Yes, the multiple-nautilus-failure loop is now fixed for VMware now. Jaunty Beta with:

brasero 2.26.0-0ubuntu2

Thank you for the fix.

Pedro Villavicencio (pedro) wrote :

Yes, thanks you both for the quick feedback. Upstream has provided a patch which is available here: http://bugzilla.gnome.org/attachment.cgi?id=131859&action=view which would fix the issue.

Nio (vs-nicolas-ubuntu) wrote :

Current Daily (2. April 09) works fine in live Mode;-)

Changed in brasero:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

a fix was already applied to the stable branch of brasero (and also trunk) which is available here: http://svn.gnome.org/viewvc/brasero/branches/gnome-2-26/

Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
luk1don (luk1don) wrote :

Ok., but when it will be Fix Released (not sources but deb packages or diffs)? I have version brasero 2.26.0-0ubuntu3 and it is a big problem...

Nio (vs-nicolas-ubuntu) wrote :

The Fix is already existing. You can Download the current Build of Ubuntu there:
http://cdimage.ubuntu.com/daily-live/current/
This Version should work fine.

luk1don (luk1don) wrote :

No Nio, there was a few bugs in this. The daily-build version (2009-04-08) does not fix this for me:(

luk1don (luk1don) on 2009-04-14
Changed in brasero (Ubuntu):
assignee: desktop-bugs → luk1don
status: Fix Committed → Invalid
Changed in brasero:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

luk1don why did you closed the bug without giving a reason? Please do not do it again.

Changed in brasero (Ubuntu):
status: Invalid → Fix Committed
assignee: luk1don (luk1don) → Ubuntu Desktop Bugs (desktop-bugs)
luk1don (luk1don) wrote :

Sorry Pedro:) It was not have to be...

Paul Bartell (paul-bartell) wrote :

shouldn't this have been fixed before the final release? It seems pretty weird that it wasn't.

Martin Pitt (pitti) wrote :

Accepted brasero into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Jaunty):
assignee: nobody → Pedro Fragoso (ember)
Changed in nautilus (Ubuntu Jaunty):
status: New → Invalid
Changed in brasero (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed

So far, things are looking good here. Nautilus desktop icons no longer
disappear when mounting a cdrom or dvd, and I was able to burn an iso
image using the revised brasero (2.26.1-0ubuntu1).

Thanks!

Steve
--

Accepted brasero into jaunty-proposed, the package will build now and be
available in a few hours. Please test and give feedback here. See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed. Thank you in advance!

** Also affects: brasero (Ubuntu Jaunty)
   Importance: Undecided
       Status: New

** Also affects: nautilus (Ubuntu Jaunty)
   Importance: Undecided
       Status: New

** Changed in: brasero (Ubuntu Jaunty)
     Assignee: (unassigned) => Pedro Fragoso (ember)

** Changed in: nautilus (Ubuntu Jaunty)
       Status: New => Invalid

** Changed in: brasero (Ubuntu Jaunty)
       Status: New => Fix Committed

** Tags added: verification-needed

--
nautilus crashed with SIGSEGV in start_thread()
https://bugs.launchpad.net/bugs/335942
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in A disc burning application for gnome 2: Fix Released
Status in “brasero” source package in Ubuntu: Fix Committed
Status in “nautilus” source package in Ubuntu: Invalid
Status in brasero in Ubuntu Jaunty: Fix Committed
Status in nautilus in Ubuntu Jaunty: Invalid

Bug description:
Binary package hint: nautilus

.Nautilus didn´t even start in the current relase of Ubuntu 9.04 (Daily) (28. Feb. 09)

ProblemType: Crash
Architecture: i386
DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module is deprecated import sets Ubuntu 9.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.25.91-0ubuntu1
ProcCmdline: nautilus
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libbrasero-media.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
 start_thread () from /lib/tls/i686/cmov/libpthread.so.0
Title: nautilus crashed with SIGSEGV in start_thread()
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Martin Pitt (pitti) on 2009-04-28
tags: added: verification-done
removed: verification-needed
Kayvee (vkkodali) wrote :

Hello,
I am experiencing this bug even with Jaunty final release. I installed it fresh on my desktop (not an upgrade from Intrepid). When I insert a movie DVD, I can play it with VLC so I guess the mounting part works okay. But when I insert a blank CD to write stuff on to it and click either on 'CD/DVD Creator' or 'Brasero', all desktop icons disappear! Brasero does not start. Right-click menu does not appear on desktop (it works okay when I am in a different program like Firefox). I installed all the updates...so this fix is yet to be put into updates?

Kayvee (vkkodali) wrote :

UPDATE: I just checked if this is an issue with only CDs and not DVDs and it turns out that it actually is an issue with mounting CDs as mentioned above! When I insert an audio CD, all desktop icons disappear and the computer behaves much like it did earlier.

Mike Hicks (hick0088) wrote :

Deeply, deeply frustrating to insert a CD-R, get ready to right-click and burn to CD like I've done for months with 8.10 Intrepid, and suddenly see Nautilus crash, especially considering that Brasero is a feature that is flaunted in the beta upgrade documentation: http://www.ubuntu.com/testing/jaunty/beta#GNOME%202.26

I ended up doing an "apt-get install nautilus-cd-burner" to revert to the old burner tool. I'll try switching to Brasero with "apt-get install brasero libbrasero-media0 sound-juicer" in a few days, but this type of introduction to Brasero makes me very disappointed.

jtholmes (jtholmes) wrote :

Try as i would i could not replicate this bug. Does not mean it doesnt exist, i could not
reproduce.

I tried nautilus open, no blank cd when selecting burn button, you name i tried everything
I was only trying to make a data cd and it worked every time.

However, I took note of the actions that occur when Burn is pressed and when a CD (blank or otherwise)
is inserted and its possible that the problem may be in the software that detects that a CD rom has been
inserted or exists etc.

jtholmes (jtholmes) wrote :

I should mention that I performed my tests with the Final Release of Ubuntu 9.04 with all the updates
avail as of 10:30P EDST on 4/30/09

This bug certainly exists for me, even after doing two fresh installs of Jaunty. (Check bug #369886)

Is there a temporary workaround for this. I don't really use Brasero, so can I remove it or something, to get the CDs working as they used to?

luk1don (luk1don) wrote :

Yes, you can.

sudo apt-get remove --purge brasero libbrasero-media0

Daeng Bo (daengbo) wrote :

Or simply
    sudo chmod a-r /usr/lib/nautilus/extensions-2.0/libnautilus-brasero-extension.so [1]

[1] http://blog.ibeentoubuntu.com/2009/04/awful-nautilus-brasero-bug-in-jaunty.html

Thanks, luk1don. That worked. I needed to reboot the computer, though.

Deang Bo, thanks to you, too, but I saw your post a little late. It seems simpler just to deactivate the app., rather than remove it completely.

Chris Coulson (chrisccoulson) wrote :

On Fri, 2009-05-01 at 09:09 +0000, Daeng Bo wrote:
> Or simply
> sudo chmod a-r /usr/lib/nautilus/extensions-2.0/libnautilus-brasero-extension.so [1]
>
> [1] http://blog.ibeentoubuntu.com/2009/04/awful-nautilus-brasero-bug-in-
> jaunty.html
>
No, please don't do that. That is not a supported workaround. Please
rather install the fixed package in jaunty-proposed, following the
instructions above, or just wait for the update.

Daeng Bo (daengbo) wrote :

Chris,

What is the problem with disabling the extension, waiting for the update, then re-enabling it? How is removing the package and reinstalling later a better solution?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Sorry, this is a Launchpad bug. I copied the jaunty-proposed update to karmic. Fixing tasks accordingly.

Changed in brasero (Ubuntu Jaunty):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Daniel Lee (longinus00) wrote :

I have brasero 2.26.1 and I'm still getting crashes in nautilus when inserting cd/dvd media. It doesn't seem to happen every time, maybe once every 2 or 3 times.

Pedro Villavicencio (pedro) wrote :

Daniel, please open a new bug with apport about it, it could not be due to this bug. Thanks.

Changed in brasero:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.