nautilus crashes with segfault when inserting CD

Bug #363435 reported by Jonas on 2009-04-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

today I did an upgrade from ubuntu 8.10 to 9.04 RC. Everything seems to work fine so far except for one thing - when I insert a CD into my CD RW drive, nautilus crashes and all icons on my desktop disappear. dmesg gives me something similar to the following:

nautilus[11914]: segfault at a783000 ip b615a7dd sp b6bebfc0 error 4 in libbrasero-media.so.0.1.1[b614a000+1e000]

I also have a DVD RW drive but the problem does not appear when I insert CDs into it.
I booted a 9.04 RC live CD to make sure it has nothing to do with the upgrade process and the same problem appears. When I boot from the DVD drive and insert a CD into the CD drive, nautilus crashes. I can also boot from the CD drive to a running gnome desktop, but the icons are missing right from the start and I can't start nautilus or brasero.

When I eject the CD I can start nautilus from a gnome-terminal and the icons appear again. When I insert the disk, it crashes again.

I tried activating apport to file a bug report, but it said I had too little memory to analyse the problem and file a report (2 GB of RAM should be enough imho, maybe another bug with apport?). Do you need further information? Shall I send the .crash file here?

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release Candidate i386 (20090414.2)
Package: nautilus 1:2.26.2-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.28-11-generic i686

Jonas (joney) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a '.crash' file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

 If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

 If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

 If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.
 I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Invalid
Jonas (joney) wrote :

sorry, as I already wrote in my original bug report, I can't use the apport tool as it quits with a message that I have too little memory for analysing the problem. The same happens when I doubleclick the .crash-file in /var/crash. Shall I send the file here as an attachement?

Sebastien Bacher (seb128) wrote :

Could you try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report?

Changed in nautilus (Ubuntu):
status: Invalid → Incomplete
Jonas (joney) wrote :
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. This bug has already been reported, but please feel free to report any other bugs you find.

affects: nautilus (Ubuntu) → brasero (Ubuntu)
Changed in brasero (Ubuntu):
status: Incomplete → Invalid
TrustyTory (botting) wrote :

FYI - the same issue just happened to me right now, although I don't seem to be able to produce a crash report. Taking the CD out and performing a reboot had everything on the desktop, and the computer, running back to normal. Out of curiosity, was it a Windows compatable CD you were trying to run? I was trying to use Wine to install a program, although it was as soon as I put the CD In that the computer crashed.

TrustyTory (botting) wrote :

I just answered my own question. The desktop and nautilus crashed when I even attempted to insert the Ubuntu 9.04 disk into the cd drive. Will this be solved by a simple update?

Felidae (nightfelidae) wrote :

I have the same problem. When inserting a CD or DVD, nautilus crashes and all desktop icons disappear.
If I try to access Desktop or CD Rom from the "Place" on the tool bar, a tag "opening Desktop" will show on the bottom tool bar for several seconds and then disappear, too.

After I take CD or DVD out, I still can't see desktop icons but can open and access them from the "Place" tag

Feistybird (bryanjen-tw) wrote :

Try this:

sudo chmod a-r /usr/lib/nautilus/extensions-2.0/libnautilus-brasero-extension.so

TrustyTory (botting) wrote :

Feisty,

That worked, I was able to navigate nautilus - although the desktop icons still disappeared. Thanks for the help thus far.

TrustyTory (botting) wrote :

Disregard - your fix COMPLETELY repaired the issue. The desktop icons only disappeared for the first time I put a CD in. It recovered them, and everything is working as it should. Thank you Feisty!

rajsrawat05 (rajsrawat05) wrote :

I am facing the same problem. Whenever I insert any cd into cd-drive, desktop icons disappear. Then I use Crtl-Alt-backspace after ejecting the cd. The icons appear then. Panel works all this while. Right click doesn't. CD drive is IDE.
Using intel celeron 2.0 GHz.
Architecture -i386.
Jaunty -9.04 main edition.

Same issue with linux mint 7 on same computer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers