beryl-xgl missing from beryl and beryl-core (feisty)

Bug #95394 reported by Sergio Domingo-Hernando on 2007-03-24
66
Affects Status Importance Assigned to Milestone
beryl-core (Ubuntu)
Medium
MOTU
Nominated for Feisty by Przemek K.

Bug Description

Binary package hint: beryl

Downgrading from version 0.2.1.dfsg+git20070318-0ubuntu1 (feisty) to 0.2.0~0beryl1 (feisty) seems to solve the problem.

This is the output after running "beryl" from de command line:

**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : XGL

Checking Display :1.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

beryl: GLX_EXT_texture_from_pixmap is missing
beryl: Using non-tfp mode
beryl: GLX_SGIX_fbconfig is missing
beryl: Failed to manage screen: 0
beryl: No manageable screens found on display :1.0

ProblemType: Bug
Architecture: i386
Date: Sat Mar 24 10:44:40 2007
DistroRelease: Ubuntu 7.04
Uname: Linux Caribdis 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

hexion (hexium) wrote :

I can confirm this bug.
In the last package, beryl-xgl executable is missing

#ls /usr/bin/beryl*
/usr/bin/beryl /usr/bin/beryl-manager /usr/bin/beryl-settings

beryl-core:
  Instalados: 0.2.1.dfsg+git20070318-0ubuntu2
beryl:
  Instalados: 0.2.1.dfsg+git20070318-0ubuntu2

After downgrading to previous version:
#ls /usr/bin/beryl*
/usr/bin/beryl /usr/bin/beryl-manager /usr/bin/beryl-settings /usr/bin/beryl-xgl

hexion (hexium) on 2007-03-25
Changed in beryl-core:
status: Unconfirmed → Confirmed
Stani (stani) wrote :

I can also confirm this bug. Beryl 0.2.1 does not work on xgl, because beryl-xgl is missing. This affects everyone who has to run XGL with fglrx on graphic cards (in my case X1300) which are not supported by the radeon driver.

I downgraded to beryl 0.2.0~beryl1 from the beryl repositories (deb http://ubuntu.beryl-project.org/ feisty main) which works very fine.

Why beryl-xgl is not included? Is this a license issue?

hexion (hexium) wrote :

stani, as a workaround you can do this:

- Install a beryl and beryl-core in version 0.2.0~beryl1 (as you did)
$ sudo cp /usr/bin/beryl-xgl /
- Upgrade to the last repository version
- beryl-xgl in missing, so:
$ sudo cp /beryl-xgl /usr/bin

This way, apt-get wont bother with beryl upgrades till next commit and will work :)

gatekeep (gatekeep) wrote :

Another quick solution would be to lock the version in Synaptic to 0.2.0~beryl1. I also confirm that beryl-xgl is missing (although a dirty solution to fixing this is as follows):

Make a shell script beryl-xgl in /usr/bin. Put the proper lines in to execute the beryl-core and emerald (if you use it). Use the LD_PRELOAD trick to get it to work properly with Xgl.

(e.x., for beryl-core: LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa beryl)

Note: That I also found there seems to be graphical glitches that occur with this method. I'm sure it probably has to do with the forcing of the preload of the fglrx libGL.

Thanks, but I just locked down Beryl as 0.2.1 is just a license upgrade.
If there is another upgrade of Beryl which seems stable, I'll release
the lock.
Stani

hexion wrote:
> stani, as a workaround you can do this:
>
> - Install a beryl and beryl-core in version 0.2.0~beryl1 (as you did)
> $ sudo cp /usr/bin/beryl-xgl /
> - Upgrade to the last repository version
> - beryl-xgl in missing, so:
> $ sudo cp /beryl-xgl /usr/bin
>
> This way, apt-get wont bother with beryl upgrades till next commit and
> will work :)
>
>

Nick (lupine) wrote :

beryl-xgl was removed from the package at the request of the MOTU... I'll see if I can get it reinstated for a future release (as I understand it, the problem was that it statically links against it's own version of Mesa - linking against the version of mesa provided in Ubuntu could be a workable solution).

hexion (hexium) wrote :

Will I ever be able to understand some MOTU's actions????

"Well, we don't like the way this package is behaving.... let's fucking BREAK it... Yeah, it's broken, we can go to bed proud of the good job done"

Definition of FIX: Take something that doesn't work (or just works sometimes) and make it work.
What MOTU does in some cases like this: Take something that WORKS but they don't like... and just delete it.

Przemek K. (azrael) wrote :

Beryl-xgl is the only way to run Beryl for some ATI users (ie. me) because their cards are not supported by the Radeon driver (ie. Radeon Xpress 200M). Removing beryl-xgl from the package is a serious issue for us.

hardhu (qzerty) wrote :

Hello everybody,
I can confirm this problem is also present in feisty amd64 as of today upgrade. I have tried one of the workarounds suggested, that is to download beryl-core-0.2.0 and extract and copy beryl-xgl to /usr/lib, but it doesn't work: bertyl starts, but all windows of applications become white and desktop is unusable.

Alex Launi (alexlauni) wrote :

Confirmed here. Beryl works great with packages from Beryl repos but there is no beryl-xgl with these packages. I can have universe enabled because I'm afraid I'll accidentally update. Please fix this, this is a major bug for anyone with a recent ATI card.

hexion (hexium) wrote :

Alex, you can hold a package to avoid upgrading it with aptitude (and apt-get I suppose)

In example, if you don't want to upgrade beryl, type:
# sudo aptitude hold beryl

Remember, when you want to upgrade it you can unhold it and upgrade OR just install it:
# sudo aptitude unhold beryl
# sudo aptitude install beryl

To know if there is a newer version, you can check your system's version and the repo's one with:
$ apt-cache policy beryl

Aleksi Uski (kapteenikuolio) wrote :

I can conform that the beryl-repo packages work fantastic with my laptop (radeon mobile x700 PCI-E) when using fglrx driver. Which I btw have to use, as the free radeon/ati driver does not work at all with my grfx-card+monitor (dead screen).

Hexion: thanks for the tip of how to hold packages, but this is still a temporary fix. Theres lots of people usin new radeon cards, and by leaving beryl-xgl out dev's are putting them in rather difficult position; if they (users) value desktop usability/eye-candy they'll move to use a distro where xgl is supported.

Mike Basinger (mike.basinger) wrote :

The beryl-repo packages work great on my Macbook Pro, I hope the packages are upgrade before Feisty is released.

golfbuf (golfbuf) wrote :

I also have a recent ATI card that is not supported by the free drivers using AIGLX. So, the only way I can get it to work with either compiz or beryl is with the XGL server. I can also report that this latest beryl is broken for me using XGL and fglrx. Please expedite the fix.

Alex Launi (alexlauni) wrote :

Is anyone working on fixing this CRITICAL bug? ATi is about half of the graphics cards out there: don't leave us in the dust. Xgl isn't legacy, even some nvidia/ati driver users prefer it to AIGLX. Leaving it out of the package is not a fix. Why can't we just sync from the beryl repos where the packages actually work?

yes, I confirm this is really a bug. A new hint has been added to Ubuntu Feisty installation guide on ATI card at Beryl Wiki. It said we should download Beryl version to 0.2.0 and the Beryl(0.2.1) distributed by Ubuntu conflict with XGL,

Hope this bug will be fixed soon.

Spoilerhead (spoilerhead) wrote :

confirmed here
just downloaded the 0.2.0 debfile (http://ubuntu.beryl-project.org/pool/feisty/main/0.2.0/beryl-core_0.2.0~0beryl1_i386.deb) extracted beryl-xgl and laced it into /usr/bin fixes the problem for me

this bug certainly breaks beryl for all XGL users, and i think theres quite a lot of them.

is there any real reason why it wasn't included, except "we don't like XGL/ATI"?
thanks a lot, and please fix it (its nothing more then a rebuild, is it?)

Alex Launi (alexlauni) wrote :

@spoilerhead: "beryl-xgl was removed from the package at the request of the MOTU... I'll see if I can get it reinstated for a future release (as I understand it, the problem was that it statically links against it's own version of Mesa - linking against the version of mesa provided in Ubuntu could be a workable solution)."

so yes, pretty much. a little bit of code changing but nothing major. where is this package maintainer, did he die or something?

ski (skibrianski) wrote :

I have this problem too. Very disappointing.

S.Rey (s.rey) wrote :

Another unfortunate user of ATI X1400.

Please fix this. ATI users are about 50%. If you want people to stay with this distro, IMO this is not the way to go.

Note that this release of ubuntu is behaving very bad with us, starting with the livecd installer not being able to start X using the vesa driver in many wide screen laptops.

By the way, I cannot downgrade to the 0.2.0 version, since that is not in the universe repository. I suppose the only way is to add the third party beryl repository.

i have this problem too...the X server crashed when i rebooted after updating beryl from the universe repository. im kinda new to linux, and i didnt know what to do with a black screen, so i wiped my hard drive and started over. I have an ATI Xpress 200M on my HP laptop, and i really wish this bug would be fixed as soon as possible!

Alessio Treglia (quadrispro) wrote :

I can confirm this bug on my Feisty for Amd64.

My gc is Nvidia GeForce4 MX 4000 (driver nvidia 9631, new legacy), the only way to have a working beryl is to downgrade beryl-core (copy beryl-xgl etc)

We need a solution

I made beyl working by compiling 0.2.1 version (0.3.0 works too, but it's too buggy and crashes sometimes) with xgl support. Then:

LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa beryl --replace --use-copy --force-xgl

Anyway, it's still buggy on my computer (laptop, radeon 200m, fglrx, xgl, feisty)
I prefer Compiz, which is completely stable (0.5.0 - it's development version but it works well) and many plugins are ported from beryl to compiz (including Emerald window decorator)

palmerthegeek (palm1004) wrote :

I can confirm issue with the ATI Radeon M22 driver, using both the fglrx and tried using Milone's Evny installer.
here is the output from beryl-manager: (i hope this helps)

* Beryl system compatiblity check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : failed

Support for non power of two textures missing
beryl: glXBindTexImageEXT is missing
beryl: Failed to manage screen: 0
beryl: No manageable screens found on display :0.0

Elie Charest (archiesteel) wrote :

I can confirm this bug here (Xpress200M with fglrx, Xgl, Feisty).

I am holding the package to version 0.2.0 from the Beryl site for now, but I have to say that this seems to me like a pretty serious bug for people with ATI cards/chipsets.

ekso (ekso) wrote :

I can also confirm this PREVENTED me from using Beryl on ATI Radeon x1600 on an AMD64.

Some have managed to make it work somehow:

http://ubuntuforums.org/showthread.php?p=2683529#post2683529

I, and probably the majority of average users around, just don't have the time.

I assigned this bug to motus.

Changed in beryl-core:
assignee: nobody → motu
importance: Undecided → Medium
w3sz (w3sz) wrote :

I also have an ATI Radeon card that requires the proprietary ATI fglrx driver, and beryl won't work because of the missing beryl-xgl. I downloaded beryl-xgl from a non-stadard repository to make things work. That shouldn't be necessary.

Please fix this bug which has been known since at least March!

Beryl is replaced by Compiz Fusion, so has been removed from Gutsy.

  status invalid
  subscribe

Changed in beryl-core:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers