Ubuntu

bcmwl-kernel-source / broadcom-sta failed to build [fatal error: asm/system.h: No such file or directory]

Reported by userdce on 2012-05-03
890
This bug affects 210 people
Affects Status Importance Assigned to Milestone
Broadcom 802.11 Linux STA driver
Fix Released
Unknown
bcmwl (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
broadcom-sta (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

upgraded to quantal and this happened

  CC [M] /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.o
/var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.c:43:24: fatal error: asm/system.h: No such file or directory

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
DKMSKernelVersion: 3.4.0-1-generic
Date: Thu May 3 17:51:26 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageVersion: 5.100.82.38+bdcom-0ubuntu6.1
SourcePackage: bcmwl
Title: bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1: bcmwl kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

userdce (userdce) wrote :
tags: removed: need-duplicate-check
description: updated
Changed in bcmwl (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1: bcmwl kernel module
- failed to build
+ failed to build [fatal error: asm/system.h: No such file or directory]
Eugene San (eugenesan) wrote :

The attachment "0005-add-support-for-linux-3.4.0.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Thank you, the patch works beautifully. For completeness' sake and future reference here's a quick rundown:

1) Download the 64-bit (or 32-bit whichever applies) .deb package from the link in post #2
2) Right-click and select to Open with Ubuntu Software Center, ignore warning about older version existing and trusting the source and install; there are other ways to install the patch, this is the GUI-est
3) Remove all conflicting drivers by
        sudo rmmod brcmsmac
        sudo rmmod b43
        sudo rmmod bcma
        sudo rmmod wl
then re-load the driver
       sudo modprobe wl
4) Disconnect wired, wireless should be working
5) It looks like the install has auto-generated its own blacklist file in /etc/modprobe.d; if after reboot the wrong drivers still load it would probably be a good idea to blacklist brcmsmac and bcma in /etc/modprobe.d/blacklist.conf

Thanks again, glad to have wireless and be able to try 12.10.

Eugene San (eugenesan) wrote :

tsj:
Package in PPA treats all conflicting modules using modules blacklist, including brcsmac and bcma.
Official package however miss some conflicting modules.

I am using PPA package for 2-3 months now and can't think of a scenario when provided modules blacklist would fail.

I propose replacing the official package with one from PPA as it solves many issues and is properly "debianized" using updated original tarballs.

tsj (ts3141592) wrote :

Eugene:

Thanks for the response and, again, for the patch.

Quick question: you say "replacing the official package with one from PPA" but I am not sure exactly what you mean (I am fairly new to ubuntu). Apart from installing the .deb and adding the ppa (sudo add-apt-repository ppa:eugenesan/ppa) is there anything else that should be done at this point?

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.38+bdcom-0ubuntu7

---------------
bcmwl (5.100.82.38+bdcom-0ubuntu7) quantal; urgency=low

  * Add 0005-Add-support-for-Linux-3.4.0.patch:
    - Thanks to Eugene San for the patch (LP: #994255).
  * debian/dkms.conf.in:
    - Make sure that both patch 0004 and 0005 are applied
      when dealing with linux 3.4.
 -- Alberto Milone <email address hidden> Tue, 22 May 2012 13:10:38 +0200

Changed in bcmwl (Ubuntu):
status: Confirmed → Fix Released
madurax86 (madura-x86) wrote :

Linux 3.4 Kernel for precise from the ubuntu mainline crashes when the system starts theres a call trace with wl(PO) and mei(C), I blacklisted mei thinking it is a conflict, but the problem persists.

Clint Byrum (clint-fewbar) wrote :

Please add a Test Case and Regression Potential to the description of this bug, per https://wiki.ubuntu.com/StableReleaseUpdates. The upload of bcmwl to oneiric-proposed cannot be accepted until this is done.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/994255

tags: added: package-qa-testing
no longer affects: broadcom-sta (Ubuntu)
Changed in broadcom-sta:
status: Unknown → Fix Committed
description: updated
Florin Andrei (florin-andrei) wrote :

broadcom-sta is affected again on 12.10:

DKMS make.log for broadcom-sta-5.100.82.112 for kernel 3.5.0-18-generic (x86_64)
Fri Nov 9 13:54:56 PST 2012
make: Entering directory `/usr/src/linux-headers-3.5.0-18-generic'
Wireless Extension is the only possible API for this kernel version
Using Wireless Extension API
Kernel architecture is X86_64
  LD /var/lib/dkms/broadcom-sta/5.100.82.112/build/built-in.o
  CC [M] /var/lib/dkms/broadcom-sta/5.100.82.112/build/src/shared/linux_osl.o
  CC [M] /var/lib/dkms/broadcom-sta/5.100.82.112/build/src/wl/sys/wl_linux.o
/var/lib/dkms/broadcom-sta/5.100.82.112/build/src/wl/sys/wl_linux.c:43:24: fatal error: asm/system.h: No such file or directory
compilation terminated.
make[1]: *** [/var/lib/dkms/broadcom-sta/5.100.82.112/build/src/wl/sys/wl_linux.o] Error 1
make: *** [_module_/var/lib/dkms/broadcom-sta/5.100.82.112/build] Error 2
make: Leaving directory `/usr/src/linux-headers-3.5.0-18-generic'

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Clint Byrum (clint-fewbar) wrote :

I'm rejecting the upload to oneiric-proposed due to lack of test case and lack of response. Please re-upload to oneiric-proposed once the issue is addressed.

Changed in bcmwl (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress
Alberto Milone (albertomilone) wrote :

SRU request:

I've uploaded bcmwl (6.20.155.1+bdcom-0ubuntu0.0.1) in precise-proposed. It fixes the problem reported in this bug report and enables a few more wireless cards. Please accept my package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in broadcom-sta (Ubuntu Precise):
status: New → Confirmed

Hello userdce, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bcmwl/6.20.155.1+bdcom-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

I tried the proposed package, and while the driver loads and detects my Wi-Fi, it does not seem to be able to get past the authentication stage. I was able to however connect to a wireless network which did not need authentication. I am running Ubuntu 12.04 and using kernel 3.4. Please let me know if you need any additional details from me.

fahad naji (fahad-anmar) wrote :

how can I use the package to install the driver?

Adam Conrad (adconrad) wrote :

kingking: Instead of running a custom 3.4 kernel, if there's a reason you need a newer kernel, could you try installing "linux-generic-lts-quantal" and see if that works for you? It's monumentally hard for us to support random non-distro kernel configs.

kingking (sricharank) wrote :

Adam: Thanks for the reply. I was running the 3.4 kernel I had downloaded from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/.

I took your suggestion and installed "linux-generic-lts-quantal" from http://www.ubuntuupdates.org/package/core/precise/main/updates/linux-generic-lts-quantal . However, I am once again facing the same problem as before: the wl driver loads and my wireless is detected, but does not seem to be able to get past the authentication stage. If you need additional information about my system, please let me know. Thanks.

Adam Conrad (adconrad) wrote :

@Alberto: can you help debug kingking's issue above as part of verifying this SRU of yours?

Timo Jyrinki (timo-jyrinki) wrote :

Installed the -proposed bcmwl update, and it continues to work fine after installing and booting https://launchpad.net/ubuntu/precise/+source/linux-lts-quantal/3.5.0-22.34~precise1 on Dell Latitude 2110 (BCM43224). Using a WPA2 encrypted network, and tested also connecting to an ad-hoc network from my phone.

kingking (sricharank) wrote :

I read here : http://ubuntuforums.org/showthread.php?t=2047426 : and in other places that the issue might be with network-manager itself as opposed to the driver, and that this problem could be resolved by using 'wicd' instead of network manager. I therefore tried using 'wicd' instead of network-manager, but once again faced the same problem - I am not able to connect to the network when using the proposed driver. When I was using wicd, the status message showed that I am able to get past the authentication stage, and then it takes infinitely long time at the 'Obtaining IP address' stage.

kingking (sricharank) wrote :

Note: My laptop is Lenovo G780, and the broadcom wireless card is BCM4313.

Hello,
corrected bcmwl does work on my machine (AO751h, 3.5.0-21-generic)
I only struggled a bit to take it into use (but mostly because of my
lack of linux admin competence).
Wireless card kept on loading b43 driver even after I had blacklisted it
in /etc/modprobe.d/blacklist.conf, until I found out that to prevent
loading of drivers already included in the kernel you need to exclude
them at boot. I did that by adding "b43.blacklist=yes ssb.blacklist=yes"
in GRUB_CMDLINE_LINUX_DEFAULT line of /etc/default/grub.
I had no problem at all in connecting to the same wireless lan I was
using with b43 driver. Even better, bcmwl seems to provide more stable
connections. With b43 driver I was experiencing random disconnections
after a few hours, that seems not to happen any more with bcmwl.
I'm also going to label the correction as valid in launchpad, of course.
Thanks for this correction!
  - Carlo

On 17/01/2013 20:50, Adam Conrad wrote:
> Hello userdce, or anyone else affected,
>
> Accepted bcmwl into precise-proposed. The package will build now and be
> available at http://launchpad.net/ubuntu/+source/bcmwl/6.20.155.1+bdcom-
> 0ubuntu0.0.1 in a few hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: bcmwl (Ubuntu Precise)
> Status: In Progress => Fix Committed
>
> ** Tags added: verification-needed
>

tags: added: verification-done
Changed in broadcom-sta:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2013-01-25
tags: removed: verification-needed

This bug was fixed in the package bcmwl - 6.20.155.1+bdcom-0ubuntu0.0.1

---------------
bcmwl (6.20.155.1+bdcom-0ubuntu0.0.1) precise-proposed; urgency=low

  [ Alberto Milone ]
  * New upstream release (LP: #923809).
  * Add 0004-Add-support-for-Linux-3.2.patch:
    - Make sure the patch can always be applied.
  * Add 0005-Add-support-for-Linux-3.4.0.patch:
    - Thanks to Eugene San for the patch (LP: #994255).
  * debian/control:
    - Drop all the dependencies on the linux-headers.
  * debian/dkms.conf.in:
    - Always apply all patches (LP: #1020059).

  [ Martin Pitt ]
  * debian/bcmwl-kernel-source.postinst:
    - Silence the errors from rmmod about the modules not being
      loaded. This is fully expected, and just causes confusion,
      as well as autopkgtest failures.
    - Mirror the actions of the installed modprobe.d files,
      i.e. rmmod the b43 driver and try to modprobe wl, so
      that this package works right after installation.
      (LP: #1065827)
    - Drop duplicate #DEBHELPER# token. It does not currently
      expand to anything, but it looks confusing.
  * debian/rules, debian/bcmwl-kernel-source.modaliases:
    - Drop parsing of src/src/wl/sys/wl_linux.c, as the current
      upstream version dropped all useful vendor matches in its
      pci_device_id struct and now has a broken modalias. Keep
      a static debian/bcmwl-kernel-source.modaliases instead
      which matches on any Broadcom network device (vendor 14E4
      class 02 subclass 80). This brings back a proper
      "Modaliases:" package header (LP: #1089943).
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 12:38:17 +0100

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

summary: - bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1: bcmwl kernel module
- failed to build [fatal error: asm/system.h: No such file or directory]
+ bcmwl-kernel-source / broadcom-sta failed to build [fatal error:
+ asm/system.h: No such file or directory]
Aaron Taggert (aaron-taggert) wrote :

This works fine in standard kernel but I can't get it to work with low latency kernel.

Thanks Aaron. :-)
On Sep 5, 2013 7:30 PM, "Aaron Taggert" <email address hidden> wrote:

> This works fine in standard kernel but I can't get it to work with low
> latency kernel.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1191660).
> https://bugs.launchpad.net/bugs/994255
>
> Title:
> bcmwl-kernel-source / broadcom-sta failed to build [fatal error:
> asm/system.h: No such file or directory]
>
> Status in Broadcom 802.11 Linux STA driver:
> Fix Released
> Status in “bcmwl” package in Ubuntu:
> Fix Released
> Status in “broadcom-sta” package in Ubuntu:
> Confirmed
> Status in “bcmwl” source package in Precise:
> Fix Released
> Status in “broadcom-sta” source package in Precise:
> Confirmed
>
> Bug description:
> upgraded to quantal and this happened
>
> CC [M] /var/lib/dkms/bcmwl/5.100.82.38
> +bdcom/build/src/wl/sys/wl_linux.o
> /var/lib/dkms/bcmwl/5.100.82.38+bdcom/build/src/wl/sys/wl_linux.c:43:24:
> fatal error: asm/system.h: No such file or directory
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1
> ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
> Uname: Linux 3.2.0-24-generic x86_64
> NonfreeKernelModules: wl fglrx
> ApportVersion: 2.0.1-0ubuntu7
> Architecture: amd64
> DKMSKernelVersion: 3.4.0-1-generic
> Date: Thu May 3 17:51:26 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64
> (20120425)
> PackageVersion: 5.100.82.38+bdcom-0ubuntu6.1
> SourcePackage: bcmwl
> Title: bcmwl-kernel-source 5.100.82.38+bdcom-0ubuntu6.1: bcmwl kernel
> module failed to build
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/broadcom-sta/+bug/994255/+subscriptions
>

Changed in broadcom-sta (Ubuntu):
status: Confirmed → Fix Committed
Changed in broadcom-sta (Ubuntu Precise):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in broadcom-sta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.