Banshee does not start

Bug #873787 reported by Juan Montoya on 2011-10-14
128
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
High
banshee (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Chow Loong Jin
Precise
Medium
Unassigned

Bug Description

Banshee just worked once.
After rebooting, running banshee from a terminal prints this:

(Banshee:2284): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.ArgumentException: Value does not fall within the expected range.
  at Hyena.Gui.Canvas.Rect.set_Height (Double value) [0x00000] in <filename unknown>:0
  at Hyena.Gui.Canvas.Rect.op_Explicit (Rectangle rect) [0x00000] in <filename unknown>:0
  at Hyena.Data.Gui.ListView`1[Banshee.Collection.AlbumInfo].OnSizeAllocated (Rectangle allocation) [0x00000] in <filename unknown>:0
  at Gtk.Widget.sizeallocated_cb (IntPtr widget, IntPtr allocation) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.sizeallocated_cb(IntPtr widget, IntPtr allocation)
   at Gtk.Widget.gtksharp_widget_base_show(IntPtr )
   at Gtk.Widget.OnShown()
   at Nereid.PlayerInterface.OnShown()
   at Gtk.Widget.shown_cb(IntPtr widget)
   at Gtk.Widget.gtk_widget_show(IntPtr )
   at Gtk.Widget.Show()
   at Banshee.Gui.BaseClientWindow.InitialShowPresent()
   at Nereid.PlayerInterface.Initialize()
   at Banshee.Gui.BaseClientWindow.InitializeWindow()
   at Banshee.Gui.BaseClientWindow..ctor(System.String title, System.String configNameSpace, Int32 defaultWidth, Int32 defaultHeight)
   at Nereid.PlayerInterface..ctor()
   at System.Reflection.MonoCMethod.InternalInvoke(System.Reflection.MonoCMethod , System.Object , System.Object[] , System.Exception ByRef )
   at System.Reflection.MonoCMethod.Invoke(System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.MonoCMethod.Invoke(BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.ConstructorInfo.Invoke(System.Object[] parameters)
   at System.Activator.CreateInstance(System.Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(System.Type type)
   at Banshee.ServiceStack.ServiceManager.RegisterService(System.Type type)
   at Banshee.ServiceStack.ServiceManager.Run()
   at Banshee.ServiceStack.Application.Run()
   at Banshee.Gui.GtkBaseClient.Initialize(Boolean registerCommonServices)
   at Banshee.Gui.GtkBaseClient..ctor(Boolean initializeDefault, System.String defaultIconName)
   at Banshee.Gui.GtkBaseClient..ctor()
   at Nereid.Client..ctor()
   at System.Reflection.MonoCMethod.InternalInvoke(System.Reflection.MonoCMethod , System.Object , System.Object[] , System.Exception ByRef )
   at System.Reflection.MonoCMethod.Invoke(System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.MonoCMethod.Invoke(BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.ConstructorInfo.Invoke(System.Object[] parameters)
   at System.Activator.CreateInstance(System.Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(System.Type type)
   at Banshee.Gui.GtkBaseClient.Startup()
   at Hyena.Gui.CleanRoomStartup.Startup(Hyena.Gui.StartupInvocationHandler startup)
   at Banshee.Gui.GtkBaseClient.Startup()
   at Banshee.Gui.GtkBaseClient.Startup(System.String[] args)
   at Nereid.Client.Main(System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.AppDomain , System.Reflection.Assembly , System.String[] )
   at System.AppDomain.ExecuteAssemblyInternal(System.Reflection.Assembly a, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile)
   at Booter.Booter.BootClient(System.String clientName)
   at Booter.Booter.Main()

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: banshee 2.2.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 13 20:34:59 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 LANGUAGE=es_PE:es
 PATH=(custom, no user)
 LANG=es_PE.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: No upgrade log present (probably fresh install)

Juan Montoya (th3pr0ph3t) wrote :

I am experiencing a very similar problem. Banshee started once, after the fresh setup of ubuntu 11.10. I designated my music location for banshee and was able to play mp3s. Since that first start, banshee doe not start up again, does not play music an produces error-messages as posted in the attachment. The messages ahve been recieved using the bash command: banshee --debug.
I did not manually work in any configuration data or changed any settings within banshee.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
Download full text (6.1 KiB)

To keep on using Banshee I uninstalled (purged) banshee and remove
configuration files in .config/banshee-1 and .gconf-something, then
reinstalled it and did not disable the many unnecessary plugins it
has.
I'd bet it's one of them what's causing this problem.

2011/10/14 Martin Liebmann <email address hidden>:
> I am experiencing a very similar problem. Banshee started once, after the fresh setup of ubuntu 11.10. I designated my music location for banshee and was able to play mp3s. Since that first start, banshee doe not start up again, does not play music an produces error-messages as posted in the attachment. The messages ahve been recieved using the bash command: banshee --debug.
> I did not manually work in any configuration data or changed any settings within banshee.
>
> ** Attachment added: "debug information: bash$ banshee --debug"
>   https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/873787/+attachment/2544626/+files/banshee_debug.log
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/873787
>
> Title:
>  Banshee does not start
>
> Status in “banshee” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Banshee just worked once.
>  After rebooting, running banshee from a terminal prints this:
>
>  (Banshee:2284): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,
>  Exception in Gtk# callback delegate
>    Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
>  System.ArgumentException: Value does not fall within the expected range.
>    at Hyena.Gui.Canvas.Rect.set_Height (Double value) [0x00000] in <filename unknown>:0
>    at Hyena.Gui.Canvas.Rect.op_Explicit (Rectangle rect) [0x00000] in <filename unknown>:0
>    at Hyena.Data.Gui.ListView`1[Banshee.Collection.AlbumInfo].OnSizeAllocated (Rectangle allocation) [0x00000] in <filename unknown>:0
>    at Gtk.Widget.sizeallocated_cb (IntPtr widget, IntPtr allocation) [0x00000] in <filename unknown>:0
>     at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
>     at Gtk.Widget.sizeallocated_cb(IntPtr widget, IntPtr allocation)
>     at Gtk.Widget.gtksharp_widget_base_show(IntPtr )
>     at Gtk.Widget.OnShown()
>     at Nereid.PlayerInterface.OnShown()
>     at Gtk.Widget.shown_cb(IntPtr widget)
>     at Gtk.Widget.gtk_widget_show(IntPtr )
>     at Gtk.Widget.Show()
>     at Banshee.Gui.BaseClientWindow.InitialShowPresent()
>     at Nereid.PlayerInterface.Initialize()
>     at Banshee.Gui.BaseClientWindow.InitializeWindow()
>     at Banshee.Gui.BaseClientWindow..ctor(System.String title, System.String configNameSpace, Int32 defaultWidth, Int32 defaultHeight)
>     at Nereid.PlayerInterface..ctor()
>     at System.Reflection.MonoCMethod.InternalInvoke(System.Reflection.MonoCMethod , System.Object , System.Object[] , System.Exception ByRef )
>     at System.Reflection.MonoCMethod.Invoke(System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
>     at System.Reflection.MonoCMethod.Invoke(BindingFlags...

Read more...

Juan Montoya (th3pr0ph3t) wrote :

To keep on using Banshee I uninstalled (purged) banshee and removed
configuration files in .config/banshee-1 and .gconf-something, then
reinstalled it and did not disable the many unnecessary plugins it
has.
I'd bet it's one of them what's causing this problem.

Bilal Shahid (s9iper1) wrote :

also experiencing the same issue..banshee icon appear but it vanished in 2 sec and bashee is not start.

Chow Loong Jin (hyperair) wrote :

Could all of you experiencing this issue please post post the values of your /apps/banshee-1/player_window/width and /apps/banshee-1/player_window/height keys? It sounds like those keys somehow got assigned an out-of-bounds value.

Chow Loong Jin (hyperair) wrote :

Please also post your results to https://bugzilla.gnome.org/show_bug.cgi?id=661824, which is the bug in the upstream bug tracker.

Changed in banshee (Ubuntu):
status: Confirmed → Incomplete
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Gema Gomez (gema) wrote :

Some users are asking how to provide the information on IRC.

The command to run is gconf-editor and in that application find the values of:
/apps/banshee-1/player_window/width
/apps/banshee-1/player_window/height

Bilal Shahid (s9iper1) wrote :

i use this one in the terminal
1). gconftool-2 -g /apps/banshee-1/player_window/width
2). gconftool-2 -g /apps/banshee-1/player_window/height

and the result is

bil21al@bil21al-ThinkPad-T60:~$ gconftool-2 -g /apps/banshee-1/player_window/height
700
bil21al@bil21al-ThinkPad-T60:~$ gconftool-2 -g /apps/banshee-1/player_window/width
1014

using gconf-editor or gconftool I get the following values:
/apps/banshee-1/player_window/width : 1024
/apps/banshee-1/player_window/heigt : 700

Following Th3Pr0ph3t's suggestion to uninstall banshee, delete the configuration files and reinstall it, I could arrange a working status too. It appears, that changing any settings according the many unusefull extra applications, such as the unrequested download of album-covers and additional information from online db's causes banshee to crash at the next startup.
This time I did not tell banshee to stop any apps, and it is still working.

Changed in banshee:
status: New → Invalid
Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in banshee:
importance: Unknown → High
status: Unknown → Confirmed
Changed in banshee (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in banshee (Ubuntu Oneiric):
status: New → In Progress
assignee: nobody → Chow Loong Jin (hyperair)
Changed in banshee (Ubuntu Oneiric):
status: In Progress → Triaged
Chris Halse Rogers (raof) wrote :

How is this going to be addressed in Precise? One of the outcomes of the SRU UDS session was that we'll be enforcing our policy more consistently; that means that this needs to be fixed in Precise first.

Getting this fixed in precise first will also give the previous -proposed upload the opportunity to mature and make it through to -updates, so we won't reset the testing clock on all that goodness.

Chow Loong Jin (hyperair) wrote :

On 14/11/2011 14:49, Chris Halse Rogers wrote:
> How is this going to be addressed in Precise? One of the outcomes of
> the SRU UDS session was that we'll be enforcing our policy more
> consistently; that means that this needs to be fixed in Precise first.
>
> Getting this fixed in precise first will also give the previous
> -proposed upload the opportunity to mature and make it through to
> -updates, so we won't reset the testing clock on all that goodness.

The patch is just a workaround, not a real fix. We still don't know exactly
what's causing the bug.

I plan on leaving the patch I just applied for oneiric-proposed out for precise
to allow for testing until later in the cycle. There are a number of releases to
go before 2.4.0 gets released for Precise. If it gets fixed before then, well
and good. Otherwise, I'll just slap the patch on again for the final 2.4.0
upload before release.

If that doesn't sound good, I suppose we can have the patch on the 2.3.x builds
in Precise as well, but the result is that we have a cheap hack that deviates
from upstream and upstream doesn't get a chance to fix the bug because it's been
worked around downstream.

--
Kind regards,
Loong Jin

Martin Pitt (pitti) wrote :

OK for me to patch in oneiric-proposed only under these circumstances. But the current SRU should still go into -updates first, otherwise we'd lose tracking of this.

Pau Oliva (poliva) wrote :
Download full text (3.2 KiB)

The crash is produced when the gconf key /apps/banshee-1/interface/panes/albumartist/browser/top/position is set to 0.

When this key is set to 0, banshee will not start anymore.

To reproduce the bug:

1. drag the window separator to the most upper side possible.
2. Banshee will start consuming a lot of CPU, and should be killed.
3. After dragging the window it will show the output pasted below.
4. When you try to start banshee again, it will not start.

Please see the attached screenshot showing how to reproduce it.

** (Banshee:11270): WARNING **: Error calling get_info: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 1041, in get_info
    return self.syncdaemon_folders.get_info(path)
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 640, in get_info
    mdobj = self.fs.get_by_path(path.encode('utf-8'))
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 781, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/poliva/.ubuntuone/Purchased from Ubuntu One'

** (Banshee:11270): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed

** (Banshee:11270): WARNING **: Error rescanning Purchased Music: No such file or directory
** (Banshee:11270): DEBUG: Loading the real store page
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.ArgumentException: Value does not fall within the expected range.
  at Hyena.Gui.Canvas.Rect.set_Height (Double value) [0x00000] in <filename unknown>:0
  at Hyena.Gui.Canvas.Rect.op_Explicit (Rectangle rect) [0x00000] in <filename unknown>:0
  at Hyena.Data.Gui.ListView`1[Banshee.Collection.AlbumInfo].OnSizeAllocated (Rectangle allocation) [0x00000] in <filename unknown>:0
  at Gtk.Widget.sizeallocated_cb (IntPtr widget, IntPtr allocation) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.sizeallocated_cb(IntPtr widget, IntPtr allocation)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Banshee.Gui.GtkBaseClient.Run()
   at Banshee.Gui.GtkBaseClient.Startup()
   at Hyena.Gui.CleanRoomStartup.Startup(Hyena.Gui.StartupInvocationHandler startup)
   at Banshee.Gui.GtkBaseClient.Startup()
   at Banshee.Gui.GtkBaseClient.Startup(System.String[] args)
   at Nereid.Client.Main(System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.AppDomain , System.Reflection.Assembly , System.String[] )
   at System.AppDomain.ExecuteAssemblyInternal(System.Reflection.Assembly a, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile)
   at Booter.Booter....

Read more...

Martin Pitt (pitti) wrote :

Please upload the fix to precise, so that this can progress to -updates. Thanks!

Changed in banshee (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed

Hello Th3Pr0ph3t, or anyone else affected,

Accepted banshee into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Could anyone please test the -proposed version? Also, can this please be fixed in precise soon, so that this can progress to -updates?

Thanks!

Hello,

the oneric-proposed package is working for me!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.2.1-1ubuntu2

---------------
banshee (2.2.1-1ubuntu2) oneiric-proposed; urgency=low

  * [8217e74] Add workaround for set_Height exceptions in Hyena.
    Thanks to Andrés G. Aragoneses <email address hidden> (LP: #873787)
 -- Chow Loong Jin <email address hidden> Sun, 13 Nov 2011 02:49:19 +0800

Changed in banshee (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Kyle Bruene (kylebruene) wrote :

Bug is back in latest update of Precise. Banshee 2.3.3

wvengen (wvengen) wrote :

I see the problem as well in Banshee 2.3.6 on Oneiric. Firing up MonoDevelop shows me that AlbumListView::OnSizeAllocated() tries to create a Hyena.Gui.Canvas.Rect from list_rendering_alloc, which throws the ArgumentException because height=-9 < 0. Not sure yet where it comes from.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.4.0-1ubuntu3

---------------
banshee (2.4.0-1ubuntu3) precise; urgency=low

  * [9b356d6] Add workaround for set_Height exception.
    This patch was previously added to the Oneiric release but left out of
    Precise to facilitate further testing of the bug. (LP: #873787)
 -- Chow Loong Jin <email address hidden> Sat, 24 Mar 2012 05:37:04 +0800

Changed in banshee (Ubuntu Precise):
status: Triaged → Fix Released
Changed in banshee:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.