banshee fail to launch

Bug #768948 reported by Mariano Cabrera on 2011-04-22
This bug report is a duplicate of:  Bug #873787: Banshee does not start. Edit Remove
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Banshee
Unknown
Unknown
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

I have report this a week ago, but it was assumed to be a duplicated for the 764646 bug. I applied the fix, so the "music store widget dies with «TypeError: find_credentials() takes exactly 3 arguments (2 given)" error is fix, no longer appears. But I still have the problem.

Starting Banshee from a terminal:
mariano@mariano-dell:~$ banshee
[Info 09:06:46.600] Running Banshee 2.0.0: [Ubuntu Natty (development branch) (linux-gnu, i686) @ 2011-04-18 16:21:33 UTC]
[Info 09:06:48.402] Updating web proxy from GConf
[Info 09:06:48.443] All services are started 0,924566
** (Banshee:5557): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:5557): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'

** (Banshee:5557): WARNING **: Error calling get_info: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 992, in get_info
    return self.syncdaemon_folders.get_info(path)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 634, in get_info
    mdobj = self.fs.get_by_path(path.encode('utf-8'))
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 773, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/mariano/.ubuntuone/Purchased from Ubuntu One'

** (Banshee:5557): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed

** (Banshee:5557): WARNING **: Error rescanning Purchased Music: No existe el fichero o el directorio
** (Banshee:5557): DEBUG: Loading the real store page
[Info 09:06:50.896] nereid Client Started
[Info 09:06:50.977] GStreamer version 0.10.32.0, gapless: True, replaygain: False
[Info 09:06:51.025] AppleDeviceSource is ignoring unmounted volume OS

One more thing, I do no have a .ubuntuone folder in my home, so I added it, even with the Purchased subfolder, but nothing happened.

Regards.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: banshee 2.0.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Apr 22 09:12:22 2011
ProcEnviron:
 LANGUAGE=es_AR:en
 LANG=es_AR.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: No upgrade log present (probably fresh install)

The stack trace is identical to the bug #764646. If you're still seeing the
issue, it means either that you did not apply the fix properly, or that the fix
is inadequate/incomplete. Please post a follow up comment on the original bug
with Banshee's output.

  duplicate 764646

--
Kind regards,
Loong Jin

dobey (dobey) wrote :

Which stack trace? The Python traceback printed on the console there is a different issue than #764646 and is non-fatal.

Mariano, can you please describe exactly what is wrong that you are expecting to happen, and is not?

The problem is that the banshee main window fails to open, but, as I realized today, banshee is running and you can play it with the indicator widget.

Regards

New clue: sudo Banshhe works fine.

Xavier Bassery (xaba) wrote :

According to comment 4, it seems that banshee can in fact run (works in the indicator applet) but the main interface wasn't showing up.
If such a case happens again, could you please try to first kill any running instance of banshee before launching it?
To do so, you can simply type in a terminal: killall banshee
If the output to the previous command is "banshee: no process found", this means that the culprit is not an already running instance of banshee for your user, but then maybe something wicked with the memorized position of the main window.
Both cases would be compatible with message #5.

Hi Xavier, Banshe is running for my user:
 2060 ? S 0:00 bash /usr/bin/banshee --redirect-log --play-enqueued
 2066 ? Sl 0:03 banshee /usr/lib/banshee/Banshee.exe --redirect-log -

The thing is, that it seems to be that the banshee main windows is there, but is invisible. I can switch between aplications and is there I can see it, when I do an Alt Tab, banshee is there.

Regards

Victor Vargas (kamus) wrote :

Mariano, have you tried to remove your banshee configuration/cache directories (.config/banshee-1 and .cache/banshee-1) and then check how banshee works?

Changed in banshee (Ubuntu):
importance: Undecided → Low

I remove the directories, but nothing change. This is the terminal output:

mariano@mariano-dell:~$ banshee
[Info 12:08:01.641] Running Banshee 2.0.0: [Ubuntu Natty (development branch) (linux-gnu, i686) @ 2011-04-18 16:21:33 UTC]
[Info 12:08:03.799] Updating web proxy from GConf
[Info 12:08:03.958] All services are started 1,048172
** (Banshee:1889): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:1889): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'

** (Banshee:1889): WARNING **: Error calling get_info: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 992, in get_info
    return self.syncdaemon_folders.get_info(path)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 634, in get_info
    mdobj = self.fs.get_by_path(path.encode('utf-8'))
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 773, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/mariano/.ubuntuone/Purchased from Ubuntu One'

** (Banshee:1889): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed
[Warn 12:08:04.654] Migrating Internet Radio Stations - System.IO.DirectoryNotFoundException: Directory '/home/mariano/.config/banshee/plugins/stations/user' not found. (in `mscorlib')
  at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in <filename unknown>:0
  at System.IO.Directory.GetFiles (System.String path, System.String searchPattern) [0x00000] in <filename unknown>:0
  at Banshee.InternetRadio.XspfMigrator.Migrate () [0x00000] in <filename unknown>:0

** (Banshee:1889): WARNING **: Error rescanning Purchased Music: No existe el fichero o el directorio
** (Banshee:1889): DEBUG: Loading the real store page
[Info 12:08:05.612] nereid Client Started
[Info 12:08:05.696] GStreamer version 0.10.32.0, gapless: True, replaygain: False
[Info 12:08:05.852] AppleDeviceSource is ignoring unmounted volume OS

Regards

dobey (dobey) wrote :

Mariano:

What resolution is your screen? And what does running the following commands output?

gconftool-2 -g /apps/banshee-1/player_window/x_pos
gconftool-2 -g /apps/banshee-1/player_window/y_pos

And if one of those is greater than your resolution, does running the following command resolve the issue?

gconftool-2 --recursive-unset /apps/banshee-1/player_window

Rodney:

My screen resolution is: 1920*1080.

gconftool-2 -g /apps/banshee-1/player_window/x_pos 0
gconftool-2 -g /apps/banshee-1/player_window/y_pos 224

I do not think this is greater than my screen resolution, but I do not like the 0, so I run the:

gconftool-2 --recursive-unset /apps/banshee-1/player_window

Banshee now is working fine!!!, thanks a lot.

dobey (dobey) wrote :

OK. Maybe the width/height got set to 0 then. It seemed more like it was off-screen though. Anyway, i'm setting this to Invalid as it works properly now.

Changed in banshee (Ubuntu):
status: New → Invalid
Daniel Ejsing-Duun (zilvador) wrote :

I just experienced exactly the same bug. Banshee opened in the launchpad and, as I found out, on the desktop, but it was invisible. I got the same stack trace as in the original post.

I ran the gconftool command in #11 after finding this report, restarted banshee and now it works again. It seems that something is still blocking this.

I am running Oneiric.

Changed in banshee (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.