Ubuntu

package firmware-b43-installer 4.150.10.5-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Reported by Dave Morley on 2010-09-29
380
This bug affects 57 people
Affects Status Importance Assigned to Milestone
b43-fwcutter (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: b43-fwcutter

B43 driver failed to install after the STA driver failed to connect to the router.

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: firmware-b43-installer 4.150.10.5-4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
AptOrdering:
 b43-fwcutter: Install
 firmware-b43-installer: Install
 b43-fwcutter: Configure
 firmware-b43-installer: Configure
Architecture: i386
Date: Wed Sep 29 11:20:27 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
PackageArchitecture: all
SourcePackage: b43-fwcutter
Title: package firmware-b43-installer 4.150.10.5-4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

issue solved

Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 firmware-b43-installer

It seems that this particular chipset isn't supported :(

Dave Morley (davmor2) on 2010-09-29
Changed in b43-fwcutter (Ubuntu):
status: New → Invalid
Köntzä (kontza) wrote :

Had the same problem, then I noticed that instead of firmware-b43-installer I had to install (manually, via synaptic) firmware-b43-lpphy-installer. My install is a x64-version via netboot, i.e. mini.iso. Just the other day when I tried x86 netbook live-cd, it managed succesfully to automatically set up my wireless.

I would still keep this as a valid bug, since the system couldn't automatically resolve this.

Changed in b43-fwcutter (Ubuntu):
status: Invalid → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

See bug 655111 about releases-notes for detail.

Changed in b43-fwcutter (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Marcelo (marceloramone-gmail) wrote :

I have the same problem in 10.10 final 32bits with all updates installed:

Se encontraron errores al procesar:
 firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is impossible to enable my wi-fi

Marcelo (marceloramone-gmail) wrote :

detailed error:

Se encontraron errores al procesar:

 firmware-b43-installer

Configurando firmware-b43-installer (4.150.10.5-4) ...

Not supported low-power chip with PCI id 14e4:4315!

Aborting.

dpkg: error al procesar firmware-b43-installer (--configure):

 el subproceso script post-installation instalado devolvió el código de salida de error 1

Pavel Sosin (pavel-sosin) wrote :

This bug prevents installation almost any package / application! But, WiFi can be repaired following instruction:
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Installing drivers in Maverick: When turning on the wifi enabled computer
crashes and does not charge.

Solution (for me): downgrade to Lucid Lynx

Marcelo (marceloramone-gmail) wrote :

I deleted my 10.10 and re-install 10.04.

I'M with WI-FI now...

I've the same problem, I'm unable to use the wifi :-(

my wifi chipset pci id is 14e4:4315
Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Marcelo (marceloramone-gmail) wrote :

Solution: System > Administration > Synaptic Package Manager > Search: firmware-b43-lpphy-installer > Click Mark > Click install > Close

Thank you Köntzä, is solved!

VladimirCZ (vlabla) wrote :

I've the same problem. I have found that Jockey tries to install the "firmware-b43-installer" instead of the right "firmware-b43-lpphy-installer" and then wifi drivers installation is screwed up. After manually uninstalling / installing the wrong / right driver in Synaptict P.M. I can use the right kernel driver "firmware-b43-lpphy-installer", but Jockey reports that the B43 driver is not activated.

my wifi chipset pci id is 14e4:4315
Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

David Leal (jdleal) wrote :

for me work this solutions:

1:
sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source

2:
With synaptic install: firmware-b43-lpphy-installer

with both the wireless work, but my problem was with Aircrack (the main reason to install Ubuntu in this Laptop)

Frank Duffey (fduffey) wrote :

I ran the command to remove the b43 installer as :
sudo apt-get purge firmware-b43-installer

zas1984 (daniel-ecb) wrote :

Yes same problem here. I was trying to uninstall and install programs with the program center, and failed to. It gives me an error

"firmware-b43-installer (4.150.10.5-4) ... Not supported low-power chip with PCI id 14e4:4315"

 so I opened the synaptic search for b43, choose the lphy, mark to install, apply changes, ok, close the synaptic and then I finally could install and uninstall the programs.

Cheers, Daniel.

Netbook mini Hp 110, Ubuntu 10.
Central de programas, erro instalar, desinstalar.

Jarl (jarl-dk) wrote :

The b43-fwcutter package needs the attached patch to download and use correct binary version which contains the necessary files:

Jarl (jarl-dk) wrote :

Hi again. The patch wont do it, the driver is looking for at file ucode16_mimo.fw and broadcom-wl-4.178.10.4.tar.bz2 only contains a ucode16.fw

tags: added: patch
Jed_c (jed-c) wrote :

This has been going on for YEARS with Ubuntu, evidently the Broadcom chipset is a bit to complicated for the folks at Ubuntu....just sayin......

Jed_c (jed-c) wrote :

No matter what, a HP zv6000 with a broadcom 4318 chipset will not work with Ubuntu. Period. Not with bcm43, not with the legacy driver, not with ndiswrapper. I double dog dare ANYONE to say otherwise. Oh well, I thought I'd give Ubuntu another shot, but seems nothing has changed.....

Xiaojun Ma (damage3025) wrote :

@Jed_c
Really? According to http://linuxwireless.org/en/users/Drivers/b43#Supported_devices and source code of Ubuntu's fw-cutter source package I checked. 4318 should work at least since 11.10

To post a comment you must log in.