Synaptic backend doesn't work in apturl

Bug #1338482 reported by Vlad Orlov
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

The Synaptic backend in apturl is non-functional. Trying to use it makes
apturl crash with Python error message.

The fix for this issue is provided in the debdiffs attached to the report.

It's a long-standing bug which is present in all current Ubuntu releases,
starting from Trusty. Would be nice to get it finally fixed. A non-working
backend isn't good at all, especially when the only other backend (aptdaemon)
might be removed soon, as stated in bug 1673258.

[Test Case]

The easiest way to make apturl use the Synaptic backend (without removing
aptdaemon from the system) is to set the environment variable when launching
it from the terminal:

$ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gnome-calculator

You can use any other package which isn't installed. I chose gnome-calculator
as it wasn't installed in my Xubuntu and Ubuntu MATE systems.

The result of this will be crash of apturl with Python error message.
The package won't be installed.

[Regression Potential]

The patch only affects the Synaptic backend. It doesn't affect aptdaemon
backend or any other parts of code. Since the Synaptic backend was broken
before, it's not possible to break it further with some regression.

[Original Description]

System: Xubuntu 14.10
apturl version: 0.5.2ubuntu4

If you'll tell apturl to use the Synaptic backend (by either removing aptdaemon from the system or specifying UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 before apturl in the terminal), it crashes with this error:

$ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gcalctool
/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py:4: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
  GObject.threads_init()
Traceback (most recent call last):
  File "/usr/bin/apturl-gtk", line 43, in <module>
    ui = GtkUI()
  File "/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py", line 38, in __init__
    self.backend = get_backend(self.dia)
  File "/usr/lib/python3/dist-packages/AptUrl/gtk/backend/__init__.py", line 49, in get_backend
    return InstallBackendSynaptic(*args, **kwargs)
TypeError: __init__() missing 1 required positional argument: 'action'

Revision history for this message
Vlad Orlov (monsta) wrote :

The effect is exactly the same in Xubuntu 14.04 (apturl's version is also the same, 0.5.2ubuntu4).

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apturl (Ubuntu):
status: New → Confirmed
Vlad Orlov (monsta)
tags: added: trusty
Revision history for this message
Vlad Orlov (monsta) wrote :

Same in 15.10 and 16.04.

tags: added: wily xenial
Changed in apturl (Ubuntu):
importance: Undecided → Medium
Vlad Orlov (monsta)
tags: added: zesty
Vlad Orlov (monsta)
tags: added: artful
removed: wily
Revision history for this message
Vlad Orlov (monsta) wrote :

So here's the fix for 17.10. Now Synaptic backend should work.

I've removed the part of debdiff with modifications to po/apturl.pot file as it's not relevant to the issue.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Debdiff with the fix for Artful" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Vlad Orlov (monsta) wrote :
Revision history for this message
Vlad Orlov (monsta) wrote :

For 14.04 I had to add one more import to the code - workaround for https://bugzilla.gnome.org/show_bug.cgi?id=673396

Vlad Orlov (monsta)
description: updated
Vlad Orlov (monsta)
tags: added: bionic
Vlad Orlov (monsta)
tags: removed: zesty
Vlad Orlov (monsta)
tags: removed: artful
Revision history for this message
Simon Quigley (tsimonq2) wrote :

Sponsored. Sorry for the delay!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu15

---------------
apturl (0.5.2ubuntu15) cosmic; urgency=medium

  * Make Synaptic backend actually work (LP: #1338482).

 -- Vlad Orlov <email address hidden> Sat, 21 Apr 2018 11:25:24 +0300

Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Vlad Orlov (monsta) wrote :

Thanks :)

Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Vlad, or anyone else affected,

Accepted apturl into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apturl/0.5.2ubuntu14.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apturl (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in apturl (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Vlad, or anyone else affected,

Accepted apturl into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apturl/0.5.2ubuntu11.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apturl (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Vlad, or anyone else affected,

Accepted apturl into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apturl/0.5.2ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Vlad Orlov (monsta) wrote :

Testing in Xubuntu 14.04. Updated to version 0.5.2ubuntu4.1 from trusty-proposed.

$ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gnome-calculator

All good, the package is installed successfully.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Revision history for this message
Vlad Orlov (monsta) wrote :

Testing in Ubuntu MATE 16.04. Updated to version 0.5.2ubuntu11.2 from xenial-proposed.

$ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gnome-calculator

All good, the package is installed successfully.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Revision history for this message
Vlad Orlov (monsta) wrote :

Unfortunately, Synaptic backend still fails in 18.04, this time due to absence of gksu. I'll try to adapt the patch to pkexec (which Synaptic supports).

For Trusty and Xenial, the patch is working fine.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Revision history for this message
Vlad Orlov (monsta) wrote :

This is the updated debdiff which adds switch from gksu to pkexec to make Synaptic actually run.

Revision history for this message
Vlad Orlov (monsta) wrote :

New debdiff makes Synaptic backend finally work in 18.04, so the old debdiff is removed.

Sponsors: please upload the updated package...

Revision history for this message
Vlad Orlov (monsta) wrote :

Hmm... the updated patch is also needed for 18.10, as version 0.5.2ubuntu15 still tries to use gksu.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

The xenial upload, even though verified, can't be released until cosmic and bionic are fixed. Let's wait for someone to sponsor the two required uploads.

Revision history for this message
Vlad Orlov (monsta) wrote :

Ok, I'm making an additional patch for 18.10 then, because the current patch (still with gksu) has already landed in the repos...

Revision history for this message
Vlad Orlov (monsta) wrote :

Ok, here's the new debdiff for 18.10, with switch from gksu to pkexec to make Synaptic actually run.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Sponsored the cosmic fix. Thanks! Once this migrates let's get this backported to bionic as well.

Revision history for this message
Vlad Orlov (monsta) wrote :

Thanks, it's in Cosmic repos now.

Revision history for this message
Vlad Orlov (monsta) wrote :

The debdiff for Bionic in comment #20 is ready to replace current 0.5.2ubuntu14.1 in bionic-proposed (if that's possible to do).

Revision history for this message
Chris Halse Rogers (raof) wrote :

I've sponsored the upload (and so cannot accept it into -proposed) with a new changelog entry, because that's easier. Thanks!

Revision history for this message
Vlad Orlov (monsta) wrote :

Oh, so it should appear in Bionic repos then?

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Vlad, or anyone else affected,

Accepted apturl into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apturl/0.5.2ubuntu14.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-bionic
removed: verification-failed-bionic
Revision history for this message
Vlad Orlov (monsta) wrote :

Ok, testing in Ubuntu MATE 18.04. Updated to version 0.5.2ubuntu14.2 from bionic-proposed.

$ UPDATE_MANAGER_FORCE_BACKEND_SYNAPTIC=1 apturl apt://gnome-calculator

All good, the package is installed successfully.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for apturl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu11.2

---------------
apturl (0.5.2ubuntu11.2) xenial; urgency=medium

  * Make Synaptic backend actually work (LP: #1338482).

 -- Vlad Orlov <email address hidden> Sat, 23 Sep 2017 13:55:22 +0300

Changed in apturl (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu4.1

---------------
apturl (0.5.2ubuntu4.1) trusty; urgency=medium

  * Make Synaptic backend actually work (LP: #1338482).

 -- Vlad Orlov <email address hidden> Sat, 23 Sep 2017 14:52:08 +0300

Changed in apturl (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.5.2ubuntu14.2

---------------
apturl (0.5.2ubuntu14.2) bionic; urgency=medium

  * Also switch from gksu to pkexec, making Synaptic backend really,
    *really* work (LP: #1338482)

 -- Vlad Orlov <email address hidden> Wed, 26 Sep 2018 17:08:54 +1000

Changed in apturl (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Vlad Orlov (monsta) wrote :

Thanks, it's complete now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.