Ubuntu

[ATI HDMI] HDMI Audio Disabled by Default (since oneiric)

Reported by Melvin Garcia on 2011-10-02
228
This bug affects 43 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Unassigned

Bug Description

Since kernel 3.0, upstream has disabled audio output for all ATI cards in the Radeon driver by default.

=== Workaround 1 ===

Edit /etc/default/grub and change this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to this line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

Now run "sudo update-grub", then reboot your computer.

=== Or workaround 2 ===

Install the proprietary Catalyst driver.

===

There's no sound at all and videos playback in fast forward when outputting through the HDMI controller. This is a regression since it worked well in previous releases.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: melvin 8335 F.... pulseaudio
 /dev/snd/pcmC1D3p: melvin 8335 F...m pulseaudio
 /dev/snd/controlC0: melvin 8335 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe6f4000 irq 16'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,10ec0888,00100101'
   Controls : 38
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfe8e8000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Oct 2 12:46:40 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110929)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:HDMI failed
Symptom_Card: RS780 Azalia controller - HDA ATI HDMI
Symptom_Jack: Digital Out, HDMI
Symptom_Type: No sound at all
Title: [GT5676, ATI RS690/780 HDMI, Digital Out, HDMI] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/18/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 7B3G1P04
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Not Available
dmi.board.vendor: Gateway
dmi.board.version: Not Available
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gateway
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr7B3G1P04:bd02/18/2008:svnGateway:pnGT5676:pvr7B3G1P04:rvnGateway:rnNotAvailable:rvrNotAvailable:cvnGateway:ct3:cvr1.0:
dmi.product.name: GT5676
dmi.product.version: 7B3G1P04
dmi.sys.vendor: Gateway

Melvin Garcia (virtualspectre8) wrote :
David Henningsson (diwic) wrote :

Hi Melvin,

nothing looks bad on the audio driver side, so it should probably be reassigned to xserver-xorg-video-radeon (I'm trying to do just that, but Launchpad gets an error when I try :-( ).

Is this a problem both on clean boots as well as returning from suspend/resume?

Melvin Garcia (virtualspectre8) wrote :

Yes it is. If I use the analog output (green jack) sound works on the computer speakers. It only happens when outputting sound through HDMI.

David Henningsson (diwic) wrote :

Ok. One thing to try could be upgrading to latest alsa drivers through https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS to see if the bug is already resolved upstream.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Serge Matveenko (lig) wrote :

I have the same problem on my "ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]".

pavucontrol shows audio streams but there is no corresponding sound.

I've just installed alsa-hda-dkms 0.201110231811~oneiric1 and the problem persists.

The only output alsamixer shows is S/PDIF.

Serge Matveenko (lig) wrote :

Just found workaround here: http://phoronix.com/forums/showthread.php?62635-No-HDMI-sound-after-upgrade-to-Kubuntu-11.10-with-my-hd4770

Adding "radeon.audio=1" into kernel boot params solved the problem.

summary: - [GT5676, ATI RS690/780 HDMI, Digital Out, HDMI] No sound at all
+ [ATI HDMI] No HDMI audio with radeon driver (since oneiric)
description: updated
Changed in alsa-driver (Ubuntu):
status: Confirmed → Triaged

I can confirm the bug and the workaround both hold on an up-to-date Precise system with a Radeon HD 3200.

Hendy Irawan (ceefour) wrote :

Bug confirmed with ASUS 1215B with E-450 AMD Processor.

However the "radeon.audio=1" workaround does not work. :-(

I confirm the bug in my notebook`s Radeon HD 4200. The "Workaround 1" worked with system running a copy of Ubuntu 11.10, which first presented this problem for me. Thanks a lot for the workaround.

summary: - [ATI HDMI] No HDMI audio with radeon driver (since oneiric)
+ [ATI HDMI] HDMI Audio Disabled by Default (since oneiric)
Scugnizzo (axelinside) wrote :

The workaround No. 1 activates the sound but it has accelerated.
When I select the HDMI output for videos play fast.
This on my Radeon HD3850 whit Precise Pangolin (Oneiric also) and open driver.

This is a big problem in Quantal because the ATI driver doesn't support the new kernel as well as it causing the display to "rollback" leading to the "gnome classic" look. The audio also doesn't work (for me) with the driver installed. Not sure if the same happens Unity.

Raymond (superquad-vortex2) wrote :

  11.994750] [drm] Radeon Display Connectors
[ 11.994752] [drm] Connector 0:
[ 11.994754] [drm] VGA
[ 11.994757] [drm] DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[ 11.994759] [drm] Encoders:
[ 11.994761] [drm] CRT1: INTERNAL_KLDSCP_DAC1
[ 11.994762] [drm] Connector 1:
[ 11.994764] [drm] HDMI-A
[ 11.994765] [drm] HPD3
[ 11.994767] [drm] DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[ 11.994769] [drm] Encoders:
[ 11.994770] [drm] DFP2: INTERNAL_KLDSCP_LVTMA
[ 12.004502] [drm] Radeon display connector VGA-1: No monitor connected or invalid EDID
[ 12.024724] EXT4-fs (sdb1): re-mounted. Opts: errors=remount-ro
[ 12.118682] [drm] Radeon display connector HDMI-A-1: Found valid EDID

Node 0x03 [Pin Complex] wcaps 0x400381: Stereo Digital
  Pincap 0x00000094: OUT Detect HDMI
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x02

how can I change that line?

Daniel Letzeisen (dtl131) wrote :

@ignacio:
gksu gedit /etc/default/grub

madbiologist (me-again) wrote :

@Hendy Irawan (ceefour) - HDMI audio support for the Radeon HD 6320 in your AMD E-450 processor arrived in the 3.5 kernel. Ubuntu 12.10 "Quantal Quetzal" is based on the 3.5 kernel. You will also need to add the "radeon.audio=1" parameter to your GRUB boot options.

Workaround 1 no longer works for me in 13.10 saucy salamander 64bit with kernel 3.11.0.12.13 and earlier.

madbiologist (me-again) wrote :

@Miguelángel León (migueleonm) - That problem is fixed either in the upstream 3.11.4 kernel, or in the upcoming upstream 3.11.5 kernel. You can track the 13.10 "Saucy Salamander" update to 3.11.4 in bug #1237530.

Geoffrey Morrison (gbmorrison) wrote :

Kubuntu 13.10 AMD64 Visiontek Radeon 5450, BIOS dual-core-enabled Sargas AM3.

Adding "radeon.audio=1" to grub config does enable the open source Radeon video video card HDMI audio driver. Mysteriously, this does distort my 1280X720 and other resolutions somewhat, though--taskbar and some icons prove barely visible now. (I'm thinking that adjusting the TV directly improves that.)

I had a great deal of difficulty in getting my search query accurate in the correct manner finally to get to these posts.

gunxfight (chrisonline1991) wrote :

Xubuntu 13.10 AMD64 Radeon 6850.

Editing grub and running 'sudo update-grub' actually breaks the ablility to boot into Xubuntu for me. Grub shows up but when i select it i just get a black screen.

gunxfight (chrisonline1991) wrote :

@madbiologist (s-j-turner)

I updated my kernel to 3.11.4 using this guide: http://ubuntuhandbook.org/index.php/2013/10/linux-kernel-3-11-4-released-upgrade-in-ubuntu/ But it doesn't seem to have fixed the error.

madbiologist (me-again) wrote :

The upstream 3.13 kernel is currently under development. The radeon.audio=1 kernel boot option will no longer be necessary with this kernel. Instead, HDMI audio on ATI/AMD Radeon cards can be enabled and disabled on the fly by typing the following in a terminal window:

xrandr --output HDMI-0 --set audio on

or

xrandr --output HDMI-0 --set audio off

If your HDMI port is numbered differently (type "xrandr" to check) - you might need to change HDMI-0 in the above command to HDMI-1 or HDMI-2.

The 3.13-rc2 kernel is currently available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

Daniel Letzeisen (dtl131) wrote :

This should be fixed in Ubuntu 14.04/Trusty (or using a kernel >= 3.13.x). If anyone still experiences issues with audio using newer kernel, please file a new bug.

Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers