[ATI HDMI] HDMI Audio Disabled by Default (since oneiric)

Bug #864735 reported by Melvin Garcia on 2011-10-02
230
This bug affects 44 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
stasnoss

Bug Description

Since kernel 3.0, upstream has disabled audio output for all ATI cards in the Radeon driver by default.

=== Workaround 1 ===

Edit /etc/default/grub and change this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to this line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

Now run "sudo update-grub", then reboot your computer.

=== Or workaround 2 ===

Install the proprietary Catalyst driver.

===

There's no sound at all and videos playback in fast forward when outputting through the HDMI controller. This is a regression since it worked well in previous releases.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: melvin 8335 F.... pulseaudio
 /dev/snd/pcmC1D3p: melvin 8335 F...m pulseaudio
 /dev/snd/controlC0: melvin 8335 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe6f4000 irq 16'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,10ec0888,00100101'
   Controls : 38
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfe8e8000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Oct 2 12:46:40 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110929)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:HDMI failed
Symptom_Card: RS780 Azalia controller - HDA ATI HDMI
Symptom_Jack: Digital Out, HDMI
Symptom_Type: No sound at all
Title: [GT5676, ATI RS690/780 HDMI, Digital Out, HDMI] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/18/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 7B3G1P04
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Not Available
dmi.board.vendor: Gateway
dmi.board.version: Not Available
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gateway
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr7B3G1P04:bd02/18/2008:svnGateway:pnGT5676:pvr7B3G1P04:rvnGateway:rnNotAvailable:rvrNotAvailable:cvnGateway:ct3:cvr1.0:
dmi.product.name: GT5676
dmi.product.version: 7B3G1P04
dmi.sys.vendor: Gateway

Melvin Garcia (virtualspectre8) wrote :
David Henningsson (diwic) wrote :

Hi Melvin,

nothing looks bad on the audio driver side, so it should probably be reassigned to xserver-xorg-video-radeon (I'm trying to do just that, but Launchpad gets an error when I try :-( ).

Is this a problem both on clean boots as well as returning from suspend/resume?

Melvin Garcia (virtualspectre8) wrote :

Yes it is. If I use the analog output (green jack) sound works on the computer speakers. It only happens when outputting sound through HDMI.

David Henningsson (diwic) wrote :

Ok. One thing to try could be upgrading to latest alsa drivers through https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS to see if the bug is already resolved upstream.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Serge Matveenko (lig) wrote :

I have the same problem on my "ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]".

pavucontrol shows audio streams but there is no corresponding sound.

I've just installed alsa-hda-dkms 0.201110231811~oneiric1 and the problem persists.

The only output alsamixer shows is S/PDIF.

Serge Matveenko (lig) wrote :

Just found workaround here: http://phoronix.com/forums/showthread.php?62635-No-HDMI-sound-after-upgrade-to-Kubuntu-11.10-with-my-hd4770

Adding "radeon.audio=1" into kernel boot params solved the problem.

summary: - [GT5676, ATI RS690/780 HDMI, Digital Out, HDMI] No sound at all
+ [ATI HDMI] No HDMI audio with radeon driver (since oneiric)
description: updated
Changed in alsa-driver (Ubuntu):
status: Confirmed → Triaged

I can confirm the bug and the workaround both hold on an up-to-date Precise system with a Radeon HD 3200.

Hendy Irawan (ceefour) wrote :

Bug confirmed with ASUS 1215B with E-450 AMD Processor.

However the "radeon.audio=1" workaround does not work. :-(

I confirm the bug in my notebook`s Radeon HD 4200. The "Workaround 1" worked with system running a copy of Ubuntu 11.10, which first presented this problem for me. Thanks a lot for the workaround.

summary: - [ATI HDMI] No HDMI audio with radeon driver (since oneiric)
+ [ATI HDMI] HDMI Audio Disabled by Default (since oneiric)
Scugnizzo (axelinside) wrote :

The workaround No. 1 activates the sound but it has accelerated.
When I select the HDMI output for videos play fast.
This on my Radeon HD3850 whit Precise Pangolin (Oneiric also) and open driver.

This is a big problem in Quantal because the ATI driver doesn't support the new kernel as well as it causing the display to "rollback" leading to the "gnome classic" look. The audio also doesn't work (for me) with the driver installed. Not sure if the same happens Unity.

Raymond (superquad-vortex2) wrote :

  11.994750] [drm] Radeon Display Connectors
[ 11.994752] [drm] Connector 0:
[ 11.994754] [drm] VGA
[ 11.994757] [drm] DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[ 11.994759] [drm] Encoders:
[ 11.994761] [drm] CRT1: INTERNAL_KLDSCP_DAC1
[ 11.994762] [drm] Connector 1:
[ 11.994764] [drm] HDMI-A
[ 11.994765] [drm] HPD3
[ 11.994767] [drm] DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[ 11.994769] [drm] Encoders:
[ 11.994770] [drm] DFP2: INTERNAL_KLDSCP_LVTMA
[ 12.004502] [drm] Radeon display connector VGA-1: No monitor connected or invalid EDID
[ 12.024724] EXT4-fs (sdb1): re-mounted. Opts: errors=remount-ro
[ 12.118682] [drm] Radeon display connector HDMI-A-1: Found valid EDID

Node 0x03 [Pin Complex] wcaps 0x400381: Stereo Digital
  Pincap 0x00000094: OUT Detect HDMI
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=00, enabled=0
  Connection: 1
     0x02

how can I change that line?

@ignacio:
gksu gedit /etc/default/grub

madbiologist (me-again) wrote :

@Hendy Irawan (ceefour) - HDMI audio support for the Radeon HD 6320 in your AMD E-450 processor arrived in the 3.5 kernel. Ubuntu 12.10 "Quantal Quetzal" is based on the 3.5 kernel. You will also need to add the "radeon.audio=1" parameter to your GRUB boot options.

Workaround 1 no longer works for me in 13.10 saucy salamander 64bit with kernel 3.11.0.12.13 and earlier.

madbiologist (me-again) wrote :

@Miguelángel León (migueleonm) - That problem is fixed either in the upstream 3.11.4 kernel, or in the upcoming upstream 3.11.5 kernel. You can track the 13.10 "Saucy Salamander" update to 3.11.4 in bug #1237530.

Geoffrey Morrison (gbmorrison) wrote :

Kubuntu 13.10 AMD64 Visiontek Radeon 5450, BIOS dual-core-enabled Sargas AM3.

Adding "radeon.audio=1" to grub config does enable the open source Radeon video video card HDMI audio driver. Mysteriously, this does distort my 1280X720 and other resolutions somewhat, though--taskbar and some icons prove barely visible now. (I'm thinking that adjusting the TV directly improves that.)

I had a great deal of difficulty in getting my search query accurate in the correct manner finally to get to these posts.

gunxfight (chrisonline1991) wrote :

Xubuntu 13.10 AMD64 Radeon 6850.

Editing grub and running 'sudo update-grub' actually breaks the ablility to boot into Xubuntu for me. Grub shows up but when i select it i just get a black screen.

gunxfight (chrisonline1991) wrote :

@madbiologist (s-j-turner)

I updated my kernel to 3.11.4 using this guide: http://ubuntuhandbook.org/index.php/2013/10/linux-kernel-3-11-4-released-upgrade-in-ubuntu/ But it doesn't seem to have fixed the error.

madbiologist (me-again) wrote :

The upstream 3.13 kernel is currently under development. The radeon.audio=1 kernel boot option will no longer be necessary with this kernel. Instead, HDMI audio on ATI/AMD Radeon cards can be enabled and disabled on the fly by typing the following in a terminal window:

xrandr --output HDMI-0 --set audio on

or

xrandr --output HDMI-0 --set audio off

If your HDMI port is numbered differently (type "xrandr" to check) - you might need to change HDMI-0 in the above command to HDMI-1 or HDMI-2.

The 3.13-rc2 kernel is currently available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

This should be fixed in Ubuntu 14.04/Trusty (or using a kernel >= 3.13.x). If anyone still experiences issues with audio using newer kernel, please file a new bug.

Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
status: Triaged → Fix Released
RobertKH (kerinr) wrote :

Problem still exits in 14.04.

Gigabyte GA-E350N motherboad with Radeon HDMI graphics onboard. I have tried everything listed in these solutions and nothing seems to work. Just updated last week.

RobertKH (kerinr) wrote :

Also running xrandr --output HDMI-0 --set audio on produces this as output:
server@server-box:~$ xrandr --output HDMI-0 --set audio on
X Error of failed request: BadName (named color or font does not exist)
  Major opcode of failed request: 140 (RANDR)
  Minor opcode of failed request: 11 (RRQueryOutputProperty)
  Serial number of failed request: 29
  Current serial number in output stream: 29

madbiologist (me-again) wrote :

Thanks RobertKH. Can you please paste the output of uname -srm and attach the output of xrandr (without the "--output HDMI-0 --set audio on") and the output of lspci -vvnn.

RobertKH (kerinr) wrote :
Download full text (16.3 KiB)

Sure thing
server@server-box:~$ uname -srm
Linux 3.5.0-27-generic x86_64
server@server-box:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
DVI-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080 60.0*+ 30.0 24.0 60.1
   1680x1050 59.9
   1600x900 60.0
   1280x1024 75.0 60.0
   1440x900 59.9
   1366x768 59.8
   1280x800 59.9
   1152x864 75.0
   1280x720 60.0
   1024x768 75.1 70.1 60.0
   1440x480 60.1
   832x624 74.6
   800x600 72.2 75.0 60.3
   720x480 59.9
   640x480 72.8 75.0 66.7 60.0
   720x400 70.1
VGA-0 disconnected (normal left inverted right x axis y axis)
server@server-box:~$ lspci -vvnn
00:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex [1022:1510]
 Subsystem: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex [1022:1510]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310] [1002:9802] (prog-if 00 [VGA controller])
 Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 41
 Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Region 1: I/O ports at f800 [size=256]
 Region 2: Memory at fdfc0000 (32-bit, non-prefetchable) [size=256K]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: radeon
 Kernel modules: radeon

00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio [1002:1314]
 Subsystem: Gigabyte Technology Co., Ltd Device [1458:1314]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 42
 Region 0: Memory at fe020000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: snd_hda_intel
 Kernel modules: snd-hda-intel

00:11.0 SATA controller [0106]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (rev 40) (prog-if 01 [AHCI 1.0])
 Subsystem: Gigabyte Technology Co., Ltd Device [1458:b002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size...

madbiologist (me-again) wrote :

Thanks RobertKH - 3.5.0-27-generic x86_64 is an old Quantal 12.10 kernel. Are you sure you upgraded to Trusty 14.04?

zenny (garbytrash) wrote :

Like RoberKH reported, HDMI audio does not work in 14.04 new installation no matter what is done (adding radeon.audio=1 line to /etc/default/grub or using xrandr) though ubuntu documentation states it should work without any modification (https://help.ubuntu.com/community/RadeonDriver#HDMI_Audio). Here are the details:

$ uname -srm
Linux 3.13.0-32-generic x86_64

$ grep -Rn radeon.audio /etc/default/grub
11:GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

$ xrandr --output HDMI-0 --set audio on

$ lspci -v | grep VGA
 Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] (prog-if 00 [VGA controller])

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080 60.0*+ 50.0 59.9 60.0
   1920x1080i 60.1 50.0 60.0
   1600x1200 60.0
   1680x1050 59.9
   1280x1024 75.0 60.0
   1440x900 59.9
   1280x960 60.0
   1366x768 59.8
   1152x864 75.0
   1280x720 60.0 50.0 59.9
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   720x576 50.0
   720x480 60.0 59.9
   640x480 75.0 72.8 66.7 60.0 59.9
   720x400 70.1
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)

zenny (garbytrash) wrote :

More details to the above post:

$ lspci -v | grep Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

stasnoss (stasnoss25) on 2015-02-09
Changed in alsa-driver (Ubuntu):
assignee: nobody → stasnoss (stasnoss25)
sergiodavies (sergio-davies) wrote :
Download full text (5.0 KiB)

I'm experiencing this bug as well. Can anyone spot a problem with this configuration?

Linux 14.04LTS clean install

$ uname -srm
Linux 3.13.0-46-generic x86_64

$ grep -Rn radeon.audio /etc/default/grub
11:GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

$ xrandr -q
Screen 0: minimum 320 x 200, current 5200 x 2130, maximum 16384 x 16384
DisplayPort-0 connected primary 1600x900+80+1050 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900 60.0*+
   1280x1024 75.0 60.0
   1280x960 60.0
   1280x800 59.8
   1152x864 75.0
   1280x720 60.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
DisplayPort-1 connected 1600x900+1680+1050 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900 60.0*+
   1280x1024 75.0 60.0
   1280x960 60.0
   1280x800 59.8
   1152x864 75.0
   1280x720 60.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
DisplayPort-2 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050 59.9*+
   1400x1050 74.9
   1280x1024 75.0
   1440x900 75.0 59.9
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
DisplayPort-3 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050 59.9*+
   1400x1050 74.9
   1280x1024 75.0
   1440x900 75.0 59.9
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
DisplayPort-4 connected 1920x1080+3280+1050 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080 60.0*+ 50.0 59.9 24.0 24.0
   1920x1080i 60.1 50.0 60.0
   1280x720 60.0 50.0 59.9
   1440x576 50.0
   1440x576i 50.1
   1440x480 60.0 59.9
   1440x480i 60.1 60.1
   720x576 50.0
   720x480 60.0 59.9
   640x480 60.0 59.9
DisplayPort-5 disconnected (normal left inverted right x axis y axis)

$ sudo lspci -vk | grep -A15 VGA
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [FirePro W600] (prog-if 00 [VGA controller])
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device 2b1e
        Flags: bus master, fast devsel, latency 0, IRQ 67
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d4000000 (64-bit, non-prefetchable) [size=256K]
        I/O ports at 2000 [size=256]
        [virtual] Expansion ROM at d4060000 [disabled] [size=128K]
        Capabilities...

Read more...

madbiologist (me-again) wrote :

@zenny - Your lspci output is somewhat imprecise. Please attach the full output of lspci -vvnn. If you do indeed have a Radeon R5 230 based card, I don't think HDMI audio is supported on those yet.

madbiologist (me-again) wrote :

@sergiodavies - You seem to have four DisplayPort monitors connected. If this is the case, you have a different bug. Nevertheless, I can advise here that support for DisplayPort audio on AMD Radeon hardware is finally available in the upstream Linux 4.0 kernel.

A PPA of the 4.0-rc2 kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are at https://wiki.ubuntu.com/Kernel/MainlineBuilds

sergiodavies (sergio-davies) wrote :

@madbiologist - Thanks for your answer.
No I have 5 of them (display ports from 0 to 4), but actually only the one connected to display port 4 has audio capability - and pulseaudio volume control (pavucontrol) is set accordingly.
Despite the pavucontrol showing audio being sent through the 4th display port, no audio is actually received on the other side.
The setup works with proprietary fglrx drivers, but those drivers have an annoying memory leak bug which fills 4GB of memory in less than one day...

Thanks for the hint on the linux kernel 4.0, I'll look at it, but will that become available from standard repository for ubuntu Trusty?

madbiologist (me-again) wrote :

Trusty 14.04 will get LTS updates with kernels from future Ubuntu releases. For example, Trusty 14.04 shipped with a 3.13-based kernel, while 14.04.2 has a 3.16-based kernel similar to the one in Utopic 14.10. I couldn't find a release date for 14.04.3, but they are currently targeting the kernel from 15.04 - see https://launchpad.net/ubuntu/+milestone/ubuntu-14.04.3
15.04 will be released with a 3.19-based kernel, so to get the 4.0 kernel you will have to use the mainline kernel PPA I mentioned in comment #33. The final 4.0 kernel should be released in 6 or 7 weeks time.

madbiologist (me-again) wrote :

At this stage it looks like a 14.04.4 release is planned, with the kernel from 15.10 - see https://launchpad.net/ubuntu/+milestone/ubuntu-14.04.4

You will be waiting a while for that though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers